Jump to content
vipermaul

CBA - Community Base Addons - ARMA 3

Recommended Posts

On 10/15/2019 at 11:20 AM, dave_beastttt said:

Getting this client error since CUP update yesterday


15:32:15 Error in expression < cba_optics_OpticBodyTexture;
_ctrlBody ctrlSetPosition _bodyPosition;
_ctrlBody>
15:32:15   Error position: <ctrlSetPosition _bodyPosition;
_ctrlBody>
15:32:15   Error Type Number,Not a Number, expected Number
15:32:15 File x\cba\addons\optics\fnc_loadScriptedOptic.sqf..., line 70

 


This error still happening in 3.14.0.200207

Share this post


Link to post
Share on other sites

Why does CBA take so long to load at the start of missions?I have mods with features that I need at the start and  depend on CBA.

  • Confused 1

Share this post


Link to post
Share on other sites

@miasdad

Did it ever occur to you that maybe some of those mods you're using only work due to CBA and are themselves what's so slow?

13:21:42 [773,195.237,0,"XEH: PreInit started. v3.12.2.190909"]
13:21:42 [CBA] (settings) INFO: Reading settings from settings file.
13:21:42 [CBA] (settings) INFO: Finished reading settings from settings file.
13:21:42 [773,195.398,0,"XEH: PreInit finished."]

0 seconds

13:21:42 [773,195.398,0,"XEH: PreInit finished."]
13:21:43 [775,196.027,0,"XEH: PostInit started. MISSIONINIT: missionName=tempMissionSP, missionVersion=53, worldName=VR, isMultiplayer=false, isServer=true, isDedicated=false, CBA_isHeadlessClient=false, hasInterface=true, didJIP=false"]
13:21:43 [775,196.028,0,"CBA_VERSIONING: cba=3.12.2.190909, "]
13:21:43 [775,196.029,0,"XEH: PostInit finished."]

1 second

 

And this was tested on a laptop.

It'll be the mods using CBA that are slow to load, not CBA itself.

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
On 2/12/2020 at 11:25 AM, atomictim7 said:

Did it ever occur to you that maybe some of those mods you're using only work due to CBA and are themselves what's so slow?

Thanks for the heads up...unloading a few mods helped.

Share this post


Link to post
Share on other sites

CBA v3.15.0 Released

 

CBA_A3 v3.15.0.200404

 

Adds the Item Context Menu Framework and some bug fixes.

 

CHANGE LOG SUMMARY:

  • ADDED: CBA_fnc_switchableAttachments function (#1294) commy2

  • ADDED: Return TARGET EXEC result back to executor UI (#1299) veteran29

  • ADDED: Item Context Menu Framework (#1303, #1314) commy2

  • ADDED: Support for Waypoints to CBA_fnc_getPos (#1305) jokoho48

  • ADDED: JAM magwells for SKS (#1308) 10Dozen

  • FIXED: Script error in Settings menu (#1295, #1296) dpottavio mharis001

  • FIXED: Script error in Scripted optics (#1297, #1304) MGTDB SchmittAkaSmallfly commy2

  • FIXED: Passed arguments of loadout player event (#1300, #1301, #1312, #1313) 10Dozen PabstMirror

  • FIXED: Per frame handler script not removed when deleting PFH object (#1306) PabstMirror

  • FIXED: CBA_fnc_formatNumber shows minus sign when all digits are zeros (#1309) commy2

Change log for CBA v3.15.0

 

_________________________________________________________________________
HOSTED AT THE FOLLOWING:

Signatures are included.

 

Submit new bugs on GitHub.

  • Like 3
  • Thanks 2

Share this post


Link to post
Share on other sites

After the last CBA update muzzle brakes on RHS weapons are broken. Where i can get previous CBA version where everything was fine?

rDZxt3a.jpg

 

Share this post


Link to post
Share on other sites
8 hours ago, Disgusting_Man said:

Where i can get previous CBA version where everything was fine?

https://github.com/CBATeam/CBA_A3

I doubt that its CBA's fault, CBA cannot change proxy offsets, if I'm interpreting your screenshot correctly.

  • Like 1

Share this post


Link to post
Share on other sites
4 hours ago, Dedmen said:

https://github.com/CBATeam/CBA_A3

I doubt that its CBA's fault, CBA cannot change proxy offsets, if I'm interpreting your screenshot correctly.

I downloaded version 3.14 and there are not such problems with muzzle brakes and silencers from different mods.

Share this post


Link to post
Share on other sites

Hi, getting this in my rpt with Antistasi dedicated:


 

Spoiler

 

9:06:16 [CBA] (xeh) INFO: [6884,123.792,0] PreInit started. v3.15.0.200404
 9:06:16 [CBA] (settings) INFO: Reading settings from settings file.
 9:06:17 [CBA] (settings) INFO: Finished reading settings from settings file.
 9:06:17 [CBA] (settings) INFO: Mission Config: File [cba_settings.sqf] loaded successfully.
 9:06:17 Error in expression <ring [10, 13, 9, 32] joinString "";
};

parseSimpleArray (["[", _string, "]"] jo>
 9:06:17   Error position: <parseSimpleArray (["[", _string, "]"] jo>
 9:06:17   Error Generic error in expression
 9:06:17 File x\cba\addons\settings\fnc_parse.sqf..., line 30
 9:06:17 Error in expression <ring [10, 13, 9, 32] joinString "";
};

parseSimpleArray (["[", _string, "]"] jo>
 9:06:17   Error position: <parseSimpleArray (["[", _string, "]"] jo>
 9:06:17   Error Generic error in expression
 9:06:17 File x\cba\addons\settings\fnc_parse.sqf..., line 30

 

any clue how to fix it?

 

EDIT: Removed cba_settings.sqf from mission file, and exported settings to userconfig/cba_settings.sqf and the error is gone

Share this post


Link to post
Share on other sites

Hello, i have some issues with CBA, when i install CBA on my life server, all of the accessory (except supressor) disapear from all of my shop in-Game. 

Share this post


Link to post
Share on other sites

Requesting help with adding and removing event handlers.

 

When I add an EH in the debug console in the game like this, I get a return number in the console as expected:

["test", {systemChat str _this}] call CBA_fnc_addEventHandler;

Return window shows a number.

If I add the _id = as per the official example, so that I can then use _id to remove the EH, the debug console shows no return number.

_id = ["test", {systemChat str _this}] call CBA_fnc_addEventHandler;

Return window shows nothing.

Using hint to show the value of _id comes back blank.

 

Because of this, I cannot remove the EH because the ID number is required.

 

Note: If don't add _id = and use the returned number in the remove function, everything works.

 

What am I doing incorrectly?

 

Thanks!

Share this post


Link to post
Share on other sites

CBA subscribed today and it is 100% preventing the game to launch if it is loaded; tried with another mod not dependent on CBA and the game launched fine. 

 

Error is: 0xC0000005 -STATUS_ACCESS_VIOLATION

 

Exception code: C0000005 ACCESS_VIOLATION at AC57FA70
Version 1.98.146303
Fault time: 2020/04/16 13:37:40
Fault address:  AC57FA70 00:AC57FA70 Unknown module

Share this post


Link to post
Share on other sites

@doc. caliban

4 hours ago, doc. caliban said:

_id = ["test", {systemChat str _this}] call CBA_fnc_addEventHandler;

Try running

_id = ["test", {systemChat str _this}] call CBA_fnc_addEventHandler;

_id

and see what it returns.

@druout1944 try repairing CBA through the launcher.

Share this post


Link to post
Share on other sites
13 hours ago, doc. caliban said:

Requesting help with adding and removing event handlers.

 

When I add an EH in the debug console in the game like this, I get a return number in the console as expected:


["test", {systemChat str _this}] call CBA_fnc_addEventHandler;

Return window shows a number.

If I add the _id = as per the official example, so that I can then use _id to remove the EH, the debug console shows no return number.


_id = ["test", {systemChat str _this}] call CBA_fnc_addEventHandler;

Return window shows nothing.

Using hint to show the value of _id comes back blank.

 

Because of this, I cannot remove the EH because the ID number is required.

 

Note: If don't add _id = and use the returned number in the remove function, everything works.

 

What am I doing incorrectly?

 

Thanks!

 

 

First of all, CBA_fnc-addEventHandler is not an EH, just a code handler (this should be named: CBA_fnc_codeHandler). The whole EH comes with CBA_fnc_localEvent (or server event, or global event...)

Note apart: I never use CBA, just because I missed the added value of this addon. I'm scripting with BIS commands/functions/sqf/EHs and that goes well enough.

 

when you write: ["test", {systemChat str _this}] call CBA_fnc_addEventHandler;  the result is a number // fine

when you write _id = ["test", {systemChat str _this}] call CBA_fnc_addEventHandler;  // there is no result because of equality. It's a line of code returning nothing wherever you use it.

 

when you need to remove this "half" EH,    you must use: ["test", _id] call CBA_fnc_removeEventHandler;   where _id is defined. From another (outer) scope/sqf  use a global variable instead.

 

  • Like 1

Share this post


Link to post
Share on other sites
14 hours ago, doc. caliban said:

What am I doing incorrectly?

You are trying to use a local variable like a global one, local variables are local only.

 

1 hour ago, pierremgi said:

First of all, CBA_fnc-addEventHandler is not an EH

Yes it is. Its a scripted eventhandler.

 

 

Share this post


Link to post
Share on other sites
15 hours ago, Freddo3000 said:

@doc. caliban



@druout1944 try repairing CBA through the launcher.


Ok, tried that; no effect. RHS mods and CUP mods which are not dependent on CBA work fine, but CBA itself still gives the error if loaded in the mods or by itself.

Share this post


Link to post
Share on other sites

If I'm right, CUP units needs CBA, at least if downloaded via Steam. This is a dependency.

Share this post


Link to post
Share on other sites
On 4/18/2020 at 10:43 AM, pierremgi said:

If I'm right, CUP units needs CBA, at least if downloaded via Steam. This is a dependency.

 

You are right, CUP requires CBA for things like the joint rails support, magazines, optics, disposable launchers...

Share this post


Link to post
Share on other sites

CBA v3.15.1 Released

 

CBA_A3 v3.15.1.200418

 

Minor improvements for Arma 3 version 1.98.

 

CHANGE LOG SUMMARY:

  • ADDED: Settings - Show raw values in tooltip for list settings (#1321) PabstMirror

  • FIXED: XEH - Update configs for 1.98 (Old Man) (#1311) PabstMirror

Change log for CBA v3.15.1

 

_________________________________________________________________________
HOSTED AT THE FOLLOWING:

Signatures are included.

 

Submit new bugs on GitHub.

  • Like 3
  • Thanks 1

Share this post


Link to post
Share on other sites

Hello! Have a question about Extended Event Handlers.

One addon has this lines. 

class Extended_PostInit_EventHandlers
{
class rm_event_strt
{
init = "EXECVM 'rm_strt\strt.sqf'";
};
};

is it possible somehow to stop strt.sqf executing without editing it? Or even prevent it from starting/override with another file?

Share this post


Link to post
Share on other sites

I also have a question, where should I put this:

[myCustomFunc.sqf, vCustom] call CBA_fnc_compileFunction;

 

So that this is run on even eden editor placed units:

["CAManBase", "fired", {_this call vCustom;}] call CBA_fnc_addClassEventHandler;

 

Thank you!

Share this post


Link to post
Share on other sites

 

I'm having trouble running the APEX Mission : https://github.com/auQuiksilver/Apex-Framework , when adding CBA_A3 this error occurs :

 

2:46:40 [CBA] (xeh) INFO: [0,10.732,0] PreStart started.

2:46:40 [CBA] (settings) INFO: Userconfig: File [userconfig\cba_settings.sqf] not found or empty.

2:46:40 [CBA] (xeh) INFO: [0,10.898,0] PreStart finished.

2:46:40 [CBA] (xeh) INFO: [0,11.007,0] init function preProcessing disabled [recompile or filepatching enabled]

Share this post


Link to post
Share on other sites
1 hour ago, barreto.alexandre said:

when adding CBA_A3 this error occurs

Where's the error? you didn't post any.

All the messages you posted say "INFO", errors would say "ERROR".

So if you have a CBA error please post that too.

Share this post


Link to post
Share on other sites

 

I checked again the error occurs when I add @ CBA_A3 , keeps giving this message and does not load the mission, if you remove the @ CBA_A3 it works normally

2:55:48 Warning Message: No entry 'bin\config.bin/CfgPatches/apex_server.units'.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×