Jump to content
silola

DAC V3.1 (Dynamic-AI-Creator) released

Recommended Posts

What is DAC_Radio_Max? I cannot find it in the readme, nor do I get a single result from google.

Share this post


Link to post
Share on other sites
What is DAC_Radio_Max?

My guess is the distance AI will share information about enemies within different groups and/or call reinforcements. The higher DAC_AI_Level is set to the higher their share range will be be between different AI groups.

Share this post


Link to post
Share on other sites
My guess is the distance AI will share information about enemies within different groups and/or call reinforcements. The higher DAC_AI_Level is set to the higher their share range will be be between different AI groups.

Looks like it can possibly be an override to the DAC_AI_Level as it is set to the same value as DAC_AI_Level if it isNil. So, if you wanted a lower AI level but higher Radio level then you can set this variable it looks like.

Share this post


Link to post
Share on other sites

Hi,

Quick question: When you setup a zone and specify for example 25 waypoints that each group gets assigned. What happens once they reach the last waypoint? Do they just cycle back to the first waypoint OR do they get a whole new set of 25 waypoints?

The DAC waypoints are not processed in order but randomly. In this respect, there is no first and no last waypoint.

Can somebody point me why im getting this error:

http://i.imgur.com/RQmfSIH.jpg (200 kB)

Anyway everything seems to work...

I think this error could have many reasons. Unfortunately I can not determine the cause, only based on this picture.

Can you reproduce this error? If so, then I need a small test mission from you to check it.

What is DAC_Radio_Max? I cannot find it in the readme, nor do I get a single result from google.

Sorry, but this variable has no meaning anymore. It is a remnant of an old version and I forgot to remove them :-(

Silola

Share this post


Link to post
Share on other sites

Does this addon support dynamic ai spawn ?

Like EOS , spawn unit only when you're like 1000 m away and delete when your too far .

Share this post


Link to post
Share on other sites
Does this addon support dynamic ai spawn ?

Like EOS , spawn unit only when you're like 1000 m away and delete when your too far .

it takes a different approach

it will despawn all units except the group leader and rebuild them once you are in reach

additionally, you can deactivate and activate zones, decativation means all units will get deleted, and then reactivating them means they will get respawned.

Share this post


Link to post
Share on other sites
The DAC waypoints are not processed in order but randomly. In this respect, there is no first and no last waypoint.

Thanks Silola but you didn't fully answer the question. In a zone configuration one specifies the total waypoints and the number each group gets. So whatever the order, I don't care. But if the group gets 10 waypoints what do they do with them. Do they just move randomly between the 10 forever? Or do they use those 10 and then get another 10 and so on forever?

Basically I am just worried about units running out of waypoints and then standing still after a time period. However, since I've never witnessed this with some missions I've designed and run for hours I suspect this doesn't happen. But just wanted to make sure.

---------- Post added at 21:26 ---------- Previous post was at 21:21 ----------

I am having a problem using DAC_fChangeZone to reposition a zone and resize it. When I try calling this it seems that sometimes (not always) other zones that are NOT linked to the one being changed stop functioning. All units just stop moving and looks like they have no waypoints. The zone that I am trying to move doesn't seem to function either. Nothing really moves to the new location.

I don't think it has anything to do with not being able to find waypoints because I'm usually moving it to an open area with lots of space to find waypoints NO problem. In fact it is moving from a smaller/similar location to a larger location.

Is there something I can look for or debug to determine the issue? Can I tell if this is a waypoint finding problem or something else?

Share this post


Link to post
Share on other sites
Thanks Silola but you didn't fully answer the question. In a zone configuration one specifies the total waypoints and the number each group gets. So whatever the order, I don't care. But if the group gets 10 waypoints what do they do with them. Do they just move randomly between the 10 forever? Or do they use those 10 and then get another 10 and so on forever?

Basically I am just worried about units running out of waypoints and then standing still after a time period. However, since I've never witnessed this with some missions I've designed and run for hours I suspect this doesn't happen. But just wanted to make sure.

I'm fairly certain that the group will get assigned 10 waypoints and cycle through those until killed (ie: it doesn't assign 10 new ones after it finishes its 'patrol'). If re-spawn is used the group will get assigned 10 new waypoints on re-spawn. If you use custom waypoints it will get assigned those first.... so if you have 5 custom wp it will assign those then 5 more from the 'random pool'

I am having a problem using DAC_fChangeZone to reposition a zone and resize it. When I try calling this it seems that sometimes (not always) other zones that are NOT linked to the one being changed stop functioning. All units just stop moving and looks like they have no waypoints. The zone that I am trying to move doesn't seem to function either. Nothing really moves to the new location.

I don't think it has anything to do with not being able to find waypoints because I'm usually moving it to an open area with lots of space to find waypoints NO problem. In fact it is moving from a smaller/similar location to a larger location.

Is there something I can look for or debug to determine the issue? Can I tell if this is a waypoint finding problem or something else?

I would guess that if it was a waypoint problem (not finding any) you would get an error.. maybe not like the ones at mission start where you have to press OK but perhaps something is logged in RPT file? Does anything show up visually if you have marker debug on?

Share this post


Link to post
Share on other sites

I would guess that if it was a waypoint problem (not finding any) you would get an error.. maybe not like the ones at mission start where you have to press OK but perhaps something is logged in RPT file? Does anything show up visually if you have marker debug on?

I don't recall whether I checked the RPT file but I might have. Next time it happens I will try and remember to look there. Otherwise there was no indication anything was wrong. Oh, I did notice that frame-rate dropped significantly as if DAC was attempting to do something or was caught in some sort of loop spinning away at CPU or something.

Nothing visually showed up and I had marker debug turned on.

Share this post


Link to post
Share on other sites

So good to see DAC back. however I'm trying to spawn new zones in game. but keep getting errors. i know its something im doing worong but not too sure what.

errors is

Error in expression <rSet == 0) then

{

_markerSet = ((_array select ((count _array) - 1)) select 0);

>

Error position: <select ((count _array) - 1)) select 0);

>

Error Zero divisor

Error in expression <ct ((count _array) - 1)) select 0);

};

_markerSet>

Error position: <_markerSet>

Error Undefined variable in expression: _markerset

Error in expression <rColorlocal ((DAC_Marker_Val select 14) select 5);

_na setMarkerColorlocal ((DAC>

Error position: <select 5);

_na setMarkerColorlocal ((DAC>

Error Zero divisor

Error in expression <0) == 0) && (((DAC_Marker_Val select 7) select 1) == 0))) then

{

deletemarkerloc>

Error position: <select 1) == 0))) then

{

deletemarkerloc>

Error Zero divisor

Error in expression <erSizelocal [((DAC_Marker_Val select 7) select 1),((DAC_Marker_Val select 7) sel>

Error position: <select 1),((DAC_Marker_Val select 7) sel>

Error Zero divisor

Error in expression <rColorlocal ((DAC_Marker_Val select 14) select 5);

_na setMarkerColorlocal ((DAC>

Error position: <select 5);

_na setMarkerColorlocal ((DAC>

Error Zero divisor

Error in expression <0) == 0) && (((DAC_Marker_Val select 7) select 1) == 0))) then

{

deletemarkerloc>

Error position: <select 1) == 0))) then

{

deletemarkerloc>

Error Zero divisor

Error in expression <erSizelocal [((DAC_Marker_Val select 7) select 1),((DAC_Marker_Val select 7) sel>

Error position: <select 1),((DAC_Marker_Val select 7) sel>

Error Zero divisor

code im using is

waituntil{DAC_NewZone == 0};

tws_zoneCounter = tws_zoneCounter + 1;

hint format["tws_zoneCounter is %1 " , tws_zoneCounter];

_zonename = "z" + (str tws_zoneCounter);

_values = [_zonename,[1,0,0],[5,2,50,8],[5],[5],[5],[0,0,0,0]];

[_townpos,_detectarea ,_detectarea ,0,0,_values] call DAC_fNewZone;

_inited = 1;

Share this post


Link to post
Share on other sites

Anyone attempted a GUI mission frontend for DAC? I know that becubed was working on one for Arma2 but I don't think he ever released it :(

I know that Gliptal is a wiz at making GUI frontends, perhaps this could be his new project ;) (or someone else :) )

Share this post


Link to post
Share on other sites

@twisted - are you testing in MP or on dedi and have DAC_Markers enabled in DAC_Config_Creator.sqf? If so try setting all DAC_Markers values to 0 and test.

@krem - there was talk of this but I haven't seen anything appear

Edited by SavageCDN

Share this post


Link to post
Share on other sites

Hi I wanted to ask few questions about making triggers that would activate DAC zones. Im working on a rather simple mission that utilizes HAL for command and DAC for providing the units. The basic idea is that there are areas for both sides to capture with, once captured activate DAC zone at the base that spawns in units for HAL to command (once DAC zone per capture, with different types of units). I want the DAC units to respawn if killed (with delay) as long as particular area in the field is captured. However if the zone is lost I want DAC units to remain on the field, but not respawn if killed, at least until the zone is recaptured.

Is this possible?

BTW: I just wanted a simple system, now that I voiced what I want it does seem to be a bit more advanced then I thought at first. I had hard time figuring out the basic capture mechanics, so please be descriptive.

Edited by Taro8

Share this post


Link to post
Share on other sites

If you want the same DAC zone to respawn or not respawn units depending on another factor/variable I think you would have to delete the zone and create a new one... I don't think there is a way to change the respawn behaviour of a zone "on the fly"

Share this post


Link to post
Share on other sites

Anyone figured out how to customize the uniforms & equipment of units spawned by DAC? I am currently trying some things, perhaps someone here could save me some time? Thanks.

Share this post


Link to post
Share on other sites
Anyone figured out how to customize the uniforms & equipment of units spawned by DAC? I am currently trying some things, perhaps someone here could save me some time? Thanks.

As far as I know you cannot customize uniforms, etc using the standard DAC config files (you can customize weapons and ammo however using DAC_Config_Weapons.sqf). You would have to write your own script to change the uniforms then apply it to the units at spawn time using DAC_Config_Events.sqf

Share this post


Link to post
Share on other sites
As far as I know you cannot customize uniforms, etc using the standard DAC config files (you can customize weapons and ammo however using DAC_Config_Weapons.sqf). You would have to write your own script to change the uniforms then apply it to the units at spawn time using DAC_Config_Events.sqf

Well I got it working, problem is all the uniforms out there are mainly bluefor uniforms, so opfor can't use them. Anyone know of a good Opfor uniform mod? Thanks.

Edited by Skelt

Share this post


Link to post
Share on other sites

How so? Using Events.sqf with a custom script?

Share this post


Link to post
Share on other sites

No, in DAC_Change_Weapons ... it didn't seem to work right anyways, but it seems to give the right access to the units as they are created. Not sure how it will work in MP but since it's how DAC normally would update the weapons carried by the AI I think it should work just fine for what I need. The only drawback I can see so far is the fact that I can only determine one custom load-out for all sides, the second you call the weapons config on a unit it gets the default random loadout from DAC_Change_Weapons. (Which works well if you want say.. all of one side to be randomly equipped. -- just be sure you have some uniforms for the side you choose to equip with this!)

Edit: I think making it selectable wouldn't be all that hard providing you know where to look, just check the side of the unit prior to conducting business.

---------- Post added at 06:49 PM ---------- Previous post was at 06:22 PM ----------

Probably going to experiment with RUSSIAN GRU and OMON SPETSNAZ for A3 by massi, look pretty nice and full class names list.

Edited by Skelt

Share this post


Link to post
Share on other sites

Yeah no problem, once I get things cleaned up.

Share this post


Link to post
Share on other sites

I do not want that someone cut up the DAC, and then uses parts of it in other addons.

Why not?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×