Jump to content
silola

DAC V3.1 (Dynamic-AI-Creator) released

Recommended Posts

3 hours ago, charliereddog said:

We are using a HC because we are using a lot of units. (200+ east groups and 100+independent groups.) The code for migrating to HC is our own clan specific so I can't comment on other set ups etc. It's entirely possible that the issue is down to what you say, however I'm not convinced it is because DAC functions perfectly for a while before falling over. However there is nothing in the rpts to indicate any errors (except a DAC marker error which seems meaningless) nor any obvious link. 

 

Sad to say but I suspect I'm going to have to write my own basic DAC. I can't wade through 160 odd uncommented and undocumented sqf to try to work out what the problems could be. I'm just not that competent. 

I'm pretty sure that DAC has its own documentation. Both for the addon and scripted version. It may not include the specific information for each .sqf but who knows - maybe the answer is still there.

 

And yeah, you are right - DAC is sadly oudated since it more of a port from Arma 2. A lot of functions changed, a lot of them were added etc.

Share this post


Link to post
Share on other sites

Lol. The documentation is more a user guide. It's not documentation of the code. Sadly :(

 

We've just set the same mission running without a HC and will check to see if DAC has stalled when I get home. If so then it points to a problem with the way our HC works. If not, well I guess we are back to square one.

Share this post


Link to post
Share on other sites
3 hours ago, charliereddog said:

Lol. The documentation is more a user guide. It's not documentation of the code. Sadly :(

 

We've just set the same mission running without a HC and will check to see if DAC has stalled when I get home. If so then it points to a problem with the way our HC works. If not, well I guess we are back to square one.

I don't use a HC at all, just nuts-simple SP missions I  like to pootle about in. I'm pretty sure that about a year ago I could call the camera function easily, first time and straight away each time, but recently I can't after a certain amount of complexity has built up. This is also noticeable in smoke scripts that I have where they still emit (#particlesource), but don't update their parameters (which are altered via script over time). I run these scripts concurrently in a DAC environment, each script monitoring and affecting a smoke source. If DAC/my scripts/all the other 3rd party scripts are being subject to some new(ish) script scheduling process then I guess this could all add up.

 

Until now I assumed it was my computer getting old and ArmA becoming more complex. But yes I suspect some scheduling issue now.

Share this post


Link to post
Share on other sites

Ok. Update. I'm a clown.:don9:

 

DAC works fine in my mission without a HC, (albeit fps is around 5 but who needs frames right). Turns out I was spawning DAC on the server despite thinking I wasn't , and the HC migration was changing the locality and therefore units were stopping moving later on as the locality changed. Once I'd sorted my code out to do what I thought it was doing in the first place, DAC ran successfully on a 24hr soak test last night. Of course all the AI vehicles and helicopters ran out of fuel but baby steps. I think I can sort that via config_events, but having seen a couple of references to the same problem in DAC3 for ARMA2 I don't see a posted solution.

 

I'm still getting an odd marker error thrown at the end of the DAC initialisation, I say odd because I've got markers set to off...

  • Like 1

Share this post


Link to post
Share on other sites
7 hours ago, charliereddog said:

Ok. Update. I'm a clown.:don9:

 

DAC works fine in my mission without a HC, (albeit fps is around 5 but who needs frames right). Turns out I was spawning DAC on the server despite thinking I wasn't , and the HC migration was changing the locality and therefore units were stopping moving later on as the locality changed. Once I'd sorted my code out to do what I thought it was doing in the first place, DAC ran successfully on a 24hr soak test last night. Of course all the AI vehicles and helicopters ran out of fuel but baby steps. I think I can sort that via config_events, but having seen a couple of references to the same problem in DAC3 for ARMA2 I don't see a posted solution.

 

I'm still getting an odd marker error thrown at the end of the DAC initialisation, I say odd because I've got markers set to off...

 

 

HCs are required to run missions like massive SP-missions using DAC or massive CTI missions with several hundred active AI....BUT

shifting AI to HC often kills the AI brain and they stop moving - would be fine if BIS would support the community by debugging some CTI missions together with the mission maker and use it as show-cases how massive it could be if HCs used correctly.

Share this post


Link to post
Share on other sites

Hello to everyone !

 

I was using the script version and i found this error :

WgIFpfLSSzmlWizdDfaEkA.png

https://community.bistudio.com/wiki/setRank

just a quick fix to this :

it should be "lieutenant" to :

DAC_Group_Air.sqf

DAC_Group_Camp.sqf

DAC_Group_Soldier.sqf

DAC_Group_Tank.sqf

DAC_Group_Vehicle.sqf

  • Like 3

Share this post


Link to post
Share on other sites

Hello everyone !

 

I'm just adding a small error that i noticed , for the Dac followers.

 

This is about the Script Version:

6 minutes ago, GEORGE FLOROS GR said:

Here is the error , where there are two "I":

 

DAC V3.1 Short instruction

ecEA4hcWQyONIij5SnOoBw.png

 

So , inspite of getting confused

10 minutes ago, GEORGE FLOROS GR said:

A problem here is that i noticed a small instruction error , I have also this line as here:


" I " Zone belongs to Site...

 

It should be:

//    J Zone belongs to Site > 0 = East, 1 = West, 2 = RACS, 3 = civilian (for more see readme page 7)
[0,   

 

Thanks !

 

and big thanks to Silola for this Great Work , DAC is unique !

 

  • Like 2

Share this post


Link to post
Share on other sites

Hi, does anyone know how to activate DAC zones from within a script? I"m trying to build a system that spawns zones and their content dynamically. I''m having trouble defining the zone.

Share this post


Link to post
Share on other sites
9 hours ago, morthon said:

Hi, does anyone know how to activate DAC zones from within a script? I"m trying to build a system that spawns zones and their content dynamically. I''m having trouble defining the zone.

 

Check page 15 of the PDF manual.

 

[Zone_Name] call DAC_Activate

 

Also check page 21 for how to create zones during the mission.

  • Like 2

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×