Jump to content
genesis92x

Vcom AI V2.0 - AI Overhaul

Recommended Posts

Is this compatible with MCC GAIA? Because I would love to have both the strategic and tactical improvements at the same time.

Share this post


Link to post
Share on other sites

As far as i know it should work with any mod, (Minus Ryanzombies), I run the addon version and these mods i know work when it comes to units/vehicles 

  1. OPTRE (First contact included)
  2. RHS
  3. CUP
  4. Lieghts OPFOR
  5. PG Services
  6. Massis mods

So i dont know why FFAA wouldnt work if it doenst, But it would most likely work i believe 

The problem I have concerns to AI static weapon deployment, I put in the same mission two squads with their equipment bags, one with original HMG and other with the FFAA_Spike launcher, both squads were advancing until they contact with an enemy vehicle, and the original HMG one deploys quickly and began to fire but the FFAA Spike launcher doesn´t accomplish deployment although his state changes to combat mode; so that I suppose that must be a compatibility issue. 

Share this post


Link to post
Share on other sites

Does anybody know a work-around for the Bastion part of EOS, when my mission turns to defend, the Opfor troops all just spawn in and just stand there and will not accept any waypoints that are generated automatically or by Zeus?

Any ideas please?

Regards

Rizla

Share this post


Link to post
Share on other sites

Holy crap this new update is damn great. The ai moves like they're real human who value there life. There flanking is great and the Use of buildings also.

Though there is some old bugs like when a Ai dies its body twitches none stop, when it twitches it acts like a invisible wall you cant get its items and cant get through, this is the only bug that's is immersion breaking for me. They doesn't use the Trucks for transport when supporting anymore, maybe you removed that feature?. But all in all this mod is great, nice work and i really like it.

Share this post


Link to post
Share on other sites

Try the version I just posted and let me know how it goes. I quickly tested the mod and got 0 zeros/warnings at least

Update:

VcomAI Mod Version 2.5

 

VcomAI Script Version 2.5

 

_TimeShot = _unit getVariabl>

Error Zero divisor

File vcomai\VCOMAI\Functions\VCOMAI_HearingAids.sqf, line 6

Error in expression <xitWith {};

 

_bullet = (_this select 0) select 6;

Share this post


Link to post
Share on other sites

Hey, is there a guide for this anywhere or anything?

If not, can anyone provide me with more information on how the artillery support stuff works so I can make sure it's being taken advantage of in my missions? Do I need to group/sync anything? Do I need to back off my arty batteries/units to ensure they aren't too close, even with mortars?

I've been poking around at getting it to work and will continue but so far I've yet to get the mortarman I placed with a mortar to engage a squad that had superior firepower and higher ground. They rebuffed a counter-attack but the mortar unit just slowly turned to face them, and then nothing happened.

 

Turns out the mod didn't enable properly when installed with the launcher.

Using RHS units, in case that matters.

 

Now the issue is how A) accurate and B) immediate the mortar support is. AI doesn't wait to assess the situation, they just immediately have mortars coming in. Is this because the mortar unit is actively attacking rather than carrying out a fire mission for other units?

Also, is there a way to make the AI not fire like 4 rounds rapid fire to pound an area? If you can't avoid the mortar fire, you just get pounded into dust rather than having a chance to survive being on the edge of a shell's explosion. I;d prefer it to be sporadic, inaccurate fire especially as these are insurgents, reacting to an assault. Should I just move these guys way back?

Share this post


Link to post
Share on other sites

The ai sometime turn there back on the enemy or just completely ignoring, looking at them without shooting them even though its right in front of them.

Share this post


Link to post
Share on other sites

I have noticed that AI placed in Editor, MCC or Zeus never remain in place when disturbed by fire or presence of an opposing force (even a passing aircraft). No matter what script is running in the init, they immediately leave their position and start scouting around, or running towards the spotted enemy.

 

Is there any way to fix them in place? Best method I have found (not foolproof) is MCC's Guard command.

Share this post


Link to post
Share on other sites

I really like how responsive this mod makes the AI. The only problem I've had so far is it seems to make the support module that's present on some scenarios take incredibly long to respond to prompts. Other than that, I'd have to say that what you've done with modifying the ai is very impressive.  

Share this post


Link to post
Share on other sites

I have noticed that AI placed in Editor, MCC or Zeus never remain in place when disturbed by fire or presence of an opposing force (even a passing aircraft). No matter what script is running in the init, they immediately leave their position and start scouting around, or running towards the spotted enemy.

 

Is there any way to fix them in place? Best method I have found (not foolproof) is MCC's Guard command.

 

Yes, you can use the disableAI command to diasble movement. More info here:

 

https://community.bistudio.com/wiki/disableAI

 

Easier solution, get this mod, which adds a bunch more options to the Eden interface, including one to stop movement in the unit attributes (basically just a GUI option for the above command):

 

https://forums.bistudio.com/topic/188312-3den-enhanced/

Share this post


Link to post
Share on other sites

   This is a great improvement for missions edit.  I am sure it is still working, ( I get shot at) but Installing the script vers, and the init.sqf to a mission folder

Produces an error  =    [] execVM "vcomai \ init.sqf";     missing ;

whats the fix? :ph34r:

Share this post


Link to post
Share on other sites

I have noticed that AI placed in Editor, MCC or Zeus never remain in place when disturbed by fire or presence of an opposing force (even a passing aircraft). No matter what script is running in the init, they immediately leave their position and start scouting around, or running towards the spotted enemy.

 

Is there any way to fix them in place? Best method I have found (not foolproof) is MCC's Guard command.

this disableai move 

Share this post


Link to post
Share on other sites

 

The only problem I've had so far is it seems to make the support module that's present on some scenarios take incredibly long to respond to prompts.

   And to confirm this, my buddy and I are seeing this as well.

Share this post


Link to post
Share on other sites

Hi Genesis. Just some feedback. Loving the AI, thanks.

Please just check if "this setVariable ["NOAI",1,false];" Is the correct syntax for your script. It threw thousands of errors in the line of "Integer detected, bool expected". When I changed it to this setVariable ["NOAI",true,false]; The errors stopped. 

Also could you please maybe give some indications what each movement order does. Like "Guard" sets a small area patrol, Loiter does this, etc etc etc. Thanks man, appreciate all your work!

Share this post


Link to post
Share on other sites

Hi genesis92x! Awesome AI mod. It is a clear improvement over vanilla!

 

I have a strange question. I am in the process of making a mission template for my group and I was in the process of integrating VCOM AI into it. With the script version, I can easily activate/deactivate it using a mission parameter. Would it be possible to do the same using the addon version?

 

Cheers.

Share this post


Link to post
Share on other sites

   And to confirm this, my buddy and I are seeing this as well.

I was starting to think it might just be my setup. Any ideas on how to fix it?

Share this post


Link to post
Share on other sites

For some reason with newest VCOM the AI simply stops when set in combat mode. I noticed an AI squad just standing in a middle of the street. I joined them (via ACE) and ordered them to move, thing happened. With VCOM addon disabled they move in combat mode as they used to (bounding overwatch etc.).

Share this post


Link to post
Share on other sites

Hi Genesis. Just some feedback. Loving the AI, thanks.

Please just check if "this setVariable ["NOAI",1,false];" Is the correct syntax for your script. It threw thousands of errors in the line of "Integer detected, bool expected". When I changed it to this setVariable ["NOAI",true,false]; The errors stopped. 

Also could you please maybe give some indications what each movement order does. Like "Guard" sets a small area patrol, Loiter does this, etc etc etc. Thanks man, appreciate all your work!

 

Thank you, i'll use    ' this setVariable ["NOAI",true,false]; ' so.

 

The Pre-created difficulty settings file    readme told me:

 

 

backup the original .sqf that came with your VCOM_AI mod.

 

But i have not any .sqf into my VCOM folder, just ' AISettingsV2.hpp ' is this normal?

Share this post


Link to post
Share on other sites

 

The Pre-created difficulty settings file    readme told me:

 

Quote

 

backup the original .sqf that came with your VCOM_AI mod.

 

But i have not any .sqf into my VCOM folder, just ' AISettingsV2.hpp ' is this normal?

 

   The .sqf file should be located in the "root" Arma/userconfig/VCOM_AI folder.

 

EDIT: It appears that the .sqf is in the script version of the latest download. and missing from the mod version. I don't know enough about mods to know whether this is a packaging mistake or not.

Share this post


Link to post
Share on other sites

Thanks so much for the update Genesis.

 

$10 in your Paypal as promised ;)

Share this post


Link to post
Share on other sites

I'm having trouble getting VCOM AI 2.5 working on our dedicated server and was hoping someone could help with the following questions?

 

1) Is VCOM AI a server side mod or do both the client and server need it installed?

2) Version 2.5 came with an hpp user config. Is this correct or should it be an sqf?

3) If VCOM is needed server and client side, do the clients also need the user config file?

 

EDIT: When I run the mod client side and server side with user configs (Arma3/userconfig/VCOM_AI/AISettingsV2.hpp) client and server side, the mod seems to load default settings and nothing I change affects the AI reactions. File patching is activated on the server but not on the clients.

 

In the config where it says VCOM_AIConfig = "Userconfig folder"; 

Am I supposed to put the file directory of the user config there or is that just a variable that indicates that the userconfig is located there. 

 

Razor

Share this post


Link to post
Share on other sites

   This is a great improvement for missions edit.  I am sure it is still working, ( I get shot at) but Installing the script vers, and the init.sqf to a mission folder

Produces an error  =    [] execVM "vcomai \ init.sqf";     missing ;

whats the fix? :ph34r:

 

Seems To Now be OK. (after I hacked at the .sqf for a day or so). .sqf is  as instructions.. Error just stopped.  B)

These are some bad ass duded now..  LOL

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×