Jump to content
genesis92x

Vcom AI V2.0 - AI Overhaul

Recommended Posts

Can someone from ArmAholic update it there too? I am getting questions about it :) Thank you!

Sorry, did not see your previous update. I did see you released test versions and did not want those mirrored but I overlooked that genuine release :(

Updated versions frontpaged on the Armaholic homepage.

 

news_download_a3_3.png

Vcom AI - Mod v2.20 revision 2

Vcom AI - Script v2.20 revision 2

Share this post


Link to post
Share on other sites

2r5ep80.jpg

Is there a special way to install the PBO version? I extracted to the userconfig folder too.

Share this post


Link to post
Share on other sites

2r5ep80.jpg

Is there a special way to install the PBO version? I extracted to the userconfig folder too.

+ 1

Sent from my iPhone so pardon any autocorrect bollocks

Share this post


Link to post
Share on other sites

2r5ep80.jpg

Is there a special way to install the PBO version? I extracted to the userconfig folder too.

 

Launch with -filePatching

Share this post


Link to post
Share on other sites

Launch with -filePatching

I second Pulstar. -filePatching is turned on, userconfig folder updated, main vcom folder updated. EDIT: My error message displays "script VCOMAI\AIBEHAVIORNEW.fsm not found"

Looking forward to giving this new version a whirl, though!

Share this post


Link to post
Share on other sites

I'm getting a "Script VCOM\AIBEHAVIOURNEW.fsm not found" error when I start a mission. Userconfig and filepatching both done.

Share this post


Link to post
Share on other sites

I'm getting a "Script VCOM\AIBEHAVIOURNEW.fsm not found" error when I start a mission. Userconfig and filepatching both done.

Me too.

Share this post


Link to post
Share on other sites

I've downloaded the script version of VComAI. Included in the zip is the userconfig folder and contents; however I thought the idea of a script was it didn't need the userconfig settings? If userconfig is needed I may as well get everybody in my clan to download the mod, which the script version is supposed to prevent?

 

Could somebody please confirm?

 

edit: ignore me, found Genesis92x post about requiring userconfig on the host to prevent crashing

Share this post


Link to post
Share on other sites

Me too.

 

+1

 

Same error message, same parameters, no other mods.

 

Should also say, this is when loading in a single solider in the 3D editor and playing.

Share this post


Link to post
Share on other sites

I've downloaded the script version of VComAI. Included in the zip is the userconfig folder and contents; however I thought the idea of a script was it didn't need the userconfig settings? If userconfig is needed I may as well get everybody in my clan to download the mod, which the script version is supposed to prevent?

 

Could somebody please confirm?

 

edit: ignore me, found Genesis92x post about requiring userconfig on the host to prevent crashing

Yeah :) The host will need it unfortunately - if you want to use it. Otherwise just ignore the message.

 

+1

 

Same error message, same parameters, no other mods.

 

Should also say, this is when loading in a single solider in the 3D editor and playing.

Host needs the userconfig folder

 

 

Sorry, did not see your previous update. I did see you released test versions and did not want those mirrored but I overlooked that genuine release  :(

Updated versions frontpaged on the Armaholic homepage.

 

news_download_a3_3.png

Vcom AI - Mod v2.20 revision 2

Vcom AI - Script v2.20 revision 2

 

No problem! Thank you!! I will probably have another version up shortly. Looks like something went wrong with the released mod version >< Doh.

 

 

Edit: This is why you dont work on things when you're sick!

If y'all got the time - try these versions :> Should of fixed the mod.

VcomAI Mod Version 2.5

 

VcomAI Script Version 2.5

 

^Can these be updated on ArmAholic as well? Thank you guys so much for your hard work :)

  • Like 1

Share this post


Link to post
Share on other sites

Host needs the userconfig folder

 

I have the userconfig folder setup with the appropriate file/subfolder

Share this post


Link to post
Share on other sites

No error popups now, thanks a lot! :)

A step in the right direction, thank you :)

 

Also for those who may be interested Pvt.Partz sent me these files for difficulty settings for VcomAI

 

I will package them in with the next version but here is a link for them now, in case anyone was interested :)

 

Download

Share this post


Link to post
Share on other sites

   Does your UserConfig/VCOM_AI/,...sqf file contents change, when ever you make updates/changes to your mod? If so then the files I uploaded may quickly become reduntant.

Share this post


Link to post
Share on other sites

I use [CTI COOP] Liberation and would like to know how I can adjust Atelari!

 

Can anyone of you help PLEASE??

 

//The following commands are to be left alone, except under rare circumstances.
MarkerArray = [];
VcomAI_UnitQueue = [];
VcomAI_ActiveList = [];
ArtilleryArray = [];

Share this post


Link to post
Share on other sites

Tried and played VCOM 2.5. It works! :)
 AI was very much more human like and more interesting. Saw being used shot detection, support call, smoke, mines, artillery, garrisoning, vehicle transport. 

The combat/stealth waypoint issue though still is in. A fix is to assign 2 extra move waypoints before the combat/stealth waypoint. Also some snipers stopped and blew themselves up with mines.

Thank you!

Share this post


Link to post
Share on other sites

No worries, we just figured you were keeping in tradition with goofing the first upload each time. :D

The AI seems pretty balanced now. I followed some squad on squad urban engagement setups, and they maneuvered well, took cover around corners, and waited in some firing lanes that resulted in ambushes. They also bounced back and forth between waypoints sometimes, but overall pretty awesome. :D Same thing in rough, non-urban terrain. Your flanking AI behavior is wicked!

 

I think pvt.partz may have done goofed on his -20% Hard skill level, b/c all the settings are defined as 0.88 or +random .88 when I think they are either meant to be variously .8 or + random .08. Some of the other difficulty levels also seem to be inconsistent with .7 versus .07 or .9 versus .09 (compared to the standard 1.0 for commanding, general, spottime, spotdistance, etc.

 

Also, acc to the wiki, higher reloadSpeed (closer to 1.0) means faster reload speed. Did you guys mean to give your AI higher ranks lower reload speed?

 

https://community.bistudio.com/wiki/AI_Sub-skills

 

 


No problem! Thank you!! I will probably have another version up shortly. Looks like something went wrong with the released mod version >< Doh.

 

 

Edit: This is why you dont work on things when you're sick!

Share this post


Link to post
Share on other sites

I think pvt.partz may have done goofed on his -20% Hard skill level, b/c all the settings are defined as 0.88 or +random .88 when I think they are either meant to be variously .8 or + random .08. Some of the other difficulty levels also seem to be inconsistent with .7 versus .07 or .9 versus .09 (compared to the standard 1.0 for commanding, general, spottime, spotdistance, etc.

   The calculations were simply a reduction or increase in percentages. I will recheck those numbers again to be sure they are consistant.

 

Edit:

@dakaodo

You have a very sharp eye sir! Thanks for watching out.

 

The files have been checked and re-upped

 

https://www.dropbox.com/s/9t7xktf5jp18867/VCOM_AI%20Modified%20Difficulty%20Levels.7z?dl=0

  • Like 1

Share this post


Link to post
Share on other sites

Hi genesis92x, you have a PM regarding Mod FFAA compatibility with VCOM, I want to thanks you the excellent job you have done with the AI behavior.

Share this post


Link to post
Share on other sites

Hi genesis92x, you have a PM regarding Mod FFAA compatibility with VCOM, I want to thanks you the excellent job you have done with the AI behavior.

As far as i know it should work with any mod, (Minus Ryanzombies), I run the addon version and these mods i know work when it comes to units/vehicles 

  1. OPTRE (First contact included)
  2. RHS
  3. CUP
  4. Lieghts OPFOR
  5. PG Services
  6. Massis mods

So i dont know why FFAA wouldnt work if it doenst, But it would most likely work i believe 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×