Jump to content

Recommended Posts

12 hours ago, baton1990 said:

I launched your test mission http://steamcommunity.com/sharedfiles/filedetails/?id=954149033&searchtext= on local server with Vanilla Arma 3, CBA and ACE. AIS not work (not init as you say) but also ACE buttons and menus stop working.

What part of 'AIS WILL NOT INIT IF ACE IS IN USE' did you not understand ?

Share this post


Link to post
Share on other sites

Understand. But I need ACE work. I want make scenario in what you can play without ace using Psyho's revive script or with ace using ace medical system.

Share this post


Link to post
Share on other sites

He dont want to use both at the same time. He want to set up a mission where it is regardles if you have ace or not. in both cases you have a medic system.

I will check this out. but i cant imagine how ais can have a impact on the ace key bindings...

 

regards

Share this post


Link to post
Share on other sites
On 7/3/2017 at 5:00 PM, baton1990 said:

I launched your test mission http://steamcommunity.com/sharedfiles/filedetails/?id=954149033&searchtext= on local server with Vanilla Arma 3, CBA and ACE. AIS not work (not init as you say) but also ACE buttons and menus stop working.

 

Is AIS still trying to init while ACE is present? Have you tried removing the script that initializes AIS? 

 

Best bet would create a switch, if ACE_Core is absent call "AIS_blahblah.sqf"

Share this post


Link to post
Share on other sites
On 7/3/2017 at 5:00 AM, baton1990 said:

I launched your test mission http://steamcommunity.com/sharedfiles/filedetails/?id=954149033&searchtext= on local server with Vanilla Arma 3, CBA and ACE. AIS not work (not init as you say) but also ACE buttons and menus stop working.

 

I can confirm this is indeed happening. Here is the report I have:

 

I am having some issues with ACE compatibility. It seems like ace is deactivated by the mission (no windows key context menu), but the default medical system does not activate even with ace not working. I still see the ace bandages but am not able to use the medical menu or the context menu to check/bandage players. If I disable ace medical the default scroll wheel med system works again. This is on a dedicated server with no headless clients. I will grab the rpt file tonight when I get back from work but just wanted to check if this was a known issue or I am missing something in the config files.  

 

Disabling the below in description.ext enabled ACE interactive keys within the mission.pbo. 

 

#include "AIS\Effects\BarDlg.hpp
 
};
class CfgFunctions {
    #include "AIS\cfgFunctions.hpp"
};
  • Like 1

Share this post


Link to post
Share on other sites

I am planning to do a small modification which will require first aid kit for stabilization.
It will consume the first aid kit if present in _injured, if not from _healer inventory.

I can roughly think how to do this modification.

But I also wanna make use of medkits. Such as: for revive medics need medkit to be present in their inventory.
The problem I have with this is medics can also use this medkit to heal people unlimited times. I want medkit to be useless in practice, just an item in inventory for allowing revival.

Any tips ?

Share this post


Link to post
Share on other sites

@Psychobastard Really love the Script!  I'm trying to add a Medivac vehicle. Not wanting to use a Blackfish or Tent etc. Am new to the world of scripting and syntax..lol  Does it use the class Name?? Wanting to use the uh-60m MEV (ESSS) medical transport, CUP_B_CH47F_USA or taro pods.. Really Appreciate all your hard work. Thx

 

Share this post


Link to post
Share on other sites

Its not the classname. Use one or more unique variable names.

 

AIS_MEDEVAC_STATIONS	=	[ [myMedevacVehicle, 15], [myMedicTent, 10] ];	

 

Share this post


Link to post
Share on other sites

I read somewhere that this mod used to enable AI to heal AI automatically, but not anymore since recent update. Is that so? I know right now AI won't go revive others by themselves but will it be enabled in future again?

Share this post


Link to post
Share on other sites

Hellow, it is me again. Im not sure but I think I found soultion for ace compatibility. In file AIS\Core\fn_preinit.sqf you need remove or disable by // lines:

 

removeAllMissionEventHandlers "Draw3D";
removeAllMissionEventHandlers "EachFrame";

 

After I did It all seems work fine with ACE and without ACE. But Im not sure for 100%. It need more testing.

  • Like 1

Share this post


Link to post
Share on other sites

Hello Psychobastard,

first, thanks for your hard work on this script.

 

I want  to give your script a try on my next mission for our small friends community. :) Up to know we're using ACE, but we want to keep it more simple, but also more realistic than basic vanilla. If your script works fine in the first test, we will use this with Vanila instead of ACE. 

One question: I made a simple mission just for testing it on my dedicated and the stabilize, revive, drag, carry, unload/load features are working fine, but I realized that unconscious player can use the TFAR anyway AIS_TOGGLE_RADIO is set to true in your setup sqf. Any idea or known issue?

 

Share this post


Link to post
Share on other sites

I'm running ALIVE snd syder addons recruitment module.  Where do i need to put. [_unit] call AIS_System_fnc_loadAIS

 

To allow recruited AI to use revive functions?

 

Thank you so much for this awesome script.

Share this post


Link to post
Share on other sites

Hi folks,

 

I observed a problem with the carrying since last update, even when my player unit is NOT from a mod:

 

whenever I choose it in scroll menu, I am stuck after the animation showing how I load the wounded on my shoulders is finished.  Only way to get moving again is to choose dragging again.  Then it plays the animations of putting the wounded on the ground, after this the animations for the drag and then I can drag and from this dragging mode I'm also able to releas/drop the injured, which doesn't work from the carry position anymore. 

 

Any ideas how to fix that?  Did anyone else have this problem?

 

Kind Regards

 

tourist

Share this post


Link to post
Share on other sites

I have a similar problem but I'm not sure if it's related to yours, @tourist. I have no idea how to fix it but I found that it's related to a certain mod.

 

My player character gets stuck at the point where he switches from the dragging animation to the lift-up-the-injured-one animation.

 

Check out the video:

 

 

Unfortunately the bug only comes when launching the game together with MOCAP Melee.

 

Any idea, psycho? :float:

Share this post


Link to post
Share on other sites

@tourist, no other mods loaded? (like Undeceived)

 

@Undeceived, i dont know this mod and i cant check compatibility with any other mods out there. :( Only chance is to have a look in this mod and check it for some anim event handlers (f.e.). Other question: who is "Costa" in your video? Players character?

 

 

regards

Share this post


Link to post
Share on other sites

Thanks a lot, @Psychobastard, your mod and forum support is great! :icon14: Of course it's understandable that you can't check other mods. What I can say is that I didn't have this problem with an older version of the AIS. :icon_biggrin: 

 

Costa is an AI teammate (not playable) in the campaign where I use your AIS. But he's not related to the video above in any way.

Share this post


Link to post
Share on other sites
On 8/5/2017 at 11:38 PM, Undeceived said:

Check out the video:

 

Any idea, psycho? :float:

 

I got same problem with animation state when I launched your example mission on steam. Animation is buggy. I was checking this example mission WITHOUT any mod, just with vanilla.

 

 

Share this post


Link to post
Share on other sites

I checked the example mission both without any mods and with MOCAP.  When MOCAP is active, the exact same thing happens in my game as shown in Undeceived's video. But even without this mod - and to make it more precise, without any other mod as well - the transition from dragging to carrying animation is playing like in Undeceived's video.  The only difference is that while I'm stuck when MOCAP is acticve, I can move again after the animation is finished when playing without MOCAP.  But if I press "W" for walking with the loaded casualty, the unloading and then loading animations are played (again), ending with the casualty loaded correctly on my shoulders. Then I can walk as I please.  Uploading a vid now, but that will take a while due to slow upload speed of my ISP. 

 

 

Edited by tourist
Video added

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×