Jump to content
Sign in to follow this  
Dwarden

BattlEye Installers (A2:OA, A2: RFT, A2)

Recommended Posts

as you can see, the problem is unrelated to STEAM (at least the application part)

beta build 75666 http://www.arma2.com/beta-patch.php is affected aswell ...

fix will be out when we kill the bug

Hi Dwarden,

I already posted on the Troubleshooting forum but will post here as well. I have the same problem as many other people since STEAM update 13.11.10, can't join any 1.55 BE-Servers.

I tried to run beta patch 75666 - no joy. Now here is the thing...with all due respect... how can you say that the problem is unrelated to STEAM, when all STEAM users i know of have this problem? All the guys playing on BE-servers all have NON-STEAM versions. This only seems to be a problem since the automatic update from STEAM from the 13.11.10. You say that you know STEAM users who claim to be able to play to play on 1.55 BattleEye servers. Is it possible that you could ask for their setup and their details? What is their game version? As much information as possible, as unrelated as it seems to be to the problem. Whats their operating system? I'm very curious how they do it, maybe then we can work out whats wrong.

We tried everything so far, reinstalling latest BattlEye, running STEAM as administrator, with and without beta patch, tried rolling back to older 1.55 beta patches... no joy.

Hope you guys find a solution soon since we are all waiting patiently for news and a resolution. Good luck, keep us posted!

Windows 7 64bit home premium, everything installed through steam.

Share this post


Link to post
Share on other sites

Well I tried uninstalling BE, deleting the BE files from my user profile and cleaning the registry. Reinstalling BE both from Steam and manually from their website still locked me out of the 1.55 servers.

I uninstalled BE, uninstalled OA from Steam and bought a new install from Sprocket. Installed the Sprocket version, updated OA and launched into MP and joined a 1.55 server that had previously locked me out. OA reported updating BE client. No problems since.

Cost me $40 for a new copy of AO but I'm rid of Steam, the problems associated with it and delays in Arma patches.

This issue may not be directly caused by Steam, but it surely was affected by it in my case.

Share this post


Link to post
Share on other sites
Well I tried uninstalling BE, deleting the BE files from my user profile and cleaning the registry. Reinstalling BE both from Steam and manually from their website still locked me out of the 1.55 servers.

I uninstalled BE, uninstalled OA from Steam and bought a new install from Sprocket. Installed the Sprocket version, updated OA and launched into MP and joined a 1.55 server that had previously locked me out. OA reported updating BE client. No problems since.

Cost me $40 for a new copy of AO but I'm rid of Steam, the problems associated with it and delays in Arma patches.

This issue may not be directly caused by Steam, but it surely was affected by it in my case.

Thx Tex Zero,

that pretty much says again that the issue is Steam related. Will consider your solution to the problem if BI don't come up with something the next one or two days and buy the game on CD. Its been 4 days now...

Share this post


Link to post
Share on other sites

I have been doing some testing with my own client /dedicated server setup (both standard steam installs A2,A@OA, BAF updated on 13/11/2010).

I have discovered that the BattlEye non intialisation problem occured first with beta patch 75445.

To elaborate server is running arma2oaserver.exe updated manually from steam on the 15/11/2010 other than that all other files autoupdated from steam on 13/11/2010.

If client is running beta patch 74858 (updates client to 1.55) i have no problem joining my own or any other 1.55 server WITH BattlEye enabled.......install beta patch 75445 and then cannot join my own or any other BattlEye enabled 1.55 server.

Looking at the changelog for 75445 it seems that a new feature was added that allowed the client to disable or enable vsync.....my guess is that this routine has somehow broken BattlEye initialisation for steam users....maybe not but it appears that something was done by the developers between 74858 and 75445 that broken BattlEye initialisation particularly for Steam users.

Conclusion is that this is most likely a Steam/BI problem and not a BattlEye problem.

Workaround for steam users is to install and use beta patch 74858 until this is sorted out.

Share this post


Link to post
Share on other sites
I have been doing some testing with my own client /dedicated server setup (both standard steam installs A2,A@OA, BAF updated on 13/11/2010).

I have discovered that the BattlEye non intialisation problem occured first with beta patch 75445.

To elaborate server is running arma2oaserver.exe updated manually from steam on the 15/11/2010 other than that all other files autoupdated from steam on 13/11/2010.

If client is running beta patch 74858 (updates client to 1.55) i have no problem joining my own or any other 1.55 server WITH BattlEye enabled.......install beta patch 75445 and then cannot join my own or any other BattlEye enabled 1.55 server.

Looking at the changelog for 75445 it seems that a new feature was added that allowed the client to disable or enable vsync.....my guess is that this routine has somehow broken BattlEye initialisation for steam users....maybe not but it appears that something was done by the developers between 74858 and 75445 that broken BattlEye initialisation particularly for Steam users.

Conclusion is that this is most likely a Steam/BI problem and not a BattlEye problem.

Workaround for steam users is to install and use beta patch 74858 until this is sorted out.

You're a bloody genius! :o

Share this post


Link to post
Share on other sites
I have been doing some testing with my own client /dedicated server setup (both standard steam installs A2,A@OA, BAF updated on 13/11/2010).

I have discovered that the BattlEye non intialisation problem occured first with beta patch 75445.

To elaborate server is running arma2oaserver.exe updated manually from steam on the 15/11/2010 other than that all other files autoupdated from steam on 13/11/2010.

If client is running beta patch 74858 (updates client to 1.55) i have no problem joining my own or any other 1.55 server WITH BattlEye enabled.......install beta patch 75445 and then cannot join my own or any other BattlEye enabled 1.55 server.

Looking at the changelog for 75445 it seems that a new feature was added that allowed the client to disable or enable vsync.....my guess is that this routine has somehow broken BattlEye initialisation for steam users....maybe not but it appears that something was done by the developers between 74858 and 75445 that broken BattlEye initialisation particularly for Steam users.

Conclusion is that this is most likely a Steam/BI problem and not a BattlEye problem.

Workaround for steam users is to install and use beta patch 74858 until this is sorted out.

it hasn't been confirmed by BI or BE, has it..?

hm its good to know their supporters are coming with conclusions faster then they are.

Share this post


Link to post
Share on other sites
what prevents you to disable BE for time until this is resolved?

We play an ArmA Cup right now and this 1.55 patch with all it's 'features' has already resulted in one team dropping out because they cannot play anymore due to the BE error. This suck's _ pardon my language.

We cannot just disable BE as we need it to catch cheats in the league.

Please try to do some better regression tests before the next patch, please.

Share this post


Link to post
Share on other sites

It would be nice to get PMC addon for free as a "sorry" for Steam users... :rolleyes:

Share this post


Link to post
Share on other sites

bug was isolated and analysed in laboratories ...

our scientists works now on best way to kill it :)

ETA .... Soonâ„¢

p.s. once again it's not related to STEAM

Share this post


Link to post
Share on other sites

The issue has been identified and a BE update fixing it will be released shortly.

There has been a change in recent OA versions that couldn't be expected which affects the BattlEye initialization. This change is present in all game editions, however it doesn't cause any problems in SecuROM-protected versions.

Again, I'm really sorry for this and apologize for any inconveniences caused.

Share this post


Link to post
Share on other sites

Glad you found it!

Still say a Release Candidate full build would help in future, even if the non full build beta's are currently considered RC's.

Edited by Wildgoose

Share this post


Link to post
Share on other sites

Damn! No free PMC addon for STEAM users... :) I'm glad you have found the bug. Do not kill your pets.

Edited by Vipera

Share this post


Link to post
Share on other sites
Alright, BE Client v1.145 has been released.

Please manually update from http://www.battleye.com/download.html to fix this issue. I think Dwarden will also release an updated BE installer ASAP.

bug was isolated and analysed in laboratories ...

our scientists works now on best way to kill it :)

ETA .... Soonâ„¢

p.s. once again it's not related to STEAM

Thx guys, will check it out ASAP!:)

Share this post


Link to post
Share on other sites
Damn! No free PMC addon for STEAM users... :) I'm glad you have found the bug. Do not kill your pets.

Everyone will get a lite version anyway if they do the same as they did with BAF. :D

The new update seems to work fine btw.

Edited by CerberusDog

Share this post


Link to post
Share on other sites

fixed version of BattlEye was published as v 1.145

ARMA 2: OA

MD5 hash of BEClient.dll : 4c264f6ef36dcda395e22b38bc39ac02

MD5 hash of BEServer.dll : 0ab3358e4cdf7a9c64209dadbd1f2e19

ARMA 2

MD5 hash of BEClient.dll : f1d4243ba0500778e12afc0c59fd8b46

MD5 hash of BEServer.dll : 404cb417c0c8a98bf34e899aad67fd6a

files are available for manual download here http://www.battleye.com/download.html

(overwrite the ones on your drive)

the installer will be published later (hopefully soon)!

Edited by Dwarden

Share this post


Link to post
Share on other sites

I've downloaded both updates for vanilla Arma2 beclient.dll (put in Arma2\BattlEye folder) and also the OA beclient.dll (put in Arma2\Expansion\BattlEye folder) and I'm still getting kicked from servers... wtf?

To double check I just checked that MD5 thingy as well and they're both correct.

The strange thing is, one of the 1.55 servers I tried to join had BE turned OFF.

Scratch that, it only seems to be AEF servers that won't let me join. False alarm, now to follow up with AEF to see what the go is =/

Edited by Dwarden

Share this post


Link to post
Share on other sites
Can you let Steam update the games?

working on it, for now you must do it manually

Share this post


Link to post
Share on other sites

i have steam versions of arma2 and oa ! i cant play oa, because battleye initialization failed. the manually update of the be dll's didnt work in oa ! after updating arma2 beclient ingame upto 1.145 i got the message "corrupted memory" !! i bought yesterday oa via steam and since them i cant play any version online on battleye required server. installing arma2 or oa standalone without any effect. in arma2 i got the "corrupted memory" error after updating beclient and in oa i still failed of "battleye initialization" !! whtas happend ?

- oa standalone works now (after re-verification of install), but i still got in arma2 the error "corrupted memory" !!!

Edited by -Flo-

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×