Jump to content
Sign in to follow this  
Dwarden

BattlEye Installers (A2:OA, A2: RFT, A2)

Recommended Posts

I still cannot connect to server due to initialisation error.

I've replaced the files manually following the instructions with the correct versions (OA etc) from battleye.com

It appears from my .rpt that battleye isn't even starting as the last entry mentioning battleye was last night at 19:29 when I gave up. It says Battleye updated to 144.

Any idea's before I throw my pc out the window?

Oh and I know the current version is 145, thats the one I got from website :(

The user above resolved his issue.

After uninstalling and reinstalling BE (for both ARMA2/ARMA2:OA) he was accessing the BE website to update the BEClient.dll & BEServer.dll with the 'Chrome' browser; which wasn't showing the latest page update (was still showing xxx.144 as the latest client file while on my 'IE' browser I was seeing xxx.145) - After sending the user my ARMA2/ARMA2:OA BE BEServer & BEClient.dll's and the user placing them into the relevant directories he was back up and running.

Share this post


Link to post
Share on other sites

sounds like cache issue ...

anyway why not use the up2date installer (it has v145) from first post ?

Share this post


Link to post
Share on other sites
sounds like cache issue ...

anyway why not use the up2date installer (it has v145) from first post ?

Indeed, as I indicated to the user when discussing his issue.

The installer wasn't used as this was done before the new updated URL was posted by yourself :p

Share this post


Link to post
Share on other sites

Ever since installing the latest set of ArmA2/OA/BAF updates, I have been unable to join any MP games.

I get a message "You were kicked form the game", "This server requires Battleye to join" even though I know I have instaleld/reinstalled Battleye.

What is going on?

I have non-steam versions of Arma2/OA/BAF and installed all the latest patches. I've never had this error message before.

What is the problem?

Share this post


Link to post
Share on other sites

did you installed the hotfixed version of BAF installer ? (download this 3.5MB file from downloads page and run it and it's done)

Share this post


Link to post
Share on other sites

Anyone with the problem Battleye patch corrupted #0 this is how i fixed mine.

Firstly there are three Battleye folders, one in the main Arma2 directory, one in the Arma2/Expansions folder and one in the Arma2/Profiles folder.

In the first two Battleye folders there are two dll files (client and server), in the third one you will find one dll file (client).

Google Battleye and find the downloads section, from that download the client and server dll files for Arma2 and Arma2 OA, then delete the current dll files you have in all three of your Battleye folders, then replace them with the files you have downloaded, put the Arma2 client and server dll files in the Arma2/Battleye folder and just the Arma2 client dll in the Profile/Battleye folder, then put the Arma2 OA client and server dll files in the Arma2/Expansions/Battleye folder.

This fixed mine i hope it fixes yours.

Edited by bazeye

Share this post


Link to post
Share on other sites

I am still having trouble with my dedicated server.

I am running a dedicated server in Combined Operations mode from a Steam install. I did this by modifying the _runA2CO.cmd script to include a "-server" option. Ever since the update to 1.55, I get "BattlEye Initialization Failed" in the dedicated server console when attempting to launch.

I did exactly what the post above said to do (manually d/l'ed BattlEye and put it in the 3 different places), and the console printed this:

14:44:08 Dedicated host created.

14:44:10 BattlEye server updated to version: 111

14:44:10 BattlEye initialization failed

I don't seem to have any problems joining servers that use BattlEye so the client appears to be fine. I just can't get a dedicated server to launch with BattlEye enabled.

Share this post


Link to post
Share on other sites

new installers are up, again some bug fixes included ... (e.g. server's BE failed to INIT one)

Share this post


Link to post
Share on other sites

ofcourse that's why these updates were released ;)

they also included in the update 1.56 installer

Share this post


Link to post
Share on other sites
again some bug fixes included ... (e.g. server's BE failed to INIT one)

This has also been fixed via auto-update yesterday (BE Server v1.112).

Share this post


Link to post
Share on other sites

hey,i applied the client patch and PMC DLC today to my game and patched my server by my server host to 1.56

Now when connecting to my server i get the message:

You were kicked off the game (BattlEye Corrupted Memory #0)

I can read that BEclient init´ed,get the GUIDnumber displayed but then the above message throws me off in ms´s

Looks like to be a server issue,something seem to be gone wrong @ patching it,gonna slap my server host today ...

If i disable BE all seems good to play,but i dont want that to be the future - gonna have a look

*edited 1.12.2010*

--------------------------------

my server provider updated the dll´s provided on the Battleye homepage,restarted it several times and did some other unknown stuff and now it runs fine again

FIXED

Edited by TheScar
addition

Share this post


Link to post
Share on other sites

Ever since the update to v1.56 virtually everyone that I know now can no longer play on a BE enabled server due to getting the You were kicked off the game (BattlEye Corrupted Memory #0) error.

There has to be a serious issue with the latest version of BE, looks like time to turn it off unless someone has got some ideas other than re-installing as two members have done that to no avail. Also tried all of the usual manual update of BE, ran the installer etc. etc.

Share this post


Link to post
Share on other sites
a BE enabled server due to getting the You were kicked off the game (BattlEye Corrupted Memory #0) error.

see my post above,its a server provider issue not a client issue

Get the admin/server provider of the server u play on to check his install and to update the dll´s of BE to the newest version and you all should be good to go

:cool:

Share this post


Link to post
Share on other sites

When I run dedicated server with this parameters:

"C:\Games\ArmA 2\arma2oaserver.exe" -config=server.cfg -netlog -port=2302

all is ok

But when I run dedicated server with this parameters:

"C:\Games\ArmA 2\arma2oaserver.exe" -netlog -port=2302 "-profiles=c:\Games\ArmA 2" -name=profile1 -config=Users\profile1\server.cfg -netlog -port=2302

I getting the You were kicked off the game (BattlEye Corrupted Memory #0) error.

I manually copy BatttEye folder from

c:\Users\Selya\AppData\Local\ArmA 2 OA\

to

c:\Games\ArmA 2\Users\profile1\

but I getting the same error.

Can anybody help me, plz?

Solved. Must be: "-profiles=c:\Games\ArmA 2\Expansion"

Edited by Selya

Share this post


Link to post
Share on other sites
You were kicked off the game (BattlEye Corrupted Memory #0)
If as a server admin running a combined operations (A2 + OA) server your players are getting the above error, the fix is to copy the dll files from 'ArmA2\Expansions\BattlEye' and place them in the 'ArmA2\BattlEye' folder.

Share this post


Link to post
Share on other sites
But when I run dedicated server with this parameters:

...

I getting the You were kicked off the game (BattlEye Corrupted Memory #0) error.

This is due to the BE Server being loaded from the BattlEye folder in "c:\Games\ArmA 2" here, which is the version for ArmA 2.

Share this post


Link to post
Share on other sites
This is due to the BE Server being loaded from the BattlEye folder in "c:\Games\ArmA 2" here, which is the version for ArmA 2.

This is the issue and makes no sense, if you run a A2 + OA server why does it take the files from there and not "c:\Games\ArmA 2\Expansions\BattlEye"?

Doing it this way surely causes issues if you then decide for whatever reason to run just A2 on it's own?

Share this post


Link to post
Share on other sites
This is the issue and makes no sense, if you run a A2 + OA server why does it take the files from there and not "c:\Games\ArmA 2\Expansions\BattlEye"?

Doing it this way surely causes issues if you then decide for whatever reason to run just A2 on it's own?

It makes perfect sense, because you used "-profiles=c:\Games\ArmA 2", which causes the BE working directory to be located there. Coincidentally the BE files for ArmA 2 are already placed there, which caused them to be loaded in your case.

Share this post


Link to post
Share on other sites

Ah OK, fair enough so if I change my profiles to "-profiles=c:\Games\ArmA 2\Expansion" then it should work correctly using the OA BattlEye without any messing around?

Share this post


Link to post
Share on other sites

Just installed this game and getting the same problem, all I want is to get online and have a game......

Share this post


Link to post
Share on other sites

updated first entry to include BattlEye for ARMA 2: RFT released today

just in case someone has troubles

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×