Jump to content
Sign in to follow this  
Dwarden

ARMA 2: OA beta build 73478

Recommended Posts

You breakin' things Dwarden? :rolleyes:

I haven't seen so many reports of a beta breaking so many things before... I hope you guys get it all sorted. :o

Share this post


Link to post
Share on other sites
Hope they fix the SetIdentity -thing soon. I can't play the game like this...
You dont have to...just launch the non beta shortcut. Beta patches are just that: beta patches. No harm done, next beta will come. The games has reached a complexity where things are easily broken when you fix another.

Share this post


Link to post
Share on other sites
the createVehicle bug is fixed internally

and setIdentity shall be too ...

... wait for next beta

Thanks, Dwarden :)

I know how it is when an innocent change in code in one place has unforeseen consequences elsewhere. That's the nice thing about having these betas, so that the official patches are ready to roll :bounce3:

Share this post


Link to post
Share on other sites
Yeah, but that kind of feels like a step backwards.

So far the developement of ArmA 2 / O.A. has made many big steps forward from my point of view.

So i guess this little step backwards should not be a big problem at all. ;)

Keep it up B.I.S. ( Dwarden ) you're doing a pretty good job. :)

Share this post


Link to post
Share on other sites

Comparing the improvements thus far with this little set back, it's worth it.

Bring it on BIS, more are welcome.

Share this post


Link to post
Share on other sites
Betas should be tested without mods, that was writen here long ago. It's the mod makers task to fix their work to make it working again.

So why don't you post it in the mando thread. At the first reading I thought this was a vanilla beta problem, not a mod induced one.

I would like to clarify this as this is not very accurate:

* it is important to test betas with and without various mods and addons

* generally speaking, we are not intending to break compatibility of any user made content so betas are the best way to enable everyone to test all kind of content and report us any unexpected problems

Share this post


Link to post
Share on other sites

Somehow i got worse performance with this beta patch again.

It would be nice if there would be some performance fixed overall for all islands, i dont know how they are done, but all people are happy if they see performance increases;)

Share this post


Link to post
Share on other sites
Bring it on BIS, more are welcome.

Yeah, for example something fixing the white faces.

Share this post


Link to post
Share on other sites

The white faces? I presume you mean the pale faces? That's caused by how ATI cards handle jpgs. I don't believe there's anything BIS can do to fix it, but if you convert your custom face to paa instead of jpg, the problem should go away.

Share this post


Link to post
Share on other sites

Wuh? I'm talking about how, when I play a mission, 90% of the soldiers I see look like their skin is made of snow-white paper. Their faces, arms and hands are BRIGHT-WHITE. Not pale. It almost looks like they haven't been textured at all.

Share this post


Link to post
Share on other sites
* it is important to test betas with and without various mods and addons

* generally speaking, we are not intending to break compatibility of any user made content so betas are the best way to enable everyone to test all kind of content and report us any unexpected problems

makes sense ! thx for your statement

here's an example of a user-cp, that cannot be loaded with the actual beta(s) (I recognized it first with 73116 and it's still not loading)

might not be a big issue, but this cp http://forums.bistudio.com/showpost.php?p=1449789&postcount=1

doesn't show up in CP-Menue ("no entry 'Campaigns\pullercamp\description.ext.Campaign".) and cannot be loaded with this beta.

Everything's working with A2 (standalone) latest patch and with CO 1.54 official /hotfixed

someone the same problem with any user made missions/camp'ns with latest betas ?

EDIT: found a statement by Bardosy, the maker of "Chesty Puller", will test this and report back ...

The Chesty's text problem may caused in the same reason: the beta-patch don't recognise BIS pbo format anymore and it uses wrong... maybe the stringtable files damaged. I have to rePBO the all campaign.

If it's urgent, you can also do this: dePBO the chesty's pbo file and then pbo it with kegety's cpbo tool. Testers said me, it's works well with newest beta-patch.

source: http://forums.bistudio.com/showpost.php?p=1754964&postcount=355

EDIT2: upper method (Unpbo <cp>.pbo and then making a new <cp>.pbo with Kegety's cpbo-tool works :-)

if anyone encounters same problem ...

Edited by langgis08

Share this post


Link to post
Share on other sites

it would be nice to see arma2oa.rpt on that .pbo it can't load ...

i think i seen something similar but w/o comapring the error line i can't be sure

please make cit report ticket and attach the arma2oa.rpt

Share this post


Link to post
Share on other sites

I just noticed that if you are very close to a tree and sway your weapon against it in first person you dont magically glide away anymore. Instead your weapon moves a bit and you stay were you are. Very nice and i didnt notice it before, though i missed a few beta's.

(In third person you still glide away from the tree though)

Share this post


Link to post
Share on other sites
@NeMeSiS

Huh? I just tried it and you still glide away.

Not in first person you shouldn't. The weapon is now lifted slightly and you can move freely without gliding.

Share this post


Link to post
Share on other sites

was playing around yesterday and alt tabbed to check task manager. OA was using 3gb of memory lol.. anything to do with the new patch?

edit:

did it again, it went to 3gb but kept on rising.. and then oa crashed..

will try w/o mods and then fill a report.

Edited by Fox '09

Share this post


Link to post
Share on other sites

Hmm, cought these in my dedicated server.rpt...

14:45:23 Face

14:45:23 Glasses

Ehh, say what? I'm not outputting those in my mission afaik. Does it have anything to do with new upcoming features?

Share this post


Link to post
Share on other sites
I just noticed that if you are very close to a tree and sway your weapon against it in first person you dont magically glide away anymore. Instead your weapon moves a bit and you stay were you are. Very nice and i didnt notice it before, though i missed a few beta's.

(In third person you still glide away from the tree though)

Which is especially sweet inside buildings (I'm looking at you, narrow staircases), as you don't get hung up on architecture as much.

(Hello SWAT :))

Good work BIS!

Share this post


Link to post
Share on other sites

Some things that are still funny with default AI:

1) place a KSK group (on Desert map) in the middle of the night against OPFOR group with danger/stealth waypoint

soldiers switching to Glock17 and using their tactical lights to reveal themselves

2) place some BLUFOR and OPFOR tanks with some helicopters and planes fighting each other

tanks are using their main (Sabot) guns to fire at aircrafts

3) place a group with AT and AA units vs. motorized + mechanized group + 1 helicopter

AA units will waste their rockets on vehicles, AT units will waste their AT ammo on soldiers

Would be great if the AI could use their weapon/ammo in a professional way with an improved analyzing + prioritizing threat system. Otherwise its imho better to implement a direct control over AI (similar like it was in OFP). AI still dont have the anticipation, knowledge and creativity of humans.

Perhaps something like an switch or option "AI default behaviour" and "AI directly controlled by player"? In this way the player could give the order and the AI would directly follow it. Sometimes you need to micromanage the AI precisely.

Share this post


Link to post
Share on other sites

Did somebody already mention the createVehicle with bombs/artillery shells makes them seemingly have next to no damage anymore?

Share this post


Link to post
Share on other sites

I'm not sure this is a known bug or what so forgive me if it is. I was trying to repair a chopper on the side of a hill yesterday and each time it slid, unkown to me but observed by my gunner, down the hill a bit and touched me, I died. Is this normal?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×