Jump to content

By-Jokese

Member
  • Content Count

    13
  • Joined

  • Last visited

  • Medals

Community Reputation

2 Neutral

About By-Jokese

  • Rank
    Private First Class

Recent Profile Visitors

645 profile views
  1. Could this extension work on rented servers like Nitrado, where you only have access to Arma 3 folder? EDIT: Cant work as only has access to mod parameter, and cant add any other parameter for launch
  2. By-Jokese

    [HELP] CBA Settings Menu

    SOLVED requiredAddons[] = {"cba_settings"}; was requiered.
  3. I want to add to my mod a setting using the CBA Setting Menu. I have followed the Wiki and so far I have done everything, but the Menu is not showing up. On my config.cpp class Extended_PreInit_EventHandlers { class my_preInit { init="call compile preProcessFileLineNumbers 'myAddon\XEH_preInit.sqf'"; }; }; And on my XEH_preInit.sqf: [ "My_ViewDistance", "SLIDER", "View Distance", "My Settings", [200, 15000, 5000, 0], true, {} ] call cba_settings_fnc_init; Settings are just for testing that the menu is showing up. What am I missing? I have been checking other mods that use the CBA, and I don't see nothing different. In Eden Editor CBA Settings Menu is empty. There no error showing up when starting arma or editor. EDIT: I have been following this wiki: https://github.com/CBATeam/CBA_A3/wiki/CBA-Settings-System#create-a-custom-setting-for-mission-or-mod
  4. By-Jokese

    Arma 3 Units - Feedback thread

    I really like the idea, but It must improve quite a bit.
  5. By-Jokese

    Arma 3 Keyframe Animation / TAC OPS

    I have trying many times, but never appeared the red line..... It works but is so difficult without that line...
  6. Thanks! Will try it and see if I have any problems. @HazJ EDIT: is this correct? action = "[ctrlText 100] execVM 'Scripts/script_name.sqf'";
  7. I have a custom dialog, with an edit box and a button. I need to send the text entered by the user to a custom script. What do I have to put in the action parameter for sending that data to the script. Thank you.
  8. That's also interesting, Will give it a look just for learning purposes. Thanks, @rübe!
  9. Swapping Cos and Sin did work. Arma always surprises me....
  10. I have coded this simple scripts, that should place an object (var name "_object"), 1 meter away from the player in the same direction he is facing. _pos = getPosATL _unit; _azimuth = getDir _unit; _far = 1; //Distance from the player to the _object _x = (_pos select 0) + (_far * (cos _azimuth)); _y = (_pos select 1) + (_far * (sin _azimuth)); _obj = createVehicle [_object, [_x, _y, (_pos select 2)], [], 0, 'CAN_COLLIDE']; I have used that technique on many other sites, but cant make it work in Arma... The object keeps spawning where it wants.... (Not random location but depending where you are facing it has 2-3 different locations where it spawns)... Can any help?
  11. By-Jokese

    Run server 64bit error

    Did you solve it? If that's the case, could you point to the solution?
  12. Sorry for posting here, but arma does not allow me to post out. I have same problem, could any help me? I have this on my config.cpp class my_class: object_class { //this is correct scope = 2; accuracy = 10000; armor = 5000; displayName = "the_name"; model = "\pbo\to\the\object.p3d"; class EventHandlers { init = "(_this select 0) execVM ""\pbo\to\the\virtual_arsenal_init.sqf""" }; }; An on the virtual_arsenal_init.sqf file: //Init stuff _crate = _this select 0; ["AmmoboxInit",[_crate,false,{true}]] spawn BIS_fnc_arsenal; //Lists of items to include _availableHeadgear = [ "H_HelmetB", "H_HelmetCrew_B" ]; _availableGoggles = [ "G_Combat", "G_Bandanna_blk" ]; _availableUniforms = [ "U_B_CombatUniform_mcam", "U_B_CTRG_3" ]; _availableVests = [ "V_BandollierB_khk", "V_PlateCarrierH_CTRG" ]; _availableBackpacks = [ "B_AssaultPack_rgr", "B_TacticalPack_mcamo" ]; //Populate with predefined items and whatever is already in the crate [_crate,((backpackCargo _crate) + _availableBackpacks)] call BIS_fnc_addVirtualBackpackCargo; [_crate,((itemCargo _crate) + _availableHeadgear + _availableGoggles + _availableUniforms + _availableVests)] call BIS_fnc_addVirtualItemCargo; [_crate,(magazineCargo _crate)] call BIS_fnc_addVirtualMagazineCargo; [_crate,(weaponCargo _crate)] call BIS_fnc_addVirtualWeaponCargo; Its says Select Error. Any idea. I want to add custom VA to a object done by me.
  13. I'm looking ot create a RHS USAF Retexture too. but i cant get it work with the USAF. It works with the ARFR. I get invisible characters.... The same texture but with the: \rhsafrf\addons\rhs_infantry2\rhs_gorka_base.p3d model works. But when i change it to: \rhsusaf\addons\rhsusf_infantry\rhsusf_army_base.p3d does not work. The texture done for the USAF work witht he AFRF (a bit distorsioned as it not for that model but works), and when i change to the USAF model (the right model for that texture) I get invisible characters. Any idea? need help. Thanks
×