Jump to content

Recommended Posts

This bug exists since the introduction of the loiter waypoint. It makes the VTOL Gunship unusable with an AI pilot and maybe also affects Drones:

 

The  Loiter Waypoint has a setting for height, that sets height above sea level for the loiter. This works however only in the Eden Editor preview. As soon as you save/load the mission, the waypoint height value is reset to -1 and therefore disabled.

The aircraft will then fly very low and copy the ground. All the scripting commands to change flightheight do not work for loiter action.

This makes it impossible to use the gunship without a human pilot!

 

I think this bug might also be related to UAVs copying ground while loitering, when being comamnded from the UAV terminal: While the UAV accepts the height you set for it in the UAV terminal, it still copies terrain even when set to 200 or 500 meters, where copying terrain is very annoying, becaue it shakes up the camera so much.

 

I noticed, that there is also no script command for setting the loiter waypoint height, while there are commands to set loiter direction and loiter radius. I suspect, that this missing command has soemthing to do with the problem of the height not correctly registering when setting it in eden waypoint options.

 

If you know a workaround to get a loiter with fixed height ASL, please let me know! I've again wasted countless hours to get this working, but without success...

Thanks.

Share this post


Link to post
Share on other sites

Roughly for drones (even CUP modded) the flight altitude works fine for "very high altitude" (2000 m). The drone seems to loiter without climbing or descending (or with a smart rate as the ground is far). That looks like a true altitude (from sea level) and it's playable as gunner. If you set to 500m in a mountainous area (say Takistan), the drone will climb (then descend) to avoid the ground (the rate is higher). That looks like a mixed altitude (from sea level when possible) with a minimal height (from terrain/obstacle).

Probably the same for aircraft.

  • Thanks 1

Share this post


Link to post
Share on other sites

thanks pierremgi,

i will test if 500 is stable enough for me. 2000 meters is much to high for my viewsettings unfortunately.

 

For manned aircraft however it is different, as you can only set a loiter waypoint in the Eden editor. The loiter waypoint has a native heightASL option built in the UI box and it does work when you click preview: It is great. It's a true ASL height, so flying gunner in the VTOL is really impressive when you smoothly float over the mountain tops of tanoa.

However this value does not get saved and always resets back to -1 after loading, or after starting the mission outside of Eden. That's the main problem!

 

With the value on -1 the aircraft copies the ground at extremely low altitude and all available comamnds (flyinheight, flyinheightASL) have no effect, which is correct behaviour in a way, since the UI for Eden clearly states that a value of -1 makes the aircraft do exactly that.

 

I assume, that the loiter height in Eden is somehow "hacked" in (since there is no script command for loiter height) and therefore does not get saved correctly. Is there a way to see what code gets executed when you create a loiter waypoint in eden and fill in a loiter height?

My thinking is, that if one could use that code directly instead of using the UI box, one could probably make it work, since i can't see how Eden editor would delete code (in waypoint init for example) by itself.

Share this post


Link to post
Share on other sites

I've posted about this bug on the feedback tracker and been told all is normal from BIS's end. Are you Dev branch? I've not tried with stable but been told that it works fine with stable branch but i have the same feeling as you about the 'hack" with the loiter waypoint

 

 

Share this post


Link to post
Share on other sites
20 minutes ago, snoops_213 said:

I've posted about this bug on the feedback tracker and been told all is normal from BIS's end. Are you Dev branch? I've not tried with stable but been told that it works fine with stable branch but i have the same feeling as you about the 'hack" with the loiter waypoint

 

 

 

Yes, i am on stable and i think it never actually worked. I also googled a lot and only found dead threads without working solutions.

 

In the Eden config viewer i found

configfile >> "CfgWaypoints" >> "Default" >> "Loiter" >> "Attributes" >> "LoiterAltitude"

 

But there is no script command that i could find to actually change that in script. I don't know how this is not a bug, when it is very obviously not working.

There are script command to set loiter direction (type) and radius and those are the values that work from Eden even after saving/loading.

It's just the stupid altitude thing, that does not work...

Share this post


Link to post
Share on other sites
7 minutes ago, snoops_213 said:

 

Well technically the z axis of the waypoint does indeed get saved (The position of the actual waypoint in space).

However the actual z axis of the aypoint has no effect on the unit behaviour.

 

Maybe you should add to the bug report, that the ui box with loiter altitude does not get saved.

Share this post


Link to post
Share on other sites
On 5/29/2019 at 9:56 PM, twistking said:

 

Well technically the z axis of the waypoint does indeed get saved (The position of the actual waypoint in space).

However the actual z axis of the aypoint has no effect on the unit behaviour.

 

Maybe you should add to the bug report, that the ui box with loiter altitude does not get saved.

You are right I wasn't clear enough so I've edited the feedback but not sure if it will ever get fixed or any chance of a script command for the loiter height either. 

Share this post


Link to post
Share on other sites
On 5/29/2019 at 8:07 AM, twistking said:

thanks pierremgi,

i will test if 500 is stable enough for me. 2000 meters is much to high for my viewsettings unfortunately.

 

For manned aircraft however it is different, as you can only set a loiter waypoint in the Eden editor. The loiter waypoint has a native heightASL option built in the UI box and it does work when you click preview: It is great. It's a true ASL height, so flying gunner in the VTOL is really impressive when you smoothly float over the mountain tops of tanoa.

However this value does not get saved and always resets back to -1 after loading, or after starting the mission outside of Eden. That's the main problem!

 

With the value on -1 the aircraft copies the ground at extremely low altitude and all available comamnds (flyinheight, flyinheightASL) have no effect, which is correct behaviour in a way, since the UI for Eden clearly states that a value of -1 makes the aircraft do exactly that.

 

I assume, that the loiter height in Eden is somehow "hacked" in (since there is no script command for loiter height) and therefore does not get saved correctly. Is there a way to see what code gets executed when you create a loiter waypoint in eden and fill in a loiter height?

My thinking is, that if one could use that code directly instead of using the UI box, one could probably make it work, since i can't see how Eden editor would delete code (in waypoint init for example) by itself.

 

 

Why isn't there a loiter altitude for 1000 meters, it doesn't make any sense. As mentioned, 2000 meter altitude is too high for many people view distance.  

Share this post


Link to post
Share on other sites

*bump*

this is still not fixed on current stable branch.

 

loither height waypoint attribute works when previewing mission, but does not get saved, so always default to -1 when trying to actually play the mission outside the editor.

apex is out for quite some time now and the vtol still does not work with AI pilot. this thing can't even take long to fix, since it does work when previewing from eden...

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×