Jump to content
[hud]dorph

update 1.86 verify signatures

Recommended Posts

So did update 1.86 screw up verifysignatures on server?

I can only get on my server with mods if I set "verifysignatures=0"

  • Like 2

Share this post


Link to post
Share on other sites

We had to disable the signature check too. I'm not sure if the actual check is broken, or if mods need to update their keys.

Share this post


Link to post
Share on other sites

wow if all modders needs to update their sigs we are in trouble for a long time ahead :[

  • Like 3

Share this post


Link to post
Share on other sites
2 minutes ago, [hud]dorph said:

wow if all modders needs to update their sigs we are in trouble for a long time ahead :[

Yea. While our group doesn't use mods that are no longer maintained, I know a lot do, and there's a lot of mods that will never get new keys.

 

Hopefully it is a small oversight on BIs end and will be fixed soon.

Share this post


Link to post
Share on other sites
11 minutes ago, [hud]dorph said:

wow if all modders needs to update their sigs we are in trouble for a long time ahead :[

They do not. That not working properly was why the update got pushed back last week.

  • Like 1

Share this post


Link to post
Share on other sites
Just now, Dedmen said:

They do not. That not working properly was why the update got pushed back last week.

So should we expect a hotfix soon?

Share this post


Link to post
Share on other sites

They are working on thar right in this moment.

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
2 minutes ago, Dedmen said:

They do not. That not working properly was why the update got pushed back last week.

why it was released today if its still not working?

Share this post


Link to post
Share on other sites
Just now, Xairooo said:

why it was released today if its still not working?

Wellllll.. You know... Eh.... *paper rustling* It seems like we *more paper rustling* eh.. We don't seem to *stack of paper falling on floor* eh.. We don't seem to have any information about that at this point in time.

  • Haha 7

Share this post


Link to post
Share on other sites
3 minutes ago, Sandro Saitek said:

How can i downgrade my version to 1.86... ?

Think you mean 1.84? But it would be:

 

  1. In your Steam Library right-click on Arma 3 and go to Properties.
  2. Go to the Betas tab.
  3. In the "Enter beta access code to unlock private beta" field enter: Arma3Legacy184
  4. Click Check Code. It should now say that the code has been accepted.
  5. In the select list above the code field, you should now be able to select "legacy - Legacy Build (1.84)".
  6. Click Ok. In the library it should now say "Arma 3 [legacy]" and it will begin downloading the rollback.
  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
1 hour ago, Xairooo said:

why it was released today if its still not working?

We've tested it ourselves successfully, including several mods in various tests (e.g. CBA, ACE, RHS, CUP, Exile, Unsung...).
We've also got some positive reports of the issue fixed from the Release Candidate testing over the weekend. (Only wish we were able to get more RC usage and smash more bugs with it)

We're on it. The goal of the security improvements was to make verifySignatures catch more malicious attempts, not to have it disabled :/ And it should work with any previously signed mod, in short both - v2 and new v3 signatures.
We are really sorry about those issues!
 

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

Same thing, all the mods give signature mismatch after update (both client and dedicated server was updated).

(RHS, CUP, many more)

  • Like 1

Share this post


Link to post
Share on other sites
11 minutes ago, oukej said:

We've tested it ourselves successfully, including several mods in various tests (e.g. CBA, ACE, RHS, CUP, Exile, Unsung...).

 

Bullshit! We run CBA and Unsung in the latest versions beside Enhanced Movement, Enhanced Soundscape, Exile and Enhanced Basebuilding on the server.

And ALL mods showed as mismatch!

  • Like 3

Share this post


Link to post
Share on other sites

Its mismatching all the mods we use on our server as well.  RHS, CUP, Exile, CBA all mismatched. The only thing that works is to turn off signature checks and that is a no go. Stuck like chuck until a hotfix comes out. 

  • Like 1

Share this post


Link to post
Share on other sites

Same issues here with the same "tested" mods! BI testing strikes again.. :eh:

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

Testing in a intranet or lan is completly differend from testing over internet ........

 

  • Like 3

Share this post


Link to post
Share on other sites

Did you not try joining even if it says mismatched? No issues apart from visual

  • Like 1

Share this post


Link to post
Share on other sites
1 minute ago, Andrew_S90 said:

Did you not try joining even if it says mismatched? No issues apart from visual

On what? Vanilla? This new mod called warlords?

You can try it on any exile server you want ...... it would not be working.

 

  • Like 1

Share this post


Link to post
Share on other sites

Same problem so we start server without signature but under password....

Waiting for hotfix.

Don't tell me that we will have to resign all addons .... :down:

  • Sad 1

Share this post


Link to post
Share on other sites
8 minutes ago, kuplion said:

Same issues here with the same "tested" mods! BI testing strikes again.. :eh:

Seems so huh? Every update for like the last 4 has severely crippled servers. Awesome how we as paying customers spend all this money on the Game and DLCs  then become the test dummies when they decide to push out updates that supposedly fixes things but destroys other things. hundreds of dollars on server fees yearly and thousands of hours spent dialing your server in only to be crippled by the developer. I have tried several different startups with setting the Sig checks from 0-3 and the only thing that works is turning off Sig checks which I wont do. I even tried putting the -v2 in the startup bat and it doesn't work. Bad business all around.

  • Like 2

Share this post


Link to post
Share on other sites
Just now, CabooseMinusOne said:

Seems so huh? Every update for like the last 4 has severely crippled servers. Awesome how we as paying customers spend all this money on the Game and DLCs  then become the test dummies when they decide to push out updates that supposedly fixes things but destroys other things. hundreds of dollars on server fees yearly and thousands of hours spent dialing your server in only to be crippled by the developer. I have tried several different startups with setting the Sig checks from 0-3 and the only thing that works is turning off Sig checks which I wont do. I even tried putting the -v2 in the startup bat and it doesn't work. Bad business all around.

I love Arma, and I've had thouands of hours of fun and play time out of the series but this is pretty much one of the reasons I stopped hosting servers; I just couldn't be bothered with the update headaches anymore.

  • Sad 3

Share this post


Link to post
Share on other sites

PROBLEM WITH CLIENTSIDE ADDONS

After this update it's not possible to let server clients use addons like JSRS/CTab/BlastCore etc without puting them into modline (forcing all clients to using the same mods).
Now every user who wants to join server must have identical modline like is on server. 

 

Before this update it worked, because server admins had possibility to put only addon keys on server without changing modline and forcing every clients to had identical modline everytime.

This update has corrupted the fact that if want to invite other Arma3 groups for Joint Operations Community event they must have identical modline like me, what force them to download a lot of extra addons.

Please fix it because it's really annoyng that i need to change server modline everytime. Before this update it worked perfectly and it was huge simplification for this kind of community events.

  • Thanks 1
  • Sad 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×