Jump to content
duda123

Advanced Sling Loading (MP & SP)

Recommended Posts

Hey guys! Does anyone knows how to pickup ropes from NIMITZ or LHD? Rope just lays down or blocks in deck texture and i cant pick it up

Share this post


Link to post
Share on other sites

Very lovely work duda  :D

The default hook in Arma is alright , as well as the other sling loading scripts out there, then theirs your script lmfao. Right on dude keep up the amazing work.

 

One thing I must add though is I am running "a3_vemf_reloaded" on my server, and in this mission system, the loot crates that are used are not the usual crates that are used in default Arma or in any other mission system that I have seen yet. I have looked through the config for this mission system to see if I could manually change the type of crate it would use, however I cannot.  :(

 

Any chance compatibility for this mission system could be added in the next few versions or so? 

Share this post


Link to post
Share on other sites

 

v2.1.1 Released
 
 
 

 - Fixing issue preventing "pick up ropes" action from appearing when on USS Nimitz (or any other structure)

 - Fixing VTOL support

 

 

Hi duda123, thank you for the update. But I believe I have found a bug with v2.1.1. The huge Mohawk heli can not lift a Ural, but the much smaller Huey can lift a Ural :huh:

This seems a little strange as the Mohawk is 2-3x the size of Huey.

Any idea on how I could fix this please???

Thank you

Share this post


Link to post
Share on other sites

Very lovely work duda  :D

The default hook in Arma is alright , as well as the other sling loading scripts out there, then theirs your script lmfao. Right on dude keep up the amazing work.

 

One thing I must add though is I am running "a3_vemf_reloaded" on my server, and in this mission system, the loot crates that are used are not the usual crates that are used in default Arma or in any other mission system that I have seen yet. I have looked through the config for this mission system to see if I could manually change the type of crate it would use, however I cannot.  :(

 

Any chance compatibility for this mission system could be added in the next few versions or so? 

 

What's the issue you're seeing with the custom crates?

 

Can you not attach ropes to them? Or, can you attach ropes, but they don't lift off the ground?

Share this post


Link to post
Share on other sites

Hi duda123, thank you for the update. But I believe I have found a bug with v2.1.1. The huge Mohawk heli can not lift a Ural, but the much smaller Huey can lift a Ural :huh:

This seems a little strange as the Mohawk is 2-3x the size of Huey.

Any idea on how I could fix this please???

Thank you

 

Sent you a message. Can you try running those scripts?

Share this post


Link to post
Share on other sites

What's the issue you're seeing with the custom crates?

 

Can you not attach ropes to them? Or, can you attach ropes, but they don't lift off the ground?

 

I get the option to attach to the crate, but when I click on attach to said crate, the ropes that I am carrying just fall directly to the ground where I am standing. 

Share this post


Link to post
Share on other sites

Okay so I did some more looking around and I found that you actually can change the crates that are used. So I changed them to the default exile crates, loot is in them and whatnot, however when trying to "Attach to cargo ropes" the ropes still just fall to the ground directly where I am standing.

 

**EDIT**

 

I am also noticing now that when I choose "Deploy cargo ropes" that the Scroll Wheel menu that used to pop up in the top left no longer shows, however you can still press the space key and get the ropes to come out if you have knowledge of where the options originally where located. This only occurs for helicopters that have ability to tow with more than one sling. Might have to do with the arma update imo :(

Share this post


Link to post
Share on other sites

Fixed issue not being able to see menu in top left hand corner. 

 

description.ext in your mission folder, change:

 

false,  // Commanding menu

 

to 

 

true,  // Commanding menu

 

Must have gotten changed on update  :P

Share this post


Link to post
Share on other sites

Fixed issue not being able to see menu in top left hand corner. 

 

description.ext in your mission folder, change:

 

false,  // Commanding menu

 

to 

 

true,  // Commanding menu

 

Must have gotten changed on update  :P

Thank you! Was scratching my head trying to find out why this suddenly stopped working on my Exile servers. I was thinking it was infiSTAR.

Share this post


Link to post
Share on other sites

Is there a way to disable the built-in arma sling loading, when we use this mod?

I don't know of any way to do this.

Share this post


Link to post
Share on other sites

could you add the extend/shorten rope option for players outside a helo? I often need to lengthen the rope a bit to attach it to ''the goods'' but you can only do this from inside the helo. Would speed things up a bit and be even more convenient.

Share this post


Link to post
Share on other sites

Suggestion - add a keybind for relase cargo for emergency situations - we had one when testing ch47 with afm from rhs and 2 hmmwvs - normally chinook would pickup two with ease, in our case chinook got smashed cause it lacked power - solution? emergency cargo (hook) relase and fly up - but lacking button to drop cargo caused crash :P its simply too much time for selecting from scroll menu to detach al cargos

  • Like 1

Share this post


Link to post
Share on other sites

Hello im a noob when it comes to server management and im having an issue with this mod and your rappelling mod. The issue is that when i install them through vilayers addon manager It caused my server to hang on the loading screen. I have done a fresh install with only the exile mod installed and then tried slingloading and rappelling seperately and both caused this issue. I have been using your advanced towing mod which was installed the same way through vilayer addon manager without issues but no matter what i try these 2 dont seem to want to work. after installing either mod my rpt file never goes past steam api failed to initialize. thanks in advance for any advice you may offer!

Share this post


Link to post
Share on other sites

Had a question about the dual slingloading. Are there any plans to try to make it a side by side load, like when a CH-52)3 moves two Humvees? Is it even possible in Arma3 with regards to limitations?

Just curious. Great mod!!

~S

Share this post


Link to post
Share on other sites

Question, is there any way to adjust this so the system is more in line with the actual weight limits of the Arma 3 sling loading system? I like this one because of the manual hook up, but don't really like the idea a Huron can lift a massive tank. 

Share this post


Link to post
Share on other sites

Question, is there any way to adjust this so the system is more in line with the actual weight limits of the Arma 3 sling loading system? I like this one because of the manual hook up, but don't really like the idea a Huron can lift a massive tank.

Yes, add this to your init.sqf file:

ASL_HEAVY_LIFTING_ENABLED = false;

Share this post


Link to post
Share on other sites

Yes, add this to your init.sqf file:

ASL_HEAVY_LIFTING_ENABLED = false;

 

So I have:   missionNamespace setVariable ["SA_ASL_HEAVY_LIFTING_ENABLED",false,true];   in my init.sqf, is this incorrect now?

Share this post


Link to post
Share on other sites

So I have:   missionNamespace setVariable ["SA_ASL_HEAVY_LIFTING_ENABLED",false,true];   in my init.sqf, is this incorrect now?

Yeah, you should change it.

Share this post


Link to post
Share on other sites

The mod is still working on dedicated right?

Yes

Share this post


Link to post
Share on other sites

I put the script on my server works great locally on my test server. As soon as I put it on my dedicated server I get kicked. I updated both the setVariable.txt and remoteExec.txt then I updated description.ext as per the readme file but still nothing getting kicked as soon as I get into the helo as pilot and use the Sling Load...

 

Any help would be appreciated on the BE Filters I need to add. I even added !"ASL_" to remoteExc.txt with no luck...

 

in setVariable.txt I put:

5="ASL_Ropes"
5="ASL_Ropes_Vehicle"
5="ASL_Ropes_Pick_Up_Helper"
5="ASL_Cargo"

In my description here is what I have:

class Functions
	{
		class ASL_Pickup_Ropes		{ allowedTargets=1; }; 
		class ASL_Deploy_Ropes_Index	{ allowedTargets=1; }; 
		class ASL_Rope_Set_Mass		{ allowedTargets=1; }; 
		class ASL_Extend_Ropes		{ allowedTargets=1; }; 
		class ASL_Shorten_Ropes		{ allowedTargets=1; }; 
		class ASL_Release_Cargo		{ allowedTargets=1; }; 
		class ASL_Retract_Ropes		{ allowedTargets=1; }; 
		class ASL_Deploy_Ropes		{ allowedTargets=1; }; 
		class ASL_Attach_Ropes		{ allowedTargets=1; }; 
		class ASL_Drop_Ropes		{ allowedTargets=1; }; 
		class ASL_Hint			{ allowedTargets=1; }; 
		class ASL_Hide_Object_Global	{ allowedTargets=2; }; 
	};

EDIT:

 

I attempted all kinds of ways but still no luck. Trying one more thing. Will post if fixed.

 

Never mind I got it fixed by REREADING the readme file again. duda writes that put !="ASL_Ropes_Pick_Up_Helper" !="ASL_Cargo" after EACH line that has a 5 in in so I had about 10 lines that started with a 5 so those 10 lines has what was previously written and now !="ASL_Ropes_Pick_Up_Helper" !="ASL_Cargo"...Works great now. Thanks for this great addon.

 

The ONLY problem I am seeing is a person on the ground cannot pick up the ropes and only the pilot can pick up the ropes. Is this suppose to be like this? Example: I have a copilot get out and he cannot pick up the ropes to attach to vehicle. I, as a pilot have to get out to attach to vehicle. But if the copilot gets in the pilot's seat and gets out he can then attach the ropes.

 

Is there a way around this?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×