Jump to content
LordJarhead

J.S.R.S. 2.2 Soundmod

Recommended Posts

I tried again, LJH, and my dedi server, when set to v2 signature verification, will not appear in my server browser with that key. As soon I take it out, the server shows right up. Sorry.

Share this post


Link to post
Share on other sites
Hi,

Love your sound mod! Been using it since day one! :)

I've installed the update today (2.1 -> 2.1b) and noticed a change in the sound (at least for the MX rifle):

https://www.youtube.com/watch?v=-SgNqn0LmRI

I hope you can hear the difference.

The last 6 seconds or so shows (hopefully) clearly that the sound in first person mode is less muffled and has more reverb.

My question is: is it intentional? :confused:

Thanks!

The first few shots are not JSRS sounds, those are ArmA3 vanilla sounds. ;) Due to the update 1.24 from ArmA3 the old configs were not working anymore and no sound was played. Now they work and thats how the MX sounds ;)

LJ

Share this post


Link to post
Share on other sites
The first few shots are not JSRS sounds, those are ArmA3 vanilla sounds. ;) Due to the update 1.24 from ArmA3 the old configs were not working anymore and no sound was played. Now they work and thats how the MX sounds ;)

LJ

My god... :smiley-punched:

That's... embarrassing... :D

Sorry bout that! I knew something was wrong! :p:D

Thanks for the quick reply tho! :rolleyes:

Ps.: That just shows I never really used the vanilla sounds, right? :-D

Edited by MX Maximus
Addition

Share this post


Link to post
Share on other sites
Ps.: That just shows I never really used the vanilla sounds, right? :-D

No problem mate hehe

No, that would be the case when you would have noticed that right away, because THAN you'd go like "What the hell happened?" ;)

LJ

Share this post


Link to post
Share on other sites
No problem mate hehe

No, that would be the case when you would have noticed that right away, because THAN you'd go like "What the hell happened?" ;)

LJ

Well, I noticed the difference but I got fooled by the still working in house reverb and distant sounds and convinced myself that it was like that.

Shame on me... :dead:

Anyway, once again, thanks for the awesome mod! ;)

Share this post


Link to post
Share on other sites

I am having a problem with the update.

I downloaded the full 2.1 and the update.

Whenever I try to fire the gun from the Cheetah, the Tigris, the Gorgon, the Marshal, the Kamysh or the Mora I get the error message bellow:

http://i.imgur.com/NRMSpV7.jpg (726 kB)

When I acknowledge the error message it'll not appear again until I enter another mission.

These are the only vehicles that produce this error message.

Has anyone had this problem?

Like I said, I have freshly downloaded both the whole mod and the 2.1b update.

Thanks. :)

Share this post


Link to post
Share on other sites
I am having a problem with the update.

I downloaded the full 2.1 and the update.

Whenever I try to fire the gun from the Cheetah, the Tigris, the Gorgon, the Marshal, the Kamysh or the Mora I get the error message bellow:

http://i.imgur.com/NRMSpV7.jpg (726 kB)

When I acknowledge the error message it'll not appear again until I enter another mission.

These are the only vehicles that produce this error message.

Has anyone had this problem?

Like I said, I have freshly downloaded both the whole mod and the 2.1b update.

Thanks. :)

Thanks for the Info, another tiny text issue. Will fix that tomorrow.

LJ

Share this post


Link to post
Share on other sites
Thanks for the Info, another tiny text issue. Will fix that tomorrow.

LJ

Thanks a million for the info, LordJarhed. I was going crazy here trying to sort this little problem out. Glad to hear that. :)

Share this post


Link to post
Share on other sites

Hi LordJarhead

Awesome mod as always :-)

I'm getting error messages when the main cannon is fired on the AFV-4 Gorgon

Sound 40_mm_40mm_AutoCannon_far not found

Sound 40_mm_40mm_AutoCannon_tail not found

Sound 40_mm_40mm_AutoCannon_echo not found

Sound 40_mm_40mm_AutoCannon_first not found

Cheers

Share this post


Link to post
Share on other sites
Hi LordJarhead

Awesome mod as always :-)

I'm getting error messages when the main cannon is fired on the AFV-4 Gorgon

Sound 40_mm_40mm_AutoCannon_far not found

Sound 40_mm_40mm_AutoCannon_tail not found

Sound 40_mm_40mm_AutoCannon_echo not found

Sound 40_mm_40mm_AutoCannon_first not found

Cheers

I'm getting the same error in general

Share this post


Link to post
Share on other sites

LJ,

Not sure why, but when more than 50m or so from greande/rocket/40mm explosions, there is no sound.

Using a fresh download of the newest version...

Share this post


Link to post
Share on other sites

And saying "killed the mod" is kinda exaggerated, as the mod lives on as long as it gets used in the community :) Tho the new project would eat up all my time as it is ... gigantic.

LJ

*insert evil laugh here*

Thank you for the Update LJ. I'm still on holidays in Croatia so I can't test anything but I was already worried that I won't be able to play A3 when I return. And you fixed the vehicle weapon issues too! I'm very happy :)

Edited by Tonci87
Pettka stole the smiley

Share this post


Link to post
Share on other sites
LJ,

Not sure why, but when more than 50m or so from greande/rocket/40mm explosions, there is no sound.

Using a fresh download of the newest version...

What? Why ... wait. That can't be. Maybe they are really quiet? Or was there a change in Ammo Classes with the latest update? Anyone else does have that?

LJ

Share this post


Link to post
Share on other sites
Confirm keys works as intended at my dedi/clients.

When you say "as intended" are you using verifySignatures=2 on your server? Aside from some of the known problems with some of the weapons mods, this is the only key (I currently have 30 working keys in my server keys folder) that will not work on my server. I'd really like to use this mod, but, things being what they are, I can't reduce my server protection in order to do so. Can anyone verify that the updated key passes v2 protection? Thanks.

Share this post


Link to post
Share on other sites
When you say "as intended" are you using verifySignatures=2 on your server? Aside from some of the known problems with some of the weapons mods, this is the only key (I currently have 30 working keys in my server keys folder) that will not work on my server. I'd really like to use this mod, but, things being what they are, I can't reduce my server protection in order to do so. Can anyone verify that the updated key passes v2 protection? Thanks.

I will upload a HotFix just now using the new DSSignFile.exe from the ArmA3 Tools, lets see if that one works for you. Also it will contain the XX_Sound not found fix :)

Give me a second!

LJ

Share this post


Link to post
Share on other sites

There you go:

HOT FIX:

JSRS Update 2.1B - HotFix (Update 2.1B needed)

Changelog 2.1B HotFix:

Fixed Keys

Fixed Script Config XX_Sound Not Found

Changelog 2.1B Second Upload:

Fixed Keys

Fixed grenade landing sounds

Fixed chemlight period noises

Fixed script macro for vehicle weapons

Fixed inroom issues for ArmA2 weapons in script config

Fixed Scorpian SMG no sounds

Loud sounds in spectator view

New Wipeout gun sound

Fixed inside FlyBy sounds in planes

Added CAS plane 1 and plane 2 sounds, placeholders from A2

Fixed Updating Base Classes

Changelog 2.1B:

*Fixed Configs due to new Silencer entries

*Deleted APC entries for independency

*Fixed Vehicleweapon Distance sounds

Hope that wont cause any new Key issues again. But lets wait and see, I'm not that trustful in my signings anymore :P

LJ

Share this post


Link to post
Share on other sites
What? Why ... wait. That can't be. Maybe they are really quiet? Or was there a change in Ammo Classes with the latest update? Anyone else does have that?

LJ

They're fine here, good volume at 100m for both grenades and UGL nades.

For some reason vehicles blowing up are way louder than arty shells/230mm rockets but that might be just me.

Share this post


Link to post
Share on other sites

Thanks for the headsup about the new patch :cool:

Release frontpaged on the Armaholic homepage.

================================================

We have also "connected" these pages to your account on Armaholic.

This means in the future you will be able to maintain these pages yourself if you wish to do so. Once this new feature is ready we will contact you about it and explain how things work and what options you have.

When you have any questions already feel free to PM or email me!

** I merged both patches and call it 1.2, I hope that is ok with you as it saves the users some work ;)

Share this post


Link to post
Share on other sites
I merged both patches and call it 1.2, I hope that is ok with you as it saves the users some work ;)

Nevermind! Sounds good :) I will provide a full JSRS2.5 Version in future now that most issues are fixed I can concentrate on Sounds only.

LJ

Share this post


Link to post
Share on other sites

I can confirm the grenades have no sound beyond 50 metres away.

Redownloading the mod and applying the hotfix now.

EDIT: Mod completely reinstalled and hotfix applied. Grenades have no landing sound beyond 3 metres nor do they have blast sound.

Only when tossing it at my feet do I hear the landing sound. The blast I can only hear when I'm standing on the grenade.

Edited by Subscyed

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×