Jump to content
Sign in to follow this  
Dwarden

ARMA 2: OA 1.62 (Release Candidate #1) build 95168

Recommended Posts

WARNING: this build is not MP compatible with 1.60 and 1.61 version of OA!

WARNING: ACR Lite maps are removed from this RC and upcoming patch and will be provided as separate download!

The time has come for brave community to get hands on RC of upcoming patch, this time 1.62 RC1

Changelog: (all from betas between 1.60 and now), minor UI stuff

mirror : http://www.gamefront.com/files/22007900/ARMA2OA_Patch_1_62-RC1.zip

CRC32: A150428D

MD5: 4C95289C2E2EDF5FB216EA9C03261B9D

SHA-1: 8869F8F35E5CCBF13D98273BECFC02194E1A3EDE

WARNING : This update will modify your existing game installation.

Rollback to previous version is not possible.

Upgrading to the final 1.62 patch also may not be possible.

It is recommended to back up your full installation folder and profile folder first (you can restore those before applying the final patch).

As always, use at your own risk. Thanks a lot for your support!

please be aware that no easy rollback to 1.60 is possible unless You have full backup

fyi changes since last beta

* fixed some crashes and MP issues (it means to stabilize MP we need change major version to 1.62)

* fixed bad playername issue

* removed ACR lite models for OA's ACR

[94918] New: command unit addMagazine[name, ammoCount]

[94912] Fixed: Video memory detection on W7/x64 sometimes wrong because of bug in IDirect3DDevice9::GetAvailableTextureMem.

[94886] Fixed: Possible gear item duplication (private https://dev-heaven.net/issues/36648 )

beta in Sync with 1.62 RC1 candidate for these who don't want install 1.62 RC1

http://forums.bistudio.com/showthread.php?137423-ARMA-2-OA-beta-build-95158-(1-62-MP-build)

BattlEye Support: ... SUPPORTED ...

Note:

If you installed 1.61 RC1/RC2/RC3 before this RC you need to use backup to restore game state to 1.60

remember to clean old ACR stuff too

Edited by Suma

Share this post


Link to post
Share on other sites

again, why you ask when it's explained in first post ?

Share this post


Link to post
Share on other sites

I really don't get it. You want us to download and check the beta but have now said that there will be no easy rollback?

Do we have to jump through hoops now? Come on BIS. At least make it easy for us.

Not hating, just confused.

Share this post


Link to post
Share on other sites

Correct me if I'm wrong, but when we were still at 1.59, weren't the 1.60 RCs easily updated to the next RC? I don't remember having to revert back to 1.59 to go from 1.60 RC1 to 1.60 RC2.

Share this post


Link to post
Share on other sites

So I have been diligently testing the new beta patches (and loving them). Then the 1.61 (94945) RC come out and I install it, followed by 95054 RC#2 and 95099 RC#3. Now the crazy bit - I download and want to install 1.62 RC#1 and I'm getting 'Update 1.61-1.62\EXPANSION\ADDONS\ANIMS_E.PBO.UPD cannot be applied, error xdelta3 returned error code: 1'

I think someone has dropped the ball on this one. Release the 'patches' (the ones that create the beta folders) but do NOT release an RC unless it is fully removable please.

Share this post


Link to post
Share on other sites

I think someone has dropped the ball on this one. Release the 'patches' (the ones that create the beta folders) but do NOT release an RC unless it is fully removable please.

Release Candidates and Patches were never fully removable, they change the addon assets. If you don't want to test then stay at beta patches that are easy to remove.

Share this post


Link to post
Share on other sites

Thanks for your input Tony. I think I've been around long enough to know what beta testing is.

Share this post


Link to post
Share on other sites

So you know that the moment you apply a RC or Final patch on arma games and the addons are changed there is no going back unless you have kept a backup or reinstall. Open then a devheaven ticket to ask for a feature to uninstall patches.

Share this post


Link to post
Share on other sites
WARNING: this build is not compatible with 1.60 and 1.61 version of OA!

What on earth does that mean? We have to roll back to 1.59?

Dwarden, please would you state to which version(s) a patch should be applied?

Having just rolled back 1.61 RC1 to 1.60 & re-patched with 1.61 RC3, & it being clear from Krem's post that this new patch will not work with 1.61 RC3, I have no idea what to do next. And I do want to aid in testing...

Share this post


Link to post
Share on other sites

I understand Beta’s and the ‘be it on your own head’ type thing that goes along with them, that’s fine. I'm playing back upto Beta 94444 as it seemed to me the best place to sit tight for a while. I also understand the dangers that can be involved in using the RC, I put 1.61 in, after first backing up, then after viewing 1.61, went back to 1.60, I got a little worried things were wondering slightly, textures etc..

However I’m a little confused that in essence this new patch 1.62 is actually going to be the sequel, if you like, to patch 1.59, as it says its not compatible with 1.60 or 1.61, therefore have we done a Bobby Ewing, and come out of the shower with a chunk of time missing/forgotten about, i.e. 1.60 + poor old 1.61, which really didn't go anywhere much, both just sort of never happened.

(your probably all too young to understand the ‘Dallas’ analogy, still) :D

Don’t mind reinstalling I have all hard copies, so there is no issues if I have problems with my backup process, but when I saw “not compatible with 1.60 or 1.61†it sort of surprised me...

Of course it could just be me getting old :butbut:

Share this post


Link to post
Share on other sites
What on earth does that mean? We have to roll back to 1.59?

Dwarden, please would you state to which version(s) a patch should be applied?

Having just rolled back 1.61 RC1 to 1.60 & re-patched with 1.61 RC3, & it being clear from Krem's post that this new patch will not work with 1.61 RC3, I have no idea what to do next. And I do want to aid in testing...

He means that you can't play on 1.60 or 1.61 servers once you apply the patch (or if you apply this to a server, people with 1.60 and 1.61 will not be able to join!). If you have applied 1.61 RC1 or 1.61 RC2 you need to roll back to 1.60 before applying this patch.

EDIT again ----> Just to let people know, I have applied it to my 1.60 base install and it all seems fine so far!

Edited by Jedra

Share this post


Link to post
Share on other sites
What on earth does that mean? We have to roll back to 1.59?

Maybe he means not online compatible with older versions

someone was faster :)

Share this post


Link to post
Share on other sites
Do we have to jump through hoops now? Come on BIS. At least make it easy for us.

We would make it easier, if it would be reasonably possible, but we see no easy option how to do this. Currently you have following options, which do not seem quite difficult to me:

- do not test full RC, test a beta only (the beta can be tested alongside with a stable version)

- before testing RC do a full copy of the game installation so that you can revert the RC if needed

Share this post


Link to post
Share on other sites

You need to have legitimate install 1.60 to be able to upgrade to 1.62. It is as simple as this. It is already extremely complex process to handle and we are always absolutely clear how Release Candidates work. There is not easy way for us to handle it differently in the existing system so you either can live with it (the easiest way is to simply create full backup of the Arma 2 OA install folder somewhere else...) or not. If not yous simply should skip RCs and wait until the final patches and maybe use betas that are more flexible alongside the stable game. We of course appreciate help of our users with finalizing the updates and without release candidates this would not be really possible for us to release further updates to the game that is as moddable and open as this.

Few notes:

* we had to raise the version number to 1.62 as there are several low level incompatibilities between some 1.61 builds that lead into CTD to clients and servers

* we had to remove the ACR lite content from the patch as some of it requires Arma 2 present and there is atm no robust way of handling the dependencies. Instead, we are going to release ACR Lite as full free optional DLC to allow all our users to be at the same compatible level without enforcing purchase of DLC pack

We certainly hope this 1.62 is the final patch iteration and we have no intention opening it again unless a serious regression is found.

Share this post


Link to post
Share on other sites

Yes yes, too late I know, but:

unit addMagazine[name, ammoCount,multiplier]

Optional Multiplier.

eg this addMagazine ["30rnd_556x45_STANAG,30,6]; to add 6 30 round, STANAGs to a unit.

-k

Share this post


Link to post
Share on other sites
You need to have legitimate install 1.60 to be able to upgrade to 1.62.

Thank you, that answers my question. Off to download, will roll back & patch tomorrow evening :)

BTW, today I started experimenting with the FXAA/SMAA/ATOC settings & the Reinhard & Filmic tone mapping - not finished but on Chernarus I'm getting another 2-3 FPS plus it looks better. Nice developments, with the new commands & the new addons dependent on them such as TPWC AI suppression, the 1.62 patch will be a milestone. Thanks to all at BIS for your hard work.

Share this post


Link to post
Share on other sites
You know guys ?!

Release a final version please ... 3 or 4 bugs added to 33333 bugs won't make a difference ^^

can you stop posting comments they are sensless, like this one ? not nice to insult them.

release is when its done...

Share this post


Link to post
Share on other sites
You know guys ?!

Release a final version please ... 3 or 4 bugs added to 33333 bugs won't make a difference ^^

Wrong. No one in their right mind would release a buggy product when they can take their time, prevent regression bugs in beta/RC tests, and avoid having to release a hotfix following the release just to fix avoidable shit that they're perfectly capable of fixing before hand. The idea with patches is to fix bugs, not create more to fix later, just so you know.

Share this post


Link to post
Share on other sites

Hi guys,

I've installed the 1.62 RC and everything for DayZ works fine, but when I try and join a 1.61 non modden server (domination for example) my game crashed to desktop and the fault report says it's because of the BEClient.dll

I've replaced it manually with the latest from the BattlEye website but that didn't work. Any suggestions?

Share this post


Link to post
Share on other sites
Hi guys,

I've installed the 1.62 RC and everything for DayZ works fine, but when I try and join a 1.61 non modden server (domination for example) my game crashed to desktop and the fault report says it's because of the BEClient.dll

I've replaced it manually with the latest from the BattlEye website but that didn't work. Any suggestions?

Maybe reading the first post would help ...

WARNING: this build is not MP compatible with 1.60 and 1.61 version of OA!

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×