Jump to content
Sign in to follow this  
Dwarden

A2OA Linux Server beta 1.59.79548

Recommended Posts

Dowload:

http://www.arma2.com/index.php?option=com_rokdownloads&view=file&Itemid=20&id=742%3Aarma-2-oa-linux-standalone-server-1-59〈=en

Direct:

ftp://downloads.bistudio.com/arma2.com/update/a2oa-server-1.59.79548.tar.bz2

tens of mirrors:

http://www.gamefront.com/files/20176377/a2oa-server-1.59.79548.tar.bz2

http://uploadmirrors.com/download/GLE6QZHV/a2oa-server-1.59.79548.tar.bz2

http://uploadmirrors.com/download/1HUHJBEU/a2oa-server-1.59.79548.tar_0.bz2

a2oa-server-1.59.79548.tar.bz2

CRC32: C6080275

MD5: B0965FDA264736EB3650DDD08A695A52

SHA-1: CE7BE4D55BF3E353F65EDD514AAFA26987C67E25

Note that it requires Arma 2: Operation Arrowhead data to be updated to version 1.59 first in order to run properly.

Please provide us with feedback to this topic.

Arma 2: Operation Arrowhead - Linux Standalone Server 1.59

===============================================================

Copyrigt © 2010 Bohemia Interactive Studio. All rights reserved.

For more information please visit

http://community.bistudio.com/wiki/ArmA:_Dedicated_Server

Installation instructions:

==========================

1. Following programs must have been installed on your Linux-box:

tar, gcc. Optional: md5sum (for setup integrity check)

1a. On some verions of Linux (this was reported for RedHat 9

and Gentoo linux 2.4.20) the NSCD deamon must be installed to

run ArmA 2 server successfully. Caching of DNS would be sufficient.

2. Copy the whole "ArmA 2 Operation Arrowhead" directory from Windows

to some Linux-directory (arma2arrowhead). DON'T DO ANY DATA CONVERSIONS

(even "dos2unix" translation of text files is not necessary).

Example: you can use PKZIP (WinZip, PowerArchiver, etc.) on

Windows and "unzip" on Linux.

Don't use upper case letters in the ArmA2 directory name

(/home/bob/arma2arrowhead will be good, /home/bob/ArmA2ArrowHead

may cause some troubles).

ArmA2 directory should contain subdirectories "Addons", "Bin",

"Campaigns", etc.

3. Copy the "server-x.xx.tar.gz" (x.xx is version number) file into

the arma2arrowhead directory. Unpack and install it with commands:

arma2arrowhead$ tar -xjf server-x.xx.tar.bz2

arma2arrowhead$ ./install

Watch the messages - they will inform you whether your installation

is successful.

4. Dedicated server can be started in foreground:

arma2arrowhead$ ./server

Or in background:

o$ nohup ./server > out.txt 2> err.txt &

[1] <pid>

5. Running server can be stopped by executing:

$ kill -s SIGINT <pid>

Where <pid> is process-id of mother server thread (printed out in

"nohup" command).

6. ArmA2 ArrowHead server has a feature: command-line parameter

"-pid=<pid_file>". It causes creation of <pid_file> with

PID of root ArmA2 process. If IP port specified in "-port=<nn>"

parameter is busy (in usage), ArmA2 will terminate immediately

and <pid_file> won't be written..

7. The "arma2server" script is provided for automatic server

start/restart/status query/etc. Please be sure to edit

CONFIGURATION PARAMETERS in lines 12 to 18 !

After this is done, install (hard-link?) the script into

"/etc/rc.d/init.d/arma2server" file. After that it can be managed

by "chkconfig" (see info/man).

previous thread about 1.57 beta linux :

Edited by Dwarden

Share this post


Link to post
Share on other sites

Thanks guys, Linux binaries on patch day is really appreciated.

Share this post


Link to post
Share on other sites
Thanks guys, Linux binaries on patch day is really appreciated.

absofsckinglutely, and it's running great so far.

Share this post


Link to post
Share on other sites
Thanks guys, Linux binaries on patch day is really appreciated.
Couldn't agree more, thanks!

Share this post


Link to post
Share on other sites

Now all my linux servers with question marks in server list :(

Share this post


Link to post
Share on other sites
Now all my linux servers with question marks in server list :(

Have you updated/patched as well the arma2oa files?

you need to patch your local installation and then upload it.

---------- Post added at 11:28 AM ---------- Previous post was at 11:26 AM ----------

---------- Post added at 11:26 AM ---------- Previous post was at 10:09 AM ----------

BI, why is it so complicated to provide a update package for Linuxservers? :confused:

It is always painful to first patch the local installation and upload the files afterward via DSL lines.

Can you not build a DELTA to the previous version and provide an package for Linuxservers?

run a rsync in dry mode to find out the delta against the current Linux server and build a package with all files and provide this as single download...this will help us a lot to just download a single package from an ftp source to our dedicated servers.....::confused:

Share this post


Link to post
Share on other sites
Have you updated/patched as well the arma2oa files?

you need to patch your local installation and then upload it.

Of course, I did it. I uploaded the same files on the windows server and it's works fine (green icon).

Share this post


Link to post
Share on other sites

byteslam it's on long term plan but the manpower is limited ...

we for sure not forgot about it, let's hope for 1.60 release ;)

Share this post


Link to post
Share on other sites
byteslam it's on long term plan but the manpower is limited ...

we for sure not forgot about it, let's hope for 1.60 release ;)

I can provide you with a delta package... or a script which generates one :-) all you have to do is, to allow us to provide it for download.

---------- Post added at 02:10 PM ---------- Previous post was at 02:09 PM ----------

Of course, I did it. I uploaded the same files on the windows server and it's works fine (green icon).

have you removed all dll what ever files and have you checked if everything is in lower case?

Share this post


Link to post
Share on other sites

Is it too hard to answer on my question? all linux servers'll have yellow status after patching 1.59?

Share this post


Link to post
Share on other sites
Is it too hard to answer on my question? all linux servers'll have yellow status after patching 1.59?
People can only answer that after 1.59 linux servers have been setup and tested, I reckon that isn't the case so much yet at this point.

byteslam's got a good point - did you toLower everything after updating to the patch?

I can provide you with a delta package... or a script which generates one :-) all you have to do is, to allow us to provide it for download.
There were server packages back in arma-1, so I think a delta should be quite fine.

Hosting can go anywhere - incl multiupload etc I suppose.

Share this post


Link to post
Share on other sites
byteslam's got a good point - did you toLower everything after updating to the patch?

Yes, all of is already done. Why do I see then on battleye server list yellow servers on linux platform with 1.59?

Share this post


Link to post
Share on other sites
...

There were server packages back in arma-1, so I think a delta should be quite fine.

Hosting can go anywhere - incl multiupload etc I suppose.

No, it is against the current copyright....If BI do not agree you can not provide this...

---------- Post added at 03:42 PM ---------- Previous post was at 03:40 PM ----------

Yes, all of is already done. Why do I see then on battleye server list yellow servers on linux platform with 1.59?

in worst case you need to run a md5 to compare if you have a broken file in your installation on the server. Did you upload by ftp?

You can also use rsync to verify.

Share this post


Link to post
Share on other sites
in worst case you need to run a md5 to compare if you have a broken file in your installation on the server. Did you upload by ftp?

You can also use rsync to verify.

Done too. Results - yellow status. Answer me plz on one question. Is it normal for server which patched by 1.59 version on linux platform?

Share this post


Link to post
Share on other sites

yep my linux server is yellow as well though think it was under 1.57 as well :)

Share this post


Link to post
Share on other sites

is the server using any -mod= ?

got ip?

Share this post


Link to post
Share on other sites
is the server using any -mod= ?

got ip?

turned mods off ip 94.171.163.116

---------- Post added at 05:46 PM ---------- Previous post was at 05:41 PM ----------

this the normal output from the logs when i startup

WATCHDOG (13152): [Fri Apr  1 17:38:19 BST 2011] Starting server (port 2302)...
Item str_disp_server_control listed twice
17:38:35 Dedicated host created.
17:38:36 Host identity created.

Share this post


Link to post
Share on other sites

can't see the server IP :(

Share this post


Link to post
Share on other sites

yeah that's strange as i can't now either, filter for ravachol and you should see it, you should see 1.59 test server and 1.57 ace server.

still having a few problems with my router though you should still see it.

Edited by anarcho

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×