Jump to content
ALiVEmod

ALiVE - Advanced Light Infantry Virtual Environment 1.0 (GA)

Recommended Posts

4 hours ago, Blaq said:

Apologies if i sound like a whiny kid but Iv had this problem for months when using the ORBAT. I keep getting the same error when i try to run the game with the exported faction in the add on section, its extremely frustrating as these factions take nearly 3 days to create, iv had to delete them then remake them multiple times. Could someone please help me as i want to make a RMC faction, RAF, RAF regiment RN and so on.  Asked this question on the ALIVE forum months ago and no one has replied , posted it on reddit and no one replied either, I even uninstalled and reinstalled ARMA twice hopefully someone here could help me out or redo it for me. (sorry for the crap quality) sorry for sounding so petty. Let me know if i should send you the folder or config etc. Please help

 

https://ibb.co/0BG6Lcc

https://ibb.co/rpSWxFn

Blaq - have you asked over on the official ALiVE Forums

http://alivemod.com/forum/

 

Maybe someone over there might have some insight - sorry that I am not more help.  I did once attempt to create my own faction but had several issues getting it to work.  Have you looked at one of the working factions created and reverse engineered it?  Just a thought.

http://alivemod.com/wiki/index.php/Supported_Factions

 

REAPER

Share this post


Link to post
Share on other sites
20 hours ago, reaper lok said:

Blaq - have you asked over on the official ALiVE Forums

http://alivemod.com/forum/

 

Maybe someone over there might have some insight - sorry that I am not more help.  I did once attempt to create my own faction but had several issues getting it to work.  Have you looked at one of the working factions created and reverse engineered it?  Just a thought.

http://alivemod.com/wiki/index.php/Supported_Factions

 

REAPER

Thanks for your reply, I have asked on ALiVE forums a couple months ago but either they dont understand the problem or no one uses the forum that much anyway, iv left a post on the github too, all the factions I used where ALiVE compatible.

Share this post


Link to post
Share on other sites

Generally people will only answer if they know the answer 🙂   It's throwing an error because you're defining a class twice somewhere in the config.  I can't say what the specific issue is without seeing the config, but it's likely a very simple fix.  Send us a copy of your custom faction and we can take a look at it.

  • Like 1

Share this post


Link to post
Share on other sites

I'm still a little new to using ALiVE, I don't know how I've not used this for longer, and I'm finding mission making is a lot quicker with it! I do have a couple of questions regarding compatibility though, does anyone have an updated list of RHS factions that work? I've tried USMC WD and CDF Ground, but neither of those work (Get a message saying faction groups are not set up correctly for the OPCOM, or something to that effect), however I do seem to have luck with GREF Nationalists/NAPA and I think ChDKZ. I've yet to go through every single faction config, but a list could save some time. I'm also fairly certain that it isn't user error, as I have no problem using other mod factions such as the ones from CFP and CUP. Also, does anyone know if this works with Chernarus 2020 from the CUP Maps 2.0? I've tried placing modules in an actual mission and on the blank map (with both modded and vanilla factions), but I consistently end up with infinite loading screens. Thanks in advance!

Share this post


Link to post
Share on other sites

Is it possible to use the LHD to its full capacity and simulate a beach assault within a mission?

Share this post


Link to post
Share on other sites

Im trying to build an ALiVE mission on Sahrani complete with an Aircraft Carrier either the Freedom or Nimitz (with a naval air-wing), a (HAFM) submarine and 2 frigates for NATO, (haven't decided on a group for OPFOR), i want them to work together by patrolling the seas surrounding the island, sharing information on targets and supporting their infantry on the ground by firing missiles and artillery inland, i would love for some ASW helicopters to work in tandem with the ships without completely intervening with the land war. Id like use USS Liberty to act as a base for AI troops so they can be transferred to shore by helicopters and boats (and maybe while also being a refuelling station for the ASW Helicopters since they cant land on the frigates).  It's gonna be an ALiVE based and a single player mission. I know this is a lot and Arma logic can only go so far,  but if anyone can help i would appreciate it.

Share this post


Link to post
Share on other sites

Hello, im having a problem with persistence, i follow the instructions in the wiki and use the cloud saving to the war room page, yesterday we started an insurgency in fallujah and after a few hours i log as admin and using the alive menu in escape i press Server save and exit, it eventually saves and ends the mission. So i then close the executable from windows server, then today i once again load up the pbo mission and find that no progress was saved, but when i go and check out war room stats it actually recorded data, im pretty sure every module is checked on persistency so i dont know what to do. 

Share this post


Link to post
Share on other sites
34 minutes ago, Synchronized said:

then today i once again load up the pbo mission and find that no progress was saved, but when i go and check out war room stats it actually recorded data, im pretty sure every module is checked on persistency so i dont know what to do. 

 

 

How is it you determined your progress was not saved; mission time, location or something similar?  I ask because you have to select what you want persistent in the Alive module (I think it's the data module, I'd have to check) to have mission time, location, ammo counts, saved as persistent.  Otherwise you'll start the next play at the original campaign start position, with original start time, load outs, ect.

 

Good day!
DrDetroit

Share this post


Link to post
Share on other sites
10 minutes ago, drdetroit said:

 

 

How is it you determined your progress was not saved; mission time, location or something similar?  I ask because you have to select what you want persistent in the Alive module (I think it's the data module, I'd have to check) to have mission time, location, ammo counts, saved as persistent.  Otherwise you'll start the next play at the original campaign start position, with original start time, load outs, ect.

 

Good day!
DrDetroit

 

hH5XRM3.png

 

Those are the settings, and of course other such as CQB module, etc... 

Share this post


Link to post
Share on other sites
1 hour ago, Synchronized said:

 

hH5XRM3.png

 

Those are the settings, and of course other such as CQB module, etc... 

 

 

Those settings look correct, except I run database source as local, not cloud.  I don't use war room, I run local or dedicated server. Make sure your Mil AI Commander has persistence set to yes.  Also, you could try to set database source to local, see if that does anything for your persistence.  

 

 

Share this post


Link to post
Share on other sites

I have been really enjoying the more user friendly aspects of alive compared to other dynamic mission creators. However I was hoping someone would be able to help me with something I want to do in my mission. With EOS insurgency type missions you commonly have multiple 1x1 km box zones that each spawn their own units inside. These boxes start off as the color red and can eventually turn green or blue once you have cleared the area of hostiles.

I tried the basic linking of markers with triggers and using the code:

OPFOR not present-
"marker1" setmarkerColor "ColorWEST";

OPFOR present-
"marker1" setmarkerColor "ColorEAST";

However this does not work properly since alive only spawns the AI in once a player comes in a defined range and my current triggers only detect AI that are actually spawned; not going to spawn. How can I have a marker start red then turn blue once my players have cleared the area of the Alive spawned AI?
Thanks.

Share this post


Link to post
Share on other sites

Hello all,

 

Firstly, I wanted to say thank you to the ALIVE team for making such an awesome contribution to ARMA 3.  ALIVE truly brought ARMA back to life for me!

 

My question pertains to getting the Global Mobilization DLC to work with the ORBAT Creator. I have entry level knowledge in utilizing the ORBAT creator to create new factions/groups to success, but the GM DLC content groups (compatible and incompatible) won’t show despite displaying as a faction in the ORBAT overview.  I’ve read on GITHUB about this issue: “Non uppercase faction names or inconsistent case for faction names lead to ALIVE not detecting them” https://github.com/ALiVEOS/ALiVE.OS/issues/651

From user senevoldsen: There is sometimes inconsistency in the addon for what the classname is for a faction and that of its units. For Global Mobilization there exists CfgFactionClasses faction gm_fc_DK, but some all units have lowercase faction = "gm_fc_dk", While GM does not seem "group-compatible" with the Orbat creator, the end result of this that even the unit editor is not, so groups cannot even be manually constructed.

 

Questions: Is there any way to get around this, as I am rather desperate to get the GM DLC content I have been enjoying over to ALIVE?  Can faction “gm_fc_DK” be overridden to a proper readable format to ALIVE? Or vis-versa can all of the “gm_fc_dk” unit names be changed?  GM uniform content was showing up in the ORBAT Creator and part of me thought about reskinning CSAT troops as East Germans, etc…but not certain how to force vehicle content to do something similar. 

Any ideas or suggestions would be greatly appreciated.

 

Thank you!

  • Like 1

Share this post


Link to post
Share on other sites

Is there a way to make the MACC more active? it rarely ever issues orders and my side needs major air support 

Share this post


Link to post
Share on other sites

Is there a way to filter out what missions are auto generated for you? Such as if you only want to get "Clear the town" missions? 

Also, in order for missions to be genrated, you have to have an AI Commander for your players side correct?

Share this post


Link to post
Share on other sites
4 hours ago, dragonfire43560 said:

Is there a way to filter out what missions are auto generated for you? Such as if you only want to get "Clear the town" missions? 

Also, in order for missions to be genrated, you have to have an AI Commander for your players side correct?


Try the bottom of this page 
http://alivemod.com/wiki/index.php/Custom_Blacklists

 

Share this post


Link to post
Share on other sites

Hi,

I am haveing issues with persistance in my mission, and I am not sure what I am doing wrong. My progres is sent to WarRoom but its not returned to session once I restart mission (I do use "save and exit" option) but nothing happens. Any chance I could get someone to get on Discord/TS to help me?

Share this post


Link to post
Share on other sites
On 9/6/2020 at 2:49 AM, dragonfire43560 said:

 

Thanks!

I cant really understand how to do it though.

 

I cant find staticData.sqf. Is this something in the editor?


No you create that file in the root of your mission folder.

Share this post


Link to post
Share on other sites

There is a bug where people get kicked out of their vehicles randomly, its really annoying, any fix for that?

Share this post


Link to post
Share on other sites
On 1/17/2021 at 11:45 AM, Synchronized said:

There is a bug where people get kicked out of their vehicles randomly, its really annoying, any fix for that?


I use ALiVE all the time and have never seen this bug. What makes you so sure it's ALiVE?

Share this post


Link to post
Share on other sites
2 hours ago, JD Wang said:


I use ALiVE all the time and have never seen this bug. What makes you so sure it's ALiVE?

 

It only happens when we use alive, and something makes me think its some module but i cannot yet determine which, because other more simpler missions do not have this bug

Share this post


Link to post
Share on other sites

I have the same issue with my squad getting kicked from vehicles, but it's from another mod.  When I use "Fire on my lead" command from the mod (can't recall the name at the moment - AiO Command or FHQ Combat Mode I think ), my guys jump out.  I have not seen this behavior with Alive.

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×