Jump to content
t-800a

[COOP][CUP] SME.Gen - SmallMilitaryEncounter Generator

Recommended Posts

smegen_logo_tp_50per.png

SmallMilitaryEncounter Generator

A dynamic mission for ARMA3 that generates small military encounters.

SME.Gen-V.040-green.svg?style=flat-squar Author-T--800a-blue.svg?style=flat-squar Utilises-CUP-orange.svg?style=flat-squar

 

The intent of the mission is to have something similiar to an Domination / Invade & Annex type COOP missions, but in a smaler and more infantry focused scope.

And have a mission that is easily customize able, at least in my opinion. Most things you may want to change can be found in the files under config/.

Also the mission is build from scratch and not a derivative of some other mission existing.

 

I hope that most of the stuff works quite stable, but the mission didn't have very much "stress-testing" or balancing. This is also a reason why I relase it here, gather some feedback/criticism.

 

You can follow further development via GitHub.

 

Missions:
_SMEGen_.Altis
- default Enemy Faction:    CSAT
- default Player Faction:    NATO

 

_SMEGen_CUP.Chernarus
- default Enemy Faction:    CUP NAPA
- default Player Faction:    CUP USMC

 

_SMEGen_CUP.Takistan
- default Enemy Faction:    CUP Takistan Army
- default Player Faction:    CUP US Army

 

SMEGen_IFA3.Staszow
- default Enemy Faction:    IFA3 Soviet Forces
- default Player Faction:    IFA3 Wehrmacht

 

DOWNLOAD from GitHub

DOWNLOAD the PBOs

DOWNLOAD from Armaholic

FIND in my Workshop

 

Changelog V.050

Spoiler

## Version V.050 - 09.02.2017
# added IFA3 variant: _SMEGen_IFA3.Staszow
- IFA3 specific Tasks
- IFA3 specific Factions

# main changes
- moved cfgRandomMissions.hpp to mission root (easier to sync after changes)
- moved initParams.sqf to fn_params.sqf (easier to sync after changes)
- missionFactions.hpp and missionPlayerFactions.hpp overhaul
- player side affected by selected player faction
- spawned vehicles can now be defined in playerFaction (new class missionVehicles)
- vehicles in player faction can also be defined to be mobile arsenal
- spawn positions based on markers defined in the config (make sure NO! objects are near those positons (10m radius))
- added RHS configs by Bek & Mashroom
- added CUP US Army Faction
- added / changed Params accroding

# minor changes
- vehicle patrols are spawned in a central location
- JIP task publish (hopefully)
- fixed BIS revive params include error (WTFBISOMG)
- small positioning impro. in fn_createConvoy.sqf
- added simpe addon check
- removed 'scrippted' mainbases in missions (all in 3DEN now)
- basic respawn system for the defined vehicles

 

 

Mission Parameters

  • select the enemy faction
  • select a reward set
  • select the amount of simultaneous mission sites
  • select the AI skill level ( militia / regular / special forces ( for details check T8/config.hpp ))
  • select if you want to keep your gear after respawning
  • select if you want vehicle patrols between objectives

 

Available tasks

Currently there are 4 types of mission-sites with different tasks available. There is always a set of tasks available. If those tasks are finished a cleanup will happen and a new set of tasks will be generated. All sites on which tasks are spawned are currated in the config files!

Towns

  • clear occupied town
  • destroy 2 mortars
  • destroy 2 resupply vehicles
  • kill HVT and his Guards
  • gather INTEL from HVT

Military Bases

  • clear occupied base
  • destroy 2 mortars
  • destroy 2 resupply vehicles
  • kill HVT and his Guards
  • collect INTEL from HVT

Road-Positions

  • destroy broken down convoy
  • clear road block / checkpoint
  • IED site: clear IEDs or gather INTEL

Installations

  • destroy communication base (radiotower)
  • recover UGV and return it to base (stomper)
  • download INTEL in a compound

 

Rewards

Player Gear

A player ranks up with every succesfully completed task. With every new rank the player will get acces to more, better gear in the virtual arsenal.

Vehicles

for completing a set of missions:

  • mobile HQ / mobile respawn
  • armed light APC
  • armed light helicopter

After completing two mission one vehicle will be spawned, starting with the MHQ. If one vehichle gets destoryed it will be respawned instead of spawning the next tiers vehicle. There won't be multiple iterations of the same vehicle. The reward vehicles can be found outside the base in the hangars. Also vehicles can be reapired in a service station in the main base.

 

Vanilla Systems

The missions uses various vanilla systems:

  • BIS tasks
  • BIS dynamic groups
  • BIS virtual arsenal
  • BIS respawn menu
  • Time Acceleration: the time is accelerated: 4h IRL = 24h in game. If you want to change this, there is a module placed in the mission.

 

Additional Scrips

And the mission uses some other scripts:

 

Singleplayer

I use the singleplayer mostly for debugging. There are also some keys preset to help with porting the mission to a new map.

You will need the following extension for SP debugging:

 

Keys:

  • F5: log current player position as 'town'
  • F6: log current player position as 'military base'
  • F7: log current player position as 'road' (direction of the player matters! look down the road)
  • F8: log current player position as 'compound' (use open, even space approx. 75m x 75m )
  • F9: exports the logged positions to a file with arma-config formating.

http://imgur.com/a/hD6mM

 

License

# SME.Gen - SmallMilitaryEncounter Generator
# A dynamic mission for ARMA3 that generates small military encounters.
# Copyright (C) 2015-2016 Hauke Sven "T-800a" Fischbach
# full License: https://github.com/T-800a/SME.Gen/blob/master/LICENSE

This program is free software; you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
the Free Software Foundation; either version 2 of the License, or
(at your option) any later version.

This program is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
GNU General Public License for more details.

You should have received a copy of the GNU General Public License along
with this program; if not, write to the Free Software Foundation, Inc.,
51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.

When publishing a derivative of this product you may not use a name that
might create the impression that your version is an official release.

Some folders of this project may contain a seperate LICENSE file. Should
that be the case, everything in that folder and all subfolders is subject
to that license instead.
  • Like 14

Share this post


Link to post
Share on other sites

Just tested a 2 site mission. It was really great !

 

May be add an optional parameter to enable the helo usage from start (or starting rank). May be I was unlucky but the two sites were at the opposite of the map. I must confess I used the camera-teleport feature instead of driving over there :) 

 

Your mission has a great potential !! Thx for sharing !

  • Like 1

Share this post


Link to post
Share on other sites

It looks like fun, but when I spawned at the airfield all that was visible on my player was a bald head.

Share this post


Link to post
Share on other sites

I know in the last update the ACE version was dropped...

 

Would  there be any reason the mission would not load with ACE active on the server?

 

I try to load the mission on my dedicated server, i can download the mission file and get to the onLoad screen.  But then it just sits there and does not progress to the map screen.

 

I can load the mission up in the editor no problem, which is what is confusing me at the moment;  I can confirm all required addons are running on the server.

Share this post


Link to post
Share on other sites

It looks like fun, but when I spawned at the airfield all that was visible on my player was a bald head.

Had the bald head more of a sweaty shine, or more a oily shine?

But sorry can't help you with that few information. But you should spawn without gear (expect uniform).

 

I know in the last update the ACE version was dropped...

Would  there be any reason the mission would not load with ACE active on the server?

I try to load the mission on my dedicated server, i can download the mission file and get to the onLoad screen.  But then it just sits there and does not progress to the map screen.

I can load the mission up in the editor no problem, which is what is confusing me at the moment;  I can confirm all required addons are running on the server.

I dropped the ACE mission because it was basically just ACE modules placed in the mission and nothing else expect a special gear set with the ACE items in it.

I think if you want to use ACE you will modfiy it yourself anyways, to fit it your ace preferences.

If I test the mission on a freshly starded dedicated server it always takes a bit longer till the server has loaded everything (with all the CUP stuff to load), maybe you were a bit impatient? Because i was too after making the Taskistan mission I got mad that it din't load, but I only was to impatient.

Share this post


Link to post
Share on other sites

I will try again, i use the ACE server config, so there shouldnt be a problem there, just disabled the revive script in mission parameters.

 

I did wait a good 5 minutes, but ill give it another shot.

 

This does look excellent though, i'm eager to try it.  Thankyou...

 

 

EDIT1:  Just waited 30 minutes no mission start. Gonna investigate more...

 

EDIT2: Ok this is getting stranger...

 

I stripped off addons in stages, until i got down to literally the required addon for the mission this being:-

@cup_units;@cup_vehicles;@cup_weapons;@cup_terrains_maps;@cup_terrains_core;@cba_a3

Still the mission will not load, so i went back to my server launch parametres.  By complete accident i turned on -autoinit, which launches the mission on selection instead of waiting for player to ready up.

 

To my suprise the mission loaded and i managed to join.  Now here's another strange thing, even though i'm now in the mission, something definatly has not initialised as the boards for the various areas (Arsenal, Repair etc.) are still sat in the middle of the runway together.  The markers on the map are also missing as are all the base objects.

 

I'm generally pretty good figuring out mission loading problems, but this has got me totally confused.

Share this post


Link to post
Share on other sites

Ohhh well that's def. too long ... I was thinking about two minutes max. And that's on the old AMD rig I have.

But I just loacaly tried with ACE on dedicated and it strated.

Share this post


Link to post
Share on other sites

Yeah i've just gone back and double checked with no -autoinit on the server and only the required addons server side and on my end.

 

No mission start...

 

Again loads fine in the editor, just not on the server.

 

Is there anyone who has this working or could check on a (non-local) dedicated server, confirm this is just a problem with my server.

 

I really want to play this aswell  :P

 

EDIT: Tried to get another guy into the server, same thing, so its def no my end, still possibly the server but other missions load fine.

 

Here is the end of the server .rpt

21:19:04 [55578,735.282,0,"XEH: PreInit Started. v2.2.0.151130. MISSINIT: missionName=co@x_sme-gen, worldName=takistan, isMultiplayer=true, isServer=true, isDedicated=true"]
21:19:04 [55578,735.448,0,"XEH: PreInit Finished."]
21:19:04 Error in expression <HitFace max HitNeck>
21:19:04   Error position: <HitFace max HitNeck>
21:19:04   Error Undefined variable in expression: hitface
21:19:04 Error compiling 'HitFace max HitNeck' in 'HitHead'
21:19:04 Error in expression <HitPelvis max HitAbdomen max HitDiaphrag>
21:19:04   Error position: <HitPelvis max HitAbdomen max HitDiaphrag>
21:19:04   Error Undefined variable in expression: hitpelvis
21:19:04 Error compiling 'HitPelvis max HitAbdomen max HitDiaphragm max HitChest' in 'HitBody'
21:19:04 Error in expression <HitArms>
21:19:04   Error position: <HitArms>
21:19:04   Error Undefined variable in expression: hitarms
21:19:04 Error compiling 'HitArms' in 'HitHands'
21:19:05 c:\w\stable\futura\lib\network\networkserver.cpp NetworkServer::OnClientStateChanged:NOT IMPLEMENTED - briefing!
21:19:05 [55579,736.702,0,"XEH: PostInit Started"]
21:19:05 [55579,736.711,0,"CBA_VERSIONING: cba=2.2.0.151130, "]
21:19:05 [55579,736.721,0,"XEH: PostInit Finished. State: _isClient=false, _isJip=false, _isDedClient=false, _isServer=true, _isDedServer=true, _playerCheckDone=true, _sp=false, _startInitDone=true, _postInitDone=true, _mpRespawn=true, _machineType=0, _sessionId=3, _level=0, _timeOut=false, _game=3, BIS_functions=<NULL-object>, group=<NULL-group>"]

 Its gets to that point then nothing...

Share this post


Link to post
Share on other sites

The words 'mission/combat generator' makes me spill my coffee and go for it ;)

Good luck !

  • Like 1

Share this post


Link to post
Share on other sites

Hi T-800a i really like your missions and its fits perfect for my re-entry into arma3.

How the Ki perform and the missions itself perfect for a round after work with his friends.

 

 

 

So i have customized your missions with own faction rhs russia against rhs east miltia and some ace features on the map mske(hail to Hotzenplotz ;) ).

Where can i change the playerfaction and the ki faction ? (East vs Indep)

 

I have changed the rewards to fit rhs russia, changed the player units on the map and changed the vehicles but when i want to join with no cup vehicles/weapons/units i cant join because he needs the addons.

I have deleted all from cup because i like the mission more with rhs but i need the non used cup addons for joining the mission, how can get rid of cup/units/weapons/vehicles ? 

In the mission sqm is no addon from cup left.

 

My last question can i add more missions locations to your mske mission, i want to place some missions locations on the other islands.

I pressed f5 for town then f9 for export and i have the killzone addons .dll in the missionfolder.

 

But what then, it searches for waypoints or something on the maps but nothing more, mayby you can explain this for a noob like me ? 

Where goes the file with the location and do i only have to add this data i get out there to your mske locations layout file ?

 

Otherwise no problem i`m happy with the mission anyway. 

Share this post


Link to post
Share on other sites

I really want to play this aswell  :P

I hope we get you there soon. :/

When I am back home I'll send you a vanilla version of the mission to try.

Or you try to get on this server: alexkall.dyndns.org:2308 it should be running a vanilla version. (I hope it's up atm.)

 

 

So i have customized your missions with own faction rhs russia against rhs east miltia and some ace features on the map mske(hail to Hotzenplotz ;) ).

Where can i change the playerfaction and the ki faction ? (East vs Indep)

 

I have changed the rewards to fit rhs russia, changed the player units on the map and changed the vehicles but when i want to join with no cup vehicles/weapons/units i cant join because he needs the addons.

I have deleted all from cup because i like the mission more with rhs but i need the non used cup addons for joining the mission, how can get rid of cup/units/weapons/vehicles ? 

In the mission sqm is no addon from cup left.

 

My last question can i add more missions locations to your mske mission, i want to place some missions locations on the other islands.

I pressed f5 for town then f9 for export and i have the killzone addons .dll in the missionfolder.

 

But what then, it searches for waypoints or something on the maps but nothing more, mayby you can explain this for a noob like me ? 

Where goes the file with the location and do i only have to add this data i get out there to your mske locations layout file ?

 

Otherwise no problem i`m happy with the mission anyway.

Player Faction:

1. change the playable units in the A3 editor to the desired units

2. open the file "mission_folder\config\cfgRandomMissions.hpp", find and change "playerFaction" (should be explained there)

AI Faction:

if you have added a faction in the "mission_folder\config\missionFactions.hpp" file then you could set it as default faction to use in the "mission_folder\config\cfgRandomMissions.hpp" file. Search for this entry: spawnUnitsFaction = "CUP_OPFOR_TAKarmy";

To also have it in the Params you would need to edit "mission_folder\config\params.hpp" and "mission_folder\initParams.sqf".

Would you mind sharing the RHS factions, then I can add them to the configs?

I'll prepare a quick tutorial on how to add locations for a map asap :).

  • Like 1

Share this post


Link to post
Share on other sites

Thank you very much, Excellent job :)

Share this post


Link to post
Share on other sites

thx t-800a!

 

"mission_folder\config\cfgRandomMissions.hpp" file. Search for this entry: spawnUnitsFaction = "CUP_OPFOR_TAKarmy";
 

 

I cant find this entry so i have leave my dirty version.

Only changed the classnames of cup to the rhs ones because i dont know where to change the enemy faction.

 

 

I sent you the mission via pm. for the rhs stuff.

 

And I found out why i cant play without the cup addons, because in the  "mission_folder\config\cfgRandomMissions.hpp" file is a classname left from cup for the helipilot whiteslist, so problem solved.

Share this post


Link to post
Share on other sites

 

 

I hope we get you there soon. :/

When I am back home I'll send you a vanilla version of the mission to try.

 

Ok sound like a plan, ill keep trying for now.

 

Thanks for your help.

 

 

EDIT:  Just a quick update, i downloaded the v0.30 version off github.

 

Firstly i tried the ACE Altis version, loaded fine on the server, seemed to have an initialisation problem as some of the billboards are not moving to the places in the base, also no map markers.

 

Then tried the CUP Takistan version, again loads fine on the server now, but there is the same issue of it not seeming to initialise properly.

 

 

On both versions, not all of the info billboards get moved into the base positions (sometimes one or two do, but not all) and there are no map markers.  Tasks pop up fine (although i've not actually checked if they have spawned).  But at least these older versions load up.

 

 

It all just seems so random and it seems i'm the only one having this problem.  I have double checked the server is right up to date as are all the mods on my end and the server.

 

Very strange...

Share this post


Link to post
Share on other sites

Hey, for some reason when I launch this I get 

 

Warning: preNLOD format in object 
ca\plants_e\tree\t_pistacial2s_ep1.p3d
 
Help?
 
EDIT: validating steam files didn't help

Share this post


Link to post
Share on other sites

Hey, for some reason when I launch this I get 

 

Warning: preNLOD format in object 

ca\plants_e\tree\t_pistacial2s_ep1.p3d

 

Help?

this seems to be a problem related to a plant from cup_terrains/aia terrain pack.

not much i can do about, maybe sth. of your data is corrupted?

Share this post


Link to post
Share on other sites

this seems to be a problem related to a plant from cup_terrains/aia terrain pack.

not much i can do about, maybe sth. of your data is corrupted?

 

If I have it on steam, is the only way to resolve this problem to redownload?

Share this post


Link to post
Share on other sites

Ok lets do an update...

 

Firstly yes, my client and the server box are both on windows.  I did have a look for the server you mentioned, but it appears to be down, i will check again tomorrow.

 

Before starting just to confirm the test on the clean version was done as so, no mods loaded on client or server.

 

Done a fair amount of testing tonight with one of my guys.  Found a few new things which may or may not help, i'll try to explain in a somewhat cohesive manner...

 

 

Running the new clean version you sent does the same thing while loading, gets stuck on the "onLoad" screen before the map.  From this point as the client, your only option is to Alt-F4, you cannot back out.

 

If you have two people in the server at this point and the admin dumps their game.  Then the map continues to load in with the other player.  The admin can then rejoin the server and get into the game fine...  At this point i'd like to say we tested lots of combinations of people logged in and letting the mission load with no one logged in.

 

This does appear to be the same behaviour as using the -autoinit parameter on the server, once in game.

 

Once in the mission, its suffers from the same initilisation problem as mentioned before.  The info billboards are still over by the hangar at the start also i noticed some base objects were misaligned.  This time while testing i stayed in the mission for a few minutes and it does appear that after a while the objects start to align and the boards move over one by one.

 

So lets wrap it up by saying either using the admin "dump" method of starting the game or the

-autoinit, it results in some kind of very (very) slow or bugged (i hesitate to say that, as i know your scripting knowledge is top knotch) initilisation of the mission scripts.

 

Just a sidenote, we went off to one of the task objectives that did appear on mission start, there are indeed AI units at these locations, so at least that works (not tested if missions complete).

 

What else....

 

I tested all of the above behaviour with the official 0.40 CUP release aswell and encountered exactly the same.

 

 

A thought, its the only thing that makes any sense to me.  You have the restricted admin slot and i noticed on the editor there is a ZEUS Gamemaster module specifically setup for you.  Could there be the possibility of the scripts which are checking for the restricted admin and stuff interfering?  That kinda doesnt make sense now i've read it back, but feck me i'm stumped on this one.

 

I think thats everything...  :blink:

 

Oh can you just confirm that the map markers i've seen in the editor are supposed to display for clients on the server?  i.e the arrows and area markers over the towns.  (If so, then they dont work either or haven't loaded)

Share this post


Link to post
Share on other sites

Nice mission, but same problem as the poster above.

We have tested it on a linux and a windows dedi server with the no mods version.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×