Jump to content
blackpixxel

TF47 Launchers [WIP]

Recommended Posts

Is this mod still under development?

 

I am getting this error like 50 times in an hour, probably an easy fix.

21:38:33 Error in expression <apons this))) && (((currentmuzzle this) == "tf47_smaw") || ((currentmuzzle this)>
21:38:33   Error position: <== "tf47_smaw") || ((currentmuzzle this)>
21:38:33   Error Generic error in expression

Share this post


Link to post
Share on other sites

Is this mod still under development?

 

I am getting this error like 50 times in an hour, probably an easy fix.

21:38:33 Error in expression <apons this))) && (((currentmuzzle this) == "tf47_smaw") || ((currentmuzzle this)>
21:38:33   Error position: <== "tf47_smaw") || ((currentmuzzle this)>
21:38:33   Error Generic error in expression
The answer was in this thread.

Share this post


Link to post
Share on other sites

The answer was in this thread.

 

Thanks for that extremely helpful post.

 

So has it to do with backblast and ACE, or is it about the currentMuzzle issue?

Share this post


Link to post
Share on other sites

No idea what the actual issue is, but it would be nice to provide the dev with a little more information. Like what mods are you useing besides the launchers, in what situation does this error occur, and so on... You get the idea ;)

Share this post


Link to post
Share on other sites

Thanks for that extremely helpful post.

 

So has it to do with backblast and ACE, or is it about the currentMuzzle issue?

No problem, man. No one but you is interested in solution of your problem. It is rude but true. Description and solution was posted in this thread 1-3 pages above. Feel free to read them all.

Share this post


Link to post
Share on other sites

Has anyone experienced this issue after the ArmA update, hasn't popped up on my .rpt

 

EDIT: Nope, still an issue

Share this post


Link to post
Share on other sites

First off; great mod. I really enjoy all these launchers and I'm looking forward to future additions. For now I have two questions, one has already come up before:

 

1. Can the spotting ammo be made to also be able to go in a vest or uniform rather than just the backpack?

 

2. I've tried adding spotting rifle ammo to a player through > _unit addMagazine "tf47_smaw_sr​"; < and > _unit addMagazine "tf47_smaw_spotting"; < and neither are working.

 

EDIT: 2. Solved by > (unitBackpack _unit) addmagazinecargo ["tf47_smaw_sr",2]; <

Share this post


Link to post
Share on other sites

Looks like RHS uses your models, Blackpixxel. But without all of your features: at4 sight open feature and auto-throw of used launchers. Is that ok and approved?

Share this post


Link to post
Share on other sites

Looks like RHS uses your models, Blackpixxel. But without all of your features: at4 sight open feature and auto-throw of used launchers. Is that ok and approved?

because we are well know for stealing other people's work without permission, are we not?

Share this post


Link to post
Share on other sites

because we are well know for stealing other people's work without permission, are we not?

Not, for sure. I wanted to know about future of tf47 launchers (will we see any updates) and lost features (will we see them in RHS). Because it is a Blackpixxel mod thread that is the best place to ask. Sorry, if my question was unrespectful or rude.

Share this post


Link to post
Share on other sites

Got a real head scratcher with this one: I do a lot of recording for my milsim community, and our tool of choice is a reworked version of gigan's GCam for Arma 3. It's basically a tool that lets me detach my view and fly the camera around like a spectator, albeit while remaining in the game and able to hear my radios. When I activate TF47 launchers, however, GCam vanishes from the list of addActions typically available. Take it out of the modpack and GCam is available. No conflict with tf47_launchers_rhs.pbo in the modpack, interestingly. Can anyone fathom why there would be a conflict between the two? Other mods in use are:

  • CBA
  • ACE3
  • RHS
  • AiA TerrainPack
  • TFR
  • Leights OPFOR

What's even more interesting is that we were using the TF47 mod with no conflicts before installing the August update (which we weren't aware of). After that was installed, the problem began. Any thoughts?

Still experiencing this problem. As a solution, I had replaced the last iteration of TF47 launchers PBO (pre-RHS integration) with the previous one, which was fine... until RHS integrated the launchers into their mod. Now I have the problem again where I can't use GCam while RHS is activated. I narrowed it down by removing the PBO "rhsusf_c_weapons.pbo" from the RHS pack. After taking that out, GCam works again, but obviously other things do not. I used Eliteness to scan the PBO, but I'm only a novice, so removing anything to nail down the culprit would just be guesswork. Can anyone offer a more educated guess as to what might cause this sort of broken interaction? Since GCam is a camera/spectator mod, is it possible something with optics is messing things up?

Share this post


Link to post
Share on other sites

Hey blackpixxel have you tried using isEqualTo to fix the error that is being caused.

((currentmuzzle this) == "tf47_smaw")
replace it with

((currentmuzzle this) isEqualTo "tf47_smaw")
Sorry if this has been mentioned.

Share this post


Link to post
Share on other sites
Empty word in sentence 'XMIT' '' 'far' 'at12' 'xmit' 
15:59:18 Error in expression <apons this))) && (((currentmuzzle this) == "tf47_smaw") || ((currentmuzzle this)>
15:59:18   Error position: <== "tf47_smaw") || ((currentmuzzle this)>

Still getting massive RPT-log spams with this error. It's causing no damage to anything as far as I know, it's just unfortunate the error pops up while in-game, and for everybody on the server.

Share this post


Link to post
Share on other sites

Hello all :)

Yesterday I had -showscripterrors enabled during our coop mission.

This error is very VERY frustrating as it appears to pop up when You are near dead person.

 

So I have done a simple fix to use until Blackpixel will patch it in mod. Download here:

tf47_launchers_armacoop_pl_doman.pbo

(sign it by Yourself)

 

(this is simple config fix thanks to earlier sugestions, "==" was replaced with "isEqualTo").

 

Thanks for this great mod and greetings from Poland! :war:

  • Like 4

Share this post


Link to post
Share on other sites

Hello all :)

Yesterday I had -showscripterrors enabled during our coop mission.

This error is very VERY frustrating as it appears to pop up when You are near dead person.

 

So I have done a simple fix to use until Blackpixel will patch it in mod. Download here:

tf47_launchers_armacoop_pl_doman.pbo

(sign it by Yourself)

 

(this is simple config fix thanks to earlier sugestions, "==" was replaced with "isEqualTo").

 

Thanks for this great mod and greetings from Poland! :war:

While I think fixing the scripting issues in this mod is really important as far as maintenance is concerned.

It should really come from either BlackPixel himself or at least come with his permission.

Send him a PM and see if he replies.

 

Allot has happened since this mods last update and I'm sure there is quite a bit of updating to do. I don't want to see this mod die like some of RH's stuff has.

Share this post


Link to post
Share on other sites

Last time he answered in this thread five months ago. This solution was given at this same day (26 August 2015). There was no other authors activity since then in this thread. If this small contribution to community (few kilobytes - one config file) bothers You - feel free to report my post, and admins will (propably?) hide it / delete link (?).

 

A lot of great mods are discontinued because of such thinking that everything is closed. And here is question for experts: if something has no license then what? :)

  • Like 3

Share this post


Link to post
Share on other sites

BlackPixxel donated most of his launcher work to CUP and will be avaliable in the next few weeks. So if he decides to close the TF47 project (hopefully not!) it will be continued in CUP Weapons.

  • Like 2

Share this post


Link to post
Share on other sites

Last time he answered in this thread five months ago. This solution was given at this same day (26 August 2015). There was no other authors activity since then in this thread. If this small contribution to community (few kilobytes - one config file) bothers You - feel free to report my post, and admins will (propably?) hide it / delete link (?).

 

A lot of great mods are discontinued because of such thinking that everything is closed. And here is question for experts: if something has no license then what? :)

 

Of course im not going to report you, please don't take it as hostile. I've PMed him to see if i can get a response.

BlackPixxel donated most of his launcher work to CUP and will be avaliable in the next few weeks. So if he decides to close the TF47 project (hopefully not!) it will be continued in CUP Weapons.

Thats great to hear (we already use TF47 launchers in our clan and i've been looking for reasons to get more CUP in), If you take a look though the posts since his last update there are some issues that need to be fixed and Ace compatibility that would be nice to have. 

  • Like 1

Share this post


Link to post
Share on other sites

We have some kick ass scripter and config gurus at CUP, and i think they gonna rewrite the code and optimize it. maybe with functions or whatever (just doing dirty work like porting, no clue about the rest :D ). Also one ACE member is also working closely with CUP, so i guess ACE features won't be a biggy. IF and ONCE we optimized the code we will give it back to BlackPixxel OFC

  • Like 2

Share this post


Link to post
Share on other sites

Then you are clearly not allowed to modify it and release the modified work like you just did. See here: http://amar.arma3.fr/#09

 

It's not modified work though, it requires the original mod.

Share this post


Link to post
Share on other sites

Sorry, my bad. Didn't realize it's a simple config patch which still requires the original mod.

Share this post


Link to post
Share on other sites

This weekend we noticed that the AT4 CS version has zero backblast (when used with ace). I am assuming its a bug but maybe its a bad combination of mods, we run a lot of stuff.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×