Jump to content
vipermaul

CBA - Community Base Addons - ARMA 3

Recommended Posts

I've tracked down to CBA that I can't switch optics when it is running. I've tried both the vanilla keypress and the CBA_Weapons keypress to cycle optics. Neither work 

Share this post


Link to post
Share on other sites

Could you guys help me with this? My RVMAT's aren't working after I've added CBA and I have no idea why. (the main post's problem is resolved, I've posted mine as a comment to that one)

 

Share this post


Link to post
Share on other sites

I will report a rather severe issue with CBA_fnc_taskPatrol here since I don't have time to do so on GitHub:

 

Steps to reproduce:

1) Open Eden Editor and create a mission on Malden. (Can be any map)

2) Add a playable unit (For the player)

3) Add 20 ai civilians and to their init fields add the example line for CBA fnc_taskPatrol.

[this, this, 300, 7, "MOVE", "AWARE", "YELLOW", "FULL", "STAG COLUMN", "this call CBA_fnc_searchNearby", [3, 6, 9]] call CBA_fnc_taskPatrol;

4) Host the mission in Multiplayer either from EDEN or via the multiplayer host but have DebugConsole enabled.

5) Leave the mission running for about an hour. (The starting server FPS in my case was 55. Now leave the computer )

6) When you return your FPS will be almost the same bare a few frames less, in my case it went from 55 to 45 yet...

 

Now press ESCAPE to access the Debug Menu and it will be extremely delayed. In fact the whole UI is schedule saturated. It takes a very long time for any UI/GUI element to update and if you die even the death screen takes up to a minute to show up.

 

Does not happen when the Civis get the [group this, getPos this, 300] call BIS_fnc_taskPatrol; in their INIT fields.

 

PS: No mods other than CBA used. Latests Arma 3 version.

  • Like 1

Share this post


Link to post
Share on other sites

Thanks for the report (CBA devs rarely read here, so you should probably post a github ticket too once you have time)

The CBA patrol thing doesn't use scheduler at all, so

5 hours ago, LSValmont said:

n fact the whole UI is schedule saturated

sounds.. weird..

Share this post


Link to post
Share on other sites
1 hour ago, Dedmen said:

Thanks for the report (CBA devs rarely read here, so you should probably post a github ticket too once you have time)

The CBA patrol thing doesn't use scheduler at all, so

sounds.. weird..

 

I can upload a DEMO MISSION if that helps 😉 

Perhaps it is CBA_fnc_searchNearby.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×