Jump to content
wolffy.au

ALiVE - Advanced Light Infantry Virtual Environment

Recommended Posts

Great balls of snot I cant get this thing working period. Read the wiki on all the modules and used the schematics yet when I try and overide csat with rhs units they stay csat. And they spawn right in my hq which is Blacklisted in their drop downs....

ANyone got Takistan along side rhs units please give this a whirl and tell me why i dumb https://dl.dropboxusercontent.com/u/62320088/Real%2520Alive%2520Try.Takistan.rar

I had a look at it froggyluv and there is a few things wrong. Your trying to play with you as the rhs desert faction against CAF Agressors. Thats fine but you have the CAF faction civilian placement with no TAOR assigned and no blacklist. Also you have it synced to a RHS desert military placement. That should be synced to the RHS faction commander.

Last but not least is the usual mistake.. a space before the faction names of both factions in various places. C2ISTAR has this and a couple placements do also. Thats why they are turning to CSAT, because ALiVE is not reading the custom faction with the space in front of it.

I have a multi mod reliant insurgency I built for my clan if you would like me to PM it to you. (I dont think this is the place to showcase a working mission etc.) Its basically blufor vs opf_g_f.

Sent to Hawken (Below). No point in making a new post to say "Sent".

Edited by bigpoppablunts

Share this post


Link to post
Share on other sites

I have a multi mod reliant insurgency I built for my clan if you would like me to PM it to you. (I dont think this is the place to showcase a working mission etc.) Its basically blufor vs opf_g_f.

Could you send it to me? I have a working mission but i love to check other peoples settings

Share this post


Link to post
Share on other sites

Thanks for checking it out.

Well thanks for offer blunts but I'd really like to try and get this specific one down - Ive ripped open a few other missions but generally they vary on how they set things up and Im trying to keep it true to schematics.

The obvious 'front space' problem was stupid of me and I've fixed that but all the other problems remain.

Ive added the giant map marker 'Map1' to all opfor modules and 'Nato1' for blufor. When you say Faction Civilian Placement your talking about the Civilian Placement and not Civ.Objective correct? Pretty sure I only had Civ Objective connected to but you may be correct Ill look back.

Other problems:

1. Says the Opfor is not defined caf_ag_me_t

2. The blufor faction never appears

3. Opfor tanks are all over my nato1 markered base -and I have set there armored capacity to zero

Obviously Im doing something very wrong, but I'd really like to not only get this to work, but understand why Im f'ing it up so bad

Share this post


Link to post
Share on other sites
Yes, not related to a spawn height issue but very well could be that i placed multiple helipads close together thats causing it or per notes. I'll play around moving them more apart. Should i place the module with a Helipad (empty object), or just the modules?

I usually just place the modules (IIRC the module places an invisible helipad) so I would start there. Make sure you have enough clear landing space around each module.

so i successfully made an asym mode for kunduz, everything WAS working great and then i open the editor to fix some things and now my c2istar gives me a horrible error message and the objectives spawn off the map alot(which has happened before but not like this). when a objective does spawn on the map, theres no garuntee anything will be there, except enemies even though im supposed to take care of a troop transport or somehting. does anyone have any ideas?? what is the reason my c2istar fails so hard? here is a picture of the error ive been getting from c2istar everytime an objective is set even if it doesnt show up on the mayp http://steamcommunity.com/sharedfiles/filedetails/?id=449398802

New one on me I've never seen this issue before. Try deleting and replacing the C2ISTAR module and try again. Failing that post your screenshot (it didn't appear in your previous post) and your RPT file if possible.

I had a look at it

Thanks for helping out bigpoppablunts.

@froggyluv - I would try using the vanilla BIS factions to start with - both RHS and CAF have had config issues in the past so it could be an issue with either mod. Vanilla factions are guaranteed to work and once you get the hang of it you can look to other factions.

Share this post


Link to post
Share on other sites

hi froggyluv

tried to fix your mission .... but sorry to say that but this mission is a big mess ! (I don't mean this rude!!!)

I consider you to read carefully ALiVE Wiki

things I found consider to change

Virtual AI System:

Spawn Radius - set this to 1000/800 not more

Active Limiter - set this to 15, if set to 50 like you did the FPS can go down to unplayable!

read specially in ALiVE Wiki how to synchronize the modules correct!

be careful when you copy paste names into the modules ... there where spaces that not be should there!

https://drive.google.com/file/d/0B1gWUNu0kwK1LTU5UGlWXy1Gc3M/view?usp=sharing

kind regards

maquez [Q-Net]

ps:

if you can wait a couple of days I will release a mission which is in development, you can then take this mission as a example for yours.

Edited by maquez

Share this post


Link to post
Share on other sites

^ thanks Maquez... two bananas for you :yay::yay:

Share this post


Link to post
Share on other sites

Wow ok thanks man, I'll download after work today . Your right I never checked the spawn radius but I thought for sure the fact that Opfor were Blacklisted from NATO base that would keep them out. Wondering if you got those RHS blufor to properly spawn as well or they are just not properlyconfiged like Savage stated.

Share this post


Link to post
Share on other sites

Tearing my hair out!! Our markers doest not save when restarting the server.. other stuff stays but not the fricking markers.. and we are using ALiVE markers yes. Please help

Share this post


Link to post
Share on other sites
Tearing my hair out!! Our markers doest not save when restarting the server.. other stuff stays but not the fricking markers.. and we are using ALiVE markers yes. Please help

There is a bug where markers that are deleted in game don't get deleted in database which causes corrupted markers. Can you post the mission name and the name of your group and a dev will check on it.

Wow ok thanks man, I'll download after work today . Your right I never checked the spawn radius but I thought for sure the fact that Opfor were Blacklisted from NATO base that would keep them out. Wondering if you got those RHS blufor to properly spawn as well or they are just not properlyconfiged like Savage stated.

I think the last RHS updated screwed some of the configs and the ALiVE devs have created their own custom configs to work with RHS. I think these are now out-of-date and should be updated for next release. Again the best way to be sure is to test with vanilla BIS (OPF_F, OPF_G_F) to make sure your setup works then add RHS factions.

Also blacklists only prevent units from spawning in those areas... nothing stops them from wandering in on their own ;)

Edited by SavageCDN

Share this post


Link to post
Share on other sites

I use RHS and ALiVE quite a lot and had never problems units or factions not spawning ...

if you configure the modules correct all factions apart of the RHS Insurgents do work without any problems

Share this post


Link to post
Share on other sites
I use RHS and ALiVE quite a lot and had never problems units or factions not spawning ...

if you configure the modules correct all factions apart of the RHS Insurgents do work without any problems

There's a config issue that causes independent side T-90's to spawn when using the OPFOR side MSV/VDV faction in the latest release but that's about the only thing I have really noticed.

Share this post


Link to post
Share on other sites

^ ah ok good to know.. .hard to keep track of what works and what doesn't :) Doesn't sound like anything that would cause major issues or groups not being spawned.

Share this post


Link to post
Share on other sites

Once I hit "server save and exit" do I need to sit there and wait for it to finish or can I player exit as admin? The server is setup persistent so it will run without players present.

Share this post


Link to post
Share on other sites

Big thanks manquez for your template. Sadly the CAF Arabs didn't work but a nice rhs island fight for Taki is awesome nonetheless. Haven't seen any Civ's spawn -what are people using for Middle Easter units/Civs/Atmosphere?

Now I can finally build off this template and understand how this masterpiece functions -love it.

EDIT: Ahh never mind, just found Leights

Edited by froggyluv

Share this post


Link to post
Share on other sites

Hey alive devs! I was wondering if it is possible and how to get alive to work with my own self-made terrain. If it is not too hard to do, I would like to do that. I know basic sqf. Though my terrain has no keypoints or named cities defined if that matters for alive.

Share this post


Link to post
Share on other sites

^ currently the indexing process has to be done internally, however there has been talk of having map makers provide a static data file to make it easy to index... perhaps in the near future.

The process does rely on the map having some infrastructure for it to detect - military structures (barracks, HQs, hbarriers, etc), civ structures like houses but also communication towers, sea ports, industrial buildings, etc. I don't think the actual naming of cities would matter (could be wrong here), but without anything for alive to detect it won't be much fun :p

Share this post


Link to post
Share on other sites

Hi, I just made an Alive mission for SP, but after I export it as SP mission, and trying to save I got a crash, something about memory not enough I think... I understand Alive was made with MP persistence in mind, so maybe there are a lot of thing to track of. So maybe you guys can give a few pointers how to make it SP friendly?

Share this post


Link to post
Share on other sites

Curious bout optimizing for SP also. Is it ok to just run in the editor or should it be zipped up and placed on a home server?

Share this post


Link to post
Share on other sites

ALiVE is not really intended for use in SP

read please http://alivemod.com/wiki/index.php/ALiVE_%28Required%29

Saving in Single Player is disabled by default, as the large amount of data in an ALiVE game can cause the client to crash on saving. Enable at your own risk!

Edited by maquez

Share this post


Link to post
Share on other sites
Curious bout optimizing for SP also. Is it ok to just run in the editor or should it be zipped up and placed on a home server?

If you can, use it on a local server. The FPS is dramatically better and persistence won't work in SP (crashes most of the time).

Share this post


Link to post
Share on other sites
Hi, I just made an Alive mission for SP, but after I export it as SP mission, and trying to save I got a crash, something about memory not enough I think... I understand Alive was made with MP persistence in mind, so maybe there are a lot of thing to track of. So maybe you guys can give a few pointers how to make it SP friendly?

Hey mate, also Hi Froggyluv!

Nice to see the "ol' dogs" in here! Dynamic scenarios were always a PITA to persist in ArmA/OFP. SP save tries to put down gigs of data and therefore crashes in most of the cases due to ram issues, also if it finally worked, the scripts werent in the same state, basically SP save just doesnt work and is disabled. We are using a database approach with callextension since MSO in A2. It also works if you want to play alone - setup a Warroom account (ofc its free) with your local IP and just run a local dedicated server (ergo the arma3server.exe with the same mods inclusing @ALiVEServer as arma3.exe). Connect to it: Win, you can even assign separate cpu cores for the server and the client, improving performance massively and taking of the load of your client. I really suggest you do that, thats also how I play most of the time -> Local dedi and client on same machine.

enjoy

Share this post


Link to post
Share on other sites

I'm sorry, that sounds like german to me. Is there a step by step guide somewhere? I always had problem with hosting, servers and all these networking stuffs... sorry for the trouble

Share this post


Link to post
Share on other sites
I'm sorry, that sounds like german to me. Is there a step by step guide somewhere? I always had problem with hosting, servers and all these networking stuffs... sorry for the trouble

Here is a video on how to setup the War Room and how to get it to connect to your server.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×