Jump to content

Recommended Posts

ambientcombat script doesnt work for me. Nothing spawns, even on sample mission.

On tanoa, just 2 crashing UAVs spawned, nothing more

Share this post


Link to post
Share on other sites

Are you getting any errors? I assume you are using latest 1.0 version as well, right?

Share this post


Link to post
Share on other sites
16 hours ago, HazJ said:

Are you getting any errors? I assume you are using latest 1.0 version as well, right?

No i wasnt getting any error and yes i use 1.0. But now it works because im using trigger. When i used gamelogic, nothing happens.


Samplemission on stratis works too, it was my mistake because i played for only about 10 seconds. But strange is that it does not work for me with gamelogic, because in the description it says we can use it with gamelogic...

 

but im happy with trigger too, its basically the same effect: everywhere where i go, it spawns units, which i wanted to have

Share this post


Link to post
Share on other sites

Ah, will try it again, used it some time ago, it was great, love this script. 

Share this post


Link to post
Share on other sites
On 24.7.2017 at 2:34 PM, Lloyd Dawkins said:

@spunfin

I have been using this pack religiously to make dynamic ai in missions and its great.

I have made an Admin GUI which on a button click

 

Can you share it? 

Share this post


Link to post
Share on other sites

Hi spunfin,

I cannot get ambientCombat to work.

nul = [450,900,30,300,6,[1,1,1],player,40,20,false,"default",false,2500,nil,["CARELESS","MOVE"],false,true,["ALL"]] execVM "\scripts\3rdparty\aissp1\LV\ambientCombat.sqf";

This is the default (except the path). Testing on Altis. Nothing happens, but in the bottom left corner of the maps, there seem to be spawns. But when I teleport there (and swim), I find no units.

 

MY BAD. I overlooked the spawn delay argument (here 30/300). Don't know where those ghost units are from. But most importantly, your scripts work :-)

6E80620B7009723C325C2D60356E5D79018AE13F

Share this post


Link to post
Share on other sites

Is fillhouse broken?

When I want to spawn in % of buildings, it spawns units in any building in range.

 

nul = [target, side, patrol, patrol type, spawn rate, radius, skills, group, custom init, ID, classes] execVM "LV\fillHouse.sqf";

 

"spawn rate": Array [a,b] works, it spawns the appropriate number of units.

But numeric does not work here. If it always spawns units in any building in the radius.

 

Example: 0 = [player,1,true,2,10,200] execVM "\scripts\3rdParty\AISSP1\LV\fillhouse.sqf";

 

Result:

2EEE7CC6C3F27481A2624DFEC78B995F549E28FF

 

Share this post


Link to post
Share on other sites

It is because it 's a Flash app. Google Chrome (must use another that has support) dropped support for Flash and other browsers will request access for it run (allow). It is working here.

8e04e520-e612-4563-8b05-e3f523cdd3c3.png

Share this post


Link to post
Share on other sites
On 9/3/2018 at 9:57 AM, tortuosit said:

Is fillhouse broken?

When I want to spawn in % of buildings, it spawns units in any building in range.

 

 


nul = [target, side, patrol, patrol type, spawn rate, radius, skills, group, custom init, ID, classes] execVM "LV\fillHouse.sqf";

 

 

"spawn rate": Array [a,b] works, it spawns the appropriate number of units.

But numeric does not work here. If it always spawns units in any building in the radius.

 

Example: 0 = [player,1,true,2,10,200] execVM "\scripts\3rdParty\AISSP1\LV\fillhouse.sqf";

 

Result:

2EEE7CC6C3F27481A2624DFEC78B995F549E28FF

 

 

If you dont mind separate scripts try this.  It is the best one i have found.

 

 

 

On 10/3/2018 at 10:07 PM, HazJ said:

It is because it 's a Flash app. Google Chrome (must use another that has support) dropped support for Flash and other browsers will request access for it run (allow). It is working here.

8e04e520-e612-4563-8b05-e3f523cdd3c3.png

 

Thanks for that. dumb mozilla.

 

Share this post


Link to post
Share on other sites

All browsers have it. It is a safety type thing. You can set it fo Always remember though. Except Chrome as it ditched Flash Player. Dumb Chrome :icon_biggrin:

Share this post


Link to post
Share on other sites

Hello everybody, sorry for the necro but I recently started creating missions and stumbled upon this pack and really love it this far. But i've got one issue that drives me crazy.

 

So i'm using the randomsector script and put gamelogics all around Malden. Everything works fine excepted that every time I get a task that's more than 2km away I got an anoying hint on the top right of the screen which says "Target too far, AI idling" with a little hint sound.

 

At first I thought that was ok, but infact once it starts showing up it nevers quit on showing up every few seconds until mission ends, even if I get to the task location.


I spend a few hours in the differents scripts and reading the pages of this thread but didn't found anything about that.

 

I also tried to switch AI patrol type from hunting player to guard zone thinking it was the cause, but no differences. I've also used zeus to check if the ai is indeed idling and they seem to do their patrols.

 

If anybody knows how to hide this hint, last precision I execute the defaut code in player's init

nul = [100, [gameLogic01,gameLogic02,gameLogic03]] execVM "randomSectors1.sqf"; #with obviously more gamelogics but this code

Here's a screenshot on steam

Share this post


Link to post
Share on other sites

the hint resides in the file "LV_fnc_follow.sqf, line 103. You could remove the text between the quotes.

 

or 

 

REM out the line with //

 

 

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, Blackheart_Six said:

the hint resides in the file "LV_fnc_follow.sqf, line 103. You could remove the text between the quotes.

 

or 

 

REM out the line with //

 

 

 

Damn I definitely missed that line, thank you very much for the help !

Share this post


Link to post
Share on other sites

Its possible to choose a position for the HQ unit (that spawn at 0.0.0), or disable simulation and model cause i got issue if i want to use an AI mode like LAMBS or GLX on a non Island map, if an AO is close to the botom left of the map all the AI leave the defending position and go to the bottom left of the map and breack the scenario.

I looked up a little bit in the script but didn't find anything on how are spawned the 3 HQ AI.

Share this post


Link to post
Share on other sites

If I understand you correctly, you want to spawn @ 0,0,0 position on the map? Just put an empty marker there, and spawn your hq unit. 

Share this post


Link to post
Share on other sites

no i dont want to spawn them  here, but i find an other way to deal with it

 

Share this post


Link to post
Share on other sites

Hello spunfin

It is possible to edit the loadout, uniform, vest, weapon, items and others
I have no idea where and how to do this, can you help me?

PS: Sorry for my english on google 😞

Thanks

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×