Jump to content
k3lt

Low CPU utilization & Low FPS

Recommended Posts

1 fps less shouldnt be ok for anyone, where is the logic there, the devs patched the game a couple of months between your benchmarks and instead gain some performance due the further processing of the game you lost frames?

Thats not acceptable in my opinion but it´s just my thought.

And thank god we have Seagulls now Ingame and 2 transport helo´s are incoming next. WOW. Not.

This can happen with fixing bugs, e.g.:

Fixing an AI bug that was preventing a block of code from running(maybe AI finding cover when under fire) now that this code runs it requires processing time, lowering overall FPS.

Edit: regarding your sarcastic comment; not everyone can work on engine performance, don't expect artists, modellers, UX designers or audio engineers to do that, it's not their area of expertise.

Share this post


Link to post
Share on other sites

How do we enable MSAA? There is no drop down menu under my nvidia control panel.

I thought this was supposed to be a fairly easy thing to do.

Please don't tell me to use Sweetfx, I gave up on that long ago.

Share this post


Link to post
Share on other sites
This can happen with fixing bugs, e.g.:

Fixing an AI bug that was preventing a block of code from running(maybe AI finding cover when under fire) now that this code runs it requires processing time, lowering overall FPS.

Edit: regarding your sarcastic comment; not everyone can work on engine performance, don't expect artists, modellers, UX designers or audio engineers to do that, it's not their area of expertise.

Not everyone? I would be happy if 1 dev would start with this.

Yeah, many of my comments contains sarcasm but thats not the point. I believe it´s hard work to start with optimizing this, i bet this is difficult as hell, anyway, it would be great as gamer if we could notice someday a noticeable push due the fps (MP/SP)

The performance is like this line ----------------------------------------------------------- month over month no significant or noticable gain due fps.

Possible that they have more important things to fix, in my opinion it would be correct if they would start to fix the most voted tickets from the feedback tracker, some tickets reaches close to 3000 "Yes" Votes, active since 12,8 or even 6 months. And still not fixed. Such votes by the community should be #1 priority.

Share this post


Link to post
Share on other sites
Not everyone? I would be happy if 1 dev would start with this.

Dev-branch patch notes mention performance improvements/fixes constantly, quite often multiple times a week.

Share this post


Link to post
Share on other sites
So tell me, how many performance did you gained by that "mentioned" fixes? Give me some numbers, fps or %, didnt matter.

Dude, you are a cancer on this forum, nothing you say is helpful and you do nothing but bitch about a game that it seems you must still be playing? You wouldn't be playing if you didn't enjoy it so get over it, we all know how you feel about it and we are all frustrated too but we are all here to enjoy it as best we can. The devs can't fix it but that doesn't mean it's not a product to enjoy still. I paid £20 for the game and would happily pay the full £40 as even in a broken state, it's worth it. Look at all the £60 PS and XBox games that give you 8 hours of mediocre gameplay. Arma is still worth it.

As for your constant whining about zero work arounds, I have just spent the evening on teamspeak with people with ancient PCs getting 15FPS they have 5 year old hardware that may still be fine for browsing and excel but not for a relatively young game like Arma 3. It was a server of 40+ people with a whole lot going on and I was getting a reliable 45-65FPS while these folks were getting 15FPS. You need to ask yourself, does it really make sense to ask a PS3 to play PS4 games?

My 4770k and R9 290x from 2013 plays my 2013 game really quite well considering it's terrible optimisation. And PLEASE, make sure your RAM is running as fast as it can, there is up to 15% to be had!

Share this post


Link to post
Share on other sites

Ehm, no. I never told that Arma would be a bad game son, so dont accuse me that i say such things. Did you checked my account on Steam and how many hours i spend to play this game?

I´ll make it easy for you: close to 4000 hours now. And the thing where i bitched about the game , feel free to show me that posting. I only can remember that i talked with a Mod (i think it was a conversation with [FRL]Myke) about this game and how great it is, and its too bad that we need to have patience..

Good attempt to tell me something about Ram and overclocking.. but i know about such things cause i,m working since ~20years with pc´s, over 10years i overclock, but thanks anyway.

Share this post


Link to post
Share on other sites

I dont understand why i am getting sub 20 fps when my system should be more than adequite, Here are my pcs specs, any help wuold be appreciated!

Processor Intel® Core i7-3770K CPU @ 3.50GHz

Manufacturer Intel

Speed 3.7 GHz

Number of Cores 8

CPU ID BFEBFBFF000306A9

Family 06

Model 3A

Stepping 9

Revision

Video Card NVIDIA GeForce GTX 660 Ti

Manufacturer NVIDIA

Chipset GeForce GTX 660 Ti

Dedicated Memory 3.0 GB

Total Memory 4.0 GB

Pixel Shader Version 5.0

Vertex Shader Version 5.0

Hardware T & L Yes

Vendor ID 10DE

Device ID 1183

Plug and Play ID VEN_10DE&DEV_1183&SUBSYS_36633842&REV_A1

Driver Version 9.18.13.4411

Memory 16 GB

Operating System Microsoft Windows 8.1 (build 9600), 64-bit

Service Pack 0

Size 64 Bit

Edition

Version 6.3.9600

Locale 0409

BIOS BIOS Date: 03/23/12 22:47:30 Ver: 04.06.05

Version American Megatrends Inc. F4

Manufacturer American Megatrends Inc.

Date 03/23/12

i get sub 20fps during any gameplay whether it be multiplayer, single player or just pottering around in the editor, i have tried running the game in ultra and i actually get better framerates than if i try to tun it in low which makes absolutely no sense to me at all, i normally try to run it in a high/very high state but as i mentioned i can knock ALL of the settings down to low and i still have the same framerates. i have tried running all the startup line tweaks i can find (which used to work for arma 2) i have all the latest drivers installed, i have the game installed on the same harddrive as my OS which is an SSD. I am stumped.

Edited by daveygary1979

Share this post


Link to post
Share on other sites

Tell us about your ingame settings, also tell us if you experience the 20 FPS during multiplayer game or single player.

Much easier to help you if we know more .

Share this post


Link to post
Share on other sites
I dont understand why i am getting sub 20 fps when my system should be more than adequite, Here are my pcs specs, any help wuold be appreciated!

Processor Intel® Core i7-3770K CPU @ 3.50GHz

Manufacturer Intel

Speed 3.7 GHz

Number of Cores 8

CPU ID BFEBFBFF000306A9

Family 06

Model 3A

Stepping 9

Revision

Video Card NVIDIA GeForce GTX 660 Ti

Manufacturer NVIDIA

Chipset GeForce GTX 660 Ti

Dedicated Memory 3.0 GB

Total Memory 4.0 GB

Pixel Shader Version 5.0

Vertex Shader Version 5.0

Hardware T & L Yes

Vendor ID 10DE

Device ID 1183

Plug and Play ID VEN_10DE&DEV_1183&SUBSYS_36633842&REV_A1

Driver Version 9.18.13.4411

Memory 16 GB

Operating System Microsoft Windows 8.1 (build 9600), 64-bit

Service Pack 0

Size 64 Bit

Edition

Version 6.3.9600

Locale 0409

BIOS BIOS Date: 03/23/12 22:47:30 Ver: 04.06.05

Version American Megatrends Inc. F4

Manufacturer American Megatrends Inc.

Date 03/23/12

i get sub 20fps during any gameplay whether it be multiplayer, single player or just pottering around in the editor, i have tried running the game in ultra and i actually get better framerates than if i try to tun it in low which makes absolutely no sense to me at all, i normally try to run it in a high/very high state but as i mentioned i can knock ALL of the settings down to low and i still have the same framerates. i have tried running all the startup line tweaks i can find (which used to work for arma 2) i have all the latest drivers installed, i have the game installed on the same harddrive as my OS which is an SSD. I am stumped.

I got an i5-3570K, pretty similar system to yours and I'm in the same boat. Only difference is I have 2 R9 280X's. Not much you really can do AFAIK. I've done all the tweaks and for most the results are negligible at best.

Share this post


Link to post
Share on other sites

In 13 Years it is playable like OPF with high FPS,thats for sure. xD

ps.

xD the wannabe overclocking guy again haha :D

Edited by TeilX

Share this post


Link to post
Share on other sites

In 13 years i am 45 years old, a little decade faster is not possible ^^ ? In 13 years PersonalComputers goes by their own outside for a walk...

Share this post


Link to post
Share on other sites
I dont understand why i am getting sub 20 fps when my system should be more than adequite, Here are my pcs specs, any help wuold be appreciated!

i get sub 20fps during any gameplay whether it be multiplayer, single player or just pottering around in the editor, i have tried running the game in ultra and i actually get better framerates than if i try to tun it in low which makes absolutely no sense to me at all, i normally try to run it in a high/very high state but as i mentioned i can knock ALL of the settings down to low and i still have the same framerates. i have tried running all the startup line tweaks i can find (which used to work for arma 2) i have all the latest drivers installed, i have the game installed on the same harddrive as my OS which is an SSD. I am stumped.

shadows above high will be rendered by gpu, below high by cpu. The only thing you can do is to overclock cpu and ram. With my 3570k at 3,7GHZ and 1600Mhz my arma3 runs like crap. Big difference to 4,5 or 4,8 GHZ cpu and 2666Mhz ram speed. Important is the cpu/ram part for single player and powerful mp-servers.

@polemic crap

opf was playable?

Share this post


Link to post
Share on other sites

Ok, I did new Benchmarks, yeah they at least managed to fix the start-the-game-issue, but it doesn't look too good. I got a massive loss of fps and as I couldn't believe it, I tested several other games which ran just fine without any change in performance, so I assume that it is not OS / Driver-related.

Arma-3 (Dev.-Build v1.33.127551)

- Windows 10 Pro WMC Technical Preview x64

- 3770k @4700MHz (Core-Parking disabled)

- 2x Gigabyte GTX780-Ti-GHz-Edition-3GB (BIOS: OCN-MOD | Power-Target: 116% | Voltage: 1.212V | Base / Boost: 1265 / 1265MHz | Memory: 7400MHz)

- GeForce v344.11 @1920x1080

- G.Skill 16G(4*4G) DDR3-2400 Quad Channel [TDX] F3-2400C10Q-16GTX (10-11-11-28-2T)

- Fred's MemAlloc

Lowest / Disabled:

- Stratis = 155fps (154fps)

- Altis = 125fps (126fps)

Low:

- Stratis = 114fps (140fps)

- Altis = 99fps (119fps)

Standard:

- Stratis = 85fps (100fps)

- Altis = 76fps (90fps)

High:

- Stratis = 60fps (75fps)

- Altis = 58fps (69fps)

Very-High:

- Stratis = 47fps (56fps)

- Altis = 44fps (52fps)

Ultra:

- Stratis = 39fps (41fps)

- Altis = 36fps (43fps)

Maxed-out:

- Stratis = 28fps (33fps)

- Altis = 14fps (17fps)

*(Dev.-Build v1.25.126046)

:j:

Edited by TONSCHUH

Share this post


Link to post
Share on other sites

[sarcasm]Maybe some kind of unidentified force, a "stay lowfps tweak" iniciated through the Illuminati or something^^ [/sarcasm]

Hmm, hard to find the issue there, could imagine that maybe the experimtal Win10 is the issue. And your Harddisk/SSD have the same space as you did the bench at first time with better fps?

Share this post


Link to post
Share on other sites
[sarcasm]Maybe some kind of unidentified force, a "stay lowfps tweak" iniciated through the Illuminati or something^^ [/sarcasm]

Hmm, hard to find the issue there, could imagine that maybe the experimtal Win10 is the issue. And your Harddisk/SSD have the same space as you did the bench at first time with better fps?

Yeah, I didn't install any additional games and the OS is still on a separate SSD to the Game and both SSD's have still heaps of free space.

I'm not 100% sure if it could be the OS, but other games are still giving me the same amount of fps as before the update.

I think I will have to wait that someone else is doing another benchmark run to be sure.

:confused:

Edited by TONSCHUH

Share this post


Link to post
Share on other sites

Windows fuckin 10 :confused:

That exists? Doesn't sound like something that would be a good thing to throw in the mix, have you tried in something less... Experimental :rolleyes:

Remember how crazy the arma engine is, I wouldn't put it past the engine to not want to play with the OS.

Now excuse me while I go look up windows 20. ;)

Share this post


Link to post
Share on other sites
Windows fuckin 10 :confused:

That exists? Doesn't sound like something that would be a good thing to throw in the mix, have you tried in something less... Experimental :rolleyes:

Remember how crazy the arma engine is, I wouldn't put it past the engine to not want to play with the OS.

Now excuse me while I go look up windows 20. ;)

Here you go: Click

The TP seems to be a bit faster overall, but as I don't know someone who is playing ARMA-3 on top of that, I can't really rule out any negative impact.

:)

Share this post


Link to post
Share on other sites

Guys, here is my specs:

AMD FX8320@4,4Ghz

AMD Radeon R9 280x

Memory 8Gb@2133Mhz 10-11-10

What are the best start parameters of the game for me? I mean -cpucount=8 -exthreads=7 -enableht. Should I use all of them?

Share this post


Link to post
Share on other sites

What are the best start parameters of the game for me? I mean -cpucount=8 -exthreads=7 -enableht. Should I use all of them?

Use either none of them or just the -enableht.

cpucount=8 and exthreads=7 are the defaults for your CPU. The hyper-threading (enableht) may or may not improve performance. My guess is not.

Share this post


Link to post
Share on other sites

-enableHT detects HT cores and uses them for less intensive tasks

Share this post


Link to post
Share on other sites
-enableHT detects HT cores and uses them for less intensive tasks

Thanks for the Info / Confirmation !

:)

Share this post


Link to post
Share on other sites

Is -cpuCount=8 now the default setting for ArmA III or is it -cpuCount=4 as for ArmA II since patch 1.07?

Have managed to get 50 FPS @ Altis after 3 runs (51, 50, 50) @ Ultra @ 1680x1050 @ Win 8.1 x64 @ SSD Intel X-25M SATA II 275 MB/s read & 80 MB/s write.

Will make another serie of 3 runs today @ 114% 3D to match 1920x1200 resolution.

Have compared FPS at different RAM speeds on Altis

Scores:

45 FPS @ 1600 MHz 8-8-8-24 2T

46 FPS @ 1866 MHz 9-9-9-27 2T

49 FPS @ 2133 MHz 9-11-10-27 2T

50 FPS @ 2400 MHz 10-11-11-30 2T

Edited by Groove_C

Share this post


Link to post
Share on other sites
Is -cpuCount=8 now the default setting for ArmA III or is it -cpuCount=4 as for ArmA II since patch 1.07?

The default is the number of cores in your CPU. If you have 8 cores, it's -cpuCount=8.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×