Jump to content
Sign in to follow this  
danieljg

Headshot didn't kill an AI?

Recommended Posts

I remember someone did a video on this issue and posted it in youtube on the damage done to AI after a certain number of headshots. It's a bug not mistaken.

Share this post


Link to post
Share on other sites

I just came home and checked this...I can don headshots with lethal outcome all the time...also with Pistol or M16.

Share this post


Link to post
Share on other sites

Try firing a M107 and see if he dies, if still not then maybe you are using a mod called 'The Iron Head AI'

Share this post


Link to post
Share on other sites

Just tested shooting AI with the M107 in the editor under 1.55

Like playing with FADE lite.

Hits were completely random. bullets would land a foot or more away for no reason

even hit people I wasn't aiming a 3-4 feet away.

Bullet kicked up dust BEHIND the enemies.

No addons

No mods

Stock intallation of Arma 2 and OA (Combined operations)

Island: Utes

Enemies at one of of the runway and me at the other.

Edited by jblackrupert

Share this post


Link to post
Share on other sites

Well thats the problem with a lot of bugs. Some people have no problems at all and others experience a lot of them.

MP is fine for me but in the editor it's next to impossible to kill enemies or even friendlies

without pumping a ton of rounds into them.

Taking down choppers with 1 shot from the M107 happens a lot also.

Share this post


Link to post
Share on other sites
Hits were completely random. bullets would land a foot or more away for no reason

even hit people I wasn't aiming a 3-4 feet away.

Bullet kicked up dust BEHIND the enemies.

AFAIK that is FADE. Try a complete reinstall, clean your registry, remove all files etc. Assuming that you have a legal version and you dont use a no-cd crack for whatever reason that should fix it i guess.

Share this post


Link to post
Share on other sites

It's not FADE. I know what FADE looks like and behaves.

and it is a complete clean install. it's been doing this since 1.50 and others reported the same behaviour but not enough to attract much attention.

It's only in the editor. everything is fine in MP. if it was FADE then MP/SP/Editor would be effected.

Edited by jblackrupert

Share this post


Link to post
Share on other sites

Taking down choppers with 1 shot from the M107 happens a lot also.

Some helicopters suffer main rotor failure from one .50 in the engine block.

It happened to me constantly in Dogs of War, with all those 14.5mm BRDM guns shooting at my Hind from half a mile away.

Share this post


Link to post
Share on other sites

A littlebird being takes down is understandable but yeah sadly the engine doesnt seem to have redundancy systems or anything like that... hence why its so easy to take down armoured choppers

Share this post


Link to post
Share on other sites

I played once online and a standing enemy was about 15m away from me. I aimed directly at the head and shot with my AK-107, nothing happened, I just saw some blood. But after the second shot he was dead. Same story with a second enemy moments later...

Share this post


Link to post
Share on other sites
Just tested shooting AI with the M107 in the editor under 1.55

Like playing with FADE lite.

Hits were completely random. bullets would land a foot or more away for no reason

even hit people I wasn't aiming a 3-4 feet away.

Bullet kicked up dust BEHIND the enemies.

No addons

No mods

Stock intallation of Arma 2 and OA (Combined operations)

Island: Utes

Enemies at one of of the runway and me at the other.

Hi jblackrupert

In all honesty what you describe as happening to you sounds like classic FADE to me. Progressivley ineffective accuracy perhaps only in the editor to begin with then going into the armory then the campaign then the contagion spreads to MP and other game mode options.

I suggest you PM Placebo with proof of purchase in order for BI to confirm you have a valid user key.

It's not FADE. I know what FADE looks like and behaves.

and it is a complete clean install. it's been doing this since 1.50 and others reported the same behaviour but not enough to attract much attention.

It's only in the editor. everything is fine in MP. if it was FADE then MP/SP/Editor would be effected.

FADE is insideous and stealthy and designed to lul the pirate into a false sense of security, with effects sneakily increasing over time. FADE is also updated with every patch, its effects randomised and new lists of cheat programs and fake or re-vended keys added with each version.

The whole thing about the philosophy of FADE is that it is designed and based on a “policy of ambiguity†in order to create Fear Uncertainty and Doubt (FUD) in software pirates and those who run cheat programs, so that they are never sure if they have an effective cheat or working key gen.

Kind Regards walker

Edited by walker

Share this post


Link to post
Share on other sites
I played once online and a standing enemy was about 15m away from me. I aimed directly at the head and shot with my AK-107, nothing happened, I just saw some blood. But after the second shot he was dead. Same story with a second enemy moments later...

You were playing online. The first shot probably killed him and you only saw him fall down on the seconds shot.

Today in MP I exited a chopper that had landed, only to die upon hitting the ground, for the chopper was actually still 10m up.

Not Arma's fault.

Share this post


Link to post
Share on other sites
He didnt fall down for 2-3 seconds. And yes, not Arma's fault... :rolleyes:

It's called lag. If it happened offline, then you would know there was some serious problem inhibiting the proper operation of scripts.

I played on short-lived beta patch where I was running around for thirty seconds after a fatal hit.

Share this post


Link to post
Share on other sites

PgUp/Down just changes my stance.

You need to go into controls and see what the zeroing keybinds are then, if none are bound you need to bind them to what keys you see fit. It's likely your sights are not zeroed in at what ever range you are attempting to fire. Like someone mentioned earlier if you are zeroed in for 300m and you are 50m away, the bullet will miss unless you aim a ways lower to compensate (like in ye old Arma 1/Arma 2 before OA without ACE). To avoid this you can zero in for 50m with the appropriate keys.

As for surviving a hit to the head. If the character is wearing any protective head gear and is at a relatively good distance away they could survive, especially if the trajectory of the bullet has been interfered with, ala the ricochet mentioned earlier. (Note this is all refering to IN GAME, let us forgo what would happen in real life, which while this game tries to emulate, it still falls short in many aspects) Same with shooting through glass, an issue that irritates me in maps like Zargabad where I'm often firing from inside a building with glass windows which plays hell with the ballistics.

Share this post


Link to post
Share on other sites

Didnt read the rest of the posts, but yes, it happens quite often that heashots dont kill (in SP).

Share this post


Link to post
Share on other sites

Never happened to me once in 500 hours of SP, and I must have gotten every other glitch known to man with every combination of patches.

I want a video. Is it even on the bugtracker so we can see the technical details? Or is it all ricochets, distance and rumors?

Share this post


Link to post
Share on other sites

One time, I hit a Takistan Militant in the leg at about 100m with an M107, and he kept running for about 5 feet, then dropped to the ground, where I had to place another round into him (again in the thigh this time) and he STILL did not die until I shot him square in the torso.

As much as it may be realistic that he would not spontaneously die from even a .50 cal, he should've been down and "game dead" right away. If you get hit by a .50, you're not getting up, even if you don't die for a minute or so.

I don't really know why this happened but it was in a the Editor, in a short mission I created.

Share this post


Link to post
Share on other sites
It's called lag. If it happened offline, then you would know there was some serious problem inhibiting the proper operation of scripts.

I played on short-lived beta patch where I was running around for thirty seconds after a fatal hit.

In my case 2-3 seconds lag and in your case 30 seconds lag? :D Well, it sounds plausible...

Share this post


Link to post
Share on other sites

FADE is insideous and stealthy and designed to lul the pirate into a false sense of security, with effects sneakily increasing over time. FADE is also updated with every patch, its effects randomised and new lists of cheat programs and fake or re-vended keys added with each version.

The whole thing about the philosophy of FADE is that it is designed and based on a “policy of ambiguity†in order to create Fear Uncertainty and Doubt (FUD) in software pirates and those who run cheat programs, so that they are never sure if they have an effective cheat or working key gen.

In my opinion, this is really bad. We all know that no system is ever going to be 100% error proof. There are always going to be some instances in which FADE is going to affect people who have bought the game legally. So, to have an ambiguous system that negatively affects your gaming experience without you really being sure of what's going on is not good.

It will only make legal owners of the game stop playing it when their gaming experience suffers and they don't know that it's the copy protection system that has gone wrong.

Edited by Johan S

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×