Jump to content
silola

X-Cam-Taunus Version 1.1

Recommended Posts

1 hour ago, Cosmo_D41 said:

Here is the solution from the CUP-Bugtracker:

http://dev.cup-arma3.org/T1864

 


Perhaps you can try this for Taunus, at least it worked for me (also it will disable the dust-effects for other maps loaded at the same time)

 

 

what if u use CUP Terrains Complete? Like we do?

 

Regards

 

Chaser

Share this post


Link to post
Share on other sites

I suppose that will work to as it organizes the order the mods are loaded. In my case i made my surface-configs depending on the CUP_Terrain_World by adding CUP_Worlds_DustEffects to my required addons and everything worked fine.

 

Try adding this dependency to your xcam_taunus.pbo config in "requiredAddons" and i suppose it will work, too:

class CfgPatches
{
	class xcam_taunus
	{
		units[] = {};
		weapons[] = {};
		requiredVersion = 1.0;
		requiredAddons[] = {"A3_Data_F","A3_Roads_F","A3_Structures_F","A3_Map_Data","GlasContainer","taunus_a3_signs","MaXx_Minigolf_Taunus","MBG_Buildings_2","MBG_Buildings_3","mbg_killhouses_a3","MXDorfschild","Max_FuelStation","Maxx_RFTower","plp_beachobjects","plp_containers","plp_rmairport","TACO_Buildings","taunus_bridge","taunus_markierung","taunus_misc","taunus_a3_wall","TaunusObjects","xCam_groundElements","xCam_Indust_Buildings","xCam_Indust_Concrete","xCam_Indust_Pipes","xCam_Indust_Stairs","xCam_Metal","xcam_objects","xCam_Pipe","xCam_Plants","xCam_Walls_01","xCam_Walls_03","xCam_Walls_04","xcam_wood","xCam_Woodworks","xyz_library","deox_Obj","deox_Obj2"};
		version = "26/03/2014";
		fileName = "xcam_taunus.pbo";
		author = "X-Cam-Team";
	};
};

 

 

Share this post


Link to post
Share on other sites
41 minutes ago, Cosmo_D41 said:

I suppose that will work to as it organizes the order the mods are loaded. In my case i made my surface-configs depending on the CUP_Terrain_World by adding CUP_Worlds_DustEffects to my required addons and everything worked fine.

 

Try adding this dependency to your xcam_taunus.pbo config in "requiredAddons" and i suppose it will work, too:


class CfgPatches
{
	class xcam_taunus
	{
		units[] = {};
		weapons[] = {};
		requiredVersion = 1.0;
		requiredAddons[] = {"A3_Data_F","A3_Roads_F","A3_Structures_F","A3_Map_Data","GlasContainer","taunus_a3_signs","MaXx_Minigolf_Taunus","MBG_Buildings_2","MBG_Buildings_3","mbg_killhouses_a3","MXDorfschild","Max_FuelStation","Maxx_RFTower","plp_beachobjects","plp_containers","plp_rmairport","TACO_Buildings","taunus_bridge","taunus_markierung","taunus_misc","taunus_a3_wall","TaunusObjects","xCam_groundElements","xCam_Indust_Buildings","xCam_Indust_Concrete","xCam_Indust_Pipes","xCam_Indust_Stairs","xCam_Metal","xcam_objects","xCam_Pipe","xCam_Plants","xCam_Walls_01","xCam_Walls_03","xCam_Walls_04","xcam_wood","xCam_Woodworks","xyz_library","deox_Obj","deox_Obj2"};
		version = "26/03/2014";
		fileName = "xcam_taunus.pbo";
		author = "X-Cam-Team";
	};
};

 

 

 

Already tried, but without success...no dust effects :-(

 

Silola

Share this post


Link to post
Share on other sites
26 minutes ago, silola said:

 

Already tried, but without success...no dust effects :-(

 

Silola

 

I have a terrain that works fine with dust but once I load @cup the dust breaks, IceBreakr has the same issue, might be worth speaking with the Cup team.

Share this post


Link to post
Share on other sites

Great guys! :drinking2:

 

No offense, but are you thinking about german "Flecktarn" camo and gear too? This would be great. :icon_biggrin:

If you guys will do so, maybe its possible to add "Tropentarn" aswell, so it could be used on Stratis or Altis. :f:

Edited by Tactical_Beard

Share this post


Link to post
Share on other sites

Take a look at the famous "BWmod", and "BWKleiderkammer". Additionally , there are lots of Retex work to improvise BW-vehicles not ingame yet.

  • Like 2

Share this post


Link to post
Share on other sites

Hi all, i am hoping someone here could help me with the taunus map,

i will run briefly through what is happening.

 

i have all the correct mods downloaded and also the taunus v1.1 map from steam workshop.

all maps and mods show green in the officiol arma 3 launcher, i try to join a server which,

results in immediate disconnect and the following screen is shown

 

2017_01_19_17_18.png

 

i have verified arma 3 files and all are good, however in the multiplayer server menu the taunus map is not showing green its showing red, i will also post this below

 

2017_01_20_14_19.png

 

i have downloaded taunus from the workshop about 5 times now and also from armaholic and nothing seems to work,

does anyone have any idea whether this is an arma bug or taunus bug ?

Share this post


Link to post
Share on other sites

From the list of missing mods, it seems you dont have APEX/Tanoa installed. Perhaps try to check your Steamfiles for errors if you own this expansion.

 

All these missing pbo with _exp_ are from that expansion.

Share this post


Link to post
Share on other sites

tnx for your response cosmo

As far as i have read on page 6 of this forum, foxone states that taunus does not require apex ?, i know that it is dependant on the cups mods though.

 

could it possibly be that uneeded pbo requirements have been left within the taunus map files, or maybe somehow got added when stuff was being packed ?

 

Edited by Ambush80

Share this post


Link to post
Share on other sites

did you try out taunus in the editor/singleplayer? do you get any problems there?

maybe the mission has some old/weird dependencies?

  • Like 1

Share this post


Link to post
Share on other sites

ok, so i gave that a try as you suggested t-800a, and the eden editor/ single player works as it should, as far as i know,

it just seems to be the multiplayer thats affected, well i have already verified arma 3 files a couple of times but just to be sure i will

remove and reinstall arma 3 just to completly rule it out as a problem, and then try again and see what happens

Share this post


Link to post
Share on other sites

@t-800a good news, once i had launched the game in the editor as you recommended and played once as single player, the missing dependencies magically resolved themselves, again tnx !

 

@silola

could you add a note in the relevant place, for this possible fix for missing depencies, i know i am not the only one to have it, as i have seen someone mention this in steam comments as well

 

tnx

  • Like 1

Share this post


Link to post
Share on other sites

no need for any depencies...you try to play an exile taunus server where in the mission file apex content is used.

 

The Xcam Taunus Map itself don´t need apex..it is this special server mate..

 

Regards

 

Chaser

Share this post


Link to post
Share on other sites

Awesome map !!!

Any plans in future to adjust lighting ?

Colours looks very dull.

Share this post


Link to post
Share on other sites
23 hours ago, Arma3_JSOC said:

Awesome map !!!

Any plans in future to adjust lighting ?

Colours looks very dull.

 

Thank you! :-)

 

Ask Bohemia for lighting changes..they ignore us and don´t tell a word about it.

Taunus was so damn beautiful before visual upgrade, but the actual stage is the maximum we can achieve on our own.

Sorry buddy.

 

Regards

Chaser

  • Like 1

Share this post


Link to post
Share on other sites
23 hours ago, Arma3_JSOC said:

Awesome map !!!

Any plans in future to adjust lighting ?

Colours looks very dull.

With all the drama in this thread about lighting changes...talk of the map not being released etc...Dont push it! :D

Share this post


Link to post
Share on other sites

Well lighting works fine all BI maps & cup maps.

Are you saying that BI is not sharing settings to change light? 

 

There is an error when I open the map and a bid building hanging 2 feet above the ground. 

Cannot open object - ca\desert2\data\plant\clutter_d2_stonesmall.p3d

 

 

Share this post


Link to post
Share on other sites

No Bohemia doesnt help with the lightning. They updated their wiki, but just with the parameters and no further explanations how to change the different lightning-styles (e.g. for European Countries, Desert, Jungle etc.)

 

The whole topic, especially about Taunus, has been discussed a long time ago when the light-effects where implemented.

Read on from here for further information and comparission (old light vs new light and shadows):

There are also some pictures for comparisson.

 

Share this post


Link to post
Share on other sites
On 21.1.2017 at 9:20 PM, Arma3_JSOC said:

Awesome map !!!

Any plans in future to adjust lighting ?

Colours looks very dull.

I am still under the impression only some of us, for unknown reasons, have this very gamma bright lighting. Metalcraze posted a fix and you can pretty well see in his sceenshot how it looks originally for us. 

 

  • Like 1

Share this post


Link to post
Share on other sites

CUP Terrains has many faults, but causing Taunus to miss dust effects is not one of them. From the V2 Taunus config I have, even if you did correctly add "CUP_Worlds_DustEffects" to your requiredAddons, dust effects would not work. This is because the values you use in the "rightDustEffects" and "leftDustEffects" array are incorrect. These should be the names of entries in your CfgSurfaces. For example "xcam_grass_green_co", you have no CfgSurfaces entry to match that, and in addition it has an "_co" suffix.

Secondly, the way you guys are defining your dust effects would actually cause dust effects to disappear on all terrains, even Stratis, Altis, and Tanoa. As I mentioned in the ticket linked above, this is only an issue because you can't inherit nested config arrays, so every map author is overwriting everyone else's dust effects when they define them, so it's just a game of whoever's config gets loaded last.

 

Here is a PBO with a config fixing the missing dust effects, as well as including all of the A3 and CUP dust effects. I did this at 2 AM so I could easily missed some Taunus surfaces, but it worked in the quick testing I did. Hopefully this post didn't come across as hostile, I just don't want people to think CUP is breaking people's maps and ignoring the issue.

  • Like 5

Share this post


Link to post
Share on other sites

NqKBK2H.jpg

kBMFvy9.jpg

 

 

So good. So many nice places. This is the BEST map. Too bad I have yet to convince others to play it with me. It's got obvious performance issues on lower end systems. But I don't care about that! Arma is just as fun running 15 fps as it is running 60. I rather play a mission where I can shoot 100's of enemies with 20 fps, than play a mission with 3 enemies that headshot me instantly while running 60 fps.

 

I'll look into making a few missions for this.

  • Like 2

Share this post


Link to post
Share on other sites

Great map, hope we will be able to deal with this terrain on 64bit. After my community first test on 32bit performance was just teribble Anyway good job, guys!

Share this post


Link to post
Share on other sites
13 hours ago, Arma3_JSOC said:

Well lighting works fine all BI maps & cup maps.

Are you saying that BI is not sharing settings to change light? 

 

There is an error when I open the map and a bid building hanging 2 feet above the ground. 

Cannot open object - ca\desert2\data\plant\clutter_d2_stonesmall.p3d

 

 

they put the wiki in, but yeah..it is documented as all the other stuff from bi ;-)

The error isn´t occuring for me. Did u load Cup Terrains Complete 1.20 as we recommend?

 

11 hours ago, Cosmo_D41 said:

No Bohemia doesnt help with the lightning. They updated their wiki, but just with the parameters and no further explanations how to change the different lightning-styles (e.g. for European Countries, Desert, Jungle etc.)

 

The whole topic, especially about Taunus, has been discussed a long time ago when the light-effects where implemented.

Read on from here for further information and comparission (old light vs new light and shadows):

There are also some pictures for comparisson.

 

Story behind is, that some of u guys posted the ugly lighting on twitter @ arma3official and they answered this guy like "they should contact us and we will help em to get into the right direction" so i contacted them and got the answer "BI is not giving support for 3rd party addons." i quoted their answer on twitter and they answered back " maybe you should open a BI Forum thread so we can help you there" 

from this point and at no time BI was helping in any case as a company to adjust the lighting.

we´ve done it on our own as good as we can and with help of some community members. the look and feel is not satisfying for us but as i said earlier..it is all we can achive...

 

2 hours ago, Pennyworth said:

CUP Terrains has many faults, but causing Taunus to miss dust effects is not one of them. From the V2 Taunus config I have, even if you did correctly add "CUP_Worlds_DustEffects" to your requiredAddons, dust effects would not work. This is because the values you use in the "rightDustEffects" and "leftDustEffects" array are incorrect. These should be the names of entries in your CfgSurfaces. For example "xcam_grass_green_co", you have no CfgSurfaces entry to match that, and in addition it has an "_co" suffix.

Secondly, the way you guys are defining your dust effects would actually cause dust effects to disappear on all terrains, even Stratis, Altis, and Tanoa. As I mentioned in the ticket linked above, this is only an issue because you can't inherit nested config arrays, so every map author is overwriting everyone else's dust effects when they define them, so it's just a game of whoever's config gets loaded last.

 

Here is a PBO with a config fixing the missing dust effects, as well as including all of the A3 and CUP dust effects. I did this at 2 AM so I could easily missed some Taunus surfaces, but it worked in the quick testing I did. Hopefully this post didn't come across as hostile, I just don't want people to think CUP is breaking people's maps and ignoring the issue.

Thanks penny for your work. We will have a look into it for further updates.

 

That guy is proof of concept, that this game is living over the years...without the immense help someone will get from the community everything would go right out the window...

But this is "thin ice" as we say in germany...BI is walking on. If this helpful community dies sometime nobody will buy their games anymore (my personal opinion)

2 hours ago, keeway said:

Great map, hope we will be able to deal with this terrain on 64bit. After my community first test on 32bit performance was just teribble Anyway good job, guys!

 

We´ve tested it with 64bit also and it runs much better in terms of micro stuttering and loading times. If and when the CUP guys bring ther occlusion update to the buildings it should run faster overall.

 

Regards

 

Chaser

  • Like 3

Share this post


Link to post
Share on other sites
3 hours ago, computer said:

 Arma is just as fun running 15 fps as it is running 60.

 

What? Seriously?  If you say that Arma  is running fine with 15 FPS then you are a lucky bastard. You can still play with computers from 2005 without upgrading until 2030.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×