Jump to content
Placebo

Will-my-pc-run-Arma3? What cpu/gpu to get? What settings? What system specifications?

Recommended Posts

You will gain a couple frames for sure but Arma players know: dont expect wonders like 20 frames more, i would say 5-7 frames more, depending on situations of course.

improvement is improvement i guess

I forgot to mention i currently and will continue to play SP only.Will it be "more" benificial?

Currently in a medium sized altis town(molos) 32vs32 ai,cqb, i get around 30-40fps,i would certainly be content with 50or slightly above.

Im using freds custom Bmalloc dll,plus the "gimme more frames" trick he posted.They certainly help me in cpu intense situations.

Share this post


Link to post
Share on other sites

it´s possible but thats all speculations. Only you will be able to enlighten the situation when u see the result on your screen. Would be cool if you would give a short info how it ends :)

Share this post


Link to post
Share on other sites

Hi, guys :)

Would it make any benefit to add another GPU (SLi) for MP PvE with lots of AI groups patrolling the village, jets and helis flying over the area, several AA's covering the perimeter and several APCs + tanks patrolling the village?

Edited by Groove_C

Share this post


Link to post
Share on other sites
it´s possible but thats all speculations. Only you will be able to enlighten the situation when u see the result on your screen. Would be cool if you would give a short info how it ends :)

Yes,i certainly will do.

That molos test has been my personal benchmarking test since i bought the game,anytime update drivers,use different DLL files,tweak vars etc,i run that scenario.Dont even need fps counter by this stage.

Will post back tommorow with before and after framerates/smoothness etc ;)

---------- Post added at 14:47 ---------- Previous post was at 14:42 ----------

Hi, guys :)

Would it make any benefit to add another GPU (SLi) for MP PvE with lots of AI groups patrolling the village, jets and helis flying over the area, several AA's covering the perimeter and several APCs + tanks patrolling the village?

Most likely no,unfortunatly.Will only really make a difference if your turning on Ambient occlusion,fxaa etc.But you never know it certainly cannot hurt.

Infact,i reverted my nvidia driver to the 331.xx build a few weeks back,and with that driver my above mentioned post stress test(really cpu heavy) ran alot smoother.

In conclusion its my guess fps wont increase,but the general smoothness may feel slightly better.Try and post back ;)

Also keep in mind,vehicles are what bring you fps down more than most other factors.A few veihicles in motion is (waypoints/firing) is enough to drop fps noticably.

If applicable,use the show/hide module to "disable" any vehicles till they are needed.

Edited by redarmy

Share this post


Link to post
Share on other sites

Most likely no,unfortunatly.Will only really make a difference if your turning on Ambient occlusion,fxaa etc.

Monitor resolution 1680x1050 @ 1920x1200 (downsampling) + 8x AA + AO + FXAA to make my GPU gump as often as possible to it's 1202 MHz boost. Otherwise it almost always remains @ 1006 MHz default clock (modded vBIOS)

Edited by Groove_C

Share this post


Link to post
Share on other sites
Monitor resolution 1680x1050 @ 1920x1200 (downsampling) + 8x AA + AO + FXAA to make my GPU gump as often as possible to it's 1202 MHz boost. Otherwise it almost always remains @ 1006 MHz default clock (modded vBIOS)

The sad truth about arma,is that it dosent really care how much muscle ones GPU has,your always limited via cpu sadly

---------- Post added at 17:04 ---------- Previous post was at 17:01 ----------

Monitor resolution 1680x1050 @ 1920x1200 (downsampling) + 8x AA + AO + FXAA to make my GPU gump as often as possible to it's 1202 MHz boost. Otherwise it almost always remains @ 1006 MHz default clock (modded vBIOS)

IF you havnt already,check out freds custom bmalloc dll for arma 3.Gave me better performance under load

Share this post


Link to post
Share on other sites

IF you havnt already,check out freds custom bmalloc dll for arma 3.Gave me better performance under load

Where to get it and how to usw it?

Share this post


Link to post
Share on other sites
Im more than happy to say im upgrading my specs(mainly for arma cpu hungriness).

Hoping someone might tell me what i can expect with the new cpu i hope to get soon.And how it compares to my last.

Curently im using an AMD phenom x4 955, along with a gtx650ti boost.

Im looking to get the intel i 74770, Keeping current gpu.

NEW mother board/system also,Though not sure yet which.

Can anyone tell me what kind of difference i should expect,or anything worth noting about switching systems in general as this is my first system,this good ole phenom.

An associate of mine, has a gtx 570. He recently upgraded his cpu from a phenom to I7. And he has seen vast improvements from 19 fps now 40 upwards.

You could save money by going Xeon 1230 (basically an I7 minus the igpu which if using a dedicated graphics card is not used)

But keeping your I7 get the devils canyon I7 4790 if it retails same as the 4770 from your choice of retailer.

Look your GPU is weak the good news is you can get a decent one for cheap secondhand if needs be.

Share this post


Link to post
Share on other sites
Where to get it and how to usw it?

http://forums.bistudio.com/showthread.php?163640-Arma3-and-the-LARGEADDRESSAWARE-flag-(memory-allocation-gt-2GB)

thats the link,follow details on page,a little setup but pretty straight forward.Hope it helps.

PS if you use ALIVE mod,it helps load it all up quite quickly-infact a while back ALIVE just wouldnt load 100% of the time for me,this bmalloc fixed that.Dont expect mind blowing performance,i experienced 4-6fps and smoother gameplay in general.Reports vary,no harm in seeing for yourself.

---------- Post added at 10:32 ---------- Previous post was at 10:27 ----------

An associate of mine, has a gtx 570. He recently upgraded his cpu from a phenom to I7. And he has seen vast improvements from 19 fps now 40 upwards.

You could save money by going Xeon 1230 (basically an I7 minus the igpu which if using a dedicated graphics card is not used)

But keeping your I7 get the devils canyon I7 4790 if it retails same as the 4770 from your choice of retailer.

Look your GPU is weak the good news is you can get a decent one for cheap secondhand if needs be.

Thanks for the info

Regarding the gpu i have,i does the job pretty well dont think it will help much in arma3 anyway.

Share this post


Link to post
Share on other sites
An associate of mine, has a gtx 570. He recently upgraded his cpu from a phenom to I7. And he has seen vast improvements from 19 fps now 40 upwards.

You could save money by going Xeon 1230 (basically an I7 minus the igpu which if using a dedicated graphics card is not used)

But keeping your I7 get the devils canyon I7 4790 if it retails same as the 4770 from your choice of retailer.

Look your GPU is weak the good news is you can get a decent one for cheap secondhand if needs be.

I had the same experience: changed from Q6600 @ 4Ghz to i5 3570k @ 4,8Ghz with a GTX570 oc and get 100-200% more fps. Then I changed the GTX570 to R9 290 and get up to 50% more frames in empty editor only and 0% more frames in ai heavy situations.

Share this post


Link to post
Share on other sites

Well im back with some very intersting results.

Havnt really used fraps or anything to monitor fps yet as still in the process of setting up all old folders on new system.

Anyway 1st thing i did was installed steam/arma3.

I have not got any tweaks enabled such as bmalloc custom dll or other settings which used to help me rum arma3 pretty decently.

Anyway

WENT FROM; phenom II X4 955 with 650ti boost averaging 30-40 FPS in a cqb town,32vs32ai(all settings ultra though view ditance just 2000/obj distance1000)and no PPAA for moment.

TO; Intel i74790, same gpu as above,same settings as above without bmalloc and other tweaks which used to net me around 8FPS more, and have managed to get over 60FPS in same scenario,with what seemed like minor dips to 55 or so with lots of particles at times(high setting)

Infact,i doubled the AI count,and my frames where still above 40.So were talking 70-80AI in molos town,Altis.cqb with Bcombat blastcore and JSRS.

NEVER DIPPED BELOW WHAT I CONSIDER PLAYABLE.

When i get time,il try post exact details to best of my limited knowledge/ability with benchmarking and get back.

Arma3 is glorious now.

One thing i noticed rite away: When first contact got made between ai,there was absolutley no noticable dip in framerate,no stutter,nothing.What i call smooth.

My start up params changed a little:CPU count-8 instead of four.

Maybe someone can tell me if 8 is the rite count for my system.Its got 8 cores but iv heard things i dont fully understand that i should set cpu count to 16 in that case??something to do with hyperthreading?

Switching from the AMD im clueless about this,any tips would be great!

Share this post


Link to post
Share on other sites

Well im back with some very intersting results.

Havnt really used fraps or anything to monitor fps yet as still in the process of setting up all old folders on new system.

Anyway 1st thing i did was installed steam/arma3.

I have not got any tweaks enabled such as bmalloc custom dll or other settings which used to help me rum arma3 pretty decently.

Anyway

WENT FROM; phenom II X4 955 with 650ti boost averaging 30-40 FPS in a cqb town,32vs32ai(all settings ultra though view ditance just 2000/obj distance1000)and no PPAA for moment.

TO; Intel i74790, same gpu as above,same settings as above without bmalloc and other tweaks which used to net me around 8FPS more, and have managed to get over 60FPS in same scenario,with what seemed like minor dips to 55 or so with lots of particles at times(high setting)

Infact,i doubled the AI count,and my frames where still above 40.So were talking 70-80AI in molos town,Altis.cqb with Bcombat blastcore and JSRS.

NEVER DIPPED BELOW WHAT I CONSIDER PLAYABLE.

When i get time,il try post exact details to best of my limited knowledge/ability with benchmarking and get back.

Arma3 is glorious now.

One thing i noticed rite away: When first contact got made between ai,there was absolutley no noticable dip in framerate,no stutter,nothing.What i call smooth.

My start up params changed a little:CPU count-8 instead of four.

Maybe someone can tell me if 8 is the rite count for my system.Its got 8 cores but iv heard things i dont fully understand that i should set cpu count to 16 in that case??something to do with hyperthreading?

Switching from the AMD im clueless about this,any tips would be great!

i7-4790K is a 4 cores processor that can handle 8 threads (2 threads per core). So yes, you can use -cpuCount=8 parameter.

Share this post


Link to post
Share on other sites
i7-4790K is a 4 cores processor that can handle 8 threads (2 threads per core). So yes, you can use -cpuCount=8 parameter.

I just wonder because I consider a future upgrade with the same CPU that you have. How is performance? You must be really happy and never drop below 50 FPS in single player mod or is this not true?

Share this post


Link to post
Share on other sites

I just wonder because I consider a future upgrade with the same CPU that you have. How is performance? You must be really happy and never drop below 50 FPS in single player mod or is this not true?

I don't play SP. Only MP. Performance wise my i7-4790K @ 4.6 GHz is better than my previous i5-760 @ 4.1 GHz.

Especially when recording with Bandicam, FPS drops less than with i5.

Share this post


Link to post
Share on other sites
Hello!

I'm new to the forums, I want to play the arma games and dayz soooo bad ;)

My current pc won't even play it on low settings.

So... this is what I came up with.

I am going to buy the cyberpower's zeus min i760.

It's specs are:

CPU: Intel® Core™ i5-4690K 3.5 GHz 6MB Intel Smart Cache LGA1150 (All Venom OC Certified)

HDD: 1TB SATA-III 6.0Gb/s 32MB Cache 7200RPM HDD (Single Drive)

MEMORY: 8GB (4GBx2) DDR3/1866MHz Dual Channel Memory (Corsair Vengeance)

MOTHERBOARD: GIGABYTE GA-Z97N-WIFI Mini-ITX w/ 802.11ac WiFi + BT 4.0, Dual GbLAN, 1 PCIe x16, 4x SATA 6Gb/s (Pro OC Certified)

SOUND: HIGH DEFINITION ON-BOARD 7.1 AUDIO

VIDEO: EVGA Superclocked NVIDIA GeForce GTX 760 2GB GDDR5 w/ ACX Cooling PCIe 3.0 x16 Video Card (Single Card)

PSU: 800 WATTS

P.S: I can upgrade to a i7 4790 for 70 dollars or a i7 4970k for 110 dollars.

LINK: (will not come with the same specs but I just edited the graphics card for EVGA and removed the keyboard)

( NO, I do not want to build one. I'm to new for it)

Thanks, JKS

I have here some benchmark number which are around 6-7 weeks old:

Latest Benchmark-Results (GeForce v337.88 | Dev.-Build: v1.21.124.861):

Tools used: MSI-Afterburner v3.0.1 Beta | HWiNFO64 v4.39-2220 Beta

Low + Disabled:

===============

Stratis = 135fps

CPU-Load: max = 88.6% | 36.9% | 55.7% | 78.7% | 46.7% | 78.6% | 61.1% | 86.9%

GPU(s)-Load: ~50-55%

Altis = 107fps

CPU-Load: max = 86.9% | 32.1% | 53.6% | 73.5% | 56.1% | 40.5% | 68.8% | 37.4%

GPU(s)-Load: ~45-50%

Low:

====

Stratis = 116fps

CPU-Load: max = 86.4% | 65.1% | 51.5% | 52.4% | 49.1% | 32.0% | 71.2% | 37.1%

GPU(s)-Load: ~50-55%

Altis = 99fps

CPU-Load: max = 89.3% | 44.9% | 55.2% | 44.7% | 47.5% | 34.2% | 60.3% | 42.0%

GPU(s)-Load: ~45-55%

Standard:

=========

Stratis = 86fps

CPU-Load: max = 84.4% | 50.9% | 67.3% | 50.4% | 53.1% | 44.5% | 52.4% | 45.7%

GPU(s)-Load: ~50-60%

Altis = 76fps

CPU-Load: max = 81.4% | 43.4% | 54.4% | 44.0% | 90.8% | 35.9% | 64.4% | 42.0%

GPU(s)-Load: ~45-55%

High:

=====

Stratis = 64fps

CPU-Load: max = 80.8% | 41.3% | 53.1% | 70.0% | 45.4% | 38.8% | 68.2% | 37.4%

GPU(s)-Load: ~60-70%

Altis = 61fps

CPU-Load: max = 81.3% | 32.8% | 80.0% | 32.5% | 44.2% | 43.3% | 89.9% | 40.3%

GPU(s)-Load: ~50-70%

Very-High:

==========

Stratis = 50fps

CPU-Load: max = 80.4% | 37.8% | 52.0% | 40.1% | 72.5% | 41.9% | 48.6% | 67.5%

GPU(s)-Load: ~60-70%

Altis = 46fps

CPU-Load: max = 89.5% | 38.4% | 63.8% | 63.5% | 47.0% | 35.4% | 82.7% | 45.1%

GPU(s)-Load: ~50-70%

Ultra:

======

Stratis = 39fps

CPU-Load: max = 79.3% | 37.4% | 54.5% | 44.9% | 47.9% | 36.3% | 94.0% | 41.7%

GPU(s)-Load: ~50-80%

Altis = 37fps

CPU-Load: max = 82.1% | 56.8% | 51.8% | 41.7% | 91.4% | 33.9% | 82.7% | 40.9%

GPU(s)-Load: ~40-75%

Maxed-Out:

==========

Stratis = 29fps

CPU-Load: max = 77.2% | 48.1% | 52.9% | 47.7% | 45.9% | 43.2% | 55.2% | 92.2%

GPU(s)-Load: ~40-70%

Altis = 13fps

CPU-Load: max = 79.4% | 35.6% | 66.2% | 75.5% | 41.2% | 36.8% | 78.9% | 33.0%

GPU(s)-Load: ~35-65%

Arma-3 (Dev.-Build v1.25.126046)

Low / Disabled:

- Stratis = 154fps

- Altis = 126fps

Low:

- Stratis = 140fps

- Altis = 119fps

Standard:

- Stratis = 100fps

- Altis = 90fps

High:

- Stratis = 75fps

- Altis = 69fps

Very-High:

- Stratis = 56fps

- Altis = 52fps

Ultra:

- Stratis = 41fps

- Altis = 43fps

Maxed-out:

- Stratis = 33fps

- Altis = 17fps

The numbers above are SP numbers and are achieved with this hardware:

Computer Type: PC/Desktop

System Manufacturer/Model Number: Custom-Build

OS: Windows-8.1-RTM-Pro-WMC-x64

CPU: Intel Core i7 3770k @4700MHz

Motherboard: Asus P8Z77-V

Memory: G.Skill 16G(4*4G) DDR3-2400 Quad Channel [TDX] F3-2400C10Q-16GTX (10-11-11-28-2T)

Graphics Card: 2x Gigabyte GTX780-Ti-GHz-Edition-3GB in 2-Way-SLI (Power-Target: 106% | Core-Voltage: 1.187V | GPU-Clock: 1241.5MHz | Memory-Clock: 7290MHz)

Sound Card: OnBoard Realtek® ALC892 8-Channel High Definition Audio

Monitor(s) Displays: Asus VE278Q 27" Wide Led Black Full HD 2ms | Dell S2409W 24" 5ms

Screen Resolution: 1920x1080

Keyboard: Roccat Isku | Logitech G13 | XBox 360 Controller wired | Logitech Dual Action GamePad

Mouse: Shogun Bros. Ballista MK-1 | Cyborg R.A.T. 7 Infection | Zalman FPSGun Mouse | Logitech G9

Mouse-Pad: Roccat Siru

PSU: Corsair AX1200i

Case: Thermaltake Level-10 GT LCS

Cooling: EK H3O HFX 240mm Liquid Cooling Kit + IC Diamond 7 Carat, CPU Thermal Paste-Grease-Compound

Hard Drives: - Intel 520S 240GB/SATA3/R 550MBs,W 520MBs/25nm/3.5"Kit/5yr - Samsung 840 EVO SATA3 500GB - Seagate Barracuda SATA3 1TB 7200RPM 64mb Cache - Seagate Barracuda SATA3 1TB 7200RPM 64mb Cache - Seagate Constellation SATA3 3TB 7200RPM 64mb Cache - Seagate FreeAgent USB 2.0 1TB - Seagate FreeAgent USB 2.0 2TB - Seagate FreeAgent GoFlex USB 3.0 2TB

Internet Speed: ADSL2+ ~15MBit/s DL | ~1MBit/s UL

Browser: Google Chrome

Antivirus: Windows Defender

Other Info: - Logitech Extreme 3D Pro Joystick - Plantronics GameCom Commander 7.1 Headset - Logitech X-210 Speakers

That should give you an idea about the ARMA-3 Performance.

Maybe I do new benchmarks soon, as I pushed my GPU's further (Power-Target: 106% | Core-Voltage: 1.187V | GPU-Clock: 1255MHz | Memory-Clock: 7380MHz) and moved on to the GeForce v344.11.

:)

Share this post


Link to post
Share on other sites
I just wonder because I consider a future upgrade with the same CPU that you have. How is performance? You must be really happy and never drop below 50 FPS in single player mod or is this not true?

put it this way:

Empty map,looking over kavala from elevated pos,12000 view distance,6000obj distance,all ultra except HDAO=67FPS - 72FPS

90 vs 90 ai Inf

6 tanks vs 6tanks

2attack choppers

1 jet

scripted artillery(off map,no ai)

night time and HDR(With TPW houselights on) highest setting/blastcore/JSRS/BCOMBAT(Trimmed with no target and chase behaviour or enhanced hearing)

View distant 3500, obj distant 2000 (all ultra except HDAO) = NEVER dipped below 50FPS.

Never stuttered even.....except when i rounded a corner with out looking and ran into a T-100.Yeah my character stuttered all over himself at that point;)

Extremely happy i am yes.But i must stress,i have various tweaks to help improve fps,they maybe give a slight 5fps more on this setup.

Highly recommend this cpu for a long term investment in ArmA3.

---------- Post added at 17:03 ---------- Previous post was at 17:02 ----------

i7-4790k is a 4 cores processor that can handle 8 threads (2 threads per core). So yes, you can use -cpucount=8 parameter.

thanks comarade!

Share this post


Link to post
Share on other sites

how did you measured/recorded the frames in the scene, is there any log.txt which shows min/max/avg frames or is that a "50FPS personal feeling" ?

Share this post


Link to post
Share on other sites
how did you measured/recorded the frames in the scene, is there any log.txt which shows min/max/avg frames or is that a "50FPS personal feeling" ?

To be honest it was sense.

I had gamebooster(which i DONT recommend using,better to learn what processes to manually close down via task manager),anyway it recorded fps on the screen.

I didnt pay much attention to it,but for most part it hover fairly well above 50.

I find that for alot of ai,making groups with more units in them,is better than making many small groups. So shoot for 30man groups etc.

Also have huge pages enabled. -bmalloc dll.

Just got done unparking the cores before testing also;)

PS. IM using Nvidia driver 331.xx Thats going back a while and it still gives best results for arma3.

Edited by redarmy

Share this post


Link to post
Share on other sites

You know how often the human brain will try to fool your eyes and sense in your entire life?

Without a recorded log with diagnostics about frames makes your bench totaly worthless in my opinion.

Sense. Lol

Share this post


Link to post
Share on other sites

This might be my first post on BI which is odd considering that I have been playing the ARMA/Flashpoint series since the original Operation Flashpoint came out in 2001. I got to say it is terribly disappointing that in the nearly 1 1/2 decades of this series, BI still has not made a well optimized game. All this time and STILL I have deal with bullshite poor performance. Hell, even Flashpoint and ARMA 1 still struggle on modern systems due to piss poor optimization. I remember in an article in PC Gamer before the release of ARMA 3, that Bohemia Interactive admitted that performance was the "white Elephant in the room" and recognized the necessity of improving optimization and fps. Well instead of playing regimental size battles like I was able to in ARMA 2, I suddenly have trouble with platoon size engagements! I hope that for ARMA 4, BI puts emphasis on quantity over quality in terms of graphics. The greatest thing about the ARMA series, is its potential to have large representations of contemporary land battles. If BI is focused on relatively unimportant side crap like foliage detail, facial animations, battle sizes will be reduced as a result. Also I have never seen a series be so unforgiving in terms of constant EXPENSIVE upgrades.

I LOVE the ARMA series. But I just wish improving performance and optimization in favor of larger battles was at the forefront of BI's goals and objectives.

Share this post


Link to post
Share on other sites
You know how often the human brain will try to fool your eyes and sense in your entire life?

Without a recorded log with diagnostics about frames makes your bench totaly worthless in my opinion.

Sense. Lol

Haha no faith man?

Ni shiesten comaraden!! haha

well,if my brain is fooling me,and gamebooster fps display is also tripping up over my brain...so be it.

I can finnally have large scale invasions, battles of kursks redone etc etc etc.

Been constantly running tests "without" benchmarking,im not trying to take arma into space so i really do not need advanced benchmarking to prove or feel i have a smooth game.

Share this post


Link to post
Share on other sites

I finally got a massive improvement, because now I get only shortly a black screen and then ARMA-3 get's minimized to the taskbar.

There is no error message popping up and the Arma.exe uses ~37% CPU-Load and ~500MB RAM.

That's really awesome !

Thanks a lot for that !

But hey, I can at least open the launcher !

Not that it would help, but at least one part of the game seems to be working ...

PS: I checked the game-files and they are ok.

:yay:

Share this post


Link to post
Share on other sites

Here are my specs

Graphics Card: SAPPHIRE 100352-3L Radeon HD 7950 3GB 384-bit GDDR5

CPU: AMD 6350 Six core 3.9 GHz

RAM: 8 gigs of DDR3

Motherboard: MSI 970A-G43

Now I can run arma 3 on high in single player and get between 45 to 60 frames but when I join any kind of multilayer sever they drop between 8 to 25. Any suggestions?

Share this post


Link to post
Share on other sites
Here are my specs

Graphics Card: SAPPHIRE 100352-3L Radeon HD 7950 3GB 384-bit GDDR5

CPU: AMD 6350 Six core 3.9 GHz

RAM: 8 gigs of DDR3

Motherboard: MSI 970A-G43

Now I can run arma 3 on high in single player and get between 45 to 60 frames but when I join any kind of multilayer sever they drop between 8 to 25. Any suggestions?

I bet you play Altis Life?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×