Jump to content

Recommended Posts

my friends  wanted to be able to search for enemy radios to use instead of spawning with them

does not make sense for prisoners to keep their own radios.

Share this post


Link to post
Share on other sites

That would case other problems. Without the radio the chat wouldn't work (Like unconscious messages etc). That is why I decided to not remove them.

Share this post


Link to post
Share on other sites

Hello sorry for the stupid question but what mods should i use to play the Escape us tanoa version? cause every time i load only the rhs mods with cba i got that ace script error

Share this post


Link to post
Share on other sites

Is it possible that loading the _enemyFrequency goes wrong in the fn_initServer.sqf, because the way I understand it this _enemyFrequency = (Param_EnemyFrequency); should set the enemy frequency to the parameter value that was selected at the start of the game. For which  I choose “a lot†in my test case. This should result in _enemyFrequency = 3.

 

In the game the start backpack had 2 weapons in it and there were 4 enemy soldiers outside the prison. However according to the code in fn_initServer.sqf (line 538), “for [{_i = 0}, {_i < ((Param_EnemyFrequency)*2)}, {_i = _i + 1}] do {“ and (line 550) “_guardCount = (2 + (_enemyFrequency)) + floor (random 2);†this cannot be so low. The number of weapons should always be 6 and the number of enemy’s should be between 5 and 6.

 

Or did I overlook something that changed these values?

Share this post


Link to post
Share on other sites

 

Hello sorry for the stupid question but what mods should i use to play the Escape us tanoa version? cause every time i load only the rhs mods with cba i got that ace script error

 

ACE script error sounds like a ACE problem not a mission problem as the mission has nothing to do with ACE.

 

 

Or did I overlook something that changed these values?

 

Most likely: Parameters are cached between sessions and automatically restored when you don't change the first parameter to "Use below and save" from default "use saved values...".

  • Like 1

Share this post


Link to post
Share on other sites

Hi,

 

I can't change the parameters in the game lobby. I searched through this topic and someone else got the same problem but there wasn't any solution.

I kinda bypassed it by depbo the mission file and changing the default values.

 

Also there a repeating errors in the console log. It doesn't break the mission but it generates a huge logfile.

 

The first error only appears once, the rest multiple times.

 

I got those errors both on 1.7.5 and 1.8.0 Altis, Stratis and Tanoa.

17:50:02 Error in expression <_unit = _units select 0;
_group = group _unit;

_group
};

drn_fnc_Escape_Create>
17:50:02   Error position: <_unit;

_group
};

drn_fnc_Escape_Create>
17:50:02   Error Undefined variable in expression: _unit
17:50:02 File mpmissions\__cur_mp.Tanoa\Scripts\Escape\Functions.sqf, line 271

#############

17:50:02 Error in expression <
_dir = random 360;
_refPosX = ((getPos _refUnit) select 0) + (_minSpawnDistance>
17:50:02   Error position: <_refUnit) select 0) + (_minSpawnDistance>
17:50:02   Error Undefined variable in expression: _refunit
17:50:02 File mpmissions\__cur_mp.Tanoa\Scripts\Escape\Functions.sqf, line 636

#############

17:51:57 Error in expression <
_dir = random 360;
_refPosX = ((getPos _refUnit) select 0) + (_minSpawnDistance>
17:51:57   Error position: <_refUnit) select 0) + (_minSpawnDistance>
17:51:57   Error Undefined variable in expression: _refunit
17:51:57 File mpmissions\__cur_mp.Tanoa\functions\DRN\fn_RoadBlocks.sqf, line 44

###########

17:52:58 Error in expression <
_dir = random 360;
_refPosX = ((getPos _refUnit) select 0) + (_minSpawnDistance>
17:52:58   Error position: <_refUnit) select 0) + (_minSpawnDistance>
17:52:58   Error Undefined variable in expression: _refunit
17:52:58 File mpmissions\__cur_mp.Tanoa\functions\DRN\fn_MilitaryTraffic.sqf, line 117

Finally I don't know if this is correct, but it seems there are no foot patrols. So action only starts after you engage any static enemies.

 

Thx for the help.

Share this post


Link to post
Share on other sites

Hi,

 

I can't change the parameters in the game lobby. I searched through this topic and someone else got the same problem but there wasn't any solution.

I kinda bypassed it by depbo the mission file and changing the default values.

 

Also there a repeating errors in the console log. It doesn't break the mission but it generates a huge logfile.

 

The first error only appears once, the rest multiple times.

 

I got those errors both on 1.7.5 and 1.8.0 Altis, Stratis and Tanoa.

 

That sounds like a problem on your end. I can't reproduce your errors. They look like the engine spawning of units fail (scripts tries to create unit -> engine fails to create unit -> unitvariable is null/nil -> error). Are you missing some mods for the mission or are some outdated?

 

Also the problem with the unchangeable parameters were solved somewhere in this thread: It happens when the server config has a default mission and/or mission rotation setup (most likely a bug in the game).

Share this post


Link to post
Share on other sites

I've become a fanatic with these missions  so I decided to try building one with Massi's USMarine/Chernarus Conflict using Podagorsk. I followed the advice Scruffy laid out,editing the Units.sqf and the mission yet Opfor doesn't show up.No guards,no patrols and prison backpack was empty.So I jumped into the camera & peeked at all the locations & they were empty also except for the structures.Now I've done some small changes before like change guard types & backpack weapons w/ no errors.Looking @ the log really didn't help much but it did spit out alot like Error Undefined variable in expression,positions,possible infantrytypes,etc.Can someone put me on the right track,eager to use this mod on other terrains.

Share this post


Link to post
Share on other sites

I've become a fanatic with these missions  so I decided to try building one with Massi's USMarine/Chernarus Conflict using Podagorsk. I followed the advice Scruffy laid out,editing the Units.sqf and the mission yet Opfor doesn't show up.No guards,no patrols and prison backpack was empty.So I jumped into the camera & peeked at all the locations & they were empty also except for the structures.Now I've done some small changes before like change guard types & backpack weapons w/ no errors.Looking @ the log really didn't help much but it did spit out alot like Error Undefined variable in expression,positions,possible infantrytypes,etc.Can someone put me on the right track,eager to use this mod on other terrains.

 

Sounds like spawning errors aswell and the missin pistols strongly indicate there is an error in your unit config and/or the array are empty.

Share this post


Link to post
Share on other sites

Hey just wanna say I really love the mission me and my friends play it nearly daily and it feels like its in a near perfect state, the only thing missing(both me and my friends agree) is the civillian ambiance, while vehicles are present we feel like they're a very rare occurance(compared to the arma 2 escape chernarus vehicle population) and i think it would really complete the mission if you guys could rework the civ or traffic framework :) thx

Share this post


Link to post
Share on other sites

Hey just wanna say I really love the mission me and my friends play it nearly daily and it feels like its in a near perfect state, the only thing missing(both me and my friends agree) is the civillian ambiance, while vehicles are present we feel like they're a very rare occurance(compared to the arma 2 escape chernarus vehicle population) and i think it would really complete the mission if you guys could rework the civ or traffic framework :) thx

 

Civilian traffic strongly depends on the map and the density of roads. For exmaple Altis has far more civilian traffic than Chernarus back in the original A2 Escape. In comparison Thirsk has nearly no civilian traffic.

Share this post


Link to post
Share on other sites

Civilian traffic strongly depends on the map and the density of roads. For exmaple Altis has far more civilian traffic than Chernarus back in the original A2 Escape. In comparison Thirsk has nearly no civilian traffic.

Hmm okay thanks, is there any way to increase it other then staying around roads?

Share this post


Link to post
Share on other sites

Hmm okay thanks, is there any way to increase it other then staying around roads?

 

Not without sacrificing the number of enemy patrols. The amount of groups is very fine tuned between playable and "OMG my server is burning down".

  • Like 2

Share this post


Link to post
Share on other sites

Hey Guys,

maybe someone could help me. Im trying to put up my own server based on escaped missions.

Im super newbish about this whole server thing but im trying to get everything working right now.

So here is the problem when i start f.e. a stratis or altis escape mission, the player spawns randomly with complete gear (map, weapons etc.) somewhere on the map. No prison on sight.

Do i have to configure the serverconfig before launching a escape mission or something?

Hope you guys could help a newbie out. Thanks!

Share this post


Link to post
Share on other sites

Hey Guys,

maybe someone could help me. Im trying to put up my own server based on escaped missions.

Im super newbish about this whole server thing but im trying to get everything working right now.

So here is the problem when i start f.e. a stratis or altis escape mission, the player spawns randomly with complete gear (map, weapons etc.) somewhere on the map. No prison on sight.

Do i have to configure the serverconfig before launching a escape mission or something?

Hope you guys could help a newbie out. Thanks!

 

Remove the default mission and mission rotation from your server config. It is known to break some stuff.

Share this post


Link to post
Share on other sites

Hi,

 

I can't change the parameters in the game lobby. I searched through this topic and someone else got the same problem but there wasn't any solution.

I kinda bypassed it by depbo the mission file and changing the default values.

 

Also there a repeating errors in the console log. It doesn't break the mission but it generates a huge logfile.

 

The first error only appears once, the rest multiple times.

 

I got those errors both on 1.7.5 and 1.8.0 Altis, Stratis and Tanoa.

17:50:02 Error in expression <_unit = _units select 0;
_group = group _unit;

_group
};

drn_fnc_Escape_Create>
17:50:02   Error position: <_unit;

_group
};

drn_fnc_Escape_Create>
17:50:02   Error Undefined variable in expression: _unit
17:50:02 File mpmissions\__cur_mp.Tanoa\Scripts\Escape\Functions.sqf, line 271

#############

17:50:02 Error in expression <
_dir = random 360;
_refPosX = ((getPos _refUnit) select 0) + (_minSpawnDistance>
17:50:02   Error position: <_refUnit) select 0) + (_minSpawnDistance>
17:50:02   Error Undefined variable in expression: _refunit
17:50:02 File mpmissions\__cur_mp.Tanoa\Scripts\Escape\Functions.sqf, line 636

#############

17:51:57 Error in expression <
_dir = random 360;
_refPosX = ((getPos _refUnit) select 0) + (_minSpawnDistance>
17:51:57   Error position: <_refUnit) select 0) + (_minSpawnDistance>
17:51:57   Error Undefined variable in expression: _refunit
17:51:57 File mpmissions\__cur_mp.Tanoa\functions\DRN\fn_RoadBlocks.sqf, line 44

###########

17:52:58 Error in expression <
_dir = random 360;
_refPosX = ((getPos _refUnit) select 0) + (_minSpawnDistance>
17:52:58   Error position: <_refUnit) select 0) + (_minSpawnDistance>
17:52:58   Error Undefined variable in expression: _refunit
17:52:58 File mpmissions\__cur_mp.Tanoa\functions\DRN\fn_MilitaryTraffic.sqf, line 117

Finally I don't know if this is correct, but it seems there are no foot patrols. So action only starts after you engage any static enemies.

 

Thx for the help.

 

I got the same Errors:

19:38:59 Error in expression <_mp.Tanoa\functions\HSC\fn_exit.sqf"
if(ATHSC_Run) then {
ATHSC_Run = false;
[] >
19:38:59 Error position: <ATHSC_Run) then {
ATHSC_Run = false;
[] >
19:38:59 Error Undefined variable in expression: athsc_run
19:38:59 File mpmissions\__cur_mp.Tanoa\functions\HSC\fn_exit.sqf, line 1

_refPosX = ((getPos _refUnit) select 0) + (_minSpawnDistance>
19:39:37 Error position: <_refUnit) select 0) + (_minSpawnDistance>
19:39:37 Error Undefined variable in expression: _refunit
19:39:37 File mpmissions\__cur_mp.Tanoa\functions\DRN\fn_MilitaryTraffic.sqf, line 117
19:39:37 Error in expression <_dir = random 360;

Share this post


Link to post
Share on other sites

 

Loving the Tanoa version guys, great job. Of course I had to make a zombies edit!

 

 

That looks great, think you can pm me the mission? :D

Share this post


Link to post
Share on other sites

 

I got the same Errors:

 

 You can safely ignore those. Both don't affect the execution of the misson. If you have scripterrors enabled and/or dev branch and you are bugged out by the popups: I will fix the display of that stuff in the next week.

 

@callmesarge: Yes, please upload.

Also I changed some stuff with the mission compiler. Addind your mission.sqms to the CI may be easier now.

Share this post


Link to post
Share on other sites

Hello all,

 

I've been working in a version with the new Halo mod(The Eridanus Insurrection). However the mod doesn't really have an Indepenent faction so I'm trying play as independent. The opposing factions off course would be OPFOR and BLUFOR.(we alway play war torn so it is no problem if they are fighting) With just changing some some unit classes in the unitclasses file I get an error in the fn_initServer.sqf on line 40. 

 

I am a noob in programming/scripting but I can read and change most of the code but this has left me speechless. Does anybody know what I have to change to change the factions of at least where to start?

Share this post


Link to post
Share on other sites

Would help if you post the exact error. Also the content of "Line 40" depends on the version you used as base.

Share this post


Link to post
Share on other sites

Hey Neo,

 

Thanks for the reaction. As I was looking up my RPT I noticed I forgot some ] and ;. Suddenly I remembered why I didn't choose programming on school. Anyway that problem seems fixed for now. I don't know why I didn't bother to look at the RPT before.

Share this post


Link to post
Share on other sites

hello i was wondering does changing the difficulty affect anything else besides making the ai more accurate with their guns?

 

It doesn't affect anything besides AI skill (varying from 0.1 to 0.5 for general patrols AFAIK).

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×