Jump to content
jakerod

The Atlas: Guide to ArmA 3 Terrain Making

Recommended Posts

 Where is the Manual?  Got files but no manual.

 

 

Thankyou even if there were no reply.  But I found the manual it was in Atlas v1.0 pdf a file I could not open until I tranfer it to a new folder, then send it to desktop and open it after chosing type of pdf to use, from drop

down menu.  The menu only work at desktop for this particular file.  I use Adobe.

Share this post


Link to post
Share on other sites

i just created a map and i see it in Editor but when i click on it to load in my arma crashes and i have no clue what to do now i have done countless things but im lost

 

http://pastebin.com/FgghP2Ec (config)

http://pastebin.com/WxxmMHrU(binlog)

http://pastebin.com/FAXbzHsm(other binlog)

http://pastebin.com/PQXrTSMF(clutter)

http://pastebin.com/UNWJ665F(surface)

http://pastebin.com/78zcHsWd(layers)

let me know if u need anything else

Share this post


Link to post
Share on other sites

Are you using Addon Builder to pack your terrain?

 

That gave me exactly the same problem as you describe, my solution was to use pboProject.

Share this post


Link to post
Share on other sites

Can one of the mods please sticky this thread? This has to be the best guide out there so why isn't it front-paged?

  • Like 1

Share this post


Link to post
Share on other sites

Can one of the mods please sticky this thread? This has to be the best guide out there so why isn't it front-paged?

 

Yep got me started, should be a sticky

  • Like 1

Share this post


Link to post
Share on other sites

After a week on-off looking for resources on how to get started this is the first tutorial that i found that is easy to follow and up to date. Thank you so much!

 

Meanwhile, the sticky resource collection is full of 404s and old shit.

  • Like 1

Share this post


Link to post
Share on other sites

edit:  Guess what, I figured it out, not sure how, but I did it all right

This tutorial was awesome.  Only problem is - I packed my map using PBOproject and loaded it up in arma, and none of the surfaces are showing up...  or the clutter.  it just looks like a bunch of dead grass when you get close.  Can't figure out what I'm doing wrong.  Which files are case sensitive?  Did I screw something up with the .rvmat files?  Any help would be appreciated, the surface mask/materials is the final step for me before I can make my own maps

Share this post


Link to post
Share on other sites

The Atlas is the successor to my Quick Tutorial /Sample Terrain guide which has recently become hard to find and had a few minor errors in it. This new tutorial covers everything the old one did but adds in items like installation, roads, and objects. If I have the time, I hope to expand it in the future and include more information about how and why things work. If you find any errors with it please post them here. I will try to check back frequently.

Download Link: The Atlas: A Guide to ArmA 3 Terrain Making (Armaholic)

Mirrors:

http://lowtac.nl/tuts/the_atlas_v1_0.zip (Thanks to ligthert)

https://lab.ligthert.net/tuts/the_atlas_v1_0.zip (Thanks to ligthert)

 

 

tnx for tutos

 

can you tell how what soft you use get satelite image

Share this post


Link to post
Share on other sites
On 11/16/2016 at 0:17 PM, vaxoiva said:

 

 

tnx for tutos

 

can you tell how what soft you use get satelite image

@vaxoiva I use MapPuzzle: http://www.mappuzzle.se/  If you want great detail, you still have to piece things together in GIMP/PS but The end result is still worth it in my opinion.  

  • Like 1

Share this post


Link to post
Share on other sites

Thanks for the tutorial.

I finished making the terrain and I wanted to make the pbo with Addon Builder.

Whenever I tried to pack it, I got an error with the config,

 

Build failed.  Result code=1

CfgConvert task failed.

File P:\Vanguard Alliance\Map\VA Map\config.cpp, line 2:/CfgPatches/: 'M'

encountered instead of '{'

Config : some input after EndOfFile.

Error reading file P:\Vanguard Alliance\Map\VA Map\config.cpp'

Class destroyed with lock count 1

 

I googled the error code and searched the forum and nothing fixed it.

I only altered the parts of the config that the tutorial said to alter.

Here is the Config

https://pastebin.com/3djCKcHG

Share this post


Link to post
Share on other sites

Your classname is the problem, is suppose:

class VA Map

Spaces within classnames are a absolute nogo. Try using something like: VA_Map or just delete the space: VRMap

And to be sure, do this also for your folder structure: P:\Vanguard Alliance\Map\VA_Map\config.cpp

 

Take care, that this also has be changed within terrainbuilder and its paths/names

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, DaRude-Vangaurd Storm said:

Thanks for the tutorial.

I finished making the terrain and I wanted to make the pbo with Addon Builder.

Whenever I tried to pack it, I got an error with the config,

 

Build failed.  Result code=1

CfgConvert task failed.

File P:\Vanguard Alliance\Map\VA Map\config.cpp, line 2:/CfgPatches/: 'M'

encountered instead of '{'

Config : some input after EndOfFile.

Error reading file P:\Vanguard Alliance\Map\VA Map\config.cpp'

Class destroyed with lock count 1

 

I googled the error code and searched the forum and nothing fixed it.

I only altered the parts of the config that the tutorial said to alter.

Here is the Config

https://pastebin.com/3djCKcHG

 

*Sigh*

Please don't use addon builder, use pboproject instead. https://armaservices.maverick-applications.com/Products/MikerosDosTools/FileBrowserFree

 

Addon Builder is very buggy and broke! pboproject will most likely tell you your configs / terrain has errors, this is because they do. Don't worry we all go through this to start with, but if you want to make a "working" map, you need pboproject.

 

As for you errors, don't use spaces and try to keep to lowercase. Again pboproject will point you in the right direction, as you have quite a few errors in your config

 

pictureMap = "yourtag\VA Map\data\imagery\VA Map.paa"; file path is wrong

worldName = "Vanguard Alliance/Map\VA Map\VA Map.wrp"; You have a / instead of a \

newRoadsShape = "\Vanguard Alliance/Map\VA Map\data\roads\roads.shp"; see above

 

And I bet your layers, surfaces rvmt are wrong as well

 

  • Like 1

Share this post


Link to post
Share on other sites

I haven't been around much and will continue to probably not be around much so I just wanted to say thank you to all of you who have been helping people.

 

Additionally, I updated the first post with the following:

UPDATE: Snakeman (and I think others) have done a great job creating another tutorial at the PMC Editing Wiki which is definitely worth checking out after or as a replacement for this one. Here's a link to the forum thread covering the PMC Editing Wiki Terrain Tutorial.

  • Like 3

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×