Jump to content
NeoArmageddon

Map Builder - Ingame 3D-Editor for terrain creation

Recommended Posts

Guest

Do you plan to add import features from sqf or something. Btw i can't edit the objects already placed in a mission(.sqm)

Share this post


Link to post
Share on other sites
Do you plan to add import features from sqf or something. Btw i can't edit the objects already placed in a mission(.sqm)

Both is possible but not in the UI yet.

For instructions have a look at this post:

http://forums.bistudio.com/showthread.php?190385-Is-it-possible-to-import-SQM-files-into-Terrain-Builder&p=2910001&viewfull=1#post2910001

Share this post


Link to post
Share on other sites

Hello

Do i need it on my server? or do the people who play the mission need the addon?

Thx

Share this post


Link to post
Share on other sites
Hello

Do i need it on my server? or do the people who play the mission need the addon?

Thx

Answerd more than one time in this thread. It depends on what you place. A3 Vanilla -> No addons needed. Everything else -> Addon(s) needed (obviously... I am not a magician (yet))

Share this post


Link to post
Share on other sites

How have I ever survived before discovering this little gem?

I'm particularly fond of the fencer. It's a babe!

Share this post


Link to post
Share on other sites

I just stumpled upon this, looking good, can I use this with any missions? I have a few on my server, which I would like to tweak a bit.

Share this post


Link to post
Share on other sites

no, it just wont let me save the map i made!!! :(

Sendjes are you able to save your work?

Edited by sonnyit

Share this post


Link to post
Share on other sites

I haven't tried saving yet, as I'm trying to edit a mission I found on the Workshop, but I'm a bit lost.

Share this post


Link to post
Share on other sites

Why doesnt it Work when i put respawn on the map, with the arma3 editor? but if i do it on another map not made by mapbuilder i Work fine!???

is there still support on this?

Share this post


Link to post
Share on other sites
Why doesnt it Work when i put respawn on the map, with the arma3 editor? but if i do it on another map not made by mapbuilder i Work fine!???

What are you trying to do? Placeing a repsawn module with MapBuilder? That shouldn't work. Also keep in mind that you should export a map as sqm and then add respawn. Trying to add repspawn directly to a MapBuilder.Terrain - map doesn't make any sense.

If objects were placed with Map Builder or with 2D Editor shouldn't make any difference.

Share this post


Link to post
Share on other sites

Hey, i cant change the height from the objects, can someone help me?

Share this post


Link to post
Share on other sites
What are you trying to do? Placeing a repsawn module with MapBuilder? That shouldn't work. Also keep in mind that you should export a map as sqm and then add respawn. Trying to add repspawn directly to a MapBuilder.Terrain - map doesn't make any sense.

If objects were placed with Map Builder or with 2D Editor shouldn't make any difference.

ive saved the map in the mapbuilder, and then opend the mapfile in arma3 own editor, and added some respawns and saved it as multiplay... but that didn Work...

i saved the map as rampage, and renamed 3 files to mission.sqm and mission.sqf and mission.txt + i created a description.ext file

Share this post


Link to post
Share on other sites

somehow i cant save the map Again.. ehmm what parameters do i need to add?

Share this post


Link to post
Share on other sites
somehow i cant save the map Again.. ehmm what parameters do i need to add?
mission.sqf and mission.txt

I have no idea what you are doing/trying to do. But when you CAN load the mission.sqm in the normal editor, your respawn problem is definitly NOT a problem with Map Builder.

Share this post


Link to post
Share on other sites

Important notice:

Since last update Battleye is blocking all extensions, so addon relying upon extensions (Map Builder, ACRE, ACE3, etc) won't work with Battleye anymore (even in singleplayer).

I sent a mail to battleye to whitelist the mapbuilder extension but appearently they haven't managed that so far.

There is no way for me to work around this problem. Blame BI and Battleye for adding such stupid/useless "security" feature BEFORE there is a way to whitelist addons.

As for now, Map Builder is officially not supported when used with Battleye running! Make sure to start without Battleye!

Edited by NeoArmageddon

Share this post


Link to post
Share on other sites
Important notice:

Since last update Battleye is blocking all extensions, so addon relying upon extensions (Map Builder, ACRE, ACE3, etc) won't work with Battleye anymore (even in singleplayer).

I sent a mail to battleye to whitelist the mapbuilder extension but appearently they haven't managed that so far.

There is no way for me to work around this problem. Blame BI and Battleye for adding such stupid/useless "security" feature BEFORE there is a way to whitelist addons.

As for now, Map Builder is officially not supported when used with Battleye running!

Could you confirm that this is fixed now?

Share this post


Link to post
Share on other sites
Could you confirm that this is fixed now?

Seems to work at my end. Thanks for your fast response!

Share this post


Link to post
Share on other sites

Great tool thanks, any tips on selecting unselected objects? sometimes it feels hard to 'grab' an actual object and generally i click and drag combo until the blue lines appear! also camera positioning feels archaic can we expect a more natural option ala Zeus, *waa waa mode off* thanks again :D that saved me about half n hours farting around with save exit / preview a million times!

Share this post


Link to post
Share on other sites

Selecting depends highly on the performance A3 gives the script and the commands that the engine offers. It also depends on the objects view geometry. I can't do much here.

Camera: What do you mean? The camera controls are nearly like the Zeus controls, except for some additional stuff and tweaks to make placement easier?

Share this post


Link to post
Share on other sites

Hello NeoArmageddon,

I have to say I been waiting for something like this to use in editor for a while, downloaded it and played with it a bit in arma3...:459: !!,

what a wonderful piece of work you have created...outstanding work and easy to use. Congrats !! :icon_eek:

Just out of curiosity Neo, every now and then I like to play Arma2 OA mods eg:I44 ect.. and some of the other WW2 mods, the standard editor functions were always a bit limited,

is there any chance of having a Map Builder for ARMA 2 OA ??..that's if there is not to much messing around with configs for you, it would be great to add more buildings/bunkers ect to some of the ww2 maps.

Thanks for time and job well done. :ok:

Share this post


Link to post
Share on other sites
Just out of curiosity Neo, every now and then I like to play Arma2 OA mods eg:I44 ect.. and some of the other WW2 mods, the standard editor functions were always a bit limited,

is there any chance of having a Map Builder for ARMA 2 OA ??..that's if there is not to much messing around with configs for you, it would be great to add more buildings/bunkers ect to some of the ww2 maps.

You can't run Map Builder in A2 as I am using a lot of script functions that are only present since A3.

But you can do this: Load your terrains/maps in A3 with AllInArmA or CUP, edit them there with only A2/Addon objects, exporting to TB or SQM and load them in A2 directly. That should work without much additional work.

Share this post


Link to post
Share on other sites
But you can do this: Load your terrains/maps in A3 with AllInArmA or CUP, edit them there with only A2/Addon objects, exporting to TB or SQM and load them in A2 directly. That should work without much additional work.

Thank you Neo much appreciate the tip, only problem Im not that knowledgeable when it comes to terrain builder or SQM :banghead:. I was hoping it was an easier set up from your end regarding the scripting side of things would have been nice

to have it for A2 but not to worry.

Thanks again and great tool for A3. :ok:

Share this post


Link to post
Share on other sites

Great work Neo, really enjoy using this... so much so that i was up until 5am last night working on a base... without reading this thread first :)

So i've built my base in the VR environment, but when I intended it for use in multiple terrains, i'm currently working on adding it to altis, but i assume all the coordinates are off? The normal scripted .sqf call never seems to work for me. Is that terrain specific? You posted up some debug script that removed coordinates from objects, could something similar help me?

TL:DR - built in VR , want to export to Altis.

any help appreciated.

Gav

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×