Jump to content
McKeewa

CJTF101's EDITOR v1.1

Recommended Posts

Hi everyone.

101_editor is back with new updates and buildings.

You can now acces to a lot of objects. Houses, misc items, ruins, Ghost hotel, HMS Proteus, etc ... !!!

Under several vanilla classes located in "Empty" side :

And Behind Vanilla names :

-Structures (Commercial)

-Structures (Cultural)

-Structures (Fences)

-Structures (Industrial)

-Structures (Infrastructures)

-Structures (Military)

-Structures (Slums)

-Structures (Town)

-Structures (Transport)

-Structures (Village)

-Structures (Walls)

-Objects (Sea)

... and more

-> The mod is still under dev and will receive updates frequently.

Don't be afraid, classnames will note change, only location in the editor could be modified =)

(backward compatible)

3DEN Compatible

-- DOWNLOADS --

My Own Link

(I am uploading frequently with the lasts Buildings/etc...)

----

news_download_a3_3.png]

CJTF's Editor v2014-03-27

 

Note:

You can post here

-new classname or infos (like "look the yellow house in 045 174")

-bugs

-improvements

-suggestions

PROTIP : use this setVectorUp [0,0,1]; in the INIT textfield of your item to make it perfectly vertical

PROTIP2 : To get a damaged building, add a this setdamage x in the INIT textfield of your house, where x is a value from 0 to 1.

changelog : 2014-07-17 : v1.14.0717

Fix of some minor errors in .rpt

Adding of the template mission by BlackViperGaming

References & Thanks :

- Titibond

- BlackViperGaming

- A big THX to Dren for the structure of this addon

- BOOtsy here

- Antihelios.de

McKeewa

-------------

Pics :

--

http://llama-vox.com/a3/1011.jpg (259 kB)

http://llama-vox.com/a3/1012.jpg (141 kB)

Edited by keewa
update 1.14.0717
  • Like 1

Share this post


Link to post
Share on other sites

Just awesome, thanks for making and sharing! Do you plan to add all the tree/bushes/etc. objects as well in the future?

/KC

Share this post


Link to post
Share on other sites

@Foxhound, We are in the same team and we worked on it together, but I'm back in charge of the dev of the mod =)

(i'm gonna ask to titi to confirm this here)

@KeyCat, Yes but no, incorporate bushes and trees is not as easy than buildings, I'll try, but it ask a different kind of approach, long story short, I want to have all tree/bushes/etc in the mod, but no schedules yet.

Share this post


Link to post
Share on other sites

Hi everyone.

@Foxhound : Be safe :) Keewa is an admin of our team. We work together.

I'll post a new on the old post to make everything clear

Have fun to edit your missions !

Share this post


Link to post
Share on other sites

Thanks for the additional info. Armaholic will be updated asap ;)

New version frontpaged on the Armaholic homepage.

** Note: since this is a project on which more people are working we will contact you in the future to discuss how you want this to be setup on Armaholic.

===================================================

We have also "connected" these pages to your account (titibond) on Armaholic.

This means in the future you will be able to maintain these pages yourself if you wish to do so. Once this new feature is ready we will contact you about it and explain how things work and what options you have.

When you have any questions already feel free to PM or email me!

Edited by Foxhound

Share this post


Link to post
Share on other sites

Hi Keewa,

You may not know the answer to this question but I have been using HTUNE's editor addon, is your mod compatible or redundant to HTUNE's release?

Share this post


Link to post
Share on other sites

as far as I know, he's using the same base addon

I don't know how far he's gone in his addon. But it was a beta version I guess. Our's is composed by some new altean buildings =)

I schedule to make an update next WE with some important and original building (amphiteater) etc...

I don't know If HTUNE continues the dev of his mod, but I do for mine =)

So, it might be redundant. may be

Share this post


Link to post
Share on other sites

Excellent!- thanks for this, soo wanted those Transmitter Towers to add to missions. :cool:

Share this post


Link to post
Share on other sites

Hi guys

I've just used this mod to add some of the extra content to my multiplayer map. Was like a kid in a sweet shop I have to say :p

Having added the content, about 6 items radar and cargo HQ's etc I uploaded it to our server and tried to join.

The server recognised I still had the mod running on my home pc and kicked me.

Fair enough I thought and disabled the mod, rebooted the game and tried again.

It was at this point a clan mate joined me for a game but we both just sat looking at the loading screen for about 5 minutes.

I then tried to remove the stuff I had added but the editor wouldn't let me open it untill I re-enabled the mod.

I did this and removed all the stuff I had added.

I then disable the mod and tried to reload the map in the editor but it was still asking for the mod to be enabled even though I had completely removed all the stuff I added through the mod.

Now I imagine the problem is I am saving the map with the mod enabled.

However, I am in a catch 22 becuase I can't edit the map to save it without the mod enabled because I need to have it enabled to open it LOL :D

I am starting to get a little bit concerned as I did a school boy error and didn't back the map up before adding the new stuff.

This map represents many hours of work so I am hoping there is a way to fix this or I will be quite dis-heartened :butbut:

Am I buggered or is there a simple thing I can do to sort this out? :)

Many Thanks

ToM

Share this post


Link to post
Share on other sites
Hi guys

I've just used this mod to add some of the extra content to my multiplayer map. Was like a kid in a sweet shop I have to say :p

Having added the content, about 6 items radar and cargo HQ's etc I uploaded it to our server and tried to join.

The server recognised I still had the mod running on my home pc and kicked me.

Fair enough I thought and disabled the mod, rebooted the game and tried again.

It was at this point a clan mate joined me for a game but we both just sat looking at the loading screen for about 5 minutes.

I then tried to remove the stuff I had added but the editor wouldn't let me open it untill I re-enabled the mod.

I did this and removed all the stuff I had added.

I then disable the mod and tried to reload the map in the editor but it was still asking for the mod to be enabled even though I had completely removed all the stuff I added through the mod.

Now I imagine the problem is I am saving the map with the mod enabled.

However, I am in a catch 22 becuase I can't edit the map to save it without the mod enabled because I need to have it enabled to open it LOL :D

I am starting to get a little bit concerned as I did a school boy error and didn't back the map up before adding the new stuff.

This map represents many hours of work so I am hoping there is a way to fix this or I will be quite dis-heartened :butbut:

Am I buggered or is there a simple thing I can do to sort this out? :)

Many Thanks

ToM

Just find and open your mission.sqm in notepad and delete any reference to the mod under the addons bit at the top. See if that works :)

Edited by TomClothier

Share this post


Link to post
Share on other sites

I'm surprised of this error, there is no added content in the mod, it's only BIS content became avalaible.

I'm gonna check that

---------- Post added at 17:25 ---------- Previous post was at 16:55 ----------

Hi guys

I've just used this mod to add some of the extra content to my multiplayer map. Was like a kid in a sweet shop I have to say :p

Having added the content, about 6 items radar and cargo HQ's etc I uploaded it to our server and tried to join.

The server recognised I still had the mod running on my home pc and kicked me.

Fair enough I thought and disabled the mod, rebooted the game and tried again.

It was at this point a clan mate joined me for a game but we both just sat looking at the loading screen for about 5 minutes.

I then tried to remove the stuff I had added but the editor wouldn't let me open it untill I re-enabled the mod.

I did this and removed all the stuff I had added.

I then disable the mod and tried to reload the map in the editor but it was still asking for the mod to be enabled even though I had completely removed all the stuff I added through the mod.

Now I imagine the problem is I am saving the map with the mod enabled.

However, I am in a catch 22 becuase I can't edit the map to save it without the mod enabled because I need to have it enabled to open it LOL :D

I am starting to get a little bit concerned as I did a school boy error and didn't back the map up before adding the new stuff.

This map represents many hours of work so I am hoping there is a way to fix this or I will be quite dis-heartened :butbut:

Am I buggered or is there a simple thing I can do to sort this out? :)

Many Thanks

ToM

@ToM666, I don't how you proceed to use the mod, but I checked, and like I though, the CJTF101 editor do not interfere with the mission.sqm and his "addons required"

I put some buildings on a fresh map with the editor and I was able to open it and edit it without any mods launched.

Check your install and the way you installed and used your mods. This is not coming from my mod =)

Or at least, post some screens to make us able to help you.

Share this post


Link to post
Share on other sites

Hi guys

First of all big thanks to Tomclothier for saving my mission LOL :cool:

Secondly

This is the 1st mod I have used so I may have got it wrong but all I did was follow this tutorial:

http://forums.bistudio.com/showthread.php?150428-Beginners-guide-How-do-i-install-mods-addons

I basically put the mod into the directory below. I didn't put a launch parameter in because the tutorial led me to believe (if I have understood it correctly) that I didn't need to.

C:\Program Files (x86)\Steam\SteamApps\common\Arma 3\@cjtf101editor\addons

I then fired up Arma 3 enabled the expansion and rebooted the game.

I then added the items to my mission, saved as a multiplayer mission and uploaded to the clan server.

The rest is as explained in my OP.

Not sure why it has happened TBH.

The mission is now playable but I am getting an error that says something like "config.bin/cfgvehicles.land_cargo40_military_F no longer exists".

I have left the new stuff I added using your mod in the mission for now as the error doesn't appear to be causing a problem in the short term.

Loving all the new stuff though mate. Thanks very much :cool:

Share this post


Link to post
Share on other sites

Hum, I didn't understand the way you installed mods.

A quite simple way is to create a shortcut of your arma3.exe on your desktop, go in property of the shortcut and then, geting something like this "c:\blabla\arma3.exe" -mod=@cjtf101editor; in the target field.

This work if you added the @cjtf101editor in the root directory of A3 (you already did it if I understand well)

What buildings precisely, did you add.

The error you sent me back, aka,"config.bin/cfgvehicles.land_cargo40_military_F no longer exists", means that you added some cargo containers. These cargo containers are avalaible vanilla since the release and I confirm that some items of the mod need to be removed due to redundancy.

This is planned for the next update that will happend in a few days.

Any way, for all the time I used my mod, I never encounter any issue like this one.

Share this post


Link to post
Share on other sites
as far as I know, he's using the same base addon

I don't know how far he's gone in his addon. But it was a beta version I guess. Our's is composed by some new altean buildings =)

I schedule to make an update next WE with some important and original building (amphiteater) etc...

I don't know If HTUNE continues the dev of his mod, but I do for mine =)

So, it might be redundant. may be

Thank your for your reply. As far as I know HTUNE has not updated his mod for sometime and I appreciate that you are continuing to update yours. I will give yours a try.

Share this post


Link to post
Share on other sites
Thank your for your reply. As far as I know HTUNE has not updated his mod for sometime and I appreciate that you are continuing to update yours. I will give yours a try.

Nice to hear it ^^

Share this post


Link to post
Share on other sites
Hum, I didn't understand the way you installed mods.

What buildings precisely, did you add.

The error you sent me back, aka,"config.bin/cfgvehicles.land_cargo40_military_F no longer exists", means that you added some cargo containers. These cargo containers are avalaible vanilla since the release and I confirm that some items of the mod need to be removed due to redundancy.

This is planned for the next update that will happend in a few days.

Any way, for all the time I used my mod, I never encounter any issue like this one.

That'll be it. I did add one container but when I previewed it yuo couldn't see it (invisible).

I've just checked in the editor and sure enough it is still in the map. I've just deleted it so hopefully that will stop the error now.

Thanks mate.

ToM

Edited by ToM666

Share this post


Link to post
Share on other sites

@KeyCat, Yes but no, incorporate bushes and trees is not as easy than buildings, I'll try, but it ask a different kind of approach, long story short, I want to have all tree/bushes/etc in the mod, but no schedules yet.

Looking forward to whatever you decide to release in the future, thanks!

/KC

Share this post


Link to post
Share on other sites

I'm loving the mod - I've been using it to build up little airbases on the west side for some simple attack missions. But I do have a quick questions to ask:

Are there any plans to add editor icons other than the question marks? I know these are probably placeholders (like with what BIS did for objects in earlier Beta stages), but it's kind of difficult to put together the building sides (airport and hospitals need all three components) and whatnot.

Share this post


Link to post
Share on other sites
That'll be it. I did add one container but when I previewed it yuo couldn't see it (invisible).

I've just checked in the editor and sure enough it is still in the map. I've just deleted it so hopefully that will stop the error now.

Thanks mate.

ToM

Just to put this issue to bed in case anyone else is having the same problem.

All the problems I was having were as a direct result of putting the container "Land_Cargo40_military_f" into my mission.

Since removing it and not using it anymore I was able to add more content using Keewa's mod, save it as a multiplayer mission, upload it to the server and join the server without any trouble.

I think I was just unlucky in that I chose to use probably the only item that wasn't in the game anymore LOL.

Thanks for your help everyone.

Regards

ToM

Share this post


Link to post
Share on other sites

@KeyCat, happy to hear that

@TheEvanCat, I hear your pain dude ^^ unfortunatly, there is no item icons precisely because the mod calls to items not avalaible yet in the editor, and, de facto, icons are not drawn yet by BIS artists.

I think there is a library somewhere, where classnames are linked to icons and automatically returned when used on the editor, that's why, if I put in the mod an item already in the editor, it will get is correct icon (look at +wrecks category and you'll see that almost all cars wrecks have icons.)

And I must confess that I have not the time and the bravery to find this lib, create icons and link them, for a mod that I hope obsolet and useless quickly. In the future, I'll look at this icon story, with trees and bushes.

For your Airport thing, protip: you have to superimpose all the 3 parts on a perfect plane surface if possible

@ToM, thanks for your feedback, the said cargo is already delete from the mod and, de facto, will not be in the future update =)

Share this post


Link to post
Share on other sites

Tadaaa !! UPDATE

changelog : 24/9

New military buildings (dome, towers, research, medevac...)

New civilians buildings

New houses

New lamps (under +civ)

Castle added (+civ and +walls)

Several fixes

Any remarks, wish or bugseeking welcomed ;)

planned :

add houses

add ruins

Edited by Keewa

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×