Jump to content
Sign in to follow this  
giallustio

=BTC= Logistic [A3] - BETA

Recommended Posts

Hey Can you add a animation door for the ghost hawk when the rope was deploy ?

Share this post


Link to post
Share on other sites

Where does the "Distance between cargo and the ground" show up? I am unable to see locate this information.

Excellent work on the script Giallustio

Share this post


Link to post
Share on other sites
Where does the "Distance between cargo and the ground" show up? I am unable to see locate this information.

Excellent work on the script Giallustio

In the lift HUD before the name of the obj lifted after you lift something of course!

Example:

PIC [1 m] Ifrit

Share this post


Link to post
Share on other sites
In the lift HUD before the name of the obj lifted after you lift something of course!

Example:

PIC [1 m] Ifrit

I am sorry, I thought you added the height information in the upper left hand area of the screen I was not looking for this change in your custom HUD :(

I apologize again for that

Share this post


Link to post
Share on other sites

@Giallustio do you have any suggestions why on a dedicated mission I see Lift, Camera on/off and HUD on/off but Camera and HUd will not show up? I can lift and release no issue.

Thanks for any advise you can give.

Share this post


Link to post
Share on other sites

Hello firstly what a fantastic script! Just one question I am wanting to emit stop certain things like the Nato Ammo crates from been dragged and loaded and lifted etc etc. Where would I place this?

obj setvariable ["BTC_cannot_lift",1,true]; // Make an object not liftable

obj setVariable ["BTC_cannot_drag",1,true]; // Make an object not draggable

obj setVariable ["BTC_cannot_load",1,true]; // Make an object not loadable

And where would I add my: nato_ammo_f ?

Thanks in advance.........

Share this post


Link to post
Share on other sites

Probably they use a HUD that override the lift HUD

@daneplant

If you want a signle object put those lines in the init, if you want to disable the features for one class, you have to remove it from all the arrays!

BTC_def_cargo

BTC_def_drag

BTC_def_placement

And modify the liftable function!

Edited by Giallustio

Share this post


Link to post
Share on other sites

So if I want to disable just one particular crate from getting dragged I simply remove that from the array. Many thanks

Edited by daneplant

Share this post


Link to post
Share on other sites

Release frontpaged on the Armaholic homepage.

===================================================

We have also "connected" these pages to your account on Armaholic.

This means in the future you will be able to maintain these pages yourself if you wish to do so. Once this new feature is ready we will contact you about it and explain how things work and what options you have.

When you have any questions already feel free to PM or email me!

Share this post


Link to post
Share on other sites

Hello Giallustio, this is a very nice script though I appear to have found a problem with the cargo drop... Whenever I airdrop a loaded ammobox from a helo on my own LAN test server it works fine, however when my friend hosts the mission on his pc (not a dedicated server if that makes a difference) and i try to airdrop the ammobox from the helo it spawns outside of the heli for a split-second and disappears. Perhaps only server hosts can airdrop?

Share this post


Link to post
Share on other sites
Probably they use a HUD that override the lift HUD

I realize my mission is not your problem but I would like your opinion/help.

When I remove this portion of the script, your HUD works perfectly.

[] spawn {

scriptName "initMission.hpp: mission start";

["video\ECWC_LEADIN.ogv", false] spawn BIS_fnc_titlecard;

waitUntil {sleep 0.4; !(isNil "BIS_fnc_titlecard_finished")};

Am I missing a parameter that is not releasing the video and in turn is preventing your HUD from displaying?

Any help would be appreciated.

Share this post


Link to post
Share on other sites

I put this on one of my training maps and the pilots reported issues while picking up boats that are floating in water. They say that when the vehicle attaches it puts it on top of the helicopter.

Share this post


Link to post
Share on other sites

Is anyone else experiencing the following:

  1. Helo loads ammo box
  2. Helo reaches destination
  3. Box is dropped
  4. Operation/Maneuvers complete
  5. Box is loaded back on helo
  6. Cargo shows box in hold
  7. Orginal Box is still on the ground

Anyone?

Share this post


Link to post
Share on other sites
I put this on one of my training maps and the pilots reported issues while picking up boats that are floating in water. They say that when the vehicle attaches it puts it on top of the helicopter.

Our dedicated server experiences the same thing.

Share this post


Link to post
Share on other sites

May i suggest you to not add the hud action if the Heli is not in tne pip list too because if the heli can't lift, it doesn't need the hud action.

Share this post


Link to post
Share on other sites

Hi guys

I'm running this on the current dev build on Altis and was just playing around with it.

I found if I loaded the supply box onto an open back HEMMT Truck then unloaded it again it burst into flames LOL

I do have a Virtual Ammo Box script running inside the supply box.

Is this a bug with the dev build? Has anyone else experienced this?

I'm going to start trying it without the VAS script and with different items but thought was just curious if anyone else had experienced this?

Thanks

ToM

Share this post


Link to post
Share on other sites

I would think there may have been a physics glitch with the box spawning back on the ground.. Where did the box spawn when you went to unload it? if it spawned directly under it, theres a fat chance thats exactly what happened...

Share this post


Link to post
Share on other sites

We used this on a dedi server all the time and i don't get this error, but we're using the stable...

Share this post


Link to post
Share on other sites
I would think there may have been a physics glitch with the box spawning back on the ground.. Where did the box spawn when you went to unload it? if it spawned directly under it, theres a fat chance thats exactly what happened...

Hi austin

It appeared to the right towards the back of the truck. I wouldn't say it was under it but it was extremely close. Just wondering whether the code needs tweaking to place it a little further away if that is the case?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×