Jump to content
Sign in to follow this  
giallustio

=BTC= Logistic [A3] - BETA

Recommended Posts

Great work! just a couple of bugs but no biggies...

1) If you crash while lifting and die when you spawn back in you get the release on your scroll wheel still

2) When you crash whilst lifting when the vehicle Re-spawns you get the option for the HUD but you do not get the HUD

Share this post


Link to post
Share on other sites

Cant seem to get lifting working?

- also when i deploy the rope and tell squad to disembark they dont do anything?

Edited by brad7

Share this post


Link to post
Share on other sites

So do I put this in my mission folder init.SQF or in the chopper init box

Code:

_logistic = execVM "=BTC=_Logistic\=BTC=_Logistic_Init.sqf";

Share this post


Link to post
Share on other sites

Installation:

Copy "=BTC=_Logistic" folder in your mission folder.

Add in the init.sqf:

_logistic = execVM "=BTC=_Logistic\=BTC=_Logistic_Init.sqf";

Add in the description.ext:

Code:

class RscPicture
{
type = CT_STATIC;
idc = -1;
style = 48;
colorBackground[] = {0, 0, 0, 0};
colorText[] = {1, 1, 1, 1};
font = "PuristaMedium"; //Typeface
sizeEx = 0;
};
class RscTitles
{
#include "=BTC=_Logistic\=BTC=_Lift\=BTC=_Hud.h"
};

Share this post


Link to post
Share on other sites
The cargo is not working atm, i'm re-writing the code...

The hud position problem could be related to your interface size and resolution, could i have your settings?

I'll check the respawn problem!

1920x1080, 16:9 WIDE, Interface: Small, Standard Quality.

Also is this the correct usage and where would I put this?

BTC_cannot_lift  = ["B_SupplyCrate_F",1,true];

Edited by Kahna

Share this post


Link to post
Share on other sites

Is it possible to allow all player models to use the lift script? By default only "B_Helipilot_F" is allowed to use it. I could add all playermodels like "B_Helipilot_F","B_Soldier_F" etc, but would be nice if there was a different solution.

Share this post


Link to post
Share on other sites
Is it possible to allow all player models to use the lift script? By default only "B_Helipilot_F" is allowed to use it. I could add all playermodels like "B_Helipilot_F","B_Soldier_F" etc, but would be nice if there was a different solution.

"Man"

Share this post


Link to post
Share on other sites
"Man"

Doesn't work

Edit:

BTC_lift_pilot   = [];

I'm probably blind, because he even said this is the way to do it in the Hints and Tips file :x

Edit 2:

There are 2 new helicopter classes: "O_Heli_Light_02_unarmed_F" (Black PO-30) and the "B_Heli_Transport_01_camo_F" (Camo Ghosthawk)

Edit 3:

Is it possible to disable the Lifting HUD?

Edited by Sethenor

Share this post


Link to post
Share on other sites
Doesn't work

Edit:

BTC_lift_pilot   = [];

I'm probably blind, because he even said this is the way to do it in the Hints and Tips file :x

Edit 2:

There are 2 new helicopter classes: "O_Heli_Light_02_unarmed_F" (Black PO-30) and the "B_Heli_Transport_01_camo_F" (Camo Ghosthawk)

Edit 3:

Is it possible to disable the Lifting HUD?

1: I was just thinking of "Man" because that's how you enable all players to revive in BTC Revive. My bad.

2: Dev build I assume?

3: I tried the option, didn't work so I just went in and commented out all of the Hud On/Off addActions in both Lift_Init and LiftInit scripts. The HUD doesn't work once a Helicopter has been re-created with a respawn script.

Has anyone gotten the unliftable variable working yet? I don't like the idea of my VAS boxes being liftable. I kept their class liftable because I want to use the IND Vehicle Ammo Box as a liftable Supply Drop which de-spawns and re-spawns at base after about 6 minutes or so. Kind of an emergency resupply that pilots can drop without having to land at all.

EDIT

NVM, simply removing "ReammoBox_F" and adding "Box_IND_AmmoVeh_F" stops my VAS boxes from being abducted. Only the Green Vehicle Ammo Crate can be lifted now.

Edited by Kahna

Share this post


Link to post
Share on other sites

Since I put the updated version in my game crashes to desktop every time I try to open my mission now with the error: "Config: some input after EndOfFile" All I changed was the min lift height to 15?

Edit: Nevermind I found the issue. I copied over the Description.ext code and somehow ended up with an extra }; in the middle. All good now

Edited by Revv
Fixed!

Share this post


Link to post
Share on other sites

You fixed the problem that momentum/ speed wasn't carried over when you release the vehicle at high speed for empty vehicles but it is still glitched when you have players inside the vehicle.

Another glitch is that players have weird and sometimes violent shaking when inside a vehicle lifted by a helicopter.

---------- Post added at 04:31 ---------- Previous post was at 04:28 ----------

Also another glitch when you cut the rope while players are riding it down, they still float down and do not fall.

Share this post


Link to post
Share on other sites

Is the fast rope actually in this or is it in another script because I can't find anything to do with it in any of the scripts in this pack. Also I can't get the cargo to load or unload I get an error when loading it into a CH-49 Mohawk saying there's a ; missing on line 26 of the Load.sqf All I cahnged was the Reammobox to the basic blue ammo box. Any help appreciated

Share this post


Link to post
Share on other sites

To make an object not liftable write in its init field:

this setvariable ["BTC_cannot_lift",1,true];

To remove the HUD just delete the actions in the lift_init.

To make the script working for all players just leave the array empty!

I'll take a look at the fast rope.

Share this post


Link to post
Share on other sites

Hm, been having a few Problems with it lately.

I'm not sure but i think once someone has died he is unable to use the lifting script, just an assumption though.

The same goes for the Fastroping, it works fine until you've died, 100% sure about that.

Share this post


Link to post
Share on other sites

Version 0.12!

- Added pip camera for choppers

- Respawn problems should be fixed

- Small fixes

Share this post


Link to post
Share on other sites

Release frontpaged on the Armaholic homepage.

===================================================

We have also "connected" these pages to your account on Armaholic.

This means in the future you will be able to maintain these pages yourself if you wish to do so. Once this new feature is ready we will contact you about it and explain how things work and what options you have.

When you have any questions already feel free to PM or email me!

Share this post


Link to post
Share on other sites

Very nice job Giallustio ! :459:

Share this post


Link to post
Share on other sites

Thank you Luki_M2K!

I forgot to change the hud position, there's a conflict with the pip in the 0.12 version, i'll change it in the next release.

The camera is shaking a lot atm, i'm pretty new to this new feature, i'll be happy if someone could help me to improve it!

Share this post


Link to post
Share on other sites

Hey,

awesome mod :)

Just a short question, will this mod maybe later work like the RAV Lifter?

So that you can lift all things that you want? Like Ammo Boxes and so on? :)

Keep going! Really amazing work :)

Share this post


Link to post
Share on other sites

Very nice update. It looks like

this setvariable ["BTC_cannot_lift",1,true];

is still not working for me. cannot_drag and cannot_load seems to be good though.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×