Jump to content
Sign in to follow this  
Dwarden

ARMA 2: Operation Arrowhead - Linux Server beta 1.62.97240

Recommended Posts

ftp://downloads.bistudio.com/arma2.com/update/a2oa-server-1.62.97240.tar.bz2

ftp://downloads.bistudio.com/arma2.com/update/a2oa-server-1.62.97240.tar.bz2

CRC32: 353589D2

MD5: AF4AE4F106CF598DB0F7884F7F62E25C

SHA-1: B84FB864FF30FE6F11DA95066D5210CB2A1C4E03

Note that it requires Arma 2: Operation Arrowhead data to be updated to version 1.62 first in order to run properly.

ideal to combine with latest OA beta client:

Please provide us with feedback to this topic.

* this version brings linux in sync with actual windows server improvements and ai/mp fixes ...

http://community.bistudio.com/wiki/ArmA:_Dedicated_Server

Arma 2: Operation Arrowhead - Linux Standalone Server 1.62

===============================================================

Copyrigt © 2010 Bohemia Interactive Studio. All rights reserved.

For more information please visit

http//community.bistudio.com/wiki/ArmA:_Dedicated_Server

Installation instructions:

==========================

1. Following programs must have been installed on your Linux-box:

tar, gcc. Optional: md5sum (for setup integrity check)

1a. On some verions of Linux (this was reported for RedHat 9

and Gentoo linux 2.4.20) the NSCD deamon must be installed to

run ArmA 2 server successfully. Caching of DNS would be sufficient.

2. Copy the whole "ArmA 2 Operation Arrowhead" directory from Windows

to some Linux-directory (arma2arrowhead). DON'T DO ANY DATA CONVERSIONS

(even "dos2unix" translation of text files is not necessary).

Example: you can use PKZIP (WinZip, PowerArchiver, etc.) on

Windows and "unzip" on Linux.

Don't use upper case letters in the ArmA2 directory name

(/home/bob/arma2arrowhead will be good, /home/bob/ArmA2ArrowHead

may cause some troubles).

ArmA2 directory should contain subdirectories "Addons", "Bin",

"Campaigns", etc.

3. Copy the "server-x.xx.tar.gz" (x.xx is version number) file into

the arma2arrowhead directory. Unpack and install it with commands:

arma2arrowhead$ tar -xjf server-x.xx.tar.bz2

arma2arrowhead$ ./install

Watch the messages - they will inform you whether your installation

is successful.

4. Dedicated server can be started in foreground:

arma2arrowhead$ ./server

Or in background:

o$ nohup ./server > out.txt 2> err.txt &

[1] <pid>

5. Running server can be stopped by executing:

$ kill -s SIGINT <pid>

Where <pid> is process-id of mother server thread (printed out in

"nohup" command).

6. ArmA2 ArrowHead server has a feature: command-line parameter

"-pid=<pid_file>". It causes creation of <pid_file> with

PID of root ArmA2 process. If IP port specified in "-port=<nn>"

parameter is busy (in usage), ArmA2 will terminate immediately

and <pid_file> won't be written..

7. The "arma2server" script is provided for automatic server

start/restart/status query/etc. Please be sure to edit

CONFIGURATION PARAMETERS in lines 12 to 18 !

After this is done, install (hard-link?) the script into

"/etc/rc.d/init.d/arma2server" file. After that it can be managed

by "chkconfig" (see info/man).

previous thread about 1.60.xxxxx linux server :

Share this post


Link to post
Share on other sites

WOW, coming fast now :)

Will be online in minutes if it's same quality as .035 ;) [edit] Seems like it is, starts in twenty seconds :yay:

Thank's BIS

Edited by Overlord

Share this post


Link to post
Share on other sites

after downloading this new server, i launch it, but i get this message :

./run_arma: ligne 88: /home/armaao/server: Aucun fichier ou dossier de ce type

WATCHDOG (16440): [samedi 22 septembre 2012, 17:36:03 (UTC+0200)] Serveur mort, attente de redémarrage...

where "run_arma" is the script that launch ArmA...

#!/bin/bash

ARMA_DIR=/home/armaao

CONFIG=server.cfg

NAME=server

CFG=arma2.cfg

PORT=2302

PIDFILE=${ARMA_DIR}/logs/${PORT}.pid

RUNFILE=${ARMA_DIR}/logs/${PORT}.run

LOGFILE=${ARMA_DIR}/logs/log.${PORT}.txt

SERVER=${ARMA_DIR}/server

OTHERPARAMS='-cpucount=2 -beta=expansion/beta;expansion/beta/expansion'

MODS="";

#=======================================================================

ulimit -c 1000000

case "$1" in

start)

if [ -f ${RUNFILE} ]; then

$0 stop

fi

echo "Démarrage du serveur Arma..."

echo "go" >${RUNFILE}

nohup </dev/null >/dev/null $0 watchdog &

;;

stop)

echo "Arret du serveur Arma..."

if [ -f ${RUNFILE} ]; then

rm -f ${RUNFILE}

fi

if [ -f ${PIDFILE} ]; then

kill -TERM $(< ${PIDFILE})

if [ -f ${PIDFILE} ]; then

rm -f ${PIDFILE}

fi

fi

;;

status)

if [ -f ${RUNFILE} ]; then

echo "Le serveur Arma fonctionne"

else

echo "Le serveur Arma ne tourne pas"

fi

if [ -f ${PIDFILE} ]; then

PID=$(< ${PIDFILE})

echo "PID file exists (PID=${PID})..."

if [ -f /proc/${PID}/cmdline ]; then

echo "Le serveur semble tourner"

fi

fi

;;

check)

echo -n "Répertoire ArmA : ${ARMA_DIR} "

if [ -d ${ARMA_DIR} ]; then

echo "OK"

else

echo "MANQUANT!"

fi

echo -n "Le serveur : ${SERVER} "

if [ -x ${SERVER} ]; then

echo "OK"

else

echo "ERREUR!"

fi

echo "Numéro de port : ${PORT}"

echo -n "Fichier de configuration : ${CONFIG} "

if [ -f ${CONFIG} ]; then

echo "OK"

else

echo "MANQUANT!"

fi

echo "PID file: ${PIDFILE}"

echo "RUN file: ${RUNFILE}"

;;

restart)

$0 stop

/bin/sleep 2

$0 start

;;

watchdog)

while [ -f ${RUNFILE} ]; do

cd ${ARMA_DIR}

echo >>${LOGFILE} "ELRON ($$): [$(date)] Démarrage du serveur (port ${PORT})..."

${SERVER} >>${LOGFILE} 2>&1 -server -config=${CONFIG} -port=${PORT} -pid=${PIDFILE} -name=${NAME} -cfg=${CFG} -profiles=${PROFILES} -mod=${MODS}

if [ -f ${RUNFILE} ]; then

echo >>${LOGFILE} "WATCHDOG ($$): [$(date)] Serveur mort, attente de redémarrage..."

sleep 5s

else

echo >>${LOGFILE} "WATCHDOG ($$): [$(date)] Serveur arrête intentionnellement, Arrêt de la surveillance par ELRON"

fi

done

;;

*)

echo "$0 (start|stop|restart|status|check)"

;;

esac

the server work with Ubuntu 12.04.1 LTS

Edited by tanaka
forgot linux version

Share this post


Link to post
Share on other sites

I need help please.

Next post have links as forum restrict me with zero posts.

---------- Post added at 17:20 ---------- Previous post was at 17:19 ----------

I need help please. I must be doing things wrong.

When following the readme, point and comments below:

1. Believe all programs are isntalled.

2. Amra 2 copied to "/arma2arrowhead/" +- 18GB.

Please see directory list here

3. a2oa-server-1.62.97240.tar.bz2 downloaded and extarcted.

./install yields good result. See here.

4. This is where I have issues.

When i run "./server" I get this

The last line is "Segmentation fault"

I run this on

On Linux "Linux deb-ub-arma 3.2.0-29-generic-pae #46-Ubuntu SMP xx i686 i686 i386 GNU/Linux

"

Ubuntu 12.04.1 LTS

I tried +- 5 times since yesterday on clean linux installs.

After it failed , i tried adding "server.cfg" and editing the "arma2oaserver" files.

It still failed.

I also tried version "1.62.97035", a previous version.

Your help will be much appreciated.

Share this post


Link to post
Share on other sites
after downloading this new server, i launch it, but i get this message :

my French sucks, and I have Debian, but assuming that you have a 64 bit system, see if you have libc6-i386 installed. Also, try the command ldd server, which should give you an error.

Share this post


Link to post
Share on other sites
after downloading this new server, i launch it, but i get this message :

where "run_arma" is the script that launch ArmA...

the server work with Ubuntu 12.04.1 LTS

You must have ia32-libs package installed to run arma's server. If you previously upgraded your dedicated server from 10.04LTS, it removes ia32-libs as it's an old package which is not supported now. So in order to run your arma server properly you must follow these steps :

run apt-get update

run apt-get upgrade

run apt-get install ia32-libs

If it doesn't work you need to rebbot your dedicated first to run these commands again.

Share this post


Link to post
Share on other sites

oooop's, i didn't see that first part was in french :D

I have done what you wrote, then the server is running very well, TY, I think the last big update of my dedicated server erase the old configuration

I am now with the same problem with the last linux version. When i connecte to the arma server with the client, i can't go in game, i get black screen with only "waiting host" and nothing happen

Share this post


Link to post
Share on other sites
I am now with the same problem with the last linux version. When i connecte to the arma server with the client, i can't go in game, i get black screen with only "waiting host" and nothing happen
Do you have a mission autostarting in your server.cfg? If you log in as admin and then do #missions, do you get to see your list of missions?

Share this post


Link to post
Share on other sites

the server.cfg is that :

hostname = "xxx";

password = "";

passwordAdmin = "miaaaaou";

reportingIP = "armedass.master.gamespy.com";

logFile = "logs/server.log";

motd[] = {

"x",

"x",

"x"

};

motdInterval = 5;

checkfiles[] = {};

maxPlayers = 32;

kickDuplicate = 1;

verifySignatures = 0;

equalModRequired = 0;

voteMissionPlayers = 64;

voteThreshold = 1;

disableVoN = 1;

vonCodecQuality = 0;

persistent = 1;

onUserConnected = "";

onUserDisconnected = "";

doubleIdDetected = "";

regularCheck = "";

onUnsignedData = "kick (_this select 0)";

onHackedData = "kick (_this select 0)";

onDifferentData = "";

BattlEye = 1;

class Missions {};

---------- Post added at 22:49 ---------- Previous post was at 22:19 ----------

i can't connect in admin...

Share this post


Link to post
Share on other sites

in the end of your server.cfg you've missed to add the missions you want to play on your server.

for example

class Missions
{
       class DM_Deathmatch
       {
               template = "MP_Deathmatch.Chernarus";// omit the .pbo suffix
               difficulty = "recruit";// difficulty: recruit, regular, veteran or mercenary (see CfgDifficulties in the main game config)
       };
};

A nice list of missions can be found at the official wiki :)

Share this post


Link to post
Share on other sites

if you let empty this line : class Missions {}, the system let the admin to choose the mission, i think. Write informations in this class, restrict the acces to some mission ?

Share this post


Link to post
Share on other sites
oooop's, i didn't see that first part was in french :D

I have done what you wrote, then the server is running very well, TY, I think the last big update of my dedicated server erase the old configuration

I am now with the same problem with the last linux version. When i connecte to the arma server with the client, i can't go in game, i get black screen with only "waiting host" and nothing happen

Which version of arma are you running client side ? if versions doesn't match it can explain why you're stuck.

Helping you is much easier when you provide logfile of the server. Although, perhaps you can create a separate post for this issue as it's have nothing to do with this version of the server.

Share this post


Link to post
Share on other sites

@tanaka: can you log in as admin (#vote admin tanaka) on that screen? And then choose missions? If so you can set up a mission rotation list (or at least one default mission) when you join server. You can always choose missions later with #missions.

Share this post


Link to post
Share on other sites
= Memphis007;2228445']Helping you is much easier when you provide logfile of the server. Although' date=' perhaps you can create a separate post for this issue as it's have nothing to do with this version of the server.[/quote']

You don't know that for sure

Share this post


Link to post
Share on other sites

No Matter what Mission the Memoryusage rises till all Memory is used and Server crashes.

Empty non persistent server takes arround 265 mb.

System:

V-Server

Debian GNU/Linux 6.0.5 (squeeze)

4Threads

1024 MB Ram

and of course Linux Server beta 1.62.97240

startscript:

#!/bin/bash

#

# armaserver: ArmA 2 Linux Dedicated Server Control Script

# © 2010 BIStudio

# ArmA 2 binary version must be 1.04 or later

#

# mod by: Psycho Dad , Date: 2012/08/05

#=======================================================================

#======== CONFIGURATION PARAMETERS ========

#======== MUST BE EDITED MANUALLY TO FIT YOUR SYSTEM PARAMETERS ========

#=======================================================================

ARMA_DIR=$HOME/server/arma/armaoa

CONFIG=server.cfg

PORT=2302

PIDFILE=${ARMA_DIR}/${PORT}.pid

RUNFILE=${ARMA_DIR}/${PORT}.run

LOGFILE=${ARMA_DIR}/${PORT}.log

SERVER=${ARMA_DIR}/server

OTHERPARAMS=-cpucount=4

MOD=beta\;

#@chn_undead\;

#=======================================================================

ulimit -c 1000000

# setup the libraries, local dir first! (add!)

export LD_LIBRARY_PATH=".:${ARMA_DIR}/lib32:/usr/lib32:${LD_LIBRARY_PATH}"

case "$1" in

start)

if [ -f ${RUNFILE} ]; then

$0 stop

fi

echo "Starting ArmA 2 server..."

# remove core dumps (add!)

find ${ARMA_DIR} -name core -type f -print | xargs -r rm -f

# file to mark we want server running...

echo "go" >${RUNFILE}

# launch the background watchdog process to run the server (mod!)

nohup </dev/null >/dev/null 2>&1 $0 watchdog-port-${PORT} &

;;

stop)

echo "Stopping ArmA 2 server..."

if [ -f ${RUNFILE} ]; then

# ask watcher process to exit by deleting its runfile...

rm -f ${RUNFILE}

fi

# and terminate ArmA 2 server process

if [ -f ${PIDFILE} ]; then

kill -TERM $(< ${PIDFILE})

if [ -f ${PIDFILE} ]; then

rm -f ${PIDFILE}

fi

sleep 1s

fi

# kill watchdog (add!)

pgrep -U ${UID} -fl watchdog-port-${PORT} | awk '{print $1}' | xargs -r kill -TERM >/dev/null 2>&1

;;

status)

if [ -f ${RUNFILE} ]; then

echo "Server should be running..."

else

echo "Server should not be running..."

fi

if [ -f ${PIDFILE} ]; then

PID=$(< ${PIDFILE})

echo "PID file exists (PID=${PID})..."

if [ -f /proc/${PID}/cmdline ]; then

echo "Server process seems to be running..."

fi

fi

;;

check)

echo -n "ArmA 2 directory: ${ARMA_DIR} "

if [ -d ${ARMA_DIR} ]; then

echo "OK"

else

echo "MISSING!"

fi

echo -n "Server executable: ${SERVER} "

if [ -x ${SERVER} ]; then

echo "OK"

else

echo "ERROR!"

fi

echo "Port number: ${PORT}"

echo -n "Config file: ${CONFIG} "

if [ -f ${CONFIG} ]; then

echo "OK"

else

echo "MISSING!"

fi

echo "PID file: ${PIDFILE}"

echo "RUN file: ${RUNFILE}"

;;

restart)

echo "Restarting ArmA 2 server..."

$0 stop >/dev/null

$0 start >/dev/null

;;

watchdog-port-${PORT})

# this is a background watchdog process. Do not start directly

while [ -f ${RUNFILE} ]; do

# launch the server...

cd ${ARMA_DIR}

echo >>${LOGFILE} "WATCHDOG ($$): [$(date)] Starting server (port ${PORT})..."

${SERVER} >>${LOGFILE} 2>&1 -server -config=${CONFIG} -port=${PORT} -pid=${PIDFILE} -mod=${MOD} ${OTHERPARAMS}

if [ -f ${RUNFILE} ]; then

echo >>${LOGFILE} "WATCHDOG ($$): [$(date)] Server died, waiting to restart..."

sleep 10s

else

echo >>${LOGFILE} "WATCHDOG ($$): [$(date)] Server shutdown intentional, watchdog terminating"

fi

done

;;

*)

echo "$0 (start|stop|restart|status|check)"

Server.cfg

hostname= "KACKSACK testing ";

passwordAdmin = "SUPERSECRETPASS";

maxPlayers = 30;

//password = "anothersupersecretpass if needed";

motd[] = {

"another-KACKSACK-server",

"Its a testing Server. So it is going to crash",

};

voteMissionPlayers = 1;

reportingIP = "arma2pc.master.gamespy.com";

kickduplicate = 1;

logFile = "server_console.log";

BattlEye = 1;

motdInterval = 5;

persistent = 0;

class Missions

{

class DM_Deathmatch

{

template = "MP_Deathmatch.Chernarus";// omit the .pbo suffix

difficulty = "recruit";// difficulty: recruit, regular, veteran or mercenary (see CfgDifficulties in the main game config)

};

class DM_Detector

{

template = "MP_Detector.Chernarus";

difficulty = "regular";

};

class Team_TeamDeathmatch

{

template = "MP_TeamDeathmatch.Chernarus";

difficulty = "veteran";

};

class COOP_Paradrop

{

template = "MP_Paradrop.Chernarus";

difficulty = "mercenary";

};

class CTI_CivilWar

{

template = "MP_CivilWar.Chernarus";

difficulty = "regular";

};

class CTI_SuperPowers

{

template = "MP_Superpowers.Chernarus";

difficulty = "regular";

};

class CTI_WarWelcome

{

template = "MP_WarWelcome.utes";

difficulty = "regular";

};

class CTI_WhenDiplomacyFails

{

template = "MP_WhenDiplomacyFails.Chernarus";

difficulty = "regular";

};

};

Share this post


Link to post
Share on other sites

Over how long time?

Btw, I recall someone say that linux dedi server will only run two threads.

If so, cpucount should probably stay 2 unless you want to limit to 1.

Share this post


Link to post
Share on other sites
Over how long time?

Btw, I recall someone say that linux dedi server will only run two threads.

If so, cpucount should probably stay 2 unless you want to limit to 1.

thank you.

I gone try it with two threads later. The runtime is random somtimes 1 hour sometimes 6.

UPDATE: No didnt helped at all. Memoryusage is still rising over time.

Edited by flaep

Share this post


Link to post
Share on other sites

1024 MB RAM is too low for server, that's what AA2 server alone wants. Sorry, not aware of any tweaks of limiting memory usage in AA2 server. Just add more RAM.

My server use just below 600 MB idle, AA2 server uses 300+ of that.

Share this post


Link to post
Share on other sites
1024 MB RAM is too low for server, that's what AA2 server alone wants. Sorry, not aware of any tweaks of limiting memory usage in AA2 server. Just add more RAM.

My server use just below 600 MB idle, AA2 server uses 300+ of that.

but it should start lagging or high ping and not crash. It just eats up all the memory.

i rode about the same issue with an older version of the windows server.

the owner used some kind of ram cleaning tool to keep the ram free. The server used to reservate memory that he actualy never used.

Edited by flaep

Share this post


Link to post
Share on other sites
You could try to check your RAM for errors (e.a. memtest).

Its a Vserver/Virtual machine.

Share this post


Link to post
Share on other sites

my box uses 1.2gig max when running heavy mission... did u try to just assign a little more ram to it? not a fan of vm here tho. ;)

but yea i am with you it shouldt crash when running out of mem... it should use the swap partition right?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×