Jump to content
Sign in to follow this  
nes4day

F-22A Raptor

Recommended Posts

even at Full throttle i can't see any options regarding AB....seriously, i reach 998-1000 in speed but nothing appears...

Share this post


Link to post
Share on other sites
Afterburner doesn't seem to work for me then. I was going 400 km/h and I had 100% throttle and there was no option for afterburner.

Yes, and i to dont see the option to activate the afterburner:butbut::(

Share this post


Link to post
Share on other sites

AB doesn´t work for me too. no optio in any way. is it possible you can add ace2 afterburner ?

the lean is just brilliant (using trackir ;) ) but may you can lean a bit more left and right, or do you have then modell collition ??

we need that leaning in all helis and planes. that makes it just easier to land or scan the surroundings.

thanks to you both for that great work...

Share this post


Link to post
Share on other sites
AB doesn´t work for me too. no optio in any way. is it possible you can add ace2 afterburner ?

the lean is just brilliant (using trackir ;) ) but may you can lean a bit more left and right, or do you have then modell collition ??

we need that leaning in all helis and planes. that makes it just easier to land or scan the surroundings.

thanks to you both for that great work...

Hey Masty ;-)

Anyone can do that btw; http://ace.dev-heaven.net/wagn/ACE_Features_for_3rd_Party_Addons

(It's specifically an example to add AfterBurners ;D)

As mission maker you can do it too: http://ace.dev-heaven.net/wagn/Afterburners+notes

In init field:

this setVariable ["ACE_hasAfterburner", true];

Share this post


Link to post
Share on other sites
Hey Masty ;-)

Anyone can do that btw; http://ace.dev-heaven.net/wagn/ACE_Features_for_3rd_Party_Addons

(It's specifically an example to add AfterBurners ;D)

As mission maker you can do it too: http://ace.dev-heaven.net/wagn/Afterburners+notes

In init field:

this setVariable ["ACE_hasAfterburner", true];

hey sickboy ;) do you stalk me .... hehehehe. thx for that fast-sicky-answer ...

Share this post


Link to post
Share on other sites

To all those who don't have working afterburner, i would appreciate it if you could do some tests for me:

place a unit and place the F-22 (you may also place the F-22 with player as pilot directly, doesn't matter) and copy this into the initline of one of the unit's (also doesn't matter in which):

nul = [] spawn {
while {true} do {
	hintsilent format ["%1", ((inputAction "HeliUp") + (inputAction "HeliThrottlePos"))];
};
};

It will show a number on the top right corner. Please check what value is shown when applying full throttle.

Also please tell me what you do use as control to control the throttle (joystick, keyboard) and what your controls are assigned to.

:Personal remark:

Personally i would prefer a nonACE solution as this would make AB available to anyone, not only to those that play with ACE2. But this is not up to me to decide and really only a personal opinion.

Edited by [FRL]Myke
typo fixed

Share this post


Link to post
Share on other sites
Myke;1852881']To all those who don't have working afterburner, i would appreciate it if you could do some tests for me:

place a unit and place the F-22 (you may also place the F-22 with player as pilot directly, doesn't matter) and copy this into the initline of one of the unit's (also doesn't matter in which):

nul = [] spawn {
while {true} do {
	hintilsent format ["%1", ((inputAction "HeliUp") + (inputAction "HeliThrottlePos"))];
};
};

It will show a number on the top right corner. Please check what value is shown when applying full throttle.

Also please tell me what you do use as control to control the throttle (joystick, keyboard) and what your controls are assigned to.

doesnt work, brings an error (nothing standing in the error window) when you pasted it in the init-line and clicked ok.

Share this post


Link to post
Share on other sites

Mep...typo...

nul = [] spawn {
while {true} do {
	hintsilent format ["%1", ((inputAction "HeliUp") + (inputAction "HeliThrottlePos"))];
};
};

hintilsent != hintsilent :rolleyes:...silly me

Share this post


Link to post
Share on other sites

Sorry for asking really dumb questions...did you checked in 3rd person view if the AB effect really doesn't kick in?

Share this post


Link to post
Share on other sites

i have a 0 when q is not pressed, than a 1 if its pressed ... andy whwn shift-q pressed there is no change.

did it from outside kiddy view :D

Share this post


Link to post
Share on other sites

Ok lads, thanks for your help. Bug is located and will be fixed. I did not enough research so my apologies for the unconvenience.

As explanation: i'm used to fly with joystick and the throttle returns a max value of 2 when full throttle is applied. Based on that i set the trigger limit to 1.95. As we've now found out (thanks to you for assistance), when using keyboard the max value is 1...therefor the action is never available.

@nes4day

this is fixed quickly. In the config.cpp in the useractions change the number in conditions from 1.95 to 0.95

Also in the init.sqf, locate line 139:

	while {(alive _plane) and  (((inputAction "HeliUp") + (inputAction "HeliThrottlePos"))>1.95)} do {

Also here change the value 1.95 to 0.95

@all

i'm very sorry for my stupidity and take full responsability for this issue.

Share this post


Link to post
Share on other sites
Myke;1852927']Ok lads' date=' thanks for your help. Bug is located and will be fixed. I did not enough research so my apologies for the unconvenience.

As explanation: i'm used to fly with joystick and the throttle returns a max value of 2 when full throttle is applied. Based on that i set the trigger limit to 1.95. As we've now found out (thanks to you for assistance), when using keyboard the max value is 1...therefor the action is never available.

@nes4day

this is fixed quickly. In the config.cpp in the useractions change the number in conditions from 1.95 to 0.95

Also in the init.sqf, locate line 139:

	while {(alive _plane) and  (((inputAction "HeliUp") + (inputAction "HeliThrottlePos"))>1.95)} do {

Also here change the value 1.95 to 0.95

@all

i'm very sorry for my stupidity and take full responsability for this issue.[/quote']

lol!Don't worry myke,that's a little mistake

Share this post


Link to post
Share on other sites

Ah I suppose I misunderstood; I thought the plain was lacking afterburners, and they were asking for ACE afterburners :D

Edited by Sickboy

Share this post


Link to post
Share on other sites

@Sickboy

one question though:

this setVariable ["ACE_hasAfterburner", true];

Would check for ACE_hasAfterburner also return true if it is enabled in config? Actually thinking about how to enable ACE afterburner without completely disabling the built-in, so at the end non-ACE player would have the built in and ACE player would have the ACE enabled.

Else i would have to check for ACE separately...no biggie, just would make it shorter if i could only check for the above variable.

Share this post


Link to post
Share on other sites
Myke;1852949']@Sickboy

one question though:

this setVariable ["ACE_hasAfterburner", true];

Would check for ACE_hasAfterburner also return true if it is enabled in config? Actually thinking about how to enable ACE afterburner without completely disabling the built-in' date=' so at the end non-ACE player would have the built in and ACE player would have the ACE enabled.

Else i would have to check for ACE separately...no biggie, just would make it shorter if i could only check for the above variable.[/quote']Currently the object variable is used as override.

So if Object variable is found, it's value (either true or false) will be used.

If the object variable does not exist, it will look in the CfgVehicles class, if the vehicle has ACE_hasAfterburner = 1;

The function we use is [_vehicle] call ace_sys_afterburner_fnc_hasAfterBurner

if return true, it has ace afterburners enabled, if false, it doesn't.

Does that answer your question?

Share this post


Link to post
Share on other sites

i think i have found a bug in the new version: the wheels or tires wont spin.

btw the new one is awesome!

Share this post


Link to post
Share on other sites

Outstanding update! The plane feels so much smoother to handle now and actually is lethal in air-air combat.

Only thing missing now is the afterburner (I tried the Shift + Q at full throttle and it didn't work). Excellent work guys!

---------- Post added at 05:41 PM ---------- Previous post was at 05:38 PM ----------

Oh and the lean issue. But other than that, awesome!

Share this post


Link to post
Share on other sites

@Leogecko27 & dingyisun

would you mind to read a little back?

Wheels not turning: known

Missing afterburner: known and almost fixed for the next update

lean issue: you know you can adjust keys in the game options -> control menu?

Share this post


Link to post
Share on other sites

I have to say that I also don't like the leaning feature as it is now. I'm not comfortable with the idea of changing the controls. I looked over it and it seems I'd have to change a lot more keys than just one wich means I'd have to memorize the new layout and forget about the old one I used since I started playing Arma 2...

Share this post


Link to post
Share on other sites

Sure, but then I had to do some acrobatic stunts with my fingers or change some customised controls.

€: I'll leave it as it is right know. Is it possible to deactivate/activate the feature via actionmenu so that you can only lean when it's activated? I have no Idea if that is possible. It's just an idea

Edited by Derbysieger

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×