Jump to content

Lockheed Martin

Member
  • Content Count

    5
  • Joined

  • Last visited

  • Medals

Community Reputation

1 Neutral

About Lockheed Martin

  • Rank
    Rookie
  1. The Arma 3 Sector Module creates a zone in-game with a visible HUD Icon when near said sector. It also creates a icon on the side of your screen for when you enter a sector. How would one change these icons, similar to how you can drawIcon3D? Context: Thank you!
  2. Lockheed Martin

    Locality on Dedicated Server Question

    Oh yeah don't worry not the issue. The _posArea is just a fake variable name to use an example in this post. The ' error was just a badcase of typing this out here, all good no syntax errors causing a malfunction in the script :)
  3. Lockheed Martin

    Locality on Dedicated Server Question

    So what Ive done is in my initServer.sqf I have called my random trigger script: Then in Trigger_Spawn.sqf I create this trigger: Upon entering the trigger, nothing occurs. I have even tried doing: I have also tried moving the code where I make the trigger, into initServer and still it does not execute when a player enters. If I do not call this trigger creation in initServer or do not use a isServer check, it will work. However it will then make triggers for both server and local, meaning one trigger will activate when a player enters, the other wont. Problem is when a player JIP the prior local created trigger will not work. Thus I feel using isServer keeps the trigger on the server side, thus clients are unable to activate it as the code hasnt been executed locally. Is there anyway to create a trigger, then make it global so when a JIP or player who is there from the start enters said trigger, it activates? All without having to call said trigger creation script every time they join, thus avoiding generating countless random triggers. Appreciate your help with this.
  4. Say you have a Dedicated Server: You would like to run a script which generates random triggers across the map activated by condition "play in thisList". You'd like to only run the script once however, so it doesn't keep generating more triggers for every single client JIP or at mission init. If I call the script in init.sqf like: It will generate the random triggers and only run the script once. However it is serverside, not Local/Global. Thus players do not activate the triggers! No success either even if I pass in player as a parameter when calling the .sqf. Would anyone know of a creative hack per say, to run a script only once when the server inits. But allow for its triggers to be accessed by all clients and JIPs? Thank you for your time. To be more specific, my init.sqf runs the script which generates my triggers. This is an example of one of the triggers conditions. Said conditions do not activate when a player is present on a dedicated server.
  5. Whenever I hit play on Arma 3 in steam it goes to the launcher which when I hit play gives the error Exit Code: 0xC000009A - STATUS_INSUFFICENT_RESOURCES Whenever I enter the game via the Arma3.exe in the games root directory it launches and allows me to join any game except its only servers WITHOUT Battleeye, as launching from the root directory is not enabling Battleye some reason. When I go to the server list it gives a prompt to enable Battleeye but fails as it restarts the game but comes up with a window giving the error and this log... 16:06:44: Starting BattlEye Service... 16:06:48: Launching game... 16:06:50: Note: File blocks can be ignored if they don't cause problems with the game. 16:06:50: [INFO] Blocked loading of file: "C:\Windows\SysWOW64\uxtheme.dll". 16:06:50: [INFO] Blocked loading of file: "C:\Windows\SysWOW64\edputil.dll". 16:06:50: [INFO] Blocked loading of file: "C:\Windows\SysWOW64\urlmon.dll". 16:06:50: [INFO] Blocked loading of file: "C:\Windows\SysWOW64\cldapi.dll". 16:06:50: [INFO] Blocked loading of file: "C:\Windows\SysWOW64\slc.dll". 16:06:50: [INFO] Blocked loading of file: "C:\Windows\System32\d3d10.dll". 16:06:50: [INFO] Blocked loading of file: "C:\Windows\System32\msimg32.dll". Please help! PS: I have tried launching with and without mods both installed and not installed. I have also reinstalled the game and moved it to another drive to no avail. I have also deleted the Battleye folder re-validated files to no success. BattleEye Errors Launcher: Error Log Report Files: https://puu.sh/CtE5Z/a8f6c7249b.zip Computer Specs:
×