Jump to content

Recommended Posts

On 12/6/2020 at 7:27 AM, pierremgi said:

That's a little bit too far from the initial intent for respawning vehicles + crew + waypoints +...  as already scripted.

Respawning vehicle on start position will reassign the waypoints. Respawning them at death position will make them continue on previous track as they didn't die.

 

For waypoints and all path issues, BI didn't manage something robust with that. There are some "workarounds", or more exactly what we call in French: Cautery on wooden leg, like:

calculatePath and pathCalculated (that will not make AIs more clever)

or

useAiSteeringComponent with steering considerations  if you want to play with...  (that will not improve the detection of obstacles).

 

So far, I will not add a line for AI/vehicle paths. It's on each scenario writer to make compromises with the map (they are not equal in term of moving units), the chosen vehicles (mods are not equal in term of vehicle motion), the chosen environment (roads, trees, rocks, cities). That can't be fine in all (pomp and) circumstances. 

 

 

 

 

Ok mate thats understood thank you.

 

Can i make a small request? Would it be possible for infantry who respawn who were linked to the "subordinate" module via high command be remembered as a subrodinate. Currently units under high command who respawn loose their place within the high command system.

 

EDIT

 

I actually found a very easy way to do this via placing a line in the groups init.Basically same effect if anyone else wonders how to do this. 

<HCO> hcsetgroup [<group>,""];

Where "<HCO> " is the player use "player" and "<group>" set the groups name.

 

after further testing it seems vanilla behaviour removes a group from HC when its dead.So calling this line from a trigger  is a better way.I never said thanks for the mod,it really is an all in one of many different mods iv been using in conjunction over the years,simplified but even more awesome.Big thanks man.

 

 

 

 

  • Like 1

Share this post


Link to post
Share on other sites

Thanks. Interesting. I should have a sharper look at HC.

  • Like 1

Share this post


Link to post
Share on other sites
On 12/10/2020 at 11:29 PM, pierremgi said:

Thanks. Interesting. I should have a sharper look at HC.

Can you have a look at the AI respawn.It seems to not work as intended if i understand correctly.

 

AI respawn is respawning vehicle crews after the vehicle was destroyed. No vehicle respawn module down.I have an empty map. Zeus module(for testing/debugging),MGI AI respawn module and one player,and the test vehicle in question,vanilla NATO APC.

 

NATO APC pre placed in editor has a move waypoint and nothing about vehicle is altered.When the vehicle is destroyed the crew respawn where the vehicle started in the scenario(a few feet off the ground as they were recorded in commander/gunner and driver positions).

 

Also im almost sure that he AI respawn/vehicle respawn module is messing up vehicle waypoints some of the time. Is there anything that the script does that could possibly affect their waypoint handling? Iv been testing this a few days now and whenever a vehicle respawns it has 20% chance to ignore assigned waypoints.

 

I tested by adding over 100 vehicles ,syncing them to the show/hide module,showing 4,letting them complete their waypoints,killing them,then unhiding/simulating the next 4,watch them complete their waypoints and so on,and i never had an issue except in one rare case. But if i run the same test with the vehicle respawn,or even the AI respawn,vehicles that respawn are often stuck(heir waypoint does register though) and the commander of the vehicle is looping commands to the gunner to target an enemy 8 km away(also the gunner doesnt target)...This could be vanilla behaviour but it doesnt seem like it to me as i believe the AI will follow way points or at least use combat repostioning when in danger mode(move the turret etc)  So all in all i dont know if that last part is vanilla arma bug,but for sure using the show hide module to "spawn" vehicles produces almost zero issues,but the vehicle respawn does alot.

 

I also had one instance where a vehicle (T -100) spawned with 4 crew members,and the 4th started moving to the waypoints while the 3 crew members were idle in the tank not moving.

 

Another instance of a tank respawning with the entire crew already dead(embarked) causing the vehicle to never meet a condition to repawn,and manually killing it didnt trigger a respawn.

 

My mod list is extremely light.Im playing with all vanilla.

 

Mods i use are

 

Eden enhanced

3rd person view

CBA

RE color

MGI

AAF in ALPAT retexture.

 

 

Share this post


Link to post
Share on other sites

Thanks for the report but difficult to do something with that.

For units killed in vehicle, then respawned on feet, I will not add a code avoiding some temporary animation. I'm using setPos. If you have a better idea...

Messing waypoints? The AIs moves depend on their behavior. So, difficult to say if waypoints are messed up. Just add a test on waypoints presence.

Something like "20% of chance to be ignored" doesn't motive me to do something. That can be an engine FSM or even a problem of scheduler in heavy context, but there is nothing to do with the script, imho. If you're trying to cope with all possible cases, you inflates the script(s) and you reach earlier the engine's limitation.

Arma definitely can't do miracle with a hundred of manned vehicles with waypoints. The first rule is to have them under a dynamic simulation. So, the contrary of what you're attempting to do.

 

Well, not perfect? probably. I can spend some times for a specific, repeatable, reproducible  issue. One by one. Not saying I'll correct or override the Arma's engine.

Initially, respawn AIs is made for SP AI waves.

I added that in MP for non-playable units, because they have their own respawn possibilities (like players).

I didn't mix stuff like respawn vehicles with all stuff (waypoints...) and respawn AIs because AIs can be on foot, in vehicle as crew or pax, dying before the vehicle or after..., disembarking before dying... So, a mess... like in real life in fact.

 

 

 

Share this post


Link to post
Share on other sites
On 12/12/2020 at 9:06 AM, pierremgi said:

Thanks for the report but difficult to do something with that.

For units killed in vehicle, then respawned on feet, I will not add a code avoiding some temporary animation. I'm using setPos. If you have a better idea...

Messing waypoints? The AIs moves depend on their behavior. So, difficult to say if waypoints are messed up. Just add a test on waypoints presence.

Something like "20% of chance to be ignored" doesn't motive me to do something. That can be an engine FSM or even a problem of scheduler in heavy context, but there is nothing to do with the script, imho. If you're trying to cope with all possible cases, you inflates the script(s) and you reach earlier the engine's limitation.

Arma definitely can't do miracle with a hundred of manned vehicles with waypoints. The first rule is to have them under a dynamic simulation. So, the contrary of what you're attempting to do.

 

Well, not perfect? probably. I can spend some times for a specific, repeatable, reproducible  issue. One by one. Not saying I'll correct or override the Arma's engine.

Initially, respawn AIs is made for SP AI waves.

I added that in MP for non-playable units, because they have their own respawn possibilities (like players).

I didn't mix stuff like respawn vehicles with all stuff (waypoints...) and respawn AIs because AIs can be on foot, in vehicle as crew or pax, dying before the vehicle or after..., disembarking before dying... So, a mess... like in real life in fact.

 

 

 

Ok man got it. Im still refreshing myself on Arma AI behaviour after a long time away. Sometimes vanilla arma especially vehicles exhibit odd behaviours,external scripts like AI mods etc can complicate it further. I was actually testing with just a few vehicles,not 100's,that was just testing.

 

 

Share this post


Link to post
Share on other sites

Pierremgi Can you explain the SP respawn on marklers? I set a marker and named it MGI_resp_bas with and without the quotes ,and set respawn postion to be on marker but everytime i respawn its on the postion i died. i used normal markers that cover an area and symbols.

Share this post


Link to post
Share on other sites

Check you named the marker MGI_respxxx  where xxx is what you want. You probably wrote into the marker text (you can write here what you want).

If multiple markers named with MGI_resp (not case sensitive) inside the names, you will respawn at random markers.

The shape of the marker doesn't matter. Only the marker position is used.

  • Thanks 1

Share this post


Link to post
Share on other sites

I cannot seem to install this any longer (on my dedi server). I had it working once, but now I can't seem to figure it out. I have tried placing the MGI_Modules.pbo in my server addons section (like DMS and Occupation), and I have also tried making it an "@MGI_Modules; folder" placed in the server root folder, but nothing.

 

It works in the editor, so I place an ADVANCED TRANSPORT module. 

 

I place a CIV helo and a CIV truck. 

 

In the Editor's preview mode, I can call the taxis and all works perfectly. I export the .SQF and call it in my dedi's initserver. When I load the server, the CIV vehicles are there, so i know the SQF is being called. However, the CALL TAXI addaction is not showing up for the player. 

 

Can anyone see what I am doing wrong?

Share this post


Link to post
Share on other sites

Don't multiply folders and instances of addon. You don't have to export anything! You're killing the process.

 

You just have to subscribe it on Steam, for server and clients. The signature is new, v2 compatible, so you just have to allow the mod for dedicated server. That means the bikey must be copied in Arma 3 Server keys folder. (of course, you don't need to do that for hosted server as you run an Arma 3 session).

So, first of all,

- remove all the added mod folders, scripts and all your own stuff about this addon, 

- un-subcribe with deletion of folders, 

- subscribe again to the mod,

- (copy the right key in the right folder of a dedicated server).

Then, run a little scenario with several modules (like advanced player and civilian life to test server and clients) then, if any problem, report (one by one) with reproducible or understandable situation for my search.

Thanks

Share this post


Link to post
Share on other sites

I have done exactly as you've said, got the addon subscribed to on my server, and the scenario loads fine. I loaded only 1 module and that was the Advanced Transport. However, what is interesting is that the moment before the game loads, there is a quick flash of "CALL TAXI" as an addaction, and then its gone. Once I have control of my player, I do not have the Call Taxi option.

 

 

Share this post


Link to post
Share on other sites

I can't reproduce that. You probably have another mod avoiding or modifying the action menu.

Share this post


Link to post
Share on other sites

Hello Pierre, sorry if this has been asked about before, but is there any chance of a Shop module? with all the new Old Man stuff, having a shop that would work in multi would be great, and I would prefer setting up one with modules in EDEN rather than through description files

Share this post


Link to post
Share on other sites
56 minutes ago, General Kong said:

Hello Pierre, sorry if this has been asked about before, but is there any chance of a Shop module? with all the new Old Man stuff, having a shop that would work in multi would be great, and I would prefer setting up one with modules in EDEN rather than through description files

Well... a lot of work... First that means a kind of account for players for purchasing some items/weapons/vehicles.

Note: I don't why the Old Man modules are so difficult to make them work.

Share this post


Link to post
Share on other sites

sorry for the late reply, yea if it is too much, then I can understand if you dont want to tackle it, thanks for the consideration though

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×