Jump to content
Αplion

HAFM NAVY - Submarines & Ships - v2

Recommended Posts

9 minutes ago, elthefrank said:

You are right, however I think it is a problem of class type CfgVehicles of the ship, because these types of boats that I show you a continuation, do not have that problem, what is used in the weapon 3 and well fine, and you To land the helicopter even with the player inside the ship, I believe that these ships are equipped with another type of CfgVehicles, if you have time to check, you will get errors when throwing them in weapon 3 but they will be problems more than all of sounds and weapons, but not working How can I solve the problem

 

http://www.armaholic.com/page.php?id=11124

 

 

mod ships class is the newest "Ship_F" and not the old "Ship". Boats class "boat_F" is also inheriting by this class ("Ship_F") as far as I remember.

 

helicopter landing on MP environment looks problematic only when you are having a ship from the beginning of the mission and try to land on it ... in case you will spawn the ship through zeus for example, you can land on it without any issue !!

 

nothing to do with weapons though ...

  • Like 1

Share this post


Link to post
Share on other sites

well then the temporary request would be to use the createvehicle command, in the current mission, it is a strange error xD

Share this post


Link to post
Share on other sites
1 minute ago, elthefrank said:

well then the temporary request would be to use the createvehicle command, in the current mission, it is a strange error xD

 

createvehicle for what ? helicopters ? create them where mate ? I'm confused on that !!

Share this post


Link to post
Share on other sites

Ship = "HAFM_Ship" createVehicle getMarkerPos "hspawn"; 

 

this would make the ship be created as soon as the mission starts, and you should not experience the current problem

  • Like 1

Share this post


Link to post
Share on other sites
3 minutes ago, Αplion said:

 

createvehicle for what ? helicopters ? create them where mate ? I'm confused on that !!

 

1 minute ago, elthefrank said:

use a scripts created by the ship already when the mission is started, without using zeus

 

ok but what vehicle you want to create ? thats confusing me ... helicopters ? 

 

or you are talking for tests using this command for ships instead zeus (probably) ?

Share this post


Link to post
Share on other sites
Just now, elthefrank said:

Ship = "HAFM_Ship" createVehicle getMarkerPos "hspawn"; 

 

aha understood now ... and what we are trying to prove by this ? probably if by this way the spawned ship has the issue with helicopters or not ?

Share this post


Link to post
Share on other sites

yes, the boats, you can add an example mission in your next update, for the people that use the boats in multiplayer

Share this post


Link to post
Share on other sites

that createvehicle thing is a workaround which should be done by the mission maker. We cannot delete the vehicle which was put via eden and then spawn it back.

So if someone wants to use the ship to land on it, please spawn the ship after mission starts.

  • Like 2

Share this post


Link to post
Share on other sites

yes, because if it is a problem of the game it is already difficult to fix it, unless Bohemian fixes it

  • Like 1

Share this post


Link to post
Share on other sites

elthefrank .. understood your point - suggestion ...

  • Like 1

Share this post


Link to post
Share on other sites

I do not know if it can be done, but I could add a script that when placing the ship in the editor, at the beginning of the mission it will be deleted and recreated in the same place

Share this post


Link to post
Share on other sites

scripts are not my expertise area ... Devastaror_cm is the guy for these :)

Share this post


Link to post
Share on other sites

creating ship is not the problem. Creating it in a way that the mission maker planned to have is, for example

- have same units inside

- have same cargo inside

- have same waypoints

- have same fuel

- have same damage

- have same combat behaviour

- have same of all what is adjustable via eden editor

So if landing is important for a specific mission, mission maker should spawn the ship by him/herself 

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, Αplion said:

 

mod ships class is the newest "Ship_F" and not the old "Ship". Boats class "boat_F" is also inheriting by this class ("Ship_F") as far as I remember.

 

helicopter landing on MP environment looks problematic only when you are having a ship from the beginning of the mission and try to land on it ... in case you will spawn the ship through zeus for example, you can land on it without any issue !!

 

nothing to do with weapons though ...

Nah, having spawned it from zeus it still didn't work. My players got in. A heli tried to land. and it went to hell or something.

Share this post


Link to post
Share on other sites
1 minute ago, Timo B. said:

Nah, having spawned it from zeus it still didn't work. My players got in. A heli tried to land. and it went to hell or something.

 

We tried that on a server today and spawning the ship using zeus caused no trouble on heli land etc ... can you repeat the mods you are using please ?

Share this post


Link to post
Share on other sites

Achilles and MCC. 

 

And again the problem only starts whenever a player gets into the boat.

Share this post


Link to post
Share on other sites

I think we said that we can't say anything about MCC yet ... we tried using CBA and Achilles ... please either test the same or just test plain HAFM and CBA ... we need to know if this is a matter of game engine or other mod conflict ... try this procedure please ... 

 

We have tried also with CUP frigate today and there was same issue ... so we need to know positively, as I said, if it is some mod conflict or just the game engine ... make your reports based on that. Using more mods isn't a good report practice ...

Share this post


Link to post
Share on other sites
2 hours ago, elthefrank said:

previously used a mod called FFAA of Arma 2, containing a frigate and a corvette, containing a script that when landing the Helicopter on the helipad of the ship, appeared an addaction that adjusted the ship to the deck, and that allowed the player enter the helmsman position of the ship and sail with the helicopter on the heliport, maybe it can be a solution

Just saw this. In fact, we are testing a driveable version of it in Arma 3 available at SW.

Unfourtunately under our point of view there is no solution to this:
 

23 hours ago, Timo B. said:

So this is the issue: 

 

 

We researched a lot and we finally assumed there isn't a fix (in MP sessions) but a workaround, which is autmatically attach the vehicle when it "touch" the Landing Deck. To detach the vehicle the ship should be in "static" mode, avoiding PhysX collision issues.

https://i.gyazo.com/43627ca115b5aff1580d5fcab305b7c1.mp4

  • Like 1

Share this post


Link to post
Share on other sites
3 minutes ago, elthefrank said:

If there is, you will see that yes :)

Unless you reach the engine limitations, which is the case. But hey, hopefully...

  • Like 1

Share this post


Link to post
Share on other sites

we had the attach script before, problem is if you attach the object the engine is not reacting to turn on/off actions...

Share this post


Link to post
Share on other sites

Getting this error thrown a few times

23:54:09 Error in expression < {};

if(_CIWS_Setup select _ArrayPos select 3) exitWith 
{
if(isAgent teamMem>
23:54:09   Error position: <select 3) exitWith 
{
if(isAgent teamMem>
23:54:09   Error Generic error in expression
23:54:09 File \HAFM_Navy_Core\scripts\CIWS_Toggle.sqf [HAFM_fnc_CIWS_Toggle], line 82

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×