Jump to content
Flax

Flax's Arma Server Tool (F.A.S.T.)

Recommended Posts

2 hours ago, eric963 said:

From version 1.1  "Fixed copying of keys from key folder (eg RHS used key not keys)."

Just to clarify for me, I'm getting an error box:

CopyKeysFromModsStipMenuItem_Click _ An exception occurred:

Could not find directory

'G:|Games\SteamCMD|steamapps\workshop\content\107410\773759919\keys'.

and then I can click OK to contine. 

Is this what is supposed to happen or should the key be copied from the \key directory?

Thanks Again

Eric

 

Hey @eric963 - it seems I haven't accounted for the capitalisation  of the folder. I'll add the list of stuff to be fixed for 1.1.3.

Share this post


Link to post
Share on other sites

I was looking for an alternative for TADST, and this looks like it could be the one when you add the new features.  Good job.

Share this post


Link to post
Share on other sites

Thanks, I've been away and busy with work. The Git should see some updates over the next week.

 

  • Like 1

Share this post


Link to post
Share on other sites
Hello have the problem
 
Starting SteamCMD to update Server
Steam Console Client (c) Valve Corporation
-- type 'quit' to exit --
Loading Steam API...OK.
Logging in user 'hh' to Steam Public...Logged in OK
Waiting for user info...FAILED.  Timed out.
OK
Task Completed

Share this post


Link to post
Share on other sites
1 hour ago, thomashirt said:
Hello have the problem
 
Starting SteamCMD to update Server
Steam Console Client (c) Valve Corporation
-- type 'quit' to exit --
Loading Steam API...OK.
Logging in user 'hh' to Steam Public...Logged in OK
Waiting for user info...FAILED.  Timed out.
OK
Task Completed

 

 

Hi that suggests there is an issue with the steam login - try logging into to SteamCMD from the SteamCMD console see if you get the same error.

Share this post


Link to post
Share on other sites
2 hours ago, thomashirt said:

hi have the same error

 

Is already the normal steam ACC or you have to register in a special place?


Yes you need to login with a normal steam account - and one that has a copy of Arma 3 on it otherwise you won't be able to download the server.

Share this post


Link to post
Share on other sites

NEW RELEASE - V1.3-beta

 

99de0e40eb13b692b559f7dc4989898c.gif

 

Testing release for new feature set:

  • Add server and save settings.
  • Launch server and up to 3 headless clients.
  • Minor fixes for other features.

 

Downloads

GitHub Release

 

Update Instructions

  1. Download and unzip.
  2. Overwrite existing files.
  • Like 2

Share this post


Link to post
Share on other sites

Will update tonight and check out the new features. Thx!!!


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

V1.3 Beta

 

Just got it updated on my server and am getting ready to give it a test but before I forget there is on thing you might want to check.  Some of the difficulty settings now have 3 options available.

 

 

 

//All options of the Custom preset are set by the engine. The values in config
class Options
{
// Simulation
reducedDamage = 0;    // Reduced damage (0 = disabled, 1 = enabled)
 
// Situational awareness
groupIndicators = 0;      // Group indicators (0 = never, 1 = limited distance, 2 = always)
friendlyTags = 0;         // Friendly name tags (0 = never, 1 = limited distance, 2 = always)
enemyTags = 0;            // Enemy name tags (0 = never, 1 = limited distance, 2 = always)
detectedMines = 0;        // Detected mines (0 = never, 1 = limited distance, 2 = always)
commands = 0;             // Commands (0 = never, 1 = fade out, 2 = always)
waypoints = 0;            // Waypoints (0 = never, 1 = fade out, 2 = always)
                        tacticalPing = 0;       //Tactical Ping (0 = disabled, 1 = enabled)
 
// Personal awareness
weaponInfo = 1;           // Weapon info (0 = never, 1 = fade out, 2 = always)
stanceIndicator = 0;      // Stance indicator (0 = never, 1 = fade out, 2 = always)
staminaBar = 0;       // Stamina bar (0 = disabled, 1 = enabled)
weaponCrosshair = 0;  // Weapon crosshair (0 = disabled, 1 = enabled)
visionAid = 0;        // Vision aid (0 = disabled, 1 = enabled)
 
// View
thirdPersonView = 0;  // 3rd person view (0 = disabled, 1 = enabled)
cameraShake = 0;      // Camera shake (0 = disabled, 1 = enabled)
 
// Multiplayer
scoreTable = 0;       // Score table (0 = disabled, 1 = enabled)
deathMessages = 0;    // Killed by (0 = disabled, 1 = enabled)
vonID = 0;            // VON ID (0 = disabled, 1 = enabled)
 
// Misc
mapContent = 0;       // Extended map content (0 = disabled, 1 = enabled)
autoReport = 0;       // Automatic reporting (0 = disabled, 1 = enabled)
multipleSaves = 0;    // Multiple saves (0 = disabled, 1 = enabled)
 

 

Share this post


Link to post
Share on other sites

I starting to think this will be my replacement for TADST.  I posted a couple issues on your GitHub but just wanted to let you know that this is really looking good.

  • Like 1

Share this post


Link to post
Share on other sites

My community has been using your app for some time, Congratulations! But we were updating on our test server and there were some unforeseen events:
 

* it did not recognize the MODS installed on the server. The dynamic links were there, appearing on the MODS tab but when checked and selected to start the server, it started without them.
 

* We reinstalled the server from scratch, from its program (we used the steam tools menu for this), he created a folder for the installation of the ArmA server with another spelling "arma" where the weapon server was installed.

 

* the dynamic links were redone one by one because the program did not create them again by the full check button. The update button indicated that all mods were up to date (note: mods are in the steamcmd folder)

 

We will perform more tests tomorrow to try to find possible errors that occurred in the installation.

We have an idea for your program: you could put a monitor like the internal Fred41 ASM.

 

Congratulations for the initiative.

[CCT] Daniel

 

PS: using google tratutor.

  • Like 2

Share this post


Link to post
Share on other sites

Hot Fix - V1.3-beta

 

You can download from GitHub or here. Thanks for the feedback - mods not launching was my issue I was using the wrong startup option... Fixed in beta release now.

@eric963 - yea I plan to add the extra options but only noticed them after I'd finished the UI for this build. Will be sure to add them soon.

@Arghbra - sorry for causing you to reinstall the whole server! That issue is fixed as said above. I really like the idea of a server monitor built in. I'll see what I can do.

  • Like 1

Share this post


Link to post
Share on other sites
 
Do not worry, Flax is a server for mission testing, addons and management / monitoring programs.

Now the MODs were recognized by the installation made by the previous version of the program (V1.3) and by the list of MOD's adopted in the older version (V1.2).
But in the list of servers, our server started the mission indicating that there were no mandatory MOD's (checking in the RPT of the mission the MOD's were loaded).
I started the mission with the MODs and log in it. It worked correctly!

Was it some internal error that he did not recognize MODs?

I would like to take advantage of it and give you another idea: our missions usually use HC's and be persistent.
I noticed that in the program we have the condition to start a HC automatically, but we know that in missions that have ALIVE the HC must be started after the admin is logged in,
so that with the passing of the saves the mission does not miss OPCOMS.

Would it be possible, in a next version, a button to start the HC without separate?

Thanks for the prompt response.

[CCT] Daniel

Share this post


Link to post
Share on other sites

@Arghbra I can split out the Server and HC launching into separate buttons but what you are saying is incorrect. Headless client's can join a server or mission at any point regardless of if the mission is ALiVE or not.

Share this post


Link to post
Share on other sites

Flax all our tests using persistence showed in the RPT, the number of opcoms decreased if the admin did not start the mission logged in before any player / HC, and in our tests, the HC only receives damages from the alive if the module of ACEX for HC's set in the mission. We played persistent missions using the Alive Warroom for about 2 years.

But do you have any idea what the server can not indicate the MOD's? I think I'm going to reinstall the server in another folder using steam and retest.

 

Thanks again for the quick response.

[CCT] Daniel

Share this post


Link to post
Share on other sites

Good evening Flax, on behalf of our CCT community "Combate Tatico Brasil", thank you in advance for dedication and great tool for servers Arma 3.

 

Regarding the HC that Arghbra mentioned, from what I understood, the increment of a Delay option to launch the HC would solve the problem. As stated, if the HC is started after some time of the mission started the problem with the ALiVE OPCOM would be solved.

  • Like 1

Share this post


Link to post
Share on other sites

Question about -mod= and -servermod=

 

When using F.A.S.T. it generated this line

 

"G:\Games\a3server\arma3server_x64.exe" -port=2302 "-config=G:\Games\Flax Server Tool\servers\New_Server\New_Server_config.cfg" "-cfg=G:\Games\Flax Server Tool\servers\New_Server\New_Server_basic.cfg" "-profiles=G:\Games\Flax Server Tool\servers\New_Server\" -name=New_Server "-serverMod=@ALiVE;@CBA_A3;"

 

Its using -serverMod=@Alive;@CBA_A3 which are mods that the clients must have and which makes them show up when the client views the server in the server browser.  Should it be using -mod= instead?  And then use in in the Extra Parameters box the -serverMod= for only mods that need to be ran on just the sever like

 

"-serverMod=@Advanced_Rappelling;@Advanced_Urban_Rappelling"

 

I'm still kinds new to the dedicated server stuff but I have been using TADST for the last year and it used -mod= to load them so I thought I would just ask here.

 

Thanks

Eric

Share this post


Link to post
Share on other sites

I'm doing some testing regarding the ALiVE issue but the next version will have an option to launch HC's separately so that should solve it in your particular instance. 

As for the mods not showing up to the user, yea that is because the tool is using the -serverMods line. I'll see if I can get way to separate out server only mods and client required mods.

 

  • Like 3

Share this post


Link to post
Share on other sites
I'm doing some testing regarding the ALiVE issue but the next version will have an option to launch HC's separately so that should solve it in your particular instance. 

As for the mods not showing up to the user, yea that is because the tool is using the -serverMods line. I'll see if I can get way to separate out server only mods and client required mods.

 


You could just -mod and those that need -servermods could just enter that in the extra Params box. There are not that many server side only mods.

Pretty sure it’s done that way in TADST.


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
5 hours ago, eric963 said:

 


You could just -mod and those that need -servermods could just enter that in the extra Params box. There are not that many server side only mods.

Pretty sure it’s done that way in TADST.


Sent from my iPhone using Tapatalk

 

Yea i'm looking at adding an extra list for server mods. Expect a stable version of 1.3 by the end of the week, found a few more bugs that need squashing first.

Share this post


Link to post
Share on other sites

Good news. Looking forward to your next release.


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×