Jump to content
Flax

Flax's Arma Server Tool (F.A.S.T.)

Recommended Posts

Open button in the RPT pane doesn't do anything. I have baretail associated to *.rpt

Share this post


Link to post
Share on other sites
16 hours ago, Tankbuster said:

Open button in the RPT pane doesn't do anything. I have baretail associated to *.rpt


Yea sorry, should have put that in the release post - didn't make it into the beta release. Working in my current build. 

  • Like 1

Share this post


Link to post
Share on other sites

Hello Im running latest version and when I try to Add Mod from URL, this mod: https://steamcommunity.com/sharedfiles/filedetails/?&id=421620913 I get this error:

 

See the end of this message for details on invoking 
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.ArgumentOutOfRangeException: StartIndex cannot be less than zero.
Parameter name: startIndex
   at System.String.Substring(Int32 startIndex, Int32 length)
   at System.String.Substring(Int32 startIndex)
   at FAST.ImportMod.ImportModToList(String modUrl)
   at FAST.ImportMod.ImportButton_Click(Object sender, EventArgs e)
   at System.Windows.Forms.Control.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ButtonBase.WndProc(Message& m)
   at System.Windows.Forms.Button.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1590.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll
----------------------------------------
Flax's Arma Server Tool
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///D:/workshopDownload/Flax's%20Arma%20Server%20Tool%20V1.3-beta/Flax's%20Arma%20Server%20Tool.exe
----------------------------------------
Microsoft.VisualBasic
    Assembly Version: 10.0.0.0
    Win32 Version: 14.6.1590.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/Microsoft.VisualBasic/v4.0_10.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll
----------------------------------------
System
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1590.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Core
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1590.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
----------------------------------------
System.Windows.Forms
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1590.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System.Drawing
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1590.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System.Configuration
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1590.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
System.Xml
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1590.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
System.Runtime.Remoting
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1590.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Runtime.Remoting/v4.0_4.0.0.0__b77a5c561934e089/System.Runtime.Remoting.dll
----------------------------------------
System.Xml.Linq
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1590.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml.Linq/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.Linq.dll
----------------------------------------
CustomMarshalers
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1590.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_32/CustomMarshalers/v4.0_4.0.0.0__b03f5f7f11d50a3a/CustomMarshalers.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
    <system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

 

Share this post


Link to post
Share on other sites

Thanks Flax for an awesome piece of software. I am currently stuck on how to get the multiplayer mission files into the mpmissions folder. The mod only shows the .bin file where it should show the .pbo file. When looking at the missions tab I see https://imgur.com/a/RiZCE .Do the missions I downloaded just not have .pbo files? I've played these missions on other servers, so I know the mods themselves work. Not sure what I am doing wrong. 

 

You saved me a ton of time already. Thanks again. 

 

-Berni

Share this post


Link to post
Share on other sites

It doesn't seem to be working correctly for me. After all the steamcmd messages and it reaches the point where it should be downloading workshop mods, it does nothing. 

 

It seems to be connecting since the folders and their correct workshop ID appear in the workshop/content/107410 location, but they remain empty. After sometime the process quits with the error: "steam download timed out, please try again"

 

I just wanted to know if this was a steam error, workshop error, or program error. Thanks for the program by the way, even if it doesn't seem to be working for me, lol, I can tell it's a great tool.

Share this post


Link to post
Share on other sites

@Percy Thrillington The "Steam download timed out" message is an error from Steam - it usually means it's taking too long to download the mod. Are you trying to download large mods? If so try it will a smaller number or smaller mods. CBA or TFAR to test and see what happens there. The messages that appear in the box on the first tab of the tool is just a printout from SteamCMD if it's a program error it'll come up in a popup box. 

@Berni Kleiner This tool hasn't been tested MPMissions on the steam workshop as they are handled differently. This just works with .pbo mission files added manually to the MPMissions folder.

Share this post


Link to post
Share on other sites
On 1/17/2018 at 3:48 AM, Flax said:

@Percy Thrillington The "Steam download timed out" message is an error from Steam - it usually means it's taking too long to download the mod. Are you trying to download large mods? If so try it will a smaller number or smaller mods. CBA or TFAR to test and see what happens there. The messages that appear in the box on the first tab of the tool is just a printout from SteamCMD if it's a program error it'll come up in a popup box. 

@Berni Kleiner This tool hasn't been tested MPMissions on the steam workshop as they are handled differently. This just works with .pbo mission files added manually to the MPMissions folder.

 

Love the app, it is a fantastic way of managing your server.

 

But I'm getting the same time out error. It is with large mods like CUP Terrains and RHS. in fact it seems like any mod over 1 gig will give me that time out. Then I have to delete the mod and re add it. As FAST thinks it is up to date.

 

It all works fine with small mods like ACE, CBA and ACRE but for larger mods like RHS, CUP, Project Opfor etc. it just times out each and everytime.

 

The frustrating thing is I can see it via a ethernet meeter that it is downloading the mods but because something like CUP Terrains CORE is 6.6gig it times out even though it is downloading.

Share this post


Link to post
Share on other sites

@Percy Thrillington and @rekkless

 

Same problem on our server, but you can restart the download by the program as many times as necessary until it does not give the timeout error.

Our server uses a lot of big MODs like CUP and Unsung. Since the time we used STEAMCMD this was already happening.

Share this post


Link to post
Share on other sites

Hey guys, thanks for the feedback. I know there hasn't been any updates but I am working on it slowly again. 

 

As for the time out issue @Arghbra is correct - this is a Steam issue that I cannot yet get around. If downloads time out just manually update the mods individually. I'll try and find a way around it. 

  • Like 1

Share this post


Link to post
Share on other sites

Yeah it is an oddity.

We have two servers one with 1000mbs connection and one with about 40mbs (our headless client)

 

FAST works perfectly fine on the gigbit connection as it can download even CUP (11gigs) before it times out. But on the HC it just can't keep up and downloading mods is tiresome and hard work. I sure hope it is something you can fix FLAX and it isn't a limitation in SteamCMD. But other than that it is a FANTASTIC program. and all in one solution for servers without a steam account.

Share this post


Link to post
Share on other sites

Can anyone help me with figuring out how to add Steam Workshop mods to the Mods section? The tool recognizes mods in the Arma root automatically, but I can’t for the life of me figure out how to add mods mods from the Workshop! folder. 

Share this post


Link to post
Share on other sites
1 hour ago, HeroesandvillainsOS said:

Can anyone help me with figuring out how to add Steam Workshop mods to the Mods section? The tool recognizes mods in the Arma root automatically, but I can’t for the life of me figure out how to add mods mods from the Workshop! folder. 

 

Just add them as if you were adding a new mod from the workshop. Grab the ID of the folder or the steam workshop link and add it into the list of mods to be updated. Next release should have auto discover for the Steam Workshop folder. 

Share this post


Link to post
Share on other sites
7 hours ago, Flax said:

 

Just add them as if you were adding a new mod from the workshop. Grab the ID of the folder or the steam workshop link and add it into the list of mods to be updated. Next release should have auto discover for the Steam Workshop folder. 

Can you give me an example for how to do that? I see two options, one to add mods from the launcher, which takes me to my Arma profile folder in my Documents (I have no idea what to click in this path), and the other which is to add a mod URL. So like, does that mean the website link? I have my workshop mods in !Workshop in my Arma root. Let’s pretend I subscribed to CBA, what do I click on or type?

 

Excellent tool, by the way. For now I just copy pasted my mods to my root and played a few hours with the server and it’s incredible! Did some Liberation and everything is working perfectly and buttery smooth now (local host wasn’t cutting it).

Share this post


Link to post
Share on other sites

@HeroesandvillainsOS you need the URL from CBA in workshop ( https://steamcommunity.com/sharedfiles/filedetails/?id=450814997 )

 

And them put in Add Mod from URL. The SteamCMD need Works OK in the Flax´s program. (the workshop  stay in these folder)

The Flax program  download de mod to the SteamCMD Workshop folder AND create a virtual link to these folder in the arma3 server folder instalation.

 

But, if you need only to create a "virtual" link in a folder to another folder,  you need to use these comand: (example)


mklink /D "C:\arma3\Arma 3 Server\@cba_a3" C:\arma3\SteamCmd\steamapps\workshop\content\107410\450814997\

 

These comand create a folder link in the arma 3 server to another folder containing your workshop library.

Create a .bat and run in CMD

 

Our community used these command to create these links and start server 

 

Follow the explanation in Portuguese.

 

Thanks to [CCT] GhostSniper

 

::
:: Na entrada de mais um mod que foi baixado pela Steam, é necessário adicionar
:: mais uma linha ao final do arquivo. essa linha deve seguir a sintaxe
::
:: SINTAXE
::
::  mklink /D <LINK> <PASTA DE ORIGEM>
::
:: EXEMPLO:
::
:: mklink /D "C:\arma3\Arma 3 Server\@kunduz_afghanistan" C:\arma3\SteamCmd\steamapps\workshop\content\107410\421620913\
::
::      - mklink /D -> Cria o link
::
::      - "C:\arma3\Arma 3 Server\@kunduz_afghanistan" - Caminho completo onde o link será criado. No exemplo o nome
::                                                       do link sera @kunduz_afghanistan
::
::      - C:\arma3\SteamCmd\steamapps\workshop\content\107410\421620913\ - Caminho completo da pasta onde encontra-se os
::                                                                         arquivos que serão exibidos pelo link simbólico.
::
::
:: Essa é a técnica usada pelo lançador do Arma 3 quando um mod que vocês se inscreveu na Steam Workshop é baixado
:: nestes casos os mods ficam armazenados na pasta !Workshop oculta na pasta rais do Arma 3
::


mklink /D "C:\arma3\Arma 3 Server\@cba_a3" C:\arma3\SteamCmd\steamapps\workshop\content\107410\450814997\

mklink /D "C:\arma3\Arma 3 Server\@acex" C:\arma3\SteamCmd\steamapps\workshop\content\107410\708250744\

mklink /D "C:\arma3\Arma 3 Server\@ace" C:\arma3\SteamCmd\steamapps\workshop\content\107410\463939057\

mklink /D "C:\arma3\Arma 3 Server\@smoke" C:\arma3\SteamCmd\steamapps\workshop\content\107410\770418577\

 

I hope you have helped, sorry for bad english.

Share this post


Link to post
Share on other sites
On 12/07/2017 at 11:48 AM, Flax said:

NEW RELEASE - V1.1

 

Some minor updates to the tool, fixes various issues and cleans up some code. Changelog:

  • Added Help and About Links.
  • Fixed ability to add duplicate mods.
  • Fixed copying of keys from key folder (eg RHS used key not keys).
  • Fixed "Update All Mods" not working with mods that hadn't been downloaded yet.
  • Changed the way multiple workshop mods are downloaded to remove steam login timeout.

Downloads

GitHub Release

 

Update Instructions

  1. Download and unzip.
  2. Overwrite existing files.

 

Fantastic work @Flax. My bold above, does this address the issue where mod downloads over 1GB always timeout via SteamCMD? I like most I assume use a bat file like the below:

 

Mod update bat file

Spoiler

"steamcmd.exe" +login ***** ***** +set_steam_guard_code ####  +force_install_dir E:\Apps\Steam +"workshop_download_item 107410 450814997" validate  +force_install_dir E:\Apps\Steam +"workshop_download_item 107410 497660133" validate

 

I've noticed when the download times out, it actually removes it from the directory (Steam\steamapps\workshop\downloads) and then starts again rather than resuming from where it should've left off. That's why I've added two identical strings above with 'validate' for each mod. As this is the only way it'll keep the download and let you resume later. Does your app do this also?

Share this post


Link to post
Share on other sites
5 hours ago, mach2infinity said:

 

Fantastic work @Flax. My bold above, does this address the issue where mod downloads over 1GB always timeout via SteamCMD? I like most I assume use a bat file like the below:

 

Hmm, it doesn't address that issue directly as Steam are the only ones who can change the timeout for downloads. It should be using validate. If not I'll make sure I'll get it in the release of V1.3 this weekend so long as I don't hit any bigger issues.

  • Like 2

Share this post


Link to post
Share on other sites

@Flax thanks for responding. Yeah I didn't mean to fix it as that's Valve's job, but rather as a workaround until they fix it. Much appreciated you taking the time to look at it. I look forward to trying out the tool.

 

As a sidenote, the issue with downloads over 1GB timing out is due to the TTL (Time-To-Live) packets expiring once it hits around 1GB: Link

Share this post


Link to post
Share on other sites

Just found this tool, and seems great. However, can't use it yet, since I can't find a way to use it with the dedicated server package (233780 -beta).

Can you make it possible to choose that branch too?

Share this post


Link to post
Share on other sites
16 minutes ago, starcos said:

Just found this tool, and seems great. However, can't use it yet, since I can't find a way to use it with the dedicated server package (233780 -beta).

Can you make it possible to choose that branch too?

 

This does use the dedi server package. That package does not have a -beta branch tag to use. 

Share this post


Link to post
Share on other sites

Ok, surely I miss something :)

As I saw, you can select only the stable, and the development branch. If I chose Stable it tries to update with 107410 steam ID. I presumed the other uses the dev branch (which is the same id).

 

The dedicated server package (the one that's free, so you don't need to buy another arma3 for you server) according to the  bistudio wiki uses the 233780 -beta branch. (And thats the way I use used it for years so must be right ;) ).

Share this post


Link to post
Share on other sites

Sorry about the delay on the 1.3 release guys. Been busy with work and other stuff, will do my best to get it out for Easter. 

  • Thanks 2

Share this post


Link to post
Share on other sites

@Flax

 

When I try to download Prei Kmaoch Luong from your program the folder name contains weird symbols. Like this: @Prei_Khmaoch_Luong__ព្រៃážáŸ’មោចលង

But When I download from Steam Workshop the folder name contains correct thai formatting.

Is there a way to solve this? Or is my PC missing thai fonts?

Cheers.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×