Jump to content
ARCHaim

After the latest update (1.64) i can't enable my controller in settings

Recommended Posts

My friend has the same experience with his joystick after this Arma update.

It just couldn't be enabled in "Settings" -> "Controls" -> "Controller".

We both have Win 10 x64 system.

I've tried to disable every mod - it doesn't help.

  • Like 1

Share this post


Link to post
Share on other sites

Same here, and my friend has it also.

Tried with refresh, pulling the joystick out en restart, new drivers, but no result. Can't enable joystick  (madcatz fly5)

had before no issue at all. 

 

hope for a fix soon

Share this post


Link to post
Share on other sites

Hey fellas,

 

I opened a support ticket with BI. I recieved this reply.

 

"Hello,

please go to your Documents, right click Arma 3 folder, select "Properties" and
make sure that it is not set as "read-only". Do the same with the files inside
the Arma 3 folder. This should fix the issue. Thank you.


Best regards,

Dominik Flandera
Bohemia Interactive"

 

I tried this but the "read-only" box keeps rechecking itself for some reason. Try it and see if it works for you or not. I sent him another email. I'll let y"all know what he says.

 

Brent

  • Like 1

Share this post


Link to post
Share on other sites

Hey DocRob,

 

thanks for opening a ticket.

 

Have the same issue with the read only box,  keeps rechecking itself

 

Gr Crash

Share this post


Link to post
Share on other sites

I'm having the same issue preventing me from really configuring my joystick or xbox controller. It has been extremely frustrating trying to get it to work.

Share this post


Link to post
Share on other sites

Yes, my folder does the same with the read only box, is this behaviour tied to the documents folder? I guess not, other Games configs are there too and work ok.

 

Strange enough, i can enable/Disable TrackIR Device ingame (it does get greyed out and white when enabled) but not the other three devices (Unable to disable)

 

My Thread: https://forums.bistudio.com/topic/194567-arma3-wont-let-me-disable-other-input-devices/

Share this post


Link to post
Share on other sites

Anyone with this issue had any luck? I cant get my xbox controller or x52 working right, and I'm pretty much useless at flying without at least one of them.

Share this post


Link to post
Share on other sites

Folders will always remain Read-only, so no need to remain bewildered as to why it always goes back to being re-checked Read-only. This is why it says right next to the Read-only checkbox, (Only applies to files in folder). What matters is that when you do uncheck read only, that the files within the folder are no longer marked Read-only.

That being said... the suggested Bohemia fix above is wrong. It is not a problem due to a read only file.

Share this post


Link to post
Share on other sites

Folders will always remain Read-only, so no need to remain bewildered as to why it always goes back to being re-checked Read-only. This is why it says right next to the Read-only checkbox, (Only applies to files in folder). What matters is that when you do uncheck read only, that the files within the folder are no longer marked Read-only.

That being said... the suggested Bohemia fix above is wrong. It is not a problem due to a read only file.

 

Folders will always remain Read-only, so no need to remain bewildered as to why it always goes back to being re-checked Read-only. This is why it says right next to the Read-only checkbox, (Only applies to files in folder). What matters is that when you do uncheck read only, that the files within the folder are no longer marked Read-only.

That being said... the suggested Bohemia fix above is wrong. It is not a problem due to a read only file.

 

 

I agree. I don't think the read only is the issue. Other keybindings save fine, as well as settings. This is completely centered around controllers. I've even tried making sure arma runs as Admin.

Share this post


Link to post
Share on other sites

This! I'm on Win 7 x64 and I have a problem with Arma 3 reading controller positions whenever you go to bind a key, so in my case it sees the Saitek pedals and decides to add a Y position to every keypress I make in controls bindings. I go to disable the Saitek as a work around, but no, they will not disable! It worked for me in 1.62. All I can do is unplug it. And probably unplug the xbox controller, and the Thrustmaster flight controls, etc because they all get read when binding keys. It did NOT work that way in the past, at least with Arma 2 it would only read a controller if you moved the controls during the bind process. They need to bring that back, and of course fix the problem with disabling controllers.

 

BTW it is normal for Windows to mark a folder as read-only, doesn't mean anything. Poorly implemented. I also checked every config file separately, none are read-only, the feature simply broke in 1.64.

  • Like 1

Share this post


Link to post
Share on other sites

Apparently enable & disable features for joysticks & pedals & controllers no longer works since last patch. Making new profiles, deleting docs folder & even clean install's will not fix it. The questions is when will Bohemia realize this & more importantly, fix it???

  • Like 1

Share this post


Link to post
Share on other sites

This! I'm on Win 7 x64 and I have a problem with Arma 3 reading controller positions whenever you go to bind a key, so in my case it sees the Saitek pedals and decides to add a Y position to every keypress I make in controls bindings. I go to disable the Saitek as a work around, but no, they will not disable! It worked for me in 1.62. All I can do is unplug it. And probably unplug the xbox controller, and the Thrustmaster flight controls, etc because they all get read when binding keys. It did NOT work that way in the past, at least with Arma 2 it would only read a controller if you moved the controls during the bind process. They need to bring that back, and of course fix the problem with disabling controllers.

 

BTW it is normal for Windows to mark a folder as read-only, doesn't mean anything. Poorly implemented. I also checked every config file separately, none are read-only, the feature simply broke in 1.64.

This is exactly what i wanted to describe (in my poor english) in my linked Thread above.

 

Additional Info:

I imported my key config file from a older computer, and i bought APEX and switched to new APEX control Presets, maybe thats why my (and AZCoders?) Devices are already enabled, cause they were "On" at older PC.

And i had to rebind some HOTAS Axis for Flight Control, and there was no Y-Axis from Rudder added, this only happens when i rebind keyboard :weird:

 

I looked in the Text of the config file in /mydocuments/Arma3 but did not see something special like "Device XXXXX Enable=1" or something.

Share this post


Link to post
Share on other sites

I fixed the problem by editing my username.Arma3Profile file (username is your username)within the Arma 3 folder in my Documents Folder. I simply searched for my joystick which is a Thrustmaster Cougar & edited the mode field from disabled to custom. Hope this helps others out, waiting for help from Bohemia is like waiting for the next coming.

 

};
class Joystick3
{
guid="80B12F80-3247-11E4-8001-444553540000";
name="hotas cougar joystick";
offset=768;
isXInput=0;
sensitivity[]={0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0};
deadZone[]={0.07,0.07,0,0.07,0.07,0.07,0,0};
steepness[]={1,1,1,1,1,1,1,1};
mode="Custom";
analogClickHigh=0.40000001;
analogClickLow=0.2;

Share this post


Link to post
Share on other sites

 

I fixed the problem by editing my username.Arma3Profile file (username is your username)within the Arma 3 folder in my Documents Folder. I simply searched for my joystick which is a Thrustmaster Cougar & edited the mode field from disabled to custom. Hope this helps others out, waiting for help from Bohemia is like waiting for the next coming.

 

};
class Joystick3
{
guid="80B12F80-3247-11E4-8001-444553540000";
name="hotas cougar joystick";
offset=768;
isXInput=0;
sensitivity[]={0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0};
deadZone[]={0.07,0.07,0,0.07,0.07,0.07,0,0};
steepness[]={1,1,1,1,1,1,1,1};
mode="Custom";
analogClickHigh=0.40000001;
analogClickLow=0.2;

 

 

This helps a ton to at least get it enabled! Still frustrating that I cannot turn my controllers on/off when I want but at least my HOTAS isnt sitting there useless.

Share this post


Link to post
Share on other sites

I also recently started having issues with my xbox one controller and arma 3 I'm not sure if it's the arma 1.64 update or that I just recently updated to the Windows 10 anniversary updated. I use my controller for vehicles and when ever I get in a vehicle it drives forward on its own, and the look function no longer works correctly if any one could help it would be appreciated.

Share this post


Link to post
Share on other sites

had problems too after update 1.64 with my Xbox one controller, it was disabled and I had to reassign all buttons again

 

following this tutorial:

https://www.youtube.com/watch?v=lkDYneBwmVU on how to enable the controller

I was successful to reassign all buttons to my needs.

Share this post


Link to post
Share on other sites

This! I'm on Win 7 x64 and I have a problem with Arma 3 reading controller positions whenever you go to bind a key, so in my case it sees the Saitek pedals and decides to add a Y position to every keypress I make in controls bindings. I go to disable the Saitek as a work around, but no, they will not disable! It worked for me in 1.62. All I can do is unplug it. And probably unplug the xbox controller, and the Thrustmaster flight controls, etc because they all get read when binding keys. It did NOT work that way in the past, at least with Arma 2 it would only read a controller if you moved the controls during the bind process. They need to bring that back, and of course fix the problem with disabling controllers.

 

Yeah this has plagued Arma 3 at least for two years or so.

Share this post


Link to post
Share on other sites

I tried this solution also, it didn't work, it had absolutely no effect. My controllers remain f***ed up and unusable after 1.64, thanks a f*** of a lot Bohemia (sorry Barthanol)

 

I fixed the problem by editing my username.Arma3Profile file (username is your username)within the Arma 3 folder in my Documents Folder. I simply searched for my joystick which is a Thrustmaster Cougar & edited the mode field from disabled to custom. Hope this helps others out, waiting for help from Bohemia is like waiting for the next coming.

 

};
class Joystick3
{
guid="80B12F80-3247-11E4-8001-444553540000";
name="hotas cougar joystick";
offset=768;
isXInput=0;
sensitivity[]={0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0};
deadZone[]={0.07,0.07,0,0.07,0.07,0.07,0,0};
steepness[]={1,1,1,1,1,1,1,1};
mode="Custom";
analogClickHigh=0.40000001;
analogClickLow=0.2;

 

Share this post


Link to post
Share on other sites

I tried this solution also, it didn't work, it had absolutely no effect. My controllers remain f***ed up and unusable after 1.64, thanks a f*** of a lot Bohemia (sorry Barthanol)

No need to be sorry, You probably didn't do my fix properly or you have an unrelated problem. Seeing how you did not post in this thread until now & describe your specific problem, I am unable to help you any further. However the guy who posted after you reveals that the new dev. branch patch does fix the ability to enable & disable joystick/controller problems. So try that or elaborate on your specific problem & if it's similar you can send me your profile file & i'll try and fix it for you. Good luck!

Share this post


Link to post
Share on other sites

No need to be sorry, You probably didn't do my fix properly or you have an unrelated problem. Seeing how you did not post in this thread until now & describe your specific problem, I am unable to help you any further. However the guy who posted after you reveals that the new dev. branch patch does fix the ability to enable & disable joystick/controller problems. So try that or elaborate on your specific problem & if it's similar you can send me your profile file & i'll try and fix it for you. Good luck!

I tried one of the dev branch things and it's working now. Your fix was not difficult to understand, it seemed to involve the changing of only a single line; indeed I found my device to be 'disabled', and I changed it to 'Custom' after the manner of all the other devices listed. There were no signs of any other disabled devices. But it didn't work. Have you tried the dev branch yourself?

Share this post


Link to post
Share on other sites

 No I haven't tried the dev. branch myself. I figure it may cause version compatibility issues with joining servers which are not running it however I do not know if that is a fact, let me know if that is the case. I was able to fix my problem as described above so I didn't need to delve into that solution but I am happy to hear that Bohemia knew of the issue & addressed it. Kind of wish they chose a hotfix option to push that fix through though as most people rarely browse the forums for solutions & aren't even aware of the dev. branch option as a fix for certain issues.

 

 Not sure why my fix didn't work for you, you clearly have an understanding of what I was doing in my fix. One thing I could attribute this to is perhaps your changes were not saved. Did you open up the file again after your edit & see if the changes remained in effect? Did you make sure the Arma launcher wasn't opened when you made your edit? I doubt it was a read only issue because you wouldn't have been able to save your changes in the first place.

 

  Another possible fix is to change the edit from disabled to enabled instead of custom & or simply remove that controller section completely & let Arma rebuild it & detect your device on it's next startup. However I guess these further alternative fixes are kind of moot since the dev. branch fixed your issues anyhow. Glad you you got it working though & perhaps we'll enjoy some gaming in Arma in the future some time. Best wishes!

Share this post


Link to post
Share on other sites

Yeah, I have the same problem. Can't enable or disable any of the controllers (I have 4 in use). The ones that were enabled before I can't disable, the ones that were disabled I cannot enable any more.

Share this post


Link to post
Share on other sites

Yeah, I have the same problem. Can't enable or disable any of the controllers (I have 4 in use). The ones that were enabled before I can't disable, the ones that were disabled I cannot enable any more.

As previous posts mentioned-this was addressed in the latest Dev branch update.If you switch to Dev branch you should not have a problem.

 

i use a controller all the time as well, but I use xpadder instead of relying on the default setup.It's worth trying if you use a controller a lot.

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×