Jump to content
Solano

Real Light V6 - ReShade Preset [WIP]

Recommended Posts

I know that you said that stuff like Ambient Light drops the fps. But it is just so beautiful. I know that some of us have really good rigs and would be willing to take the performance loss for a really beautiful ARMA. Maybe you could release a "Performance Heavy" version now for us that don't mind the performance hit, while also working on a "Light" version for everybody else. I just wanna see those beautiful graphics no matter the performance cost haha.

I think offering a Lite and a Heavy Version is a good idea.

I already annotated the important areas of the config files for those who like to adjust contrast, saturation and what not.

It turns out that the Debanding effect also isn´t that light in performance so these two effects - Ambient Light and the Debanding for the skies - are two candidates which won´t make it into a "lite" version.

Share this post


Link to post
Share on other sites

Is it as simple as changing out the .FX Files to swap between them ?

If so I'm happy to test the "heavy" version too...

Running SLI - 980's so unlikely to get much FPS loss.

Share this post


Link to post
Share on other sites
Is it as simple as changing out the .FX Files to swap between them ?

If so I'm happy to test the "heavy" version too...

Running SLI - 980's so unlikely to get much FPS loss.

The newer versions of reshade have much more than just the reshade.fx - so it would be a bit more to swap which isn´t really complicated but jeah - there will be more files.

Reshade got modularised and therefore there are more seperate configs.

And man - a SLI with 980´s is more than a beast-rig!

You won´t notice anything on that - that´s for sure.

I will take another night and look into optimizing V6 and still think there will be 2 variants in the end; Lite and Heavy (although I will think of better names)

Share this post


Link to post
Share on other sites

Multi-GPU doesnt work in Arma3 (oh what a suprise ^^) cause there is no SLI Profile in Nvidia Forceware drivers for Arma. Does not matter how many GPu´s we are using - quad SLi - Tri SLi - whatever. The Engine of Arma is simply expert at deny any chance to have good performance ^^

Share this post


Link to post
Share on other sites

Not true... I can actively see both gpus working...

The sli I profile may not exist, but that doesn't mean they won't share the workload.

On maps like the Ukrainian one just wip as beta release, (orshanets?) they will be pushed quite hard in fact.

You can really push them by bumping up to 4k oversampling too... that effectively maxes them both.

We, not talking cpu here just rendering the existing scene using post process injectors... perfect for beefier gpus

Share this post


Link to post
Share on other sites
Multi-GPU doesnt work in Arma3 (oh what a suprise ^^) cause there is no SLI Profile in Nvidia Forceware drivers for Arma. Does not matter how many GPu´s we are using - quad SLi - Tri SLi - whatever. The Engine of Arma is simply expert at deny any chance to have good performance ^^

Yes it does..

use nvidia inspector and make you own profil and crank up the settings.. i mannage to get 91% out of 2x 780TI.

now i just running a 980TI :D

Back on tread,.. give us V6 ;D

Share this post


Link to post
Share on other sites
Yes it does..

use nvidia inspector and make you own profil and crank up the settings.. i mannage to get 91% out of 2x 780TI.

now i just running a 980TI :D

Back on tread,.. give us V6 ;D

Then be so kindly and share your settings you made in the inspector. You can send me a PM too if you dont want to get too much Offtopic here. Thanks :)

Share this post


Link to post
Share on other sites

Back on tread,.. give us V6 ;D

Ok - I will.

Tonight.

I tracked down the performance issues.

Everything is done - except the correct visualization of the new Version on my page. But that can follow later.

I am packing everything in a few moments and provide the Downloads on my page.

Downloads?

Yeah - Downloads. There will be a Real Light V6 - and a Real Light V6 | Advanced Version which has more impact on performance but shouldn´t be a problem for a better rig.

Since my Preset has always been developed with the goal to be as lightweight as possible - this is the way I had to go now to realise that goal.

I will get back here when everything is set and give you guys the link.

Till later then.

Share this post


Link to post
Share on other sites

Real Light V6 is now Live

http://sh8.videopilot.link/arma3/real-light-v6/

The website will be extended of course to provide more screens and information on how to individualize Real Light V6 for example. But for now - if you want more or less contrast and saturation, extra sharpness or a tint - you should check out the SweetFX_settings.cfg!

Every Feedback is very welcome!

Enjoy

Edited by Solano

Share this post


Link to post
Share on other sites

One Advanced please. :D

Thanks for working to put this out.

Share this post


Link to post
Share on other sites
One Advanced please. :D

What do you mean by that?

EDIT

you meant it like a booking i guess - sorry for the long line ;)

Edited by Solano

Share this post


Link to post
Share on other sites

Shit....to the 23.7. I have only 64kb downloadspeed....ok I will download it over night :p

Share this post


Link to post
Share on other sites

not bad i like it. same time i like the vanilla as it seams you take away the dirt grime and grunge. that you expect on some of those buildings. and given the current state of the area you are operating in. maybe you can get a version out there that will keep the immersive dirty building look. instead of making them look new or well kept. still going to give it a try tho

Share this post


Link to post
Share on other sites

My game seems to crash whenever I start up with the RL V6 Advanced. It also crashed when I mixed RL V5 w/ SweetFX... And by crash I mean, black screen with the windows loading cursor and it's "not responding".

Any help would be appreciated.

Share this post


Link to post
Share on other sites
My game seems to crash whenever I start up with the RL V6 Advanced. It also crashed when I mixed RL V5 w/ SweetFX... And by crash I mean, black screen with the windows loading cursor and it's "not responding".

Any help would be appreciated.

Do you have an updated win7?

Share this post


Link to post
Share on other sites
Yes. I reinstalled it and it still isn't working.

Hi -

just want to make a few things sure.

Did you use the reshade framwork from reshade.me and nothing else?

Did you use the ReShade32. dll?

Did you overwrite everything when copying RL6 over the reshade framework files? And merged the textures folder from customfx?

Is there only the renamed dxgi.dll or are there maybe a d3d9.dll or even a ReShade32.dll?

Do you start with other recording software than bandicam or shadow play?

If you had real light v5 installed before - please delete it or back it up.

Regards

Share this post


Link to post
Share on other sites
Hi -

just want to make a few things sure.

Did you use the reshade framwork from reshade.me and nothing else?

Did you use the ReShade32. dll?

Did you overwrite everything when copying RL6 over the reshade framework files? And merged the textures folder from customfx?

Is there only the renamed dxgi.dll or are there maybe a d3d9.dll or even a ReShade32.dll?

Do you start with other recording software than bandicam or shadow play?

If you had real light v5 installed before - please delete it or back it up.

Regards

Yes to all, but I reneamed ReShade32.dll to dxgi.dll. Also I don't start with any recording software and RL5 isn't installed.

Share this post


Link to post
Share on other sites
Yes to all, but I reneamed ReShade32.dll to dxgi.dll.

Ok thats good then...

But I have no clue at the moment what else could be the problem.

I can only send you to the troubleshooting section from ReShade.me

Sorry I can´t do more at this point - this seems technical then.

Regards

Share this post


Link to post
Share on other sites

Lol I was about to trow this shader away because I was not happy how it was. When I used it I had a nasty light blue overlay over the game. Anyway, I needed to reinstall Steam yesterday and though also Arma. Now I put Real Light back on it...no Blue Overlay. Don't know what caused it but now it looks just great. Maybe I can even use the advance version now! :3

Anyway, thanks for the release!

Share this post


Link to post
Share on other sites
Now I put Real Light back on it...no Blue Overlay

Thanks Moon_chilD - happy you like it!

I guess you used the early release - which had the blue tint by default. Not much time after I adjusted the download to no tint by default cause it had issues.

This caused intentionally a slight blue highlight. Now its off by default and has another option in the SweetFX_settings.cfg for a warm tint...

Anyway - I am glad you like it now.

For the saturation there are settings as well in the SweetFX_settings.cfg if you want to customize it a bit.

Regards

Share this post


Link to post
Share on other sites

Perhaps a stupid question, but are there more ATI people having problems than nVidia ones ? Should it work with both vendors ?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×