Jump to content
Sign in to follow this  
kaelies

Kaelies' South Zagorian Army Mod

Recommended Posts

About NVgoggles and your post:

That's pretty much it. As humans, it's easier to distinguish between shades of green light than it is other colors. By default, infrared cameras and goggles would be grey, but yeah the green is an extra filter. I did some reading and apparently this also allows NVGs to run at dimmer levels, saving battery life.

Share this post


Link to post
Share on other sites
I'll consider putting the language addon into the optional folder of the main addon with the next release, I'll need to get some feedback then regarding whether its too big of a download though.

Regarding weapons like the D30, well, I've still got a good bit to go until I start adding static weapons with all these vehicles everyone wants hm? :rolleyes:

@Tinter:

Yea, the scopes got bugged on the RPG when I tried to make them work with Suddens' scopes, at the moment I'm just using it as a placeholder until I can take the effort to make a proper PGO optic for the RPG. Thanks for the praise on the iron sights by the way :)

@Serjames:

I don't really see any way that the addon would specifically cause speed of sound to stop working, maybe some of my sounds are incompatible with a script in it or something? The sounds added by this mod are all in seperate .pbos, so maybe have him try moving those out of the folder? Also of course try to make sure it is indeed this mod causing it by trying without it .

Also, great to hear that you got it working successfully with ALiVE, I wish the SZ-Royal Marine alliance (if I understood right) manages to fight off those Takistanis :D

Regarding the CDF supplies:

To me it makes most sense that they are strongly supported by the US, given that the US went as far as to invade on their behalf during Harvest Red. The sorta alternate timeline I've been going with in my head recently, in a brief form, has the US crush most of the ChDKZ, pull out, give the CDF equipment and tell them to finish the job, then the survivors of the ChDKZ reform into the South Zagorians and with monetary and equipment support from Russia, fight off the CDF and manage to regain a strong foothold in the region. Naturally, the US would probably not only have to leave some of their supplies behind if their going home was rushed (maybe it was to say, prevent a Russian invasion of the region?), but would also probably try to help out the CDF stay stable in the region.

Regarding the non-US things, well, I imagine that war is a huge profit-making business for companies that make military arms, so any sensible company producing such would give out free samples in the hopes that the CDF will end up buying from them in the future.

Finally, I know that Kuwait, Iraq, and Egypt all use the M1a1, albeit in a downgraded form, so I really see no reason why the CDF wouldn't end up getting stocks of it from the US as well.

Regarding other miscellaneous things:

I hope to have my next update out about the 19th, +/- a week. In addition to the BMP, I should have the Isklaristani weapons, maybe Isklaristani troops, elite Takistani troops, and maybe some other things added. Dreams include adding an ACOG and a CCO as well, but who knows. If you have any suggestions for mods which add NATO scopes, which I might add to the addon, please let me know so I might make a compatibility addon; provided they work fine with BIS weapons, shouldn't be a problem to add them to my own.

I'm going to also add in more specialized medical troops such as the Field Medic (Meant as a platoon-level medical entity, less armed and more supplied than the normal medic) and the Field Doctor (With different supplies). Of course, with the standard Arma medical system it won't have much meaning, but I will be doing an xmed compatibility .pbo as well.

One question I would like to have answered: The NVGoggles/NVScopes and the like are green due to an extra filter, correct? Due to something like the human eye differentiating those colours better? I was considering, if that is the case, to create some custom NVGoggles including arma-2 style ones and also a special set without that particular filter, mostly as a matter of personal preference. If anyone could show me any documents regarding russian night vision goggles/optics, aside from the NSPU, I would appreciate it.

Also, still looking for some feedback on the GP-25 and whatever the GL on the XM8 is!

What I mean is to include 2 separate packs, one with the normal download and one that already has it installed and working, if that makes sense.

Share this post


Link to post
Share on other sites

The AKS-74u shooting "flame" is displayed a few cms below the cannon of the rifle.

Share this post


Link to post
Share on other sites

Very nice! The UAZ is super fun to drive around with. The recoil on the guns seem to be very low though?

Share this post


Link to post
Share on other sites

Hey,

So, in regards to the recoil:

I just looked up a few AK-74 videos of it being fired in full-auto, seems like there's very little recoil, so I get the feeling that my values aren't too far off from the real thing. Keep in mind that the AK-74 not only has a very small amount of recoil due to it's round but also has a muzzle brake, which also has a few holes strategically placed to recoil muzzle rise. If you want to point out a specific gun which has too little recoil, please let me know and I might take a look at it and any videos I find; any gun with a bipod on it will also have less recoil when prone than others.

I did however put some more backwards recoil per request, maybe see if you like it after this next update...

In regards to Czech army DLC:

Yea, BIS released the models, but not the textures. None of the tools I've tried allow me to de-pbo the DLC textures and then use them, and I can't do textures myself (if anyone remembers the SVD which was my first ever mod...). Unfortunately, I don't think there's any way for me to use those things in this addon.

In regards to NV:

I found a way to change the colour, but it requires a scripted approach. I'm trying to stay away from a CBA requirement for as long as I can get by with, so custom NV is going to be pushed onto the stack of things I'll be doing when start adding scripts to the addon.

In regards to the BMP:

So, I have some bad news on this topic. I've been trying what I can and looking at various resources, but I cannot get the vehicle to properly move faster than 10 km/h. Chances are, it won't be finished soon enough for me to include it in this weekend's release.

If anyone would care to take a look at my config and tell me I made an error somewhere, here's my config:

Mass of vehicle is 15,000

/// PhysX part
simulation			= tankX;
maxSpeed        = 120;
enginePower			= 582;
maxOmega 		   	= 276;
peakTorque 			= 4832;
torqueCurve[] 	= {
{0, 0},
{(1600/2640), (2650/2850)},
{(1800/2640), (2800/2850)},
{(1900/2640), (2850/2850)},
{(2000/2640), (2800/2850)},
{(2200/2640), (2750/2850)},
{(2400/2640), (2600/2850)},
{(2640/2640), (2350/2850)}
};
thrustDelay			= 0.1;    	/// how much time does it take to get the full thrust (default 1), used to reduce initial wheel slipping
clutchStrength 		= 180.0;
fuelCapacity		= 1885;
brakeIdleSpeed		= 1.78; 	/// speed in m/s below which braking is applied
switchTime = 0.41;
latency 			= 2.0;
tankTurnForce		= 600000; /// Random magic number, expected to be something like 11 x mass of vehicle
wheelCircumference = 10.65;

/// Gearbox and transmission
idleRpm = 700; // RPM at which the engine idles.
redRpm = 2640; // RPM at which the engine redlines.

engineLosses = 25; // power losses on the engine's crank-shaft (before the gearbox) in Nm. (Multiplied by the gear ratio)
transmissionLosses = 15; // power losses on wheel axis (in/after the gearbox) in Nm. (Constant)
changeGearMinEffectivity[] = {0.95,0.15,0.25,0.28,0.25,0.75,0.75,0.65};

class complexGearbox {
GearboxRatios[]    = {"R1",-4.7,"N",0,"D1",5.0,"D2",2.25,"D3",1.18,"D4",.59,"D5",.398};
TransmissionRatios[] = {"High",14.3};
gearBoxMode        = "auto"; //gearbox can be of type: full-auto (only requires 'W' or 'S'), auto (requires shift between drive and reverse), semi-auto, manual
moveOffGear        = 1; // defines what gear an automatic or semi-automatic gearbox will move off from stationary in. 1 by default.
driveString        = "D"; // string to display in the HUD for forward gears.
neutralString      = "N"; // string to display in the HUD for neutral gear.
reverseString      = "R"; // string to display in the HUD for reverse gears.
transmissionDelay  = 0.1;
 gearUpMaxCoef = 0.9;
 gearUpMinCoef = 0.7;
 gearDownMaxCoef = 0.75;
 gearDownMinCoef = 0.7;
};
/// end of gearbox

class Wheels {
class L2 {
	boneName = "wheel_podkoloL1";
	center   = "wheel_1_2_axis";
	boundary = "wheel_1_2_bound";
	damping  = 75.0;
	// tanks do not have steerable wheels
	steering = 0;
	/// We need to distinguish the side to apply the right thrust value
	side = "left";
	/// weight of the wheel is defined per wheel, it reduces overall mass of vehicle
	weight = 150;
	mass = 150;
	MOI = 25;
	latStiffX = 25;
	latStiffY = 280;
	longitudinalStiffnessPerUnitGravity = 1000;
	maxBrakeTorque = 40000;
	sprungMass = 1250.0;
	springStrength = 324000;
	springDamperRate = 36000;
	dampingRate = 1.0;
	dampingRateInAir = 8830.0;
	dampingRateDamaged = 10.0;
	dampingRateDestroyed = 10000.0;
	maxDroop = 0.15;
	maxCompression = 0.15;
};
class L3: L2 {
	boneName = "wheel_podkolol2";
	center   = "wheel_1_3_axis";
	boundary = "wheel_1_3_bound";
};
class L4: L2 {
	boneName = "wheel_podkolol3";
	center   = "wheel_1_4_axis";
	boundary = "wheel_1_4_bound";
};
class L5: L2 {
	boneName = "wheel_podkolol4";
	center   = "wheel_1_5_axis";
	boundary = "wheel_1_5_bound";
};
class L6: L2 {
	boneName = "wheel_podkolol5";
	center   = "wheel_1_6_axis";
	boundary = "wheel_1_6_bound";
};
class L7: L2 {
	boneName = "wheel_podkolol6";
	center   = "wheel_1_7_axis";
	boundary = "wheel_1_7_bound";
};
// rear left wheel, usually Idler or Drive Sproket
// Note, this wheel may not always be touching the ground, but we need it anyway!
class L9: L2 {
	boneName = "wheel_podkolol9";
	center   = "wheel_1_9_axis";
	boundary = "wheel_1_9_bound";
	sprungMass = 1500.0;
	springStrength = 37500;
	springDamperRate = 7500;
	maxDroop = 0;
	maxCompression = 0;
};
// front left wheel, usually Idler or Drive Sproket
// Note, this wheel may not always be touching the ground, but we need it anyway!
class L1: L2 {
	boneName = "";
	center   = "wheel_1_1_axis";
	boundary = "wheel_1_1_bound";
	sprungMass = 1500.0;
	springStrength = 37500;
	springDamperRate = 7500;
	maxDroop = 0;
	maxCompression = 0;
};

class R2: L2 {
	boneName = "wheel_podkolop1";
	center   = "wheel_2_2_axis";
	boundary = "wheel_2_2_bound";
	side = "right";
};
class R3: R2 {
	boneName = "wheel_podkolop2";
	center   = "wheel_2_3_axis";
	boundary = "wheel_2_3_bound";
};
class R4: R2 {
	boneName = "wheel_podkolop3";
	center   = "wheel_2_4_axis";
	boundary = "wheel_2_4_bound";
};
class R5: R2 {
	boneName = "wheel_podkolop4";
	center   = "wheel_2_5_axis";
	boundary = "wheel_2_5_bound";
};
class R6: R2 {
	boneName = "wheel_podkolop5";
	center   = "wheel_2_6_axis";
	boundary = "wheel_2_6_bound";
};
class R7: R2 {
	boneName = "wheel_podkolop6";
	center   = "wheel_2_7_axis";
	boundary = "wheel_2_7_bound";
};
// rear right wheel, usually Idler or Drive Sproket
// Note, this wheel may not always be touching the ground, but we need it anyway!
class R9: R2 {
	boneName = "wheel_podkolop9";
	center   = "wheel_2_9_axis";
	boundary = "wheel_2_9_bound";
	sprungMass = 1500.0;
	springStrength = 37500;
	springDamperRate = 7500;
	maxDroop = 0;
	maxCompression = 0;
};
// front right wheel, usually Idler or Drive Sproket
// Note, this wheel may not always be touching the ground, but we need it anyway!
class R1: R2 {
	boneName = "";
	center   = "wheel_2_1_axis";
	boundary = "wheel_2_1_bound";
	sprungMass = 1500.0;
	springStrength = 37500;
	springDamperRate = 7500;
	maxDroop = 0;
	maxCompression = 0;
};
};
/// End of PhysX

Some other Misc. Stuff:

To start off, let me just note that the Lee-Enfield is going to have a bolting sound; an awesome bolting sound, at that! Hopefully it and the other awesome weapon sounds can make up for me missing the BMP.

I've also made the bipods on various rifles attachments (so far the AK's are finished, shouldn't be too hard to do the rest), so its possible to do stuff like take off the bipod on an RPK and put it on your AKM, but the effect is only cosmetic for now. It'll also be possible to have both open and closed variants and switch between them; I'll see if I can't do something special with that by the weekends ;)

The HK33, HK53, MP5, and a longer version of the HK33 will be included, in the a2 (fixed) and a3 (collapsible) stock variants. Might have time to do the G3 as well, and each will have a rotating drum with four sight pictures, being an open one, and three aperture sights. MP5 is zeroed for 25 on all of them, while the others are zeroed at 100-400m. The Elite Takistani troops will be using some of these, as well as them being the primary firearm of the Isklaristani troops; unfortunately, those troops aren't ready for this weekend.

Hopefully, I'll be able to put in some improvements on the hinds as well as the adding the m320/m230/EGLM and adding zeroing to the RPG-7, but the BMPs have pushed me off-schedule.

Finally, if I haven't mentioned it already, I'll be adding field medics (platoon-level) and field doctors to the current medical staff, who will at first just be armed more lightly; however, I will also be adding a compatibility .pbo for xmedsys which will give them more reasonable supplies fit for their roles.

Share this post


Link to post
Share on other sites

Thanks, I'll give it a try, though it seems to still be the .pbos so it might have the same issues.

Share this post


Link to post
Share on other sites

well, I ported bmp1 from acr dlc and I didn't ecounterd any problems with texture editing. Regarding bmp take a look how I configured it in my addon. Moi and damperinair needs to be very low

Share this post


Link to post
Share on other sites

H¡,

Im using SZ mod with RDS Tank Pack Extension for South Zagoria v1.2, and when i place a ALIVE module to spawn armored it dont works. I think its too important for your mod to works full with ALIVE.

Nice work!!!

Share this post


Link to post
Share on other sites
In regards to the BMP:

So, I have some bad news on this topic. I've been trying what I can and looking at various resources, but I cannot get the vehicle to properly move faster than 10 km/h. Chances are, it won't be finished soon enough for me to include it in this weekend's release.

Here maybe I'm going a bit off-limits but, having in mind that Reyhard has get the BMP 1, BMP2, T72, T55, T34, Shilka working in his East tank pack, and even make a patch to make them compatible with your mod ( all of those can be found here ).

Maybe you could think ( if you fancy ), some joint effort to avoid having to do/port everything twice. That could be from sharing some files, to make a unified mod, or just use the other as a requirement. Just a suggestion.

BTW I can't wait for the new sounds and stuff, loving your mod :)

Edited by MistyRonin

Share this post


Link to post
Share on other sites

@ESUSSanchez - *sigh* well, it's not Kaelies error but mostly mine so it's not perfect place to mention things like that

Share this post


Link to post
Share on other sites

I don't think that Reyhards config overwrites the main SZ groups config so ALiVE will only see generic SZ vehicles groups. BUT you can do what we do and spray a peppering of hand place tanks + BMP's units around the map that then get profiled and will be used by Alive.

SJ

Share this post


Link to post
Share on other sites

sorry if this has been covered already, but I'm having serious problems with this mod. somehow, for some reason, this mod makes it so that I can't hear other players firing unless it's a specific firemode. for example, I can't hear single fire on any MX rifles, but I can hear full auto. I can't hear burst on RH's M4 pack but I can hear semi and full etc. I managed to fix this about a month ago by completely removing the mod and deleting all my configs then reinstalling the mod, but now it broke itself again without me actually changing anything and I can't get it to work this time.

Share this post


Link to post
Share on other sites

Hey,

@Kju, Reyhard

Thanks for the heads-up, I assume then that the textures you used for your BMP were from the link that .kju posted? I've been trying with the ACR ones I had from installing the expansion itself and that didn't work, might be why I've had issues. Will give it a shot this weekend.

---

well, I ported bmp1 from acr dlc and I didn't ecounterd any problems with texture editing. Regarding bmp take a look how I configured it in my addon. Moi and damperinair needs to be very low

Thanks for the suggestion, though I tried last night with just those changes and it didn't work, maybe I missed something else. I'll take a look at how you did it when I can download everything over the weekend; haven't been keeping up with others' mods recently :rolleyes:

By the way, thanks for making a compatibility configuration for your addon to use my units!

---

@ESUSSanchez

The compatibility addon isn't written by me so I'm afraid I cannot help. However, I think it may be that there are no predefined groups that actually use the new units, which ALiVE requires to have them automatically spawn, and ALiVE also has some very specific conditions for naming everything, which is the problem I'm having with my UAZs not working either.

---

sorry if this has been covered already, but I'm having serious problems with this mod. somehow, for some reason, this mod makes it so that I can't hear other players firing unless it's a specific firemode. for example, I can't hear single fire on any MX rifles, but I can hear full auto. I can't hear burst on RH's M4 pack but I can hear semi and full etc. I managed to fix this about a month ago by completely removing the mod and deleting all my configs then reinstalling the mod, but now it broke itself again without me actually changing anything and I can't get it to work this time.

I really have no clue as to how my addon would do anything to affect this, since I don't think I have anything that changes any of the default values. I just inherit off some base BIS classes and then make my own stuff that's separate. I can only suggest the following to try and get it to work again:

1) Check if its my mod by not loading its modfolder at all

2) Find the "Kae_SZ_Weapons_snds.pbo" and "kae_sz_air_snds_new.pbo", as well as the similarly named .bisigns and remove them from the modfolder; this should remove the sound part of the addon, and would help me to know if its one of those two causing the issue

Sorry that I can't be of much more assistance, but let me know if either of those two helps to fix your issue.

---

It seems I have some thinking to do on where I want to go now, but in the meantime I hope you all enjoy the update which I'll probably be uploading Sunday :)

Share this post


Link to post
Share on other sites

It seems I have some thinking to do on where I want to go now, but in the meantime I hope you all enjoy the update which I'll probably be uploading Sunday :)

It's gonna be a long, but worth wait :)

Share this post


Link to post
Share on other sites

I really have no clue as to how my addon would do anything to affect this, since I don't think I have anything that changes any of the default values. I just inherit off some base BIS classes and then make my own stuff that's separate. I can only suggest the following to try and get it to work again:

1) Check if its my mod by not loading its modfolder at all

2) Find the "Kae_SZ_Weapons_snds.pbo" and "kae_sz_air_snds_new.pbo", as well as the similarly named .bisigns and remove them from the modfolder; this should remove the sound part of the addon, and would help me to know if its one of those two causing the issue

I tried both of those already. I also tried only having this mod enabled to make sure it wasn't a conflict between other mods. it doesn't make any sense to me either, but it's happening.

Share this post


Link to post
Share on other sites

Still planning on including a separate version with the language addon installed? I'd just title one the "Base" mod and one the South Zagorian Army mod-With Language Addon.

Share this post


Link to post
Share on other sites

so after a bit more research I found out that the problem isn't only this mod. for some reason the game was forcing parts of BWmod to be active even though I uninstalled it, and I've now discovered that the the problem was a conflict between BWmod and this.

Share this post


Link to post
Share on other sites
so after a bit more research I found out that the problem isn't only this mod. for some reason the game was forcing parts of BWmod to be active even though I uninstalled it, and I've now discovered that the the problem was a conflict between BWmod and this.

That's weird, I've both mods activated. And 0 problems :confused:

Are you using the dev branch or the stable?

Share this post


Link to post
Share on other sites
That's weird, I've both mods activated. And 0 problems :confused:

Are you using the dev branch or the stable?

stable

Share this post


Link to post
Share on other sites

We (18th Guards Motostrelki guys) run the mod on stable-branch, and aren't running into any trouble with that setting.

-edit: Then again we don't use Bundeswehr-mod either.. So I hope the problems are fixed now? :)

Share this post


Link to post
Share on other sites
We (18th Guards Motostrelki guys) run the mod on stable-branch' date=' and aren't running into any trouble with that setting.

-edit: Then again we don't use Bundeswehr-mod either.. So I hope the problems are fixed now? :)[/quote']

my arma 3 has a notorious talent for finding new ways to break itself which never seem to be apparent for other people who play the game.

probably something on my end, or at least something more to do with the game as opposed to the mod

Share this post


Link to post
Share on other sites

@Bruhmis: we got the same Problem. solution: everyone you play with needs the SZ mod or you will stumble into the described sound Problems. or you have to de-activate the SZ mod if you play with somebody who hasn´t this mod.

sounds crazy but we encountered the problem n our own server. it was more obvious after one of my team mates got the mod and i could hear his sounds but not the sounds from the guys who did not have the mod.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×