Jump to content
Drongo69

Drongos Artillery (an advanced artillery system)

Recommended Posts

Drongo, what about a stringtable so the interface can be translated? That would help english impaired folks to enjoy your work better and may even make it ubiquitous among some communities.

I, of course, am willing to translate it in the obscure language thatFrench is (we have a french artilleryman among us so I better have to to do it right ^^).

Share this post


Link to post
Share on other sites

I'll look into how much work it is. My holiday is almost over, so my time for modding will probably drop off soon.

Share this post


Link to post
Share on other sites

Thanks for taking it into consideration.

If it too much work for you at this time of the year, maybe you could give me a rough guideline and I'll give it a try?

All the best.

Share this post


Link to post
Share on other sites

I've never used a stringtable mate, so I can't really give any advice. Most of the text is in the Menu.hpp file that defines the dialog though.

Share this post


Link to post
Share on other sites

hey man, thx for an absolute awesome mod.

I've been doing some testing and 2 things came up,

1) in the RDS static weapons pack there is the D30 that works with your mod, but also the M119 howitzer. This doesnt work with your mod, as it uses 105mm shells which your mod doesnt support.

Due to my lack of patience ;), i had a crack at it (hope you dont mind). By copying all the parts you made for the D30 and replacing the class names to the M119, it again works like a charm.

all the class names for the M119 : magazinetype, ammotype, .... are almost the same, except. (example) where you would use "RDS_30Rnd_122mmHE_D30" for the D30 it becomes "RDS_30Rnd_105mmHE_M119" for the M119

2) the second thing is something with the postion of the gun and im guessing how it used to calculate the range to a target. basically when ever i use your mod on stratis or altis, it works like a charm. But when i place the same gun on a costum map like : Takistan, Cherno, Zargabad, ..... it stops working. You always get feedback "Out of Range", which is weird cause my targets where just 2.5km away. ive noticed that the position of the gun which is shown in the selectmenu, is nowhere near where i am according to the grid on the map. And perhaps that causes the range calc to be completely off. Just a wild guess ?

Gun coordinates according to the assets menu http://s1244.photobucket.com/user/chiel0/media/2014-09-24_00001.jpg.html?o=0

Gun coordinates according to the mapgrid http://s1244.photobucket.com/user/chiel0/media/2014-09-24_00002.jpg.html?o=1

Anyways Thanks for a great mod, and Thank you for all the work you've put into this.

Edited by K4ble

Share this post


Link to post
Share on other sites

Sorry for the big delay responding to above posts. I'll take a look at these issues. I am also thinking of adding an option to allow map-clicking for coordinates, instead of manual input (configurable by the mission maker).

Share this post


Link to post
Share on other sites

First post updated with version 0.28. Changes:

  • Partial French localization (all done by Kawa)
  • Added support for Reyhard's M119 (thanks to K4ble for reminding me to add this)
  • Added an option to use mapclick to input coordinates (can be disabled with a module)
  • Removed the "Elevation" option from the dialog as it does not work
  • Added support for weapons that inherit from Reyhard's Static Weapons

I am now looking for people who can localize in the following languages:

  • Czech
  • German
  • Hungarian
  • Polish
  • Portuguese
  • Russian
  • Spanish

Share this post


Link to post
Share on other sites

New version frontpaged on the Armaholic homepage.

==================================================

You are not registered on Armaholic, or at least not that we are aware of. In the future we offer the possibility to authors to maintain their own pages.

If you wish to be able to do this as well please register on Armaholic and let me know about it.

This is not mandatory at all! Only if you wish to control your own content you are welcome to join, otherwise we will continue to follow your work like we have always done ;)

When you have any questions already feel free to PM or email me!

Share this post


Link to post
Share on other sites

Hi...

Drongo, hell of a mod you've made there. I've tested it just for a few rounds, but i'm like hit by a shell -> blown away ;)

It works like a charm, but one thing to complain:

Since we (TF47) play a lot of Zeus missions and excessive use of TFAR and almost all the radios, could you please implement a easier way to assign a FO? Like syncing to a "is arty operator" module that only synced units are able to use the arty and not defined by a radio type?

Share this post


Link to post
Share on other sites

I'll look at different ways to (optionally) allow/disallow access to the dialog.

Share this post


Link to post
Share on other sites

My Rounds never seem to hit on target EVER. i use the Laser Designator that gives GPS grids....i input those grids into the controller and they always miss or never truly correct....am i missing something?

Share this post


Link to post
Share on other sites

The grid reference to input is not the same as the grid reference on the map. To test where your rounds are landing, put down [DTA] Debug and [DTA] No initial inaccuracy modules, then use the mapclick method to input coordinates.

Also note that the arty uses an 8-digit grid reference whereas Arma uses 4 or 6 depending on the level of zoom. So if on Altis your target is at X: 158 (numbers going left to right) and Y: 173 (numbers going bottom to top) then the coordinates to input would be X: 1730 Y: 1580.

Share this post


Link to post
Share on other sites

Hi,

Just wanted to say that the click option is a realy good fix for the corrdinates issue, Thanks for that.

1 small issue remains though. The M119 is now supported, but i think your mod isnt detecting the required shell type.

if you put an m119 down and want to call in an artillary strike you cannot select any type of round, they are just not there.

Anyways, thanks again for a great mod :D

Share this post


Link to post
Share on other sites

Funny, I was just searching for the same issue as audiocustoms. Would be great if there is something like a tablet or something like that to prevent everyone with a radio using the artillery mod :) Besides that, great mod, I like it!

Share this post


Link to post
Share on other sites

First post updated with version 0.29. Changes:


  • Fixed airburst not working
  • Fixed menu selections not saving
  • Made it possible to restrict users by class and/or unit
  • Added the ability to set which audio is used for each side
  • Reduced the default time to process the first round of a firemission from 60 + (random 30) to 30 + (random 30)
  • Improved initial loading time
  • Tweaked mixed impact/airburst to alternate by odd and even numbered tubes in a battery
  • Added support for Reyhard's M119 (don't know where it went the first time)

HOW YOU CAN HELP

I am looking for native speakers with decent microphones and knowledge of artillery language to provide voice sets for different countries (especially keen on UK English, Russian, Arabic and Australian English).

In the near future I will be looking at tweaking the adjust fire code, since this gives a lot of trouble presently. After that laser guided, self-guided and WP shells will be the priority.

Share this post


Link to post
Share on other sites

Drongo i dont suppose this will work for RHS artillery pieces(one arty piece,is on truck flatbed classed as truck)

GAIA,nor FFE(Fire for effect) mods recognize RHS as artillery(config issue) And thus no way to make AI fire without grouping arty to my character.

I dont suppose you have some magical cure?

;)

Share this post


Link to post
Share on other sites

Restricting users doesn´t work for me. Dont get it where put what?

Tried to name the unit which should have access to artillery and named it s1. Then put

dtaAuthorizedUnits = dtaAuthorizedUnits + [s1];

this in the init.sqf -> didn´t work

in the init field of the unit itself -> didn´t work

I tried it with

dtaAuthorizedUnits = dtaAuthorizedUnits + [player];

in the init field of the unit. That also didn´t work. With or without parnethesis doesn´t have any effect.

Also I don´t hear any sounds beside the readio beeps.

Edited by CommanderX

Share this post


Link to post
Share on other sites

@Redarmy

RHS is not currently supported, maybe in a future patch. I'd like to find a way to automate support for mods instead of hard-coding everything.

@CommanderX

You need to run the code after the system has initialized. Try making a script that adds the desired units and put a sleep of 5 or 10 seconds at the start.

Share this post


Link to post
Share on other sites
I dont have any sounds either just the beeps

I made a typo which will be fixed in the next version. For now, run this code about 5 seconds after the mission starts;

dtaAudioBLUFOR = "US";
dtaAudioREDFOR = "PER";
dtaAudioINDEP = "GRE";

Share this post


Link to post
Share on other sites
@Redarmy

RHS is not currently supported, maybe in a future patch. I'd like to find a way to automate support for mods instead of hard-coding everything.

@CommanderX

You need to run the code after the system has initialized. Try making a script that adds the desired units and put a sleep of 5 or 10 seconds at the start.

Yeah automate would be great,much easier.Hope to see it one day incorperated,the bm rocket truck(katyushya) is awesome,would love to see it fire one day.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×