Jump to content
Alwarren

Arma Toolbox for Blender - Arma 2/3 exporter script

Recommended Posts

@RacerX
By default no, vehicles are not animated like that in Arma. Vehicles run with model.cfg defined animations. See BI wiki for "how to animate a model".

Cycles has also nothing to do with animations or the toolbox, so yes cycles renderer can be used along the toolbox but nothing from it really translates into Arma.

Share this post


Link to post
Share on other sites

As HorribleGoat said. Only creatures are animated via RTM's, and sometimes the collapse of buildings, but that's the extend of it.

Share this post


Link to post
Share on other sites

Added. 

Also could you help me understand how I could run the P3D import with Blenders python? 

I have a bunch of P3Ds Id like to import and process with few automated things for Blender terrain placement but my Python skillz are only so and so when it comes to running addon stuff.

Share this post


Link to post
Share on other sites

Hello, I might sound stupid, surely there is something trivial I am missing because Im not yet very familiar with Blender, but when I install the addon, it shows that I've installed in Blender, but after that I can't see any Arma tools tools or no option to export in .P3D either.. is there something I am missing? Tried it in blender 2.81 and now in 2.82 and still, cant see any tools, even if the addon manager shows its installed. Thanks in advance!

Share this post


Link to post
Share on other sites
5 minutes ago, caimaN said:

Hello, I might sound stupid, surely there is something trivial I am missing because Im not yet very familiar with Blender, but when I install the addon, it shows that I've installed in Blender, but after that I can't see any Arma tools tools or no option to export in .P3D either.. is there something I am missing? Tried it in blender 2.81 and now in 2.82 and still, cant see any tools, even if the addon manager shows its installed. Thanks in advance!


Did you activate it? 

Share this post


Link to post
Share on other sites

If you mean check the box in the addons settings, then yes

Share this post


Link to post
Share on other sites

That's what's showing in the console

 

fake_module: addon missing 'bl_info' gives bad performance!: 'C:\\Users\\tomky\\AppData\\Roaming\\Blender Foundation\\Blender\\2.82\\scripts\\addons\\MDLexporter.py'

 

edit: ok so I reinstalled blender and remade my model...and now it works, software is weird

Share this post


Link to post
Share on other sites
Posted (edited)

Never Mind. Nothing to see here.

Edited by Macser
Poster solved issue
  • Confused 1

Share this post


Link to post
Share on other sites

hey i have downloaded the arma toll box for blender did everythin etc.

i have an p3d file but cant import it it say something with mdl whats wrong?

Share this post


Link to post
Share on other sites
4 hours ago, mrbrandyde said:

hey i have downloaded the arma toll box for blender did everythin etc.

i have an p3d file but cant import it it say something with mdl whats wrong?

 

That isn't exactly an exhaustive error description.

What I guess is happening is that it tells you that the MDL you are trying to import has the wrong version. The most likely explanation for that is that you are trying to import a binarized P3D (also known as an ODOL) file. The toolbox doesn't load binarized models.

 

Share this post


Link to post
Share on other sites

Hi Alwarren,

 

Recently I started updating some of my old models. I often delete one half of the model, fix the remaining half and mirror it when I am done.

Now when putting it back into oxygen I have noticed that due to some miracle the ailerons and other parts somehow retain/get reassigned their old names (usually I use names like aileron_l/aileron_r).

Same for wheels and flaps and other movable parts. I would have expected the mirrored parts to get the same name as the origin mesh. That happens to propellers (I usually name them prop_1, prop_2,...not ..._l or ..._r).

 

What kind of magic is this? Did you actually make the script scan for _l and _r containing names in the selections? Or is this some blender feature?

Share this post


Link to post
Share on other sites
1 hour ago, DSabre said:

Hi Alwarren,

 

Recently I started updating some of my old models. I often delete one half of the model, fix the remaining half and mirror it when I am done.

Now when putting it back into oxygen I have noticed that due to some miracle the ailerons and other parts somehow retain/get reassigned their old names (usually I use names like aileron_l/aileron_r).

Same for wheels and flaps and other movable parts. I would have expected the mirrored parts to get the same name as the origin mesh. That happens to propellers (I usually name them prop_1, prop_2,...not ..._l or ..._r).

 

What kind of magic is this? Did you actually make the script scan for _l and _r containing names in the selections? Or is this some blender feature?


Blenders mirror tool does that. As in changes _l to _r.

  • Thanks 1

Share this post


Link to post
Share on other sites

Thank you for clearing that up. It's a great feature. Had it happen a few times before but never really investigated further.

So it did repay to redo my selection names : )   I used to have a lot of old arma 2 style names like lkh/pkh klapka from learning how to mod by doing arma 2 ports.

 

And many thanks again for this tool Alwarren!

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×