Jump to content
Sign in to follow this  
Richie

Hacked by a player with no ID

Recommended Posts

Didn't work for me on 1.06 Wasteland, players got no dialogue box and we all spawned on the northern spawn island location.

Same for Rarek from Ahoy World - fix does NOT work

PLS READ MY POST:

Hi All , I think I got him, look at this screenshot: http://postimg.org/image/xd914h9af/

All players have ID except one player : pc, but for a few seconds when he was connecting to my server a few times ( after I restarted mission ) his ID was shown , I made a screenshot and I do have his ID. The question is: is it him or it is innocent player - I don't think so - because 3 times when he connected his ID was deleted and then server was hacked.

That's an odd ID it just looks like a timestamp of when he joined the server...

Share this post


Link to post
Share on other sites
Same for Rarek from Ahoy World - fix does NOT work

That's an odd ID it just looks like a timestamp of when he joined the server...

no, read what I wrote, It is screenshot after his ID WAS DELETED. I DO HAVE OTHER SCREENSHOT WITH HIS ID STARTING WITH 76.......

regards

pawel

Share this post


Link to post
Share on other sites
ATTENTION: the following simple fix will not work with missions depending on BIS_fnc_MP,

because it disables the whole BIS_fnc_MP, so that NO code can be executed from remote this way.

This means all missions depending on BIS_fnc_MP will not work correctly with this fix.

I tested this with xeno's nice Domination 2 mission (2.99d) and it seems to works well.

(Domination makes currently no use of BIS_fnc_MP)

If you would try this AND you are familiar with .pbo extracting/packing just do the following :

1. Extract the co40_Domination_2_99d_Blufor_Lite_Alpha.Stratis.pbo

2. in init.sqf, at beginning of this file, insert this line:

"BIS_fnc_MP_packet" addPublicVariableEventHandler {};

3. Repack the .pbo

4. use it on your server

Hope it helps for now ...

Thanks Fred, that combined with overwriting the function, it cleans the infected clients aswell.

At the moment my server is running full. Infected team members got cleaned up and could connect on our private server without problems.

Share this post


Link to post
Share on other sites
Thanks Fred, that combined with overwriting the function, it cleans the infected clients aswell.

At the moment my server is running full. Infected team members got cleaned up and could connect on our private server without problems.

What mission are you running?

Share this post


Link to post
Share on other sites
no, read what I wrote, It is screenshot after his ID WAS DELETED. I DO HAVE OTHER SCREENSHOT WITH HIS ID STARTING WITH 76.......

regards

pawel

You are correct my apologies I did not look closely enough

Share this post


Link to post
Share on other sites
Thanks Fred, that combined with overwriting the function, it cleans the infected clients aswell.

At the moment my server is running full. Infected team members got cleaned up and could connect on our private server without problems.

Aye Tyrghen, please could you post a little tut (even if it's just amalgamating two other posts) so others could follow suite? Personally I'm not a fan of MP in its current state (I mean, without the infection ^.^) but I'm sure others will benefit greatly.

Share this post


Link to post
Share on other sites
PLS READ MY POST:

Hi All , I think I got him, look at this screenshot: http://postimg.org/image/xd914h9af/

All players have ID except one player : pc, but for a few seconds when he was connecting to my server a few times ( after I restarted mission ) his ID was shown , I made a screenshot and I do have his ID. The question is: is it him or it is innocent player - I don't think so - because 3 times when he connected his ID was deleted and then server was hacked.

That PC guy came on my server this morning and about 30 seconds later - the BS started and he logged.

Do we know conclusively whether this is transmitted by the client or deployed by an individual who actually has to physically log in to a server in order to initiate the script.

Edited by BangTail

Share this post


Link to post
Share on other sites
PLS READ MY POST:

Hi All , I think I got him, look at this screenshot: http://postimg.org/image/xd914h9af/

All players have ID except one player : pc, but for a few seconds when he was connecting to my server a few times ( after I restarted mission ) his ID was shown , I made a screenshot and I do have his ID. The question is: is it him or it is innocent player - I don't think so - because 3 times when he connected his ID was deleted and then server was hacked.

You can reproduce that effect by dragging your mouse to copy id's. Happens to me all the time, i think its a known bug. Next time use shift + arrow keys to copy.

Share this post


Link to post
Share on other sites

As Fred stated, it will only work if your mission doesn't use the function.

We are running a customized Dynamic War Sandbox.

I just added the following at the end of the init.sqf

"BIS_fnc_MP_packet" addPublicVariableEventHandler {};

BIS_fnc_MP = {};

Our server runs full for an hour now.

Share this post


Link to post
Share on other sites
That PC guy came on my server this morning and about 30 seconds later - the BS started and he logged.

Do we know conclusively whether this is transmitted by the client or deployed by an individual who actually has to physically log in to a server in order to initiate the script.

I'm 99 percent it is him, I restarted server 3 times and it was working ok until he connected and disconnected, As I wrote I do his arma ID.

Share this post


Link to post
Share on other sites
Thanks Fred, that combined with overwriting the function, it cleans the infected clients aswell.

At the moment my server is running full. Infected team members got cleaned up and could connect on our private server without problems.

@Tyrghen: what means "that combined with overwriting the function" please post the complete procedure !

thx in advance

greetings Thunder

Share this post


Link to post
Share on other sites
Thunder666;2381096']@Tyrghen: what means "that combined with overwriting the function" please post the complete procedure !

thx in advance

greetings Thunder

He just replied with it.

"I just added the following at the end of the init.sqf

"BIS_fnc_MP_packet" addPublicVariableEventHandler {};

BIS_fnc_MP = {};"

Use that.

EDIT: Thanks Tyrg, forgot to show my gratitude :)

Share this post


Link to post
Share on other sites

thx Guys, but no Chance. 30 Mins no Problems and after start a new Map the same Bullshit. So Password is the only Solution for now i think ! :(

greetings

U can get the PW in our TS

Share this post


Link to post
Share on other sites

Actually, I modified the script line with a waituntil to keep overwriting the function.

We'll just wait and see :)

Share this post


Link to post
Share on other sites

@BIS / BE: however long it takes, please keep all these worthless skiddies' IDs safely logged, then kindly Global Banhammer them all as soon as the opportunity arises, à la DayZ.

Share this post


Link to post
Share on other sites
Well if they cant keep a couple of hackers out why the hell do they sell games ?

Did you and the rest of this thread fail to read the word after "ArmA 3" when you bought it?

Share this post


Link to post
Share on other sites

For those of you wanting players on your newly passworded server, it seems a lot more practical to have them pm you for the password here. Not everyone wants to bother with Skype (I love it, but not when my enemies are all on the same channel as my teammates LOL).

Share this post


Link to post
Share on other sites
Did you and the rest of this thread fail to read the word after "ArmA 3" when you bought it?

not sure but i think you mean "Alpha " right ?. So why then Arma 2 after how much of Years and Tonns of Patches is hacked by Dayz Kids again and again ?!

Congratulations BIS a single boy has the whole multiplayer community to its knees. lol

I'm not sure whether this is good for the reputation of Arma 3

greetings Thunder

Share this post


Link to post
Share on other sites

Ah this just happened on my server as well and I am glad I checked here first. Are connection logs on automatically or something you have to enable? Also where would I find these logs?

Share this post


Link to post
Share on other sites

As annoying as it is, its nothing we shouldn't expect from an alpha like this, and it is a part of the alpha process.

And I would love to join some of the private passworded servers, send me a PM with info if you run a server I can join sometime.

Share this post


Link to post
Share on other sites

Theres a bunch of servers running full which have anti-hack, why not just play on those instead of running your own servers if its so hard.

Share this post


Link to post
Share on other sites
Theres a bunch of servers running full which have anti-hack, why not just play on those instead of running your own servers if its so hard.

Bolded and underlined the answer to your question.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×