Jump to content
shay_gman

MCC Sandbox 3 - Dynamic mission creating tool for ArmA 3

Recommended Posts

MCC holds no preference at all. It spawns what is in the mod. If you can select it on the client side but it does not show up on the server then the server is not running that mod.

Sorry spirit,i wasnt clear.This is single player.It worked before but not now.

Share this post


Link to post
Share on other sites
Sorry spirit,i wasnt clear.This is single player.It worked before but not now.

I have similar problem with the reinforcement drop off, the heli never comes.

Share this post


Link to post
Share on other sites

I have a question: when i place the AC-130 and use the MCC Console Item at first time it works like it should, when i exit the screen to use the AC-130 a bit later nothing shows up on the Console Screen, it just stays black. But numbers and coordinates from the crosshair ar still there, so what i am doing wrong?

Share this post


Link to post
Share on other sites

Just updated to the new and wildly nice MCC :D

But where have you hide the Role selection :D have i missed something or am i just blind ? :D

Share this post


Link to post
Share on other sites
Sorry spirit,i wasnt clear.This is single player.It worked before but not now.

Singleplayer is unsupported (unless you mean playing alone in a multiplayer environment). If there are no groups defined for that faction/side by the addon maker, then there are no groups also to spawn. I see no issues with the groups in MCC.

I have similar problem with the reinforcement drop off, the heli never comes.

What is it you do? Exactly please ! :) or i will have to gues on how to support. I see no issues with the reinforcement. Not in the generator and not in MCC console (i tried all variants from heli to trucks).

Edited by spirit6

Share this post


Link to post
Share on other sites

spirit,i know what you mean,however the groups that are not spawning are AAF groups.

Also,for some odd reason mcc keeps auto changing my weather to fog evry 2minutes.Is there way to stop that?

Share this post


Link to post
Share on other sites
What is it you do? Exactly please ! :) or i will have to gues on how to support. I see no issues with the reinforcement. Not in the generator and not in MCC console (i tried all variants from heli to trucks).

Spawn menu, select group, reinforcement, then i select drop off QRF. The heli wont come :).

Share this post


Link to post
Share on other sites

Hi! When you get the time,could you please make some sort of Ambient "Top Gun" module for the new Jets module that may interact with the AA-teams that can be used with MCC - that can play a sort of `side-mission`on the fly with the Zeus mode and MCC.That will add to the emersion of the game.

Things get to tend to be much more advanced for players to be experts in some fields that we will seldom use-if that could be used `Semi-Automatic`by the system that could play the Cat and Mouse game of CAS on it`s own using some kind of "Air combat and AAA Systems" scripting that could Only be made Server-Side/Headless

Client,that could acctually make it somewhat random that the aircraft can acchive the mission ,sometimes we must find the pilot before the enemy.

This is way to advanced for the player to make himself. Maybe you could add a camera to make BDA Missions or some sort of Rescue Mission being run by Server

to add things that randomizes important events.

Thanks for a wonderfull modification for Arma 3!

Edited by Teddybear1

Share this post


Link to post
Share on other sites
spirit,i know what you mean,however the groups that are not spawning are AAF groups.

Also,for some odd reason mcc keeps auto changing my weather to fog evry 2minutes.Is there way to stop that?

Confirmed. Thanks for noting, there is an issue with direct CREATE button and AAF (actualy its bigger then AAF but that is where most note it i gues). If you spawn them in there is no issue. (Side not correctly handled on neutrals).

Spawn menu, select group, reinforcement, then i select drop off QRF. The heli wont come :).

Works as intended and still dont see any bug in it. Click Spawn in Zone, then click where you wan the heli to start. Works fine on our end. All the time, so helping is hard then.

nevermind

We dont minde :)

Hi! When you get the time,could you please make some sort of Ambient "Top Gun" module for the new Jets module that may interact with the AA-teams that can be used with MCC - that can play a sort of `side-mission`on the fly with the Zeus mode and MCC.That will add to the emersion of the game.

Things get to tend to be much more advanced for players to be experts in some fields that we will seldom use-if that could be used `Semi-Automatic`by the system that could play the Cat and Mouse game of CAS on it`s own using some kind of "Air combat and AAA Systems" scripting that could Only be made Server-Side/Headless

Client,that could acctually make it somewhat random that the aircraft can acchive the mission ,sometimes we must find the pilot before the enemy.

This is way to advanced for the player to make himself. Maybe you could add a camera to make BDA Missions or some sort of Rescue Mission being run by Server

to add things that randomizes important events.

Thanks for a wonderfull modification for Arma 3!

I read it 3 times now and i must say, i really have no clue what you mean.

@ALL

The update for MCC with some fixes are a little delayed because Shay Gman has had its internet exploded. So he can't push/pull to the GIT we share :) Stay tuned, it wont be long :)

Share this post


Link to post
Share on other sites

Feature Request

I really like how the IEDs act in the Dynamic mission.

Populating a town with my own missions, but IEDs take quite some time.

I DO like that we can customize our own IEDs, but... forked from the code you use to make them dynamically; can we have a function to place a zone, and tell it to randomly spawn X IEDs inside?

That would be very helpful.

Share this post


Link to post
Share on other sites

I allow my self to repost since i think the post got missed by everyone :D

And working on a mission thats pretty dependent on the roleselection just cant find it in the new mcc.

Just updated to the new and wildly nice MCC

But where have you hide the Role selection have i missed something or am i just blind ?

Share this post


Link to post
Share on other sites

Spirit,thanks for the relpy regarding the AAF groups not spawning.Not a big deal for me just was reporting.

However,the constant change of weather is.I mentioned that MCC keeps changing my screen to full fog setting,particularly with more units on screen.Is This intentional to avoid lag when accessing mcc?Its really irritating,i will enter mcc,turn the fog back to zero,exit MCC and 2seconds later.....full screen of fog again.

Really irritating i cant seem to fix it and im about to roll back to previous mcc rite now because of it.

Any way i can fix it?And is anyone else having this issue or is it just me?

Share this post


Link to post
Share on other sites
Spirit,thanks for the relpy regarding the AAF groups not spawning.Not a big deal for me just was reporting.

However,the constant change of weather is.I mentioned that MCC keeps changing my screen to full fog setting,particularly with more units on screen.Is This intentional to avoid lag when accessing mcc?Its really irritating,i will enter mcc,turn the fog back to zero,exit MCC and 2seconds later.....full screen of fog again.

Really irritating i cant seem to fix it and im about to roll back to previous mcc rite now because of it.

Any way i can fix it?And is anyone else having this issue or is it just me?

I have never seen this issue by anybody. Not even when running an mcc night with about 20 people, we did not experience that. Maybe you need to make sure your server is clean of old MCC mission files and is all up tot date with the latest MCC. Maybe there are other mods doing it, but i have not seen this issue at all on an isolated MCC only setup.

There are no lag preventing scripts runnig at all. We are here to give control to teh mission maker, not to bug him :)

If you like, gimme a pm and we go on my dedicated server with the right mods. I am curious to see what happens then.

On a side note: if you play singleplayer then i dont know. Singleplayer is not supported. All our test and support are in a multiplayer environment.

Edited by spirit6

Share this post


Link to post
Share on other sites

i have "Arma 2 US Helicopters import" from there http://www.armaholic.com/page.php?id=24845 .

i can order those helis for cas support (s&d , bombing run , gun run etc) but i get no support . the only thing that working for support is the a3 uav and the litllebird..

is something from mcc , or is from the heli mod???

Share this post


Link to post
Share on other sites
Works as intended and still dont see any bug in it. Click Spawn in Zone, then click where you wan the heli to start. Works fine on our end. All the time, so helping is hard then.

Was doing it all wrong my bad :), big THX for the help Spirit6.

Share this post


Link to post
Share on other sites
Spirit,thanks for the relpy regarding the AAF groups not spawning.Not a big deal for me just was reporting.

However,the constant change of weather is.I mentioned that MCC keeps changing my screen to full fog setting,particularly with more units on screen.Is This intentional to avoid lag when accessing mcc?Its really irritating,i will enter mcc,turn the fog back to zero,exit MCC and 2seconds later.....full screen of fog again.

Really irritating i cant seem to fix it and im about to roll back to previous mcc rite now because of it.

Any way i can fix it?And is anyone else having this issue or is it just me?

i think that is bis weather related problem.

if you see a few posts back , i have a similar problem with rain....

somone told me that i must check the manual rain option (i cant find this option anywere.....btw)

i read also that bis on previous update remove this option for some reasons and on next update (1.14) they improve the weather system .

i m waiting for the update to see the differences ...

Share this post


Link to post
Share on other sites
I have never seen this issue by anybody. Not even when running an mcc night with about 20 people, we did not experience that. Maybe you need to make sure your server is clean of old MCC mission files and is all up tot date with the latest MCC. Maybe there are other mods doing it, but i have not seen this issue at all on an isolated MCC only setup.

I told you several threads back I had this same issue. I can set the weather to full clouds, with no rain, and seconds later I'll have rain and the slider will have moved.

I was applauding you for the updated weather sliders, but asking if they could be more granular like they are in the 2D editor.

Also, it also only seems like the weather "changes over time" when IT wants to. I was also saying it'd be nice: when you put in a weather change to see it happen over 30 seconds or so, rather than instant.

So, in short. Let the weather change when WE want it to. And be static, and not have a mind of its own, other times.

On Fallujah, I like to run with full clouds, and lightning, and no fog or rain. That's only doable in the vanilla, 2D editor, and Zeus.

Share this post


Link to post
Share on other sites
I told you several threads back I had this same issue. I can set the weather to full clouds, with no rain, and seconds later I'll have rain and the slider will have moved.

I was applauding you for the updated weather sliders, but asking if they could be more granular like they are in the 2D editor.

Also, it also only seems like the weather "changes over time" when IT wants to. I was also saying it'd be nice: when you put in a weather change to see it happen over 30 seconds or so, rather than instant.

So, in short. Let the weather change when WE want it to. And be static, and not have a mind of its own, other times.

On Fallujah, I like to run with full clouds, and lightning, and no fog or rain. That's only doable in the vanilla, 2D editor, and Zeus.

I think shay answered you there already. Apart from that, i dont think changing weather and not seeing results is the same as always getting foggy weather. But i get right back to work on it in my free time there. No reason to bully me here, i know you pay my salery.

*edit* Hmm seems shay answered another person about weather. I leave the weather question to shay.

Edited by spirit6

Share this post


Link to post
Share on other sites
No reason to bully me here, i know you pay my salery.

I am sorry you felt bullied. Also, our clan has gotten such a benefit out of MCC: you show us where we can donate, and we'll give you some money to "pay that salary". I feel there is real value in supporting the development of a thing that we benefit from, as well as quality developers that interact with their "customers".

Share this post


Link to post
Share on other sites
I am sorry you felt bullied. Also, our clan has gotten such a benefit out of MCC: you show us where we can donate, and we'll give you some money to "pay that salary". I feel there is real value in supporting the development of a thing that we benefit from, as well as quality developers that interact with their "customers".

Its ok mate, its not that bad. Good to see you have a good time with it. I dont think you will see a donation button anywhere soon. The fun and easy going part of making it differs from the pressure at work. I dont think i would want that into pressure in my free time. Anyway, we continue :)

*edit* Shay seems to be back in internet land and his ISP got on its knees. Expect a fix incoming tonight.

Edited by spirit6

Share this post


Link to post
Share on other sites

Hi,

first really great mod.

But i run in some trouble lately when i am using it on our server. (i also tested MCC r18 and the new r19)

So i started to made a campaign for my clan and build a template. This should be used to build missions in 2d editor and to run some mcc missions.

On the map i placed down some vehicles, crates, ambient stuff, X39 Med Modul, MCC Access Modul and put some scripts into it. During the first evening, at some point we could not access our vehicles anymore. I spawnt some new, and the same thing happend again after some time.

Today i build the same setup without scripts, delete the access modul but it still happens. After a few hours testing, it seems to me that when i spawn an IED or using the Missions Wizard (at least after using this to options i noticed it happen) this "bug" happens.

I can not really say why this is happens. But somehow it seems to me that it become something like desync. (I checked it but not one of us was desync on the evening) Because i can place an IED, run over it but the detonation do not kill or disable me. (And yes i checked that it is not on Fake) Vehicle played with the 3D editor, are invisible to some players (me the mission maker included) and to others not.

But now i don`t know what to do, so my question is what is it that i am doing wrong?

Share this post


Link to post
Share on other sites

My internet really sucks at the moment so it is a miracle if this post will even send, i'm just hoping that uploading the latest version will work without hanging out on me ;)

But anyway lads here come the first update for MCC 4:

Download Link - MP Mission version - Stratis:

https://www.dropbox.com/s/vk1makz2q2vnfpn/mcc_sandbox.Stratis.pbo

Download Link - MP Mission version - Altis:

https://www.dropbox.com/s/d25xly1ln63dgd6/mcc_sandbox.altis.pbo

Download Link - MP/SP Mod version:

https://www.dropbox.com/s/cbpinx8knu5fw42/%40mcc_sandbox.rar

Change log r2:0

GAIA:

- Fixed: Fortify updated with altered CBA taskdefend (credits CBA & Rommel).

Engine:

- Fixed: Groups/units created with "Create" button are not saved.

- Fixed: Error creating Resistance's groups/units created with "Create" button.

- Re-added: Role Selections.

3D Editor:

- Added: Close button.

- Fixed: Drop down menus backgrounds are no longer opaque.

- Added: Re-added structures in the drop down menu (hopefully BIS will introduce the new structures classes..

- Added: Weapons' holders, intel exc to the 3D (on Dev branch).

- Fixed: Recruit preset will recruit the whole unit's group (vehicle's crew).

- Added: Pickable items preset will have by default enableSimulation off so you can place them on tables exc.

GUI:

- Fixed: When opening a new container all other containers will be closed and not overlap.

- Fixed: In Box Gen drop down menus backgrounds are no longer opaque.

- Fixed: Changing view mod hide the video feed.

- Fixed: When selecting reinforcement or garrison the create button will not show only add to zone.

- Fixed: Missing units count for artillery and SF infantry when right clicking on a group icon.

VAS:

- Updated to the latest version.

IED:

- Fixed: Non-jammable IED didn't explode.

Mission Wizard:

- Added: Mini map and zone combobox.

- Added: Random option for most of the wizard options - add more suprise to the mission maker.

- Added: Help tooltip to all options.

- Fixed: Self propelled artillery spawn on top of each other.

Delete:

- Added: Delete lights - will delete all light sources in the area.

I am sorry you felt bullied. Also, our clan has gotten such a benefit out of MCC: you show us where we can donate, and we'll give you some money to "pay that salary". I feel there is real value in supporting the development of a thing that we benefit from, as well as quality developers that interact with their "customers".

I'll have milk and coockies if you can send them over ;)

Iceman;2643740']Hi' date='

first really great mod.

But i run in some trouble lately when i am using it on our server. (i also tested MCC r18 and the new r19)

So i started to made a campaign for my clan and build a template. This should be used to build missions in 2d editor and to run some mcc missions.

On the map i placed down some vehicles, crates, ambient stuff, X39 Med Modul, MCC Access Modul and put some scripts into it. During the first evening, at some point we could not access our vehicles anymore. I spawnt some new, and the same thing happend again after some time.

Today i build the same setup without scripts, delete the access modul but it still happens. After a few hours testing, it seems to me that when i spawn an IED or using the Missions Wizard (at least after using this to options i noticed it happen) this "bug" happens.

I can not really say why this is happens. But somehow it seems to me that it become something like desync. (I checked it but not one of us was desync on the evening) Because i can place an IED, run over it but the detonation do not kill or disable me. (And yes i checked that it is not on Fake) Vehicle played with the 3D editor, are invisible to some players (me the mission maker included) and to others not.

But now i don`t know what to do, so my question is what is it that i am doing wrong?[/quote']

It sounds like Dsync maybe you are over using the server? Take it slower and do a mission restart from time to time - delete brush is nice but if you want to start a new mission just do a restart.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×