Jump to content
Sign in to follow this  
FuriMatt

1.07 Stop using -winxp tag now

Recommended Posts

Unless you need it for compatibility to get the game to run, everyone should drop the -winxp and memory tags on startup. Keeping it on negates most of the performance increases from the 1.07 patch. With it off I'm getting a 15-25% fps improvement on a very complicated Dom server (all settings maxed and view at 5km) from 25-30 fps average to 30-40 fps average. Same story for the campaign missions.

FYI my machine is a i7 920 oc'd to 4ghz with HT turned off, 6gb of ram at 1800, and 2x 5850

Share this post


Link to post
Share on other sites

I'm glad your saying this, we need to keep bringing it up to remove the old -maxmem=2047 tag also!

I think some people will still have these commands set, and they wonder why they have not seen an improvement!

I'm seeing a big leap of performance, the only command I have on startup is -nosplash

Share this post


Link to post
Share on other sites

I get reduced FPS when I remove the -winxp tag :p

Share this post


Link to post
Share on other sites

It can still be needed by people with non-HT dual core rigs or low memory, but the majority trying to run arma is above that low tier. Everyone just needs to experiment with their own rig. Run a campaign mission with the tags on and off and see which is better for you.

Edited by FuriMatt

Share this post


Link to post
Share on other sites
I've got a quad core and 4gb of memory.

Pfft. I have a dual core and 6gb of memory. :p

Unless you need it for compatibility to get the game to run, everyone should drop the -winxp and memory tags on startup.

Any other tags we should drop because of the v1.07 patch?

Share this post


Link to post
Share on other sites

I'm pretty sure -winxp is still needed for for people using SLI to get better performance on vista/7.

-winxp switch forces the game to use Direct3D version 9 only, not the extended Vista / Win7 Direct3D 9Ex - the most visible feature the Ex version offers is a lot faster alt-tabing.

Share this post


Link to post
Share on other sites

-winXP disables usage of DX9Ex in Vista and Seven and may help work with OLD drivers to resolve some issues with SLI / Crossfire

there is no reason to use this with newest drivers which are all supposed to have SLI/Crossfire profiles for ARMA 2

if you need use -winXP to get performance then there is something wrong with drivers or your system in overall ...

also the description of -winXP was wrong (myth style) ... proper one is up2date now on wiki

Share this post


Link to post
Share on other sites

Pretty much the only important tags you should need now is cpuCount (just to make sure it didn't auto-detect wrong) and possibly exThreads if you're having some major problems with 1.07 with texture pop-in and loading. Of course -nosplash and all of those tags are up to your personal preference.

One of my clan mates was running on a laptop that somehow screwed up on the exthreads, but when he manually set it down to 1 everything went back to normal.

Share this post


Link to post
Share on other sites

I wanted to chime in with my thanks for this post.

With all that is out there I got lost in my command line and it wasn't until this thread that I realized my

I7 920 OC' 3.71ghz 6 gigs dd3 SLI GTX275's still has this in the launch line.

Thanks Dwarden for the information on why I had it way back when.

I had forgotten because I was immersed in the wiz of bullets and blood.

:)

Virtually I mean.

Share this post


Link to post
Share on other sites

Does anyone use Maxmem command anymore? I have 8 gigs of RAM but I don't know if the engine is optimized for greater RAM now or not.

Share this post


Link to post
Share on other sites
Pretty much the only important tags you should need now is cpuCount (just to make sure it didn't auto-detect wrong) and possibly exThreads if you're having some major problems with 1.07 with texture pop-in and loading. Of course -nosplash and all of those tags are up to your personal preference.

One of my clan mates was running on a laptop that somehow screwed up on the exthreads, but when he manually set it down to 1 everything went back to normal.

What do you put for cpucount if you have a quad core? 4?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×