Jump to content
Sign in to follow this  
maruk

Arma II Linux Server 1.04 Public Alpha

Recommended Posts

ive got tolower.c, im getting allot of errors when running the gcc -O -o tolower tolower.c command or make.
Hmm... what Linux distribution are you running? You are missing important parts of the GCC compiler suite.

Share this post


Link to post
Share on other sites

Ubuntu 8.04 LTS. I might compile it locally and transfer it over. Getting their slowly! thanks for the help.

---------- Post added at 01:39 PM ---------- Previous post was at 01:38 PM ----------

All sorted, :) corrected characters in the mission name and directory. So no need of running tolower :)

Share this post


Link to post
Share on other sites
So no need of running tolower :)
I'd advise you to get tolower running nonetheless, in case you upload new maps to your server ;)

Share this post


Link to post
Share on other sites
Ok, now the server is able to run on two cores, as we observed it on windows. But it seems like the server code still can't split the AI-computing part into two or more threads, which is the most important one.

I run the test-mission without cpucount and with cpucount 3 and 4. There was no difference between those runs. After at least 30 min the server dropped to 16-17 FPS, but the server process never produced load over 150% (100% = 1 core at full load). Mostly it was at around 120% CPU load.

Is this still the case with the latest version, and is it going to remain so? Is this also the case with the Windows standalone server?

We're upgrading our server hardware in a matter of weeks and I'm wondering if we should get a quad-core or possibly just a dual-core with clocks as high as you can go to get best performance for the money.

I guess this question is mostly directed at Bohemia: Is there any benefit at all from more than two CPU cores for the Linux standalone server?

---------- Post added at 04:23 AM ---------- Previous post was at 03:35 AM ----------

I'd advise you to get tolower running nonetheless, in case you upload new maps to your server ;)

In addition to the tolower program, the following command should also convert all file names (subdirectories included) to lower case under the directory where you run it:

find -depth -execdir rename 'y/A-Z/a-z/' {} \;

It should work with any reasonably modern Linux distribution.

Edited by Antti Salonen
typo

Share this post


Link to post
Share on other sites

is it possible to build a command for an admin (no voted admins...only admins who authentice themselfs with the admin PW) to switch on/off the password of a server?

Sometimes i wanna lock a mission while playing...or open a passworded mission up, so everybody can join...but i always got to restart the server :(

Share this post


Link to post
Share on other sites
admin commands #lock, #unlock

close...but not what i am looking for! ;-)

i still want that my clanmate who know the password are able to join. if i lock the server nobody will be able to join, right?

Share this post


Link to post
Share on other sites

You can probably code a server side addon that start a dialog for every mission,

that makes ppl enter the pass key.

SBSMac and CoolBox did a somewhat similar thing for their missions.

Share this post


Link to post
Share on other sites

that sounds like a complicated workaround! there is actually a server command, that should force the server to re-read the server.cfg

but that doesn't seem to work.

i tried entering a password into the server.cfg and then i use the #init command

maybe BI makes my wish come true ;-)

It would be really nice to have an ingame command like "#password on" or something like that. That way each of my clanmember will be able to setup a password...cause i am the only armaplayer at my clan who knows how to work with a linux shell *g*

Edited by Dr.Pulp

Share this post


Link to post
Share on other sites

Sorry for continuing this off-topic, but when you #lock the server, the client gets a password box when trying to connect. But there is nowhere to set a password for this in the server config. Is this a unfinished feature, or a bug?

Share this post


Link to post
Share on other sites
Sorry for continuing this off-topic, but when you #lock the server, the client gets a password box when trying to connect. But there is nowhere to set a password for this in the server config. Is this a unfinished feature, or a bug?

i'd say that's a legit feature request. "#lock" for the old behaviour, but "#lock [password]" to set a temporary password maybe?

Share this post


Link to post
Share on other sites

is there an option now that the linux server uses more than one CPU-core?

i run a core i7 server with 8gb ram here and one core is at 100% and the others are around 0-10%.

With Warfare BE edition the Server runs around 12 frames.

Share this post


Link to post
Share on other sites

are You sure you are using the last version (b59962 and newer)?

because the multicore optimizing wasn't available in the first alpha build!

Share this post


Link to post
Share on other sites

i'm pretty sure...

at all i've got this file on my server: arma2_linux_server-1.04.59962.tar.bz2

(loaded yesterday evening and utilizing -cpucount=4)

Edit: the CPU-Load is around 150% so Arma-Server uses more than one core, but one is at 100% what lowers the FPS dramatically

Edited by Schuldi

Share this post


Link to post
Share on other sites

So what's the current verdict on the ArmA 2 "Linux" server by those who are using it / have tried it out (I see it's being called an "Alpha" still so I was just wondering)? Any time frame goal announced by BIS for aiming to release a Beta or a "Final"? As it stands though (2nd alpha build or whatever you're calling it) Is it all as "stable" (yes I know this can be a patronizing term ; ) and fully functional as the Windows server version or what? How about performance comparisons? Any hyperlinks to other threads/sites this might have already been discussed with some conclusions drawn would also naturally be appreciated. Thanks in advance for any insight on this matter.

Edited by Bob.Dob

Share this post


Link to post
Share on other sites

runs fine so far! We use persistent mode and our server now runs with the same domination mission for several days.

fps between 25 and 18. (thats okay...we also have 2 Left4Dead, 2 Counterstrike and a TS Server on the same hardware).

runs as good as the arma 1 server i'd say....but the mission filenames are not as restricted as before.

Share this post


Link to post
Share on other sites

What are the recommended system req's for runing a linux server? How much faster would linux be vs dedi wintel?

Share this post


Link to post
Share on other sites

Hi all

Server FreeBSD

Linux Beta: v1.04.60159

Start server

WATCHDOG (57163): [Fri Nov 27 21:58:04 YEKT 2009] Starting server (port 2302)...

Cannot register unknown string STR_USRACT_ACTION_CONTEXT

Cannot register unknown string STR_USRACT_NETWORK_DS_INTERFACE

Cannot register unknown string STR_ADDON_ACTIONS_INSTALL_CORE

Cannot register unknown string STR_ADDON_ACTIONS_INSTALL_MOD

Cannot register unknown string STR_ADDON_ACTIONS_PLAY_MISSION

Cannot register unknown string STR_ADDON_ACTIONS_TRY_ENTITY

Cannot register unknown string STR_ADDON_ACTIONS_TRY_WEAPON

Cannot register unknown string STR_MSG_ADDON_NOT_FOUND

Cannot register unknown string STR_MSG_ADDON_CANNOT_OPEN

Cannot register unknown string STR_MSG_ADDON_UNKNOWN_PRODUCT

21:58:11 Создан выделенный Ñервер.

Warning Message: No entry 'bin\config.bin/CfgCoreData.textureLine3D'.

Warning Message: '/' is not a value

21:58:12 Идентификатор Ñервера Ñоздан

???

Share this post


Link to post
Share on other sites

Try using the contents of the beta folder as a mod. That should fix most of these messages.

Share this post


Link to post
Share on other sites
Hi all

Server FreeBSD

Linux Beta: v1.04.60159

Start server

WATCHDOG (57163): [Fri Nov 27 21:58:04 YEKT 2009] Starting server (port 2302)...

Cannot register unknown string STR_USRACT_ACTION_CONTEXT

Cannot register unknown string STR_USRACT_NETWORK_DS_INTERFACE

Cannot register unknown string STR_ADDON_ACTIONS_INSTALL_CORE

Cannot register unknown string STR_ADDON_ACTIONS_INSTALL_MOD

Cannot register unknown string STR_ADDON_ACTIONS_PLAY_MISSION

Cannot register unknown string STR_ADDON_ACTIONS_TRY_ENTITY

Cannot register unknown string STR_ADDON_ACTIONS_TRY_WEAPON

Cannot register unknown string STR_MSG_ADDON_NOT_FOUND

Cannot register unknown string STR_MSG_ADDON_CANNOT_OPEN

Cannot register unknown string STR_MSG_ADDON_UNKNOWN_PRODUCT

21:58:11 Создан выделенный Ñервер.

Warning Message: No entry 'bin\config.bin/CfgCoreData.textureLine3D'.

Warning Message: '/' is not a value

21:58:12 Идентификатор Ñервера Ñоздан

???

Try using the contents of the beta folder as a mod. That should fix most of these messages.

+ ARMA2_Build_60588.zip

Start server

WATCHDOG (64130): [sat Nov 28 05:33:25 YEKT 2009] Starting server (port 2302)...

Cannot register unknown string STR_USRACT_ACTION_CONTEXT

5:33:32 Создан выделенный Ñервер.

5:33:33 Идентификатор Ñервера Ñоздан

???

Edited by Sergei_100

Share this post


Link to post
Share on other sites
+ ARMA2_Build_60588.zip

Start server

WATCHDOG (64130): [sat Nov 28 05:33:25 YEKT 2009] Starting server (port 2302)...

Cannot register unknown string STR_USRACT_ACTION_CONTEXT

5:33:32 Создан выделенный Ñервер.

5:33:33 Идентификатор Ñервера Ñоздан

???

That's as good as it gets with the beta. As you can tell, there is one missing string, but you'll see this in Windows aswell using the betas.

All is well - your Linux ArmA II server is working(*). Enjoy!

(*) I can't read Russian, but I hope the two last messages correspond to the two last lines in this quote:

WATCHDOG (8688): [sat Nov 28 08:42:37 CET 2009] Starting server (port 2302)...

Cannot register unknown string STR_USRACT_ACTION_CONTEXT

8:42:52 Dedicated host created.

8:42:54 Host identity created.

---------- Post added at 08:52 AM ---------- Previous post was at 08:45 AM ----------

What are the recommended system req's for runing a linux server? How much faster would linux be vs dedi wintel?
1) I'd say a machine with at least 2 GiB memory and the fastest CPU you can get hold of.

2) I doubt there's going to be much difference between a properly configured Windows and Linux server on the same hardware. Use the OS you are most comfortable with.

Share this post


Link to post
Share on other sites

Server FreeBSD

Linux Beta: v1.04.60159

+ ARMA2_Build_60588

AI in the game does not work.

in the log server.

Cannot create non-ai vehicle Misc_Cargo1B

Cannot create non-ai vehicle Misc_Cargo1Bo

Cannot create non-ai vehicle Misc_Cargo1Bo

Bots in the game are on the ground, motionless.

Cannot register unknown string STR_USRACT_ACTION_CONTEXT

Mission test1.utes: Missing 'description.ext::Header'

Server: Object 3:1 not found (message 213)

Client: Remote object 3:0 not found

Unit not created: Subgroup 0:0 not found

Cannot create object 3:3

Cannot create non-ai vehicle Misc_Cargo1B,

Cannot create non-ai vehicle Misc_Cargo1Bo,

Cannot create non-ai vehicle Misc_Cargo1B,

21:38:08 Игра началаÑÑŒ.

Server: Object 3:25 not found (message 121)

Server: Object 3:29 not found (message 121)

Respawn failed - body disappeared

Server: Object 3:34 not found (message 121)

Server: Object 3:38 not found (message 121)

Server: Object 3:41 not found (message 121)

Server: Object 3:43 not found (message 121)

Server: Object 3:45 not found (message 121)

Client: Object 3:49 (type Type_66) not found.

Client: Object 3:49 (type Type_67) not found.

Server: Object 3:52 not found (message 121)

Server: Object 3:56 not found (message 121)

Edited by Sergei_100

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×