Jump to content
Sign in to follow this  
Jonney Napalm

Nvidia 190.38 Beta Drivers?

Recommended Posts

Just seen that the 190.38 beta drivers for Vista (not sure about XP etc) are out.

Anyone tried them?

Don't seem to mention any Arma related things in the info, and I'm not sure if they enable SLi like the patch did.

Can you even use the Nvidia SLi patch with it?

Anyways, if anyone has found any improvement, either performance or stopping the CTD's don't be shy ;)

Share this post


Link to post
Share on other sites
Just seen that the 190.38 beta drivers for Vista (not sure about XP etc) are out.
Yes also ones for XP (& the vista ones are also for Win 7)
Anyone tried them?
Yes (Vista 64) and just tried a very quick run around in a saved editor mission that had used when trying settings
Don't seem to mention any Arma related things in the info, and I'm not sure if they enable SLi like the patch did.
Yes, The new driver has an ArmA2 profile (works with SLI)
Can you even use the Nvidia SLi patch with it?
no need, it's Now already in the driver as standard
Anyways, if anyone has found any improvement, either performance or stopping the CTD's don't be shy ;)
only had a very quick run around on a test mission, but I definitely got more FPS (on FRAPS) than I did before and it stayed at 60 more often, unless I went in woods with lots of shadows where it dipped to 45-50 at times.

Share this post


Link to post
Share on other sites

Arma2 crash just as much and just as fast with the new beta driver as with any other driver for nvidia geforce 275 - 285 and 295...

Share this post


Link to post
Share on other sites

I'm using two GTX 285's in SLI and I haven't had a single crash since installed the game (on 186.18 or so far with 190.38)

But I do see that there are others who are having a lot of problems

Edited by Pave Low

Share this post


Link to post
Share on other sites

Thanks for the reply Pave Low, I might give it a whirl then.

It won't stop my CTD's I don't think, as I'm running a similar set-up to delevero, the fatal combo of a core i7 and a GTX295.

Share this post


Link to post
Share on other sites

This driver gave me a pretty big FPS boost!

Gonna test a bit more.

Share this post


Link to post
Share on other sites

Same for me, the 190.38 are fantastic. I started playing a particular SP mission last night and was getting around 30fps or so, after installing 190.38 and resuming the same mission I'm seeing frames hit over 40. Outstanding.

Share this post


Link to post
Share on other sites

I did a few tests in the DEMO and did not see any improvement between 186.18 and 190.38... same fps on an 8800GTX.

Later I installed the full version of the game and I have to say it seems "smoother" than the demo... maybe I havent gone into any towns yet but it was running at about 35 to 45fps on Very High settings in chenarous....

Yapa

Share this post


Link to post
Share on other sites

My benchmarks show absolutely no performance increase from using this driver. Most changes relate to the nVidia Control Panel interface.

Share this post


Link to post
Share on other sites

This is the annoying bit about PC gaming... what provides an astounding improvement for some (like me) ends up not being overly dramatic for others. :(

I'd call an easy 10+ fps boost astounding, and if there's even a chance your system will like these drivers I see no reason not o give them a shot. Do be sure to install 'em properly of course, just in case.

Share this post


Link to post
Share on other sites

My findings:

New Beta NVidia Drivers 190.38 - ArmaMarkII Score - 2198.xx

Old Nvidia 180.48 ArmaMarkII Score - 2430.xx

Nvidia 186.18 ArmaMarkII Score 2186.xx

Athlon 4400+ Overclocked 4 Gig RAM

Nvidia Superclocked 9800 GTX+ 512Meg Grafix

Same game settings and ArmaMark2 Score run twice (these are second numbers for each driver)

Share this post


Link to post
Share on other sites

I tried them out on a GTX 285. They messed up the whole picture, textures weren't drawn and some objects had terribly LOD issues. The driver worked nicely in other games, but it wasn't enjoyable in Arma2. I went back to 190.15 (Vista 64-bit).

Share this post


Link to post
Share on other sites

Yeah it looks like the newer 2xx and > cards like 190.15 drivers and the 9800's and lower seem to like the 180.48 drivers.

Share this post


Link to post
Share on other sites

Where's those 190.15 drivers? nVidia's site only shows 186.18 and 190.38.

I'm currently using the 185.50. With the 186.18 the LoD and texture loading was more severe than now. But I've made a clean install of the game and the drivers, so I don't know if that is behind the beter performance, or if it's really the driver's version.

I'm thinking about moving to 190.38. If Arma 2 gets even more annoying, I'll stop playing it. I've only played it a couple times this week anyway... Too many CTDs.

Share this post


Link to post
Share on other sites
Where's those 190.15 drivers? nVidia's site only shows 186.18 and 190.38.

I'm currently using the 185.50. With the 186.18 the LoD and texture loading was more severe than now. But I've made a clean install of the game and the drivers, so I don't know if that is behind the beter performance, or if it's really the driver's version.

I'm thinking about moving to 190.38. If Arma 2 gets even more annoying, I'll stop playing it. I've only played it a couple times this week anyway... Too many CTDs.

Here: Google is my friend ;)

http://www.guru3d.com/news/geforce-forceware-19015-win-7--vista--xp/

Share this post


Link to post
Share on other sites
190.38 -> 5-10fps increase on my rig. Tetxure loading feels "faster"...

Thats measurment noise.

Share this post


Link to post
Share on other sites

For nVidia this is WHQL drivers LINK :rolleyes:

Share this post


Link to post
Share on other sites
Thats measurment noise.

Measurment done in vybor, where the campain mission has hanged for me, cant move, I got around ~18, now im at ~26.

Anyone know how to bypass the gamelogic, so i can finnish the campaign, please pm me!?

Edited by Baxalasse

Share this post


Link to post
Share on other sites

I'm curious if these are still plagued by the texture issues with it not detecting memory properly same as the other drivers? I have 8gigs of ram in Vista 64

Share this post


Link to post
Share on other sites

I find if I set video memory to Very High in ArmA2 it gives me around 500mb in the CFG file. I am running dual 8800GT's (512mb a piece) so it should be showing me at 512mb in the cfg... so I'm close.

Share this post


Link to post
Share on other sites

For those who want to know: The new drivers dont solve the 8 GB RAM issue.

For me, they even pressed down the localVRAM and nonlocalVRAm to a new minimum: 2 MB (~2 million bytes, a string of seven digits)!

I guess the "old" known workarounds still work, though.

Share this post


Link to post
Share on other sites
My benchmarks show absolutely no performance increase from using this driver.

Me neither -

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×