Jump to content
S.Newbould

Dedicated Server Issue "Server Can Not Transmit All Data"

Recommended Posts

Hey guys,

 

I rent a dedicated server from a company for me and my friends to play Co-Op/PvP missions on using mods. I am getting an issue with the server currently as I am getting the following error "Server cant transmit all data: some mods might be missing or their signatures can not be recognised" .

Things I have tried:
- Loading mods 1 by 1 to see if any of them are broken/outdated 
- Checked keys folder for any missing keys in relation to their mods
- Checked mod line to see if there is any typos

It seems to me that if I have a set number of mods it works but if I go over that number it seems to break the server and as far as I am aware my service provider is not imposing any restrictions on how many mods I can use (if its even possible). Could really do with some help with this one guys as I have been at it now for over a week its driving me insane! 

Thanks in advanced

Share this post


Link to post
Share on other sites

There is a limit to the number of mod folders that can be loaded, it becomes an exponential issue once you go over a certain number.

I posted information about this a good while back, cannot remember how long ago

Work around, combine mods into custom mod folders.

eg

@MyIslands

@MyVehicles

@Miscellaneous

 

There are some mod folders you cannot do this with, TFAR is one of them, most likely also ACRE, basically any mod that has a custom .dll that is hard coded to a mod folder name

Share this post


Link to post
Share on other sites
22 hours ago, terox said:

TFAR is one of them

No it isn't.

 

Another workaround is also to just shorten folder names on your server. Combining them is a very bad idea because then the automatic workshop integration won't work anymore as you can only have one workshop item per folder.

  • Thanks 1

Share this post


Link to post
Share on other sites
31 minutes ago, Dedmen said:

Combining them is a very bad idea because then the automatic workshop integration won't work anymore as you can only have one workshop item per folder.

Not if you take the files out of the workshop mod and put them into your own mod, ideally thats what you'd want to do, if and when theres an update then launch the

arma3 launcher and you will see what updates, then grab the new files (copy) and put them in your mod, works for me np.

Share this post


Link to post
Share on other sites
50 minutes ago, Gunter Severloh said:

Not if you take the files out of the workshop mod and put them into your own mod

If you are trying to say that people should just repack and reupload mods to the workshop.. VERY bad idea. That would violate the Steam Subscriber agreement and could get your Steam account banned if you're unlucky.

And if you are a repeat offender it could even lead to a ban on the BI Forums.

Share this post


Link to post
Share on other sites
2 hours ago, Dedmen said:

If you are trying to say that people should just repack and reupload mods to the workshop

Is there anywhere in my reply that says put other people's mods/files in a mod of your own and reupload to steamworkshop?

     Why is what i say taken out of context? Were talking about enabling a mod on a server not uploading mods on steam workshop.

 

I dont need the forum rules thrown at me either, I know the rules, this aint my first pony ride.

I built many compilation mods that alot of modders over 100 old and new, even moderators know about, this is why i suggested a compilation mod

as its always worked for me, even terox suggested it.

 

What i said before which is based on the limits of the game related to workshop running multiple mods together you could

take the multiple mod's files that is the pbo's and bisigns, put them in your own mod (Create a folder name it @mod and then create an addons folder inside that).

THEN PUT THAT MOD ON YOUR SERVER.

 

As the OP says in his post: 

"It seems to me that if I have a set number of mods it works but if I go over that number it seems to break the server"

So like i said take the number of mods you want, and combine them into one, basically take the pbo's and bisigns out of them and create your own mod,

and then upload that mod onto your server. So for all the maps @maps, for all the units @units, for all the weapons, @Weapons, ect,.

Share this post


Link to post
Share on other sites
1 hour ago, Gunter Severloh said:

"It seems to me that if I have a set number of mods it works but if I go over that number it seems to break the server"

You didn't read correctly then. "Server cant transmit all data". Removing all the mods from the Arma Launcher is a really bad fix for the issue that not all mods are showing up in Arma Launcher.

 

1 hour ago, Gunter Severloh said:

So like i said take the number of mods you want, and combine them into one, basically take the pbo's and bisigns out of them and create your own mod

That would remove all mods from the Launcher. And considering that the error in OP's post isn't actually any problem with the server itself but the mods not showing up in Arma Launcher. How is removing the mods from Arma Launcher a "fix" ?

 

 

Also as I already said..

5 hours ago, Dedmen said:

Combining them is a very bad idea because then the automatic workshop integration won't work anymore as you can only have one workshop item per folder.

Only way to get around that and still put all your mods into one folder is to...

3 hours ago, Dedmen said:

just repack and reupload mods to the workshop

 

 

Sorry that I assumed you knew what I was talking about.

Share this post


Link to post
Share on other sites

I never said remove any mods from the launcher, besides instead of using the launcher to connect to the server connect to the server through the server's IP address as once you have done that once,

MP will remember, so go to recent and your server will show up listed provided its running.

Imo connecting through IP is the fastest way, if there are issues with mods on the server then do as terox and myself suggested compile your mods, upload the mod to the server, and make sure

your loading your mod, and not the ones your subbed too, just uncheck those.

 

Share this post


Link to post
Share on other sites
14 hours ago, Gunter Severloh said:

I never said remove any mods from the launcher

That is what packing them into a single folder would do though.

Every folder has it's meta.cpp with the Steam itemID inside. If you remove the folder, the server cannot transmit the itemID anymore and the Launcher can't detect what mods the server is using.

As I said. Shorten the folder names. You need to fit everything into a fixed size packet. So just reduce the size of your elements. Of course at a certain number of mods even that won't help.

But I don't consider just not showing any mods in Launcher a "fix"

Share this post


Link to post
Share on other sites
6 hours ago, Dedmen said:

Every folder has it's meta.cpp with the Steam itemID inside. If you remove the folder, the server cannot transmit the itemID anymore and the Launcher can't detect what mods the server is using.

I know that and thats the point when you create your own compilation mod.

As i said your not using the launcher to connect to the server with your new mod, again imo your best bet is to get

the server's ip and connect through mp and thats not using the launcher you wont have any issues, you can still use the launcher to launch arma3 with the mod

using the +local mod tab, your just not going to server to choose your server.

 

   Whatever the OP chooses. Im off i got better things to do to have everything i say analyzed, if you got the answers then by all means, i just gave my advice and perspective

based on how i play, as did terox which i also suggested the same.

Cheers have fun with the launcher.

 

 

 

Share this post


Link to post
Share on other sites
On 8/20/2018 at 10:34 AM, Dedmen said:

Another workaround is also to just shorten folder names on your server.

mmmh...very interesting, ty!

so it is actually a character limit rather than a mod limit, is this limit value know?

Share this post


Link to post
Share on other sites

Did anyone ever solve this? I'm having the exact same issue on my server and I've tried shortening the names to single letters and still have the problem. I am very hesitant to create a compilation of mods just for the steam updating portion of it. 

Share this post


Link to post
Share on other sites

@Dedmen, to my understanding it's a character limitation of the mod names in the mod.cpp files of all the mods combined, not the actual folder names. This might explain why it isn't working for @S. Bacon.

 

Here's a ticket on the feedback tracker that explains it in detail: https://feedback.bistudio.com/T123655

 

@Gunter Severloh, what Dedmen is trying to say is that the OP is looking for a way to automatically load the mod list via the launcher. What you were suggesting completely bypasses the launcher's automatic loading of mods, defeating the purpose.

Share this post


Link to post
Share on other sites
8 hours ago, Drift_91 said:

to my understanding it's a character limitation of the mod names in the mod.cpp files of all the mods combined, not the actual folder names.

If you don't have a mod.cpp it will fallback to folder name afaik.

Considering most mods don't have one...

Share this post


Link to post
Share on other sites
On 3/4/2019 at 2:50 AM, Dedmen said:

If you don't have a mod.cpp it will fallback to folder name afaik.

Considering most mods don't have one...

Ah alright, that makes more sense.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×